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SAFETY STEPS TO FOLLOW IF SOMEONE IS THE 
VICTIM OF ELECTRICAL SHOCK. 

   

1 DO NOT TRY TO PULL OR GRAB THE 
INDIVIDUAL. 

   

2 IF POSSIBLE, TURN OFF THE ELECTRICAL 
POWER. 

   

3 
IF YOU CANNOT TURN OFF THE ELECTRICAL 
POWER, PULL, PUSH, OF LIFT THE PERSON TO 
SAFETY USING A WOODEN POLE OR A ROPE OR 
SOME OTHER INSULATING MATERIAL. 

   

4 SEND FOR HELP AS SOON AS POSSIBLE. 
   

5 

AFTER THE INJURED PERSON IS FREE OF 
CONTACT WITH THE SOURCE OF ELECTRICAL 
SHOCK, MOVE THE PERSON A SHORT DISTANCE 
AWAY AND IMMEDIATELY START ARTIFICIAL 
RESUSCITATION. 
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General handling guidelines for Valence Technology Lithium-ion Polymer Cells 
 

WARNING 
 
• Do not expose the cell to extreme heat. 
 
• Do not disassemble or modify the cell. 
 
• Do not use soldering methods when connecting to the cell leads. 
 
• Do not puncture the cell or in any way breach the cell packaging. 
 
• Do not use a cell that appears to be damaged or deformed is discolored or appears to have defects in 

the heat seal areas. 
 
• Keep the cells dry and away from water. 
 
• Avoid placing cells on metal surfaces.  Avoid external short-circuiting of cell leads in general. 
 
• Do not fold, bend, or apply excessive pressure to the main body of the cell (inside the sealed areas). 
 
• If heat seal flanges are to be folded, do so in a manner that mechanical pressure is not transmitted to 

internal components.  It is recommended that Valence engineering be consulted in the event that any 
alteration of the edge fold is considered. 

 
• The edge of the heat seal flange is electrically conductive (see Application Note, VT-AN-004). 
 
• Avoid installation or placement of cells in such a manner that this edge could come in contact with 

other cell terminals, printed circuit boards or other conductive surfaces in general.  60°C can be used 
to extend cycle life at the elevated temperatures. 

 
• Do not use the battery pack in combination with primary battery pack (such as a dry-cell battery pack) 

or battery packs of different capacities or brands.  Otherwise, the battery pack can be over-
discharged during use or overcharged during recharging, abnormal chemical reactions may occur, 
possibly leading to acid leakage, overheating, smoke emission, bursting and /or ignition.  In the event 
the batteries are swallowed, consult a doctor. 

 
• If recharging operation fails to complete even when a specified recharging time has elapsed, 

immediately stop further recharging.  Otherwise, acid leakage, overheating, smoke emission, 
bursting, and/or ignition can occur. 

 
• Do not place the battery into a microwave oven or pressurized container.  Rapid heating or disrupted 

sealing can lead to acid leakage, overheating, smoke emission, bursting, and/or ignition. 
 
• If the battery pack leaks or gives off a bad odor, remove it from any exposed flame.  Otherwise, the 

leaking electrolyte can catch fire, and the battery pack may emit smoke, burst, or ignite. 
 
• If the battery pack gives off an odor, generates heat, becomes discolored or deformed, or in any way 

appears abnormal during use, recharging or storage, immediately remove it from the equipment or 
battery pack charger and stop using it.  Otherwise, the problematic battery pack can develop acid 
leakage, overheating, smoke emission, bursting, and/or ignition. 
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WARNING 
 

Do not be misled by the term "low voltage".  Potentials as low as 50 volts may 
cause death under adverse conditions. 

 
• For Artificial Respiration, refer to FM 4-25.11, First Aid for Soldiers. 
 
• Review the precautions in TB 385-4, Safety Requirements for Maintenance of Electrical and 

Electronic Equipment before attempting repairs or service of electronic equipment. 
 

CAUTION 
 
• Do not use or subject the battery pack to intense sunlight or hot temperature such as in a vehicle in 

hot weather.  Do not use or leave battery near a heat source, such as fire or a heater (192°F).  
Otherwise, acid leakage, overheating, smoke emission, bursting, and/or ignition can occur.  Also, its 
guaranteed performance will be lost and/or its service will be shortened. 

 
• The battery pack incorporates built-in safety devices.  Do not use in a location where static electricity 

(greater than the manufacturer’s guarantee) may be present.  Otherwise, the safety devices can be 
damaged possibly leading to acid leakage, overheating, smoke emission, bursting and or ignition. 

 
• The guaranteed recharging temperature range is 0 to 40°C.  A recharging operation outside this 

range can lead to acid leakage and/or overheating of the battery pack, and may cause damage to it. 
 
• If acid leaking from the battery pack contacts your skin or clothing, immediately flush it thoroughly 

with running water.  Otherwise, skin inflammation can occur. 
 
• If you find rust, a bad odor, overheating, and/or other irregularities when using the battery pack for the 

first time, return it to your supplier or vendor. 
 

General Safety Information for the AA Alkaline Battery 
 

WARNING 
 
• Always handle batteries carefully. 
 
• Do not drop, puncture, disassemble, mutilate, or incinerate batteries. 
 
• Touching both terminals of a battery with a metal object will short circuit the battery, which could 

cause an explosion or a fire.  Do not carry batteries loosely if the contacts may touch coins, keys, and 
other metal objects (such as in pockets or bags). 
 

• Do not heat the batteries to try to rejuvenate their charge. 
 
• Batteries may leak electrolytes that may cause irritation to the skin and eyes.  Should this occur, 

irritated areas should be flushed thoroughly with water. 
 
 
 
 
 

c/(d blank) 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 

 

 



UNCLASSIFIED//FOR OFFICIAL USE ONLY 
TM 11-5810-410-13&P 

 
 

LIST OF EFFECTIVE PAGES/WORK PACKAGES 
 
NOTE:  Zero in the “Change No.” column indicates an original page or work package. 
 
 Date of issue for the original manual is: 
Original:  1 September 2007  
 
 TOTAL NUMBER OF PAGES FOR FRONT AND REAR MATTER IS 48 AND TOTAL 
 NUMBER OF WORK PACKAGES IS 46 CONSISTING OF THE FOLLOWING: 
 
Page/WP No. Change No. Page/WP No. Change No. 
Title 0 Chp 3 Title Page 0 
Title Blank 0 Chp 3 Title Page - Blank 0 
Warnings (4 Pgs)                                0 WP 0031 (22 pgs) 0 
A 0 WP 0031.1 (8 pgs) 0 
B – blank 0 Chp 4 Title Page 0 
i – xxviii 0 Chp 4 Title Page - Blank 0 
Chp 1 Title Page 0 WP 0032 (4 pgs) 0 
Chp 1 Title Page - Blank 0 WP 0033 (6 pgs) 0 
WP 0001 (4 pgs) 0 Chp 5 Title Page 0 
WP 0002 (6 pgs) 0 Chp 5 Title Page - Blank 0 
WP 0003 (12 pgs) 0 WP 0034 (2 pgs) 0 
Chp 2 Title Page 0 WP 0035 (8 pgs) 0 
Chp 2 Title Page - Blank 0 WP 0036 (12 pgs) 0 
WP 0004 (14 pgs) 0 Chp 6 Title Page 0 
WP 0005 (6 pgs) 0 Chp 6 Title Page - Blank 0 
WP 0006 (12 pgs) 0 WP 0037 (8 pgs) 0 
WP 0007 (28 pgs) 0 WP 0038 (4 pgs) 0 
WP 0008 (10 pgs) 0 WP 0039 (2 pgs) 0 
WP 0009 (18 pgs) 0 WP 0040 (2 pgs) 0 
WP 0010 (16 pgs) 0 Chp 7 Title Page 0 
WP 0011 (10 pgs) 0 Chp 7 Title Page - Blank 0 
WP 0012 (6 pgs) 0 WP 0041 (2 pgs) 0 
WP 0013 (6 pgs) 0 WP 0042 (6 pgs) 0 
WP 0014 (30 pgs) 0 WP 0043 (2 pgs) 0 
WP 0014.1 (4 pgs) 0 WP 0044 (4 pgs) 0 
WP 0015 (30 pgs) 0 WP 0045 (2 pgs) 0 
WP 0016 (30 pgs) 0 WP 0046 (2 pgs) 0 
WP 0017 (18 pgs) 0 Rear Matter Title Page                      0 
WP 0018 (18 pgs) 0                        Rear Matter Title Page - Blank          0 0 
WP 0019 (30 pgs) 0 Glossary-1 - Glossary -6                    0 
WP 0020 (12 pgs) 0  Index-1 - Index-8                               0
WP 0021 (6 pgs) 0  
WP 0022 (12 pgs) 0  
WP 0023 (4 pgs) 0  
WP 0024 (14 pgs) 0  
WP 0025 (4 pgs) 0  
WP 0026 (12 pgs) 0  
WP 0027 (8 pgs) 0  
WP 0028 (20 pgs) 0  
WP 0029 (26 pgs) 0  
WP 0030 (2 pgs) 0  

 

A/(B blank) 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 

 

 

 

         FOR OFFICIAL USE ONLY



UNCLASSIFIED/FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P  

i 
UNCLASSIFIED/FOR OFFICIAL USE ONLY 

 *HEADQUARTERS 
DEPARTMENT OF THE ARMY 

 Washington, DC 1 September 2007 
 

TECHNICAL MANUAL 
 

OPERATOR'S AND FIELD MAINTENANCE MANUAL 
INCLUDING REPAIR PARTS AND SPECIAL TOOLS LIST 

FOR THE 
TRANSFER UNIT, CRYPTOGRAPHIC KEY 

AN/PYQ-10 (C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
(NSN 5810-01-517-3587) (EIC: N/A) 

 

REPORTING ERRORS AND RECOMMENDING IMPROVEMENTS 
 

You can help improve this manual.  If you find any mistakes, or, if you know of a way to improve the 
procedures, please let us know.  Fill out an electronic DA Form 2028 (Recommended Changes to 
Publications and Blank Forms) at:  https://aeps.ria.army.mil/aepspublic.cfm (ensure you provide the 
correct publication number) or mail a letter or paper DA Form 2028 to Director, U.S. Army 
Communications Security Logistics Activity, ATTN:  SELCL-IA-NMP (EPCO) US ARMY CECOM CSLA, 
2133 Cushing St., Ste 3600, Fort Huachuca, AZ 85613-7041 (mark the letter or the DA Form 2028, or DA 
Form 2028-2 located in back of this manual UNCLASSIFIED//FOR OFFICIAL USE ONLY on the top and 
bottom of the letter or form).  You may also forward information via Army Knowledge Online (AKO) e-mail 
to epco.csla@conus.army.mil.  A reply will be furnished you. 
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HOW TO USE THIS MANUAL 

 
Spend a few minutes and look through this Technical Manual.  This manual contains the hardware 
description and the instructions to use the system software for the Simple Key Loader (SKL).  It also 
provides maintenance procedures and a repair parts and special tools list.  This book, along with the 
manuals that are referenced, includes all the necessary information to effectively utilize and maintain the 
SKL. 
 
TABLE OF CONTENTS Refer to the Table of Contents to locate information.  The Table of Contents 

lists each Work Package, showing subject, and page numbers.   
  
ABBREVIATIONS For the sake of brevity, this manual makes use of abbreviations.  

Abbreviations are identified with the complete meaning at the first use and 
frequently thereafter.  If you need a meaning of an abbreviation, it may be 
found in the Glossary located at the rear of this manual. 

 
The following is an overview of the information contained in each chapter and rear material in this 
Technical Manual: 
 
• Chapter 1 contains general information, equipment description and data, and principles of operation. 
 
• Chapter 2 contains a description and use of the operator controls and indicators, operation under 

usual conditions, and operation under unusual conditions. 
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• Chapter 3 contains troubleshooting procedures. 
 
• Chapter 4 contains PMCS and maintenance procedures. 
 
• Chapter 5 contains instructions for the receipt of equipment, installation, and checkout. It also 

contains maintenance instructions. 
 
• Chapter 6 contains the Repair Parts and Special Tools List (RPSTL). 
 
• Chapter 7 lists References that are called out in this Technical Manual, the Maintenance Allocation 

Chart (MAC), Components of End Item List (COEI) and Basic Issue Items (BII), Additional 
Authorization List (AAL), and Expendable Supplies and Materials List. 

 
• Glossary contains a list of abbreviations/acronyms and definitions of words used in this Technical 

Manual. 
 
• Index contains a complete listing of the Information and Procedure paragraphs in this Technical 

Manual. 
 
Throughout this technical manual, Warnings, Cautions, and Notes are posted to alert the reader to 
special provisions and provide additional information concerning the operation of the SKL, the software 
that is being used, or general operational practices. 
 

WARNING 
 

Warnings denote conditions, practices, or procedures that could lead to personal 
injury or loss of life. 
 

CAUTION 
 

Cautions warn about conditions, practices, or procedures that could damage or 
destroy equipment or create a potential security problem. 
 

NOTE 
 

Notes are used to draw attention to information of importance, special interest, or 
information that aids job performance. 
 

There are certain conventions used throughout this Technical Manual.  These conventions are standard 
and help the user to understand the procedures to be followed in a clear and concise manner.  These 
conventions are listed below: 
 

 

TIP:  This symbol represents a glowing light bulb.  Whenever this is shown in the manual it 
indicates an operational TIP that will make a procedure easier to accomplish. 

 
 Tap 
 
Tap and release the Inductive Stylus once. 
 
 Double-Tap 
 
Tap on the selection twice in rapid succession with the Inductive Stylus. 
 
 

xxvii 
UNCLASSIFIED/FOR OFFICIAL USE ONLY 



UNCLASSIFIED/FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P  

 Select 
 
Indicates a menu selection or dialog box selection.  Tap or double-tap the Inductive Stylus to select an 
item. 
 
 Highlight 
 
Tap on a selection with the Inductive Stylus that will change the background of the selected item to 
reverse video. 
 
 Bolded Word(s) 
 
Bolded Word(s) are either selections on a menu or button titles that should be selected or tapped to 
complete an action in the technical manual. 
 
 Un-bolded Button(s)/Selections 
 
These are descriptive only.  The user may select these at their discretion. 
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OPERATOR MAINTENANCE 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
 

 
GENERAL INFORMATION 
 
 
SCOPE 
 
This Technical Manual (TM) describes the hardware portion of the Transfer Unit, Cryptographic Key 
AN/PYQ-10 (C), also referred to as the Simple Key Loader (SKL), and the required procedures to 
effectively utilize the SKL’s software packages.  It also defines the care and maintenance procedures that 
the user should follow to maintain the SKL in proper operating condition. 
 
Applicability 
 
This Technical Manual will be used by all Army users employing the Simple Key Loader and is applicable 
to all personnel within the active Army, Army Reserve (USAR), and Army National Guard (ARNG). 
 
Equipment Components 
 
The AN/PYQ-10 (C) is a self-contained item that consists of a hand-held mini-computer or Personal 
Digital Assistant (PDA).  This small computer contains all the functions of a desktop computer but with the 
added features of portability on the battlefield and the ruggedness to withstand the rigors of combat. 
 
Purpose Of Equipment 
 
The Simple Key Loader is a replacement item for the Army’s Data Transfer Device (DTD) that is currently 
fielded to the U.S. Army.  It will provide all the functions currently resident in the DTD along with new 
features that make management of Communications Security (COMSEC) key, Electronic Protection (EP) 
data, and Signal Operating Instructions (SOI) quicker and easier for the soldier on the battlefield. 
 
Security Information 
 
The Simple Key Loader (SKL) is a Controlled Cryptographic Item (CCI) because of the KOV-21 
Information Security (INFOSEC) card imbedded in it.  When classified database information is resident in 
the SKL, the SKL takes on the classification of the data.  The SKL is considered unclassified when no 
database or key is present in the device or the database or key is unclassified.  Refer to DA PAM 
25-380-2, Security Procedures for Controlled Cryptographic Items, for CCI safeguarding, and handling 
procedures.  Refer to AR 25-2, Information Assurance, for safeguarding the SKL when classified 
information is stored in the SKL. 
 
MAINTENANCE FORMS, RECORDS, AND REPORTS 
 
Reports of Maintenance and Unsatisfactory Equipment 
 
Department of the Army forms and procedures used for equipment maintenance will be those prescribed 
by DA PAM 750-8, The Army Maintenance Management System (TAMMS) and as contained in 
Maintenance Management Updates. 
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Reporting of Item and Packing Discrepancies 

Fill out and forward Special Form (SF) 364, Report of Discrepancy, as prescribed in Army Regulation 
(AR) 735-11-2, Reporting of Item, and Packaging Discrepancies. 
 
Transportation Discrepancy Report 

Fill out and forward SF 361, Transportation Discrepancy Report, as prescribed in 
Federal Property Management Regulation (FPMR), Code of Federal Regulations, Title 41, Chapter 101,  
Public Contracts  and Property Management.  
 
REPORTING EQUIPMENT IMPROVEMENT RECOMMENDATIONS (EIR) 
 
If your SKL needs improvement, let us know.  Send us an EIR.  You, the user, are the only one who can 
tell us what you don't like about your equipment.  Let us know why you don't like the design or 
performance.  Put it on an SF 368, (Product Quality Deficiency Report).  Mail it to:  Director, U.S. Army 
Communications Security Logistics Activity ATTN: SELCL-IA-CS, Fort Huachuca, AZ, 85613-7041.  We'll 
send you a reply. 
 
CORROSION PREVENTION AND CONTROL (CPC) 
 
It is important that any corrosion problems with SKL components are reported so that the problem can be 
corrected and improvements can be made to prevent the problem in future components.  While corrosion 
is typically associated with the rusting of metals, it can also include deterioration of other materials, such 
as rubber and plastic.  Unusual cracking, softening, swelling, or breaking of these materials may be a 
corrosion problem.  If you find a corrosion problem, it can be reported using SF 368.  The use of 
keywords such as corrosion, rust, deterioration, or cracking will help ensure the information is identified as 
a CPC problem.  Submit the form to the address specified in DA PAM 750-8. 
 
DESTRUCTION OF ARMY MATERIEL TO PREVENT ENEMY USE 
 
Destruction of Army electronics materiel to prevent enemy use shall be accomplished in accordance with 
Technical Manual (TM) 750-244-2, Procedures for Destruction of Electronic Materiel to Prevent Enemy 
Use.  Destruction will be by any means that will render the equipment unusable and un-repairable.  
Destruction should be sufficiently thorough to result in the least likelihood of reconstruction of the logic 
circuits. 
 
PREPARATION FOR STORAGE AND SHIPMENT 
 
Before placing equipment into administrative storage, operational checks will be performed and 
necessary repairs made.  Remove batteries prior to storage.  When removing equipment from 
administrative storage, an operational check will be performed to assure operational readiness. 
 
Repackaging 
Repackage the equipment using the original packaging materials in the reverse order of the original 
unpacking procedures.  If the original packaging materials are not available, the equipment shall be 
repackaged in a fast pack container conforming to PPP-B-1672.  If fast pack containers are not available, 
or the equipment is too large to fit in a fast pack, substitute packaging materials may be selected from 
those items listed in SB 746-1, Packaging Army General Supplies.  If more that one item is being 
shipped, a quantity of the repackaged items shall be over-packed within a close-fitting box. 
 
Marking for Shipment and Storage 

All repackaged items shall be marked in accordance with MIL-STD-129, Marking for Shipment and 
Storage. 
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WARRANTY INFORMATION 
 
A Warranty Service Contract has been awarded to Turtle Mountain Communications, Inc (TMCI) to 
support warranty repair or replacement services required for the AN/PYQ-10 (C).  Details of the warranty 
services are provided in Technical Bulletin (TB) 11-5810-410-24, Warranty Program for Transfer Unit, 
Cryptographic Key AN/PYQ-10 (C). 
 
NOMENCLATURE CROSS-REFERENCE LIST 
 
Table 1, Nomenclature Cross-Reference List provides common and official nomenclatures/names for 
equipment described in this manual.  Official nomenclature/names must be used when completing report 
forms. 
 

Table 1.  Nomenclature Cross-Reference List. 
 

Common Name Official Nomenclature 
Simple Key Loader AN/PYQ-10 (C) 
ACES Workstation  AN/GYK-33D 
LCMS Workstation  AN/GYK-49 (V)3 
Data Transfer Device (DTD) AN/CYZ-10 (V)3 

 
ABBREVIATIONS/ACRONYMS AND DEFINITIONS 
 
Refer to the Glossary for a list of abbreviations, acronyms, and definitions of terms useful to the SKL 
operator. 
 
 
 
END OF WORK PACKAGE 
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OPERATOR MAINTENANCE 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
 
EQUIPMENT DESCRIPTION AND DATA 
 
 
EQUIPMENT CHARACTERISTICS, CAPABILITIES, AND FEATURES 
 
The purpose of the Simple Key Loader is to replace the Data Transfer Device (DTD) that is currently 
fielded to support the Electronic Key Management System (EKMS) architecture.  The SKL will 
significantly enhance the ability of the user to utilize and distribute electronic key material, EP material, 
and SOI information.  The SKL is backward compatible with existing End Cryptographic Units (ECUs) and 
forward compatible with future equipment.  The SKL provides for the receipt, display, transmission, 
preparation, storage, and accountability of key material (to include Black Key Packages), EP material, 
and SOI information. 
 
Description Of The SKL 
 
The Simple Key Loader has been designed around the concept of the Personal Digital Assistant (PDA) 
devices that are used today by the general public.  The SKL however has been ruggedized to withstand 
battlefield conditions.  The SKL is a handheld digital computer running a Windows CE.Net operating 
system hosting the Core Library and SKL User Application Software (UAS) programs that interface with 
the Local COMSEC Management Software (LCMS) and Automated Communications Engineering 
Software (ACES) Workstations, and ECUs on the battlefield.  The technical characteristics of the SKL are 
provided in Table 1, SKL Technical Characteristics. 
 

Table 1.  SKL Technical Characteristics. 
 

ITEM DESCRIPTION 
• Computer SKL 

♦ Processor 32-bit Intel® XScale CPU (400MHz) 
♦ Operating System WindowsCE.Net 
♦ Memory 

o Storage RAM 
o Working RAM 
o ROM 

 
64MB of SDRAM 
64MB of SDRAM 
64MB of Flash Memory 

♦ User Input Dual, High Resolution Inductive Sensor Stylus Input Pens 
4 User Buttons 
4 Directional and 1 “Enter” Button 
2 Screen Brightness Control Buttons 
Power On/Off Button 
Recessed “Zeroize” Button 

• Display VGA, 65K Color Transflective HR-TFT LCD Display, 3.5” 
Diagonal LED Backlit, Manual Brightness Control, Color 
Mapping for NVG use Extended Operating Temperature LCD 
Display Module. 

♦ Resolution 240x320 pixels, 8 bit color per pixel 
♦ Graphics 2-D Accelerator for high speed image manipulation 

 
 
 
 

0002-2 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0002 
 

Table 1.  SKL Technical Characteristics. (continued) 
 

ITEM DESCRIPTION 

• Power Supply 
� Lithium-Ion Polymer Cell 

(Primary means of power.) 

Main Battery is a Waterproof, Quick-change 7.4V, with the 
following capacities: 
• Standard Capacity Battery Pack:  3680mAh @ 7.4V 
• High Capacity Battery Pack:  6600mAh @ 7.4V 
• AA Battery Pack Capacity:  2850mAh @ 12V 

 
Li-Ion “Smart” Battery Pack Fuel Gauge monitors temperature 
and battery voltage dynamically to output remaining capacity 
percentage on Windows CE.Net Taskbar. 

o Battery Operating Time 
   

o Data Holding Time 
 
 

• *High Capacity Battery > 60 operational hrs. 
• *Standard Capacity Battery > 33 operational hrs. 
• **High Capacity Battery > 60 days 
• **Standard Capacity Battery > 45 days 

 
*Exact duration depends on the specific activity the operator 
is performing. 
**Assumes SKL is not powered up or utilized in any way 
during this time frame. 

o Recharging Time >2 hrs 
♦ Battery Eliminator (Additional 

Authorized Item, but not 
issued as part of the SKL) 

The Battery Eliminator eliminates the need for batteries for 
prolonged stationary use or during times when the batteries 
are being recharged. 

♦ AA Alkaline Batteries 
(Additional means of 
powering the SKL.) 

SKL can use 8 AA quick-change Alkaline batteries that fit into 
an AA battery case. 

o Battery Operating Time > 20 operational hours. 
• Environmentals:  

♦ Non-Op Temp Range -26 to 160 oF 
♦ Op Temp -22 to 160 oF 
♦ Non-Op Humidity Range 5% to 100% 
♦ Op Humidity Range 10% to 100% 

• Card Slots 1ea PCMCIA Type II card slot. 

• PCMCIA Card Indicator Right-Angle “power on” indicator prism that reduces visual 
signature for night use. 

• SKL Case 33% Glass Fiber Composite Housing/Access Port, TPR 
Overmold.  Transparent CIK Access Door. 

• LCD Protection Hardened Polycarbonate Lens sealed and isolated from LCD 
Display for greater protection against high impact sub-
munitions. 

• Contents Security Recessed and door protected Zeroize button triggers passive 
zeroization of all key material. 

 
LOCATION AND DESCRIPTION OF MAJOR COMPONENTS 
 
The SKL has three major components.  They are the SKL, Battery, and Battery Pack Charger.  These 
components are shown in Figures 1 through 3 below. 
 
The SKL contains the Operating System (OS) software, Core Library software, SKL User Application 
Software (UAS), and the SKL Database.  It also houses the KOV-21 INFOSEC card which is CCI.  This 
card along with the Crypto Ignition Key (CIK) provides the protection for the data stored in the SKL.   
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The Lithium Ion Battery comes in two (2) different sizes.  The first is the Standard Battery and the second 
is the High Capacity Battery.  These two batteries provide the primary power for the SKL and its software 
programs as well as the KOV-21 card.  The operating time for each battery is listed in Table 1 above. 
 
The Battery Pack Charger Assembly provides the means to re-charge the batteries when they require 
charging. 
 

 
 

Figure 1.  SKL. Figure 2.  Lithium Ion Battery Pack. 
 

 
 

Figure 3.  Battery Charger Assembly. 
 
EQUIPMENT DATA 
 
The following table lists the dimensions and weights of the SKL. 
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Table 2.  Dimensions and Weights. 
 

Size 7.4” x 3.75” x 1.5” 
Weight 18.25oz without battery, 27.4oz with Li-Ion battery 

 
 
 
END OF WORK PACKAGE 
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OPERATOR MAINTENANCE 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
 
THEORY OF OPERATION 
 
 
EKMS OVERVIEW 
 
The SKL was designed as a replacement for the DTD that is currently fielded to the Department of 
Defense components.  A limited understanding of the EKMS operational environment is helpful in 
understanding the operation of the SKL.  The components of the EKMS include: 
 
EKMS Tier 0 The National Security Agency (NSA) Central Facility provides for 

production, management, and distribution of specialized electronic 
cryptographic key and associated materials. 

  
EKMS Tier 1 Tier 1 facilities serve as focal points for the production, management, and 

distribution of service-unique electronic cryptographic key and materials.  
Tier 1 facilities also provide an interface between the Central Facility and 
service EKMS Tier 2 elements and facilitate interoperability for joint 
operations at the theater and strategic levels. 

  
EKMS Tier 2 Tier 2 or LCMS Workstations perform generation, management, and 

distribution of electronic keying material to include Black Key Packages.  
The LCMS Workstation works in conjunction with the ACES Workstation 
and SKL to distribute electronic keying material to those networks with 
electronically keyed Communications Security (COMSEC) equipment. 

  
Automated 
Communications 
Engineering Software 
(ACES) Workstations 

The ACES Workstation integrates cryptonet planning, Electronic Protection 
(EP) distribution, and Signal Operating Instructions (SOI) generation, 
management, and distribution.  The ACES Workstation V1.8 will accept 
Black Key Packages from the LCMS Workstation and send the network 
planning information to the SKL to automate cryptonet control operations for 
networks with electronically keyed COMSEC equipment. 

  
EKMS Tier 3 Tier 3 or the Simple Key Loader device integrates the functions of 

COMSEC Key management, control, distribution, EP management, SOI 
management, Benign Fill, and Black Key Packages into one comprehensive 
mobile system.  The SKL will interface with the ACES and LCMS 
Workstations to receive its database information and then interface with 
End Cryptographic Units (ECUs) to upload the required keying material and 
data to those units. 

 
EKMS INFORMATION FLOW 
 
The flow of information in the EKMS architecture is straightforward.  Depicted in Figure 1, EKMS Sub-Tier 
1 Information Flow, the ACES Workstation builds the communication plan based on information received 
from the G3/S3.  Toward the end of the communication plan build, the ACES Workstation operator 
requires some keying information from the LCMS Workstation.  The LCMS Workstation operator 
generates short titles and keys based on information provided by the ACES Workstation operator.  When 
the short titles are generated, they are provided to the ACES Workstation to complete the 
communications plan.  Now the communications plan data can be downloaded to the SKL.  Once the SKL 
has the plan data, it can request electronic keys from the LCMS Workstation that will then marry up to the 
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short titles in the communications plan.  The SKL can then load the End Cryptographic Units with 
electronic keys based on the communication plan. 
 
 

Distributes Electronic Keys 
and Data to ECUs 

Key Requirements

Short Title Information / 
Black Key Packages 

ACES Workstation 
generates the 
communications plan 
based on data 
supplied by the 
G6/S6. 

Plan Data

Electronic Keys 
Distributed as 
Needed 

SKL stores the 
Plan Data and 
requests keys 
from the LCMS 
Workstation as 
needed. 

LCMS Workstation 
generates the short 
titles and electronic 
keys based on 
information supplied 
by the ACES 
Workstation. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1.  EKMS Sub-Tier 1 Information Flow. 
 
SKL ARCHITECTURE OVERVIEW 
 
The hardware platform that hosts the SKL software (including the Secure Library) is a vendor-supplied 
ruggedized Personal Digital Assistant (PDA) device equipped with a KOV-21 Personal Computer Memory 
Card International Association (PCMCIA) card.  There is no hard drive in the SKL.  All programs are 
stored in non-volatile Flash Memory.  The SKL memory is divided into the following three physical types: 
 

• Flash Memory (64MB, Non-Volatile Memory):  The Flash Memory contains the Bootloader and 
Operating System (OS) images as well as application and support software.  The contents of 
Flash Memory are not deleted during loss of power or zeroization.  The Flash Memory has two 
partitions:  a binary partition to allow for system start-up, and a File Allocation Table (FAT)-based 
file system where updateable software is stored.   

 
• Storage Memory (64MB SDRAM):  The Storage Memory is battery-backed volatile Synchronous 

Dynamic Random Access Memory (SDRAM).  Power remains applied to Storage Memory unless 
the battery power expires (excluding a short hold-up time to allow for battery replacement) or the 
Zeroize button is activated.  Storage Memory contains data that is to be maintained between SKL 
shutdown and start-up, but deleted upon zeroization.  Storage Memory contains the encrypted 
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database and an Advanced Encryption Standard (AES) Key Checkword in a Direct Memory 
Access (DMA) file system. 

 
• Working Memory (64MB SDRAM):  The Working Memory is battery-backed volatile SDRAM.  

The contents of the Working Memory are lost when battery power expires, when the SKL is 
powered off, or when the Zeroize button is activated.  Working Memory is logically partitioned into 
Working Memory for general operations and a FAT-based file system.  Working system data files 
are stored in the Working Memory FAT-based file system.  During system start-up, the encrypted 
database in Storage Memory is decrypted and placed in this file system. 

 
The SKL memory architecture is shown in Figure 2, SKL Memory Architecture, below. 
 

Physical Description Logical Description 
  
64 MB Flash Memory 
Non-Volatile 

Partition 1 (approximately 22MB) 
 
This partition contains the Bootloader Image and OS Image. 

 Partition 2, FAT File System, (approximately 42MB) 
/Flash 
 
This partition contains the executables to start the Secure 
Library, Core Library, Registry, and SKL CE programs. 

  
64 MB Storage Memory 
Power removed upon 
zeroization 
 

FAT File System (64MB) 
/Storage 
 
This file system contains the Encrypted Database and the 
AES Init Checkword. 

  
Working Memory (approximately 50MB) 
 
This area of Working Memory is for general operating system 
usage. 

64 MB Working Memory 
Power removed upon 
zeroization or power-
down 

FAT File System (approximately 14MB) 
/Working 
 
This area of Working Memory is where the Unencrypted 
Database is stored. 

 
Figure 2.  SKL Memory Architecture. 

 
KOV-21 INFOSEC CARD 
 
The KOV-21 provides Type I encryption/decryption services and provides the secure interface between 
the host computer and interfacing devices.  The SKL uses an embedded KOV-21 approach.  As such, the 
National Security Agency (NSA) requires that a Crypto Ignition Key (CIK) be used to lock and unlock the 
KOV-21 INFOSEC card. 
 
The KOV-21 has the following states: 
 

• Power-Up • Mismatched • Operations 
• Un-initialized • Split Update • Alarm 
• Initialized • New PIN • Zeroized 
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CRYPTO IGNITION KEY (CIK) 
 
The CIK is a separate, removable, non-volatile memory device designed to protect internal SKL keys 
and/or data from physical compromise when the SKL is in an unattended, non-secured environment.  
When the CIK is removed from the SKL, the KOV-21 card cannot be unlocked.  Therefore, access to the 
data is denied.  The absence of the CIK prevents the use of SKL operations. 
 
SKL INFORMATION FLOW 
 
There are three different information flows that are explained in the following paragraphs.  The first one is 
the way information flows within the SKL during normal use.  The second is the Receive information flow 
and the third is the Transmit information flow. 
 
SKL Database Information Flow 

When the SKL is first powered up certain functions start.  After logon and the initiation of the SKL UAS, 
the resident Mission Database is opened.  The way in which the Mission Database becomes useable to 
the operator is depicted in Figure 30, SKL Database Information Flow.  Use this figure to follow the 
description in the following paragraph.  
 
This description starts at power up and ends at power down.  Once the Power button is depressed the 
SKL starts the boot routine.  As part of the boot up the system checks to see if there is a valid CIK 
present so that the KOV-21 can be unlocked (1).  Once the operator has logged on and the SKL UAS is 
started, the resident database is called from Storage Memory and decrypted (2).  The decrypted 
database is then sent to Working Memory (3).  From Working Memory the database is available to the 
SKL UAS and is viewable on the SKL display (4).  When the SKL operator is finished making any desired 
changes or is finished viewing the database he exits the SKL UAS program causing the database in 
Working Memory to be encrypted by the KOV-21 (5).  The database is then sent to Storage Memory (6).  
When the user logs out of the Core Library the KOV-21 is then locked by the CIK (7).  The SKL can then 
be powered down. 
 
 

KOV-21 
INFOSEC CARD 

1

Storage Memory

Working Memory

5

3

6 2

4     SKL UAS 
 
  SKL Display 

Valid 
CIK 

 
 
 
 7
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 3.  SKL Database Information Flow. 
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SKL Receive Information Flow 

The Receive Information Flow within the SKL is depicted in Figure 4.  SKL Receive Information Flow.  
Use this figure to follow the description in the following paragraph. 
 
This description assumes that the SKL is powered up and the operator is logged on and the SKL UAS is 
open and ready for work.  Once a receive operation is initiated with the SKL UAS and the SKL is 
connected to an ACES or LCMS Workstation via the Fill Port (1) to receive information and/or key.  It then 
goes to the KOV-21 (2).  The KOV-21 encrypts the data and sends it to Storage Memory (3).  The 
database is then moved from Storage Memory back to the KOV-21 (4).  The KOV-21 decrypts the data 
and sends it to Working Memory (5).  The data is then displayed on the SKL Display (6).  The operator 
may now utilize the data as necessary to complete the assigned mission. 
 
 

KOV-21 
INFOSEC CARD 

Valid 
CIK 

Storage Memory

Working Memory

    SKL UAS 
 
  SKL Display 

6

5

3 4

2

1
ACES or LCMS Workstation

Fill Port

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4.  SKL Receive Information Flow. 
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SKL Transmit Information Flow 

The Transmit Information Flow within the SKL is depicted in Figure 5, SKL Transmit Information Flow.  
Use this figure to follow the description in the following paragraph. 
 
This description assumes that the SKL is powered up and the operator is logged on and the SKL UAS is 
open and ready for work.  Once a transmit operation is initiated with the SKL UAS the information to be 
transmitted is selected (1).  The information is sent to the KOV-21 (2).  The KOV-21 then sends the 
information to the Fill Port (3) where it is then sent to the ECU (4) via a Fill cable.    
 
 

KOV-21 
INFOSEC CARD 

Storage Memory

Working Memory

    SKL UAS 
 
  SKL Display 

2

1 

3

4

ECU

Fill Port

Valid 
CIK 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 5.  SKL Transmit Information Flow. 
 
 
 
 
 

0003-7 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED/FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0003 
 
MISSION DATA ORGANIZATION WITHIN THE SKL 
 
The Mission Data organization in the SKL is not the same as it is in the DTD.  As stated earlier, the SKL 
uses a Windows CE.Net operating system with the Core Library and SKL User Application Software 
(UAS) loaded on it.  The mission data is organized very similar to how data is displayed in the Windows 
Explorer program.  It uses tree structures with tabs as shown in Figure 6 through Figure 9 below.  The 
Mission Data organization concept as depicted in the below figures needs to be understood so that you 
can accomplish your mission in the most timely and correct manner.  This concept starts with the 
Platform.   
 

  
Figure 6.  Plats Tab Expanded. Figure 7.  Eqs Tab Expanded. 

  
 

  
Figure 8,  Keys Tab Expanded. Figure 9.  SOI Tab Expanded. 

  
 
Platform Mission Data 

As depicted in Figure 6 above, the first Platform depicted is named "AH-64 APACHE".  Assigned to this 
Platform are the names of three pieces of equipment.  They are RT2 KY58, RT2 ARC201A, and TOC 
PLGR001.  Under each piece of equipment there are Fill locations that may need to be filled with data 
and COMSEC key.  In Figure 6 above, the equipment RT2 KY58, has been expanded to show the Short 
Titles of the key assigned to LOC1, LOC2, LOC3, and LOC6.  Therefore, if you wanted to load key into 
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locations 1, 2, 3, and 6 of the RT2 KY58, you would simply select the equipment from the expanded 
Platform tab and then select File→Transmit→Load, or tap on the Load Icon and the process would be
automatic.  The necessary data for the RT2 KY58 equipment under the Platform AH-64 Apache would b
pulled from the database and transmitted to the RT2 KY58.  Under this scenario, you would not need to 
know anything else other than the Platform name and the name of the equipment.  
 

 
e 

quipment Mission Data 

s depicted in Figure 7 above, the Equipment Tab is open showing just the equipment and assigned 
 

n 

ey Mission Data 

s depicted in Figure 8 above, the Keys Tab is open showing the Short Title, Edition, and Segment of the 

ct 
y 

y 

OI Mission Data 

s depicted in Figure 9 above, the SOI Tab is open showing the 1-12th INF-STD Group expanded to 
 

SSIGNED VERSUS UNASSIGNED KEY 

he SKL Mission Data can contain keys that are either assigned to equipment fill locations or are not 

or 

ve 

hen you select File→Transmit→Load, to load equipment, you are loading equipment with key that has 
 

hen you select File→Transmit→Load Selected Key to load equipment, you can be loading equipment 

 

E
 
A
keys.  This tab is very good at allowing you to see all the equipment and assigned keys that are in the
database.  You may from this window select equipment and then select File→Transmit→Load, or tap o
the Load Icon and the process of loading the equipment with key would be automatic.  However, there is 
one drawback using this procedure.  That is, you must know which Platform the equipment is assigned to 
first to ensure that you are loading the correct equipment associated with the correct Platform.  Therefore, 
if you are going to load equipment using the File→Transmit→Load procedure, you should always be on 
the Platform tab with the equipment you want to load highlighted. 
 
K
 
A
keys that are currently in the Mission Database.  These keys can be either assigned to individual pieces 
of equipment or unassigned, meaning that they are not assigned to a piece of equipment and can be 
transmitted and/or loaded to equipment by selecting File→Transmit→Load Selected Keys.  There is 
danger in performing this type of loading operation.  First, you have to make sure you select the corre
Short Title for the equipment location that you are attempting to load.  Second, you must know thoroughl
how to load the equipment because no Profile window will step you through the process.  Finally, if you 
select the wrong Short Title and load it into the wrong equipment fill location, that piece of equipment ma
not be able to communicate with other equipment in its net.  This Technical Manual will address the 
differences between Assigned and Unassigned Key below. 
 
S
 
A
show the first 5 Time Periods.  The tab also will show you the Pyro, Smoke, and any Quick References
that you may have added to the Quick Reference folder.  There are various ways to view the SOI data.  
These are addressed later in this TM. 
 
A
 
T
assigned to any equipment.  This distinction is very important.  If you have unassigned keys in your 
database, it means that you either created one from some device that has key generation capability, 
you loaded the SKL with a key from another device such as a KYK-13, DTD, or KYX-15.  In either case, 
you may have violated your local COMSEC rules.  COMSEC key generation should only be done with 
your COMSEC Custodian's permission so accountability is maintained.  This is why you should only ha
assigned keys in your Mission Database.  This is not to say that there may be circumstances that will 
require you to have unassigned key in your database.  But those instances should be rare. 
 
W
been assigned to specific fill locations on the equipment you selected.  This is the way you should always
load key into equipment. 
 
W
with assigned or unassigned key.  The danger is that you need to know exactly which key to select from 
the Keys Tab to load into a specific equipment fill location.  If you get it wrong, then that radio may not be
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able to communicate.  The other drawback to this type of loading procedure is that you don't get a Profile 
window to help you load the equipment.  This TM will have specific loading instructions for both Assigned 
and Unassigned Key in Chapter 2.  These two loading procedures are named Load and Load Selected 
Key.  Load is associated with Assigned key and Load Selected Key is associated with Unassigned key. 
 
Knowing how to load key into equipment is half the battle.  The easiest way to remember how to load key 

 the key(s) were received into the SKL using the File→Receive→Key Needed operation, then the key(s) 

 

 the key(s) were received into the SKL using the File→Receive→Key operation, then the key(s) received 

ATABASE MANAGEMENT 

he SKL gives the user the ability to create Platforms, Equipment, and Key Tags.  It also will allow you to 

w an 

EY TAG CREATION 

he SKL gives the user the capability to create a new key tag and then assign it to equipment.  Once the 

 

ENERIC PROCEDURES 

he SKL UAS provides a Generic selection when attempting to perform an Over the Air Distribution 
sed 

emember that you should always select your OTAD equipment from the Select Equipment window if it is 

is to remember how the key was put into the Mission Database in the first place. 
 
If
received in this fashion are assigned to specific Fill locations on specific equipment.  These keys should 
be loaded using the File→Transmit→Load selection.  This loading procedure is defined in Work Package
0014. 
 
If
in this fashion are not assigned to specific fill locations on specific equipment.  These keys should be 
loaded using the File→Transmit→Load Selected Keys selection.  This loading procedure is defined in 
Work Package 0015.  Or the keys can be assigned to specific fill locations on specific equipment and 
then you can use the File→Transmit→Load selection. 
 
D
 
T
assign Equipment to Platforms and Key Tags to Equipment.  You can also edit Platforms, Equipment, and 
Key Tags, as well as unassign Key Tags from Equipment and Equipment from Platforms.  The totality of 
this is called Database Management.  These functions provide for greater flexibility when dislocated from 
the ACES and LCMS Workstations.  The user can now manipulate the database to fit changing mission 
requirements.  The procedures to perform these tasks are located in multiple different paragraphs 
throughout Chapter 2.  However for convenience, Work Package 0024 has been constructed to sho
SKL operator the entire creation and assignment process in one procedure.   
 
K
 
T
assignment has been made the user can use the Key Needed procedure located in Work Package 0017 
to obtain the actual key.  Remember you should have permission from the COMSEC custodian to use this
procedure prior to creating a key tag.  Accountability for COMSEC key is paramount and should not be 
violated except in very unusual circumstances.  The procedure to create a new key tag is contained in 
Work Package 0021. 
 
G
 
T
(OTAD) Manual Rekey (MK) or Automatic Rekey (AK) procedure.  This Generic selection should be u
if the equipment you are attempting to perform an OTAD MK or AK on is not listed in the Select 
Equipment window.  The Generic selection will work with most DS-101 and DS-102 equipment. 
 
R
listed.  Otherwise select Generic.  However, remember that if you should select Generic, that you must 
understand all the equipment settings and procedures required to perform an OTAD procedure.  You 
should have the TM for that piece of equipment available when the OTAD procedure is performed. 
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HOST (SYSTEM) TIME/DATE VERSUS KOV-21 CARD TIME/DATE 
 
In the Simple Key Loader (SKL) the Host time is very important in that it is the time that is used when 
loading time to certain ECUs (i.e., SINCGARS, AN/PSC-5, ARC-201D, etc).  When using the Date Load 
feature of the SKL to load keys, the Host date is used not the KOV-21 card date.  The only procedure that 
uses the KOV-21 card time/date is the Audit Trail in Core Library.  The SKL with SKL UAS V4.0 software 
shows the date or time in the taskbar of the Windows CE.Net operating system (OS).  This is explained 
further in Chapter 2 of this Technical Manual.  The Host date/time cannot be changed by the Host 
Operating System (OS) program.  It can only be changed by changing the KOV-21 card date/time. 
 
Accordingly, software has been written that allows the Host time/date to sync up with the KOV-21 card 
time/date.  There are two ways this is accomplished.  Initially upon power-up the Host time/date is synced 
to the card time/date.  Secondly, once the SSO has set the KOV-21 Card time/date using the procedures 
in Work Package 0007 then a user can manually tell the system to have the Host time/date sync with the 
KOV-21 card time/date using the procedure in Work Package 0007. 
 
It is very important that when loading an ECU radio net including time from multiple SKLs, that each SKL 
has the KOV-21 card time in sync with the other SKLs for the mission.  Since the Host time is supposed 
to be in sync with the KOV-21 card time, each radio that is loaded in the net when time is also loaded 
should be able to communicate. 
 
 
END OF WORK PACKAGE 
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OPERATOR MAINTENANCE 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
 
DESCRIPTION AND USE OF OPERATOR CONTROLS AND INDICATORS FOR THE SKL 
 
 
DESCRIPTION AND USE OF OPERATOR CONTROLS AND INDICATORS FOR THE SKL 
 
The features that come with the standard SKL are many and varied.  Figure 1, SKL Device Controls and 
Indicators and Figure 2, Navigation/Control Panel, call out each feature on the SKL. 
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Figure 1.  Controls and Indicators. 
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Figure 2.  Navigation/Control Panel. 

 
Table 1, SKL Controls and Indicators Description, defines the features and what they are used for. 
 

Table 1.  SKL Controls and Indicators Description. 
 

FEATURE EXPLANATION 
Fill Port The Fill Port is a standard 6-pin fill connector used on the DTD 

and other communications devices.  A standard Fill Cable is used 
to connect the SKL to other COMSEC equipment.  The Fill Port is 
located on the top of the SKL. 

  
Zeroize Button Pressing the Zeroize button activates the Zeroize function.  

Zeroization is immediate. 
  

Power This button controls the SKL power.  When the Power button is 
depressed, the SKL is powered-on.  When the SKL is powered-on 
and the Power button is depressed the SKL shuts down. 

  
Inductive Stylus (2ea) The Inductive Stylus is used to make selections on the Windows 

CE operating system, Core Library, and the SKL UAS.  The 
Stylus uses an inductive coil.  This means that you can lay your 
arm or hand on the screen and it’s not going to cause any 
problems.  The SKL does not use a touch screen; rather it uses 
an active display technology that must have the special stylus to 
make selections. 

  
Crypto-Ignition Key (CIK) Access The CIK Access area allows the operator to remove or replace 

the CIK.  The CIK is used to control access to the secure domain 
(KOV-21 INFOSEC card).  The SKL cannot be operated without a 
CIK. 

  
5-Way Control Buttons At the bottom center of the SKL are the 5-way Control Buttons.  

These buttons are used to navigate the menus of the SKL. 
  
Brightness Controls There are two buttons below the 5-way Control Buttons.  The one 

on the right will increase the screen brightness and the one on the 
left will decrease the screen brightness. 
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Table 1.  SKL Controls and Indicators Description. (continued). 
 

FEATURE EXPLANATION 
General Purpose Buttons (1-4) Just above the 5-way Control Buttons are four buttons aligned 

from left to right.  These buttons are pre-programmed by the 
manufacturer to perform certain actions.  Button 1 is set up to 
open the Start Menu, Button 2 opens the selected application 
menu, Button 3 places the device into Night Vision mode, and 
Button 4 activates Mouse mode. 

  
KOV Light When this light is steady on, it means that the KOV-21 card is 

powered on and working properly.  If it is blinking, there could be 
a potential problem with the KOV-21 card. 

  
Battery Pack The battery pack can be one of two different types.  The first type 

and preferred battery pack is the Lithium-Ion Polymer Cell.  There 
are two types of Li-Ion Battery Packs.  They are High Capacity 
and Standard Capacity batteries.  The second type is an AA 
Battery Container that holds 8 AA Alkaline batteries. 

  
Battery Pack Screw This screw is used to remove the battery pack and to secure the 

battery pack to the SKL housing.  This screw was recently 
replaced on the High Capacity Battery Pack to allow the user to 
better tighten the Battery Pack to the SKL.  The longer screws 
were shipped to the locations the SKLs were shipped originally. 

  
USB Ports There are two types of USB ports on the SKL.  There is a Mini-B 

which is the one located toward the bottom of the SKL.  It is used 
for an ActiveSync connection to a PC.  The USB port above the 
Mini-B is a Mini-A which can be used to connect an external 
keyboard, mouse, or mass storage device. 

 
AN/PYQ-10 (C) Simple Key Loader Operator Interfaces 
 
The operator may interface with the SKL in the following ways: 
 

• Navigation and Control Buttons Interface 
• Fill Port Interface 
• Inductive Stylus Interface 
• Virtual Keyboard Interface 
• Zeroize Button Interface 
• Crypto Ignition Key Interface 
• USB Interfaces 

 
Each of these specific operator interfaces will be explained in this Work Package. 
 
Navigation/Control Buttons Interface 

The Navigation and Control buttons are located on the bottom front of the SKL as shown in Figure 3, 
Navigation/Control Panel, below.  There are several buttons that make up the Navigation and Control 
panel.  The numbered Control Buttons, when pressed, perform specific functions.   
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Figure 3.  Navigation/Control Panel. 

 
1. Control Button 1 will open the Start Menu.  Use the following to open the Start Menu. 
 

a. To open the Start Menu in Windows CE.Net, press Control Button 1.  The window in Figure 4, 
Start Menu, opens. 

 

 
 

Figure 4.  Start Menu. 
 

b. Now you can use the Up/Down, Left/Right, and Open/Enter buttons to navigate through the Start 
Menu.  Once you are finished with the Start Menu, press the Control Button 1 again to close the 
Start Menu. 

 
2. If you are in the SKL UAS program and want to accomplish some action that is initiated from one of 

the main menu selections, you can use the Control Button 2 to highlight and open the first main menu 
selection.  This button functions like the Alt key on a windows keyboard.  Use the following to activate 
a selected application’s menu structure. 

 
a. If you have pressed Control Button 1 just before you press Control Button 2 you will have to 

activate the SKL UAS Desktop again by clicking on something on any of the tabs.  Once you do 
that then press Control Button 2 again.  The main menu as shown in Figure 5, SKL UAS Main 
Menu from Button 2, will open. 
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Figure 5.  SKL UAS Main Menu from Button 2. 

 
b. When button 2 is depressed as described in the previous paragraph, the File menu opens.  You 

can use the Up/Down, Left/Right, and Open/Enter buttons to navigate through the File menu.  
Once you are finished with the File Menu, press the Control Button 2 again to close the File 
Menu. 

 
3. There are times in the performance of the mission when you must operate the SKL at night.  To help 

you in your nighttime SKL operations, provisions have been made to turn the display into Night Vision 
Goggles mode.  When you press Control Button 3 your display will change to Night Vision Goggles 
mode.  To return to normal display mode, press Control Button 3 again. 

 
4. Control Button 4 when pressed activates the Mouse Mode for the SKL.  This means that once 

Control Button 4 is pressed the mouse arrow that is normally controlled by the Inductive Stylus alone, 
is now controlled by the Navigation Buttons and the Stylus.  With the Mouse Mode turned on you 
don’t need to use the Stylus to make selections.  When the Mouse Mode is turned on you will see the 
Navigation Icon on the Taskbar of the Windows CE.Net OS.  To exit the Mouse Mode, press Control 
Button 4 again. 

 
5. There are two (2) Brightness Control buttons on the Navigation/Control Panel.  These are indicated 

by a dark sun and light sun.  If you want the display darker, press and hold the black sun button until 
the display is to your liking.  If you want the display brighter (lighter), press and hold the white sun 
button until the display is to your liking. 

 
6. There are four (4) Navigation Buttons.  These buttons allow you to navigate left, right, up, and down 

menu selections and the tabs in the SKL UAS program.  They are also used to move the mouse 
arrow when in Mouse Mode.  The center button in the Navigation area is the Open/Select button.  
Once you have highlighted the selection you want using the Navigation buttons, you can select it by 
pressing on the Open/Select button. 

 
END OF TASK 
 
Fill Port Interface 
 
The Fill Port is located on top of the SKL and covered by a urethane protector.  It receives a standard Fill 
cable that allows for the transfer of database information and key to a receiving device or from a 
transmitting device.  It also will accommodate a specially designed RS-232 Cable that will connect to a 
workstation to receive database information.  The Fill Port provides a direct connection to the KOV-21 
INFOSEC card.  The SKL Fill Port is shown in Figure 6, Fill Port. 
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NOTE 
 

It is recommended that the O-rings in these cables be lubricated with silicon so 
that the locking connection can be made with the Fill Port more easily and without 
damaging the Fill Port internally. 

Fill Port 

 
Figure 6.  Fill Port. 

 
Inductive Stylus Interface 
 
The SKL is supplied with two (2) Inductive Styli that are the primary means for operator interaction with 
the SKL.  The stylus is used for logging on to the SKL, navigating menu structures and tabs, and initiating 
data transfer actions on the SKL.  Inductive touch-panel technology creates a magnetic field above the 
display's surface and can then detect changes in this field when a special pen with passive circuitry is in 
range.  The pen's position can be detected even when it is above the surface of the panel so that 
hovering and variable pressure effects can be used as part of the user interface. 
 

 
Figure 7.  Inductive Stylus. 
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Calibrating The Inductive Stylus 
 
Through use, over time, the Inductive Stylus can become un-calibrated which leads to difficulty in 
selecting items that are in close proximity to each other.  When this happens, the Inductive Stylus will 
have to be re-calibrated.  There is a calibration program on the Windows CE.Net Desktop for stylus 
calibration.  You can open this program two different ways.  The first is to select 
Start→Programs→Calibrate.  The second way is if you are already on the Windows CE.Net Desktop, 
just double-tap on the Calibrate icon.  The following steps will lead you through the calibration process. 
 
1. On the Windows CE.Net Desktop there is a “Calibrate” icon.  Double-tap on the Calibrate icon.  The 

window in Figure 8, Calibrate, opens. 
 

NOTE 
 

To effectively calibrate the stylus, make sure that you hold the stylus straight up 
and down so that the exact point of the stylus is centered on the cross hairs. 

 

Figure 8.  Calibrate. 
 

. Follow the directions on the window.  First place the point of the stylus on the target in the upper left 

 
ND OF TASK 

irtual Keyboard Interface 

he SKL uses a Virtual Keyboard for its data entry.  The Virtual Keyboard is unique to the Windows 
s 

y, 

.  

 

2
of the window.  The window will then change.  Then place the point of the stylus on the target in the 
lower right of the window.  This action will calibrate the stylus.  The Calibrate window will close 
automatically.  You may have to perform this operation several times to get the stylus perfectly 
calibrated.  The new stylus on the V2 SKL is much more responsive. 

E
 
V
 
T
CE.Net operating system.  Since the Windows CE.Net OS is generally used on small footprint device
such as the SKL, which are normally not equipped with a hardware keyboard to accommodate text entr
a virtual (software generated) keyboard is used.  It is located in the Taskbar of the Windows CE.Net 
operating system.  Tapping on the Keyboard icon with the Inductive Stylus can activate this keyboard
Figures 9 and 10 below show the two keyboards depending on whether or not the CAPS key is toggled 
on or off. 

0004-8 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0004 
 

 
Figure 9.  Virtual Keyboard Lower Case. 

 
Figure 10.  Virtual Keyboard Upper Case. 

 
Zeroize Button Interface 
 
The Zeroize button is Red with a Z embossed on it and is located on the top of the SKL just to the right of 
the Fill Port.  A swivel cap protects the Zeroize button so that it cannot be accidentally depressed.  
Depressing the Zeroize button causes the KOV-21 INFOSEC card to begin a zeroization process of the 
SKL UAS mission data.  Once this process is started it cannot be stopped.  To Zeroize the KOV-21 
INFOSEC card, swing open the swivel cap and depress and hold down the Red Button for more than 1 
second.  Zeroization is immediate!  See Figure 11, Zeroize Button Location. 
 

Figure 11.  Zeroize Button Location. 
 

rypto Ignition Key (CIK) Interface 

-hand side of the SKL toward the bot own in Figure 12, 
 

remove the CIK, no one can access that data.  Work Package 0035 describes the CIK insertion process. 

Zeroize 
Button 

 

C
 

he CIK interface is located on the rightT tom as sh
CIK Location.  It is covered by a hinged door and has O-Rings that provide a barrier to the elements.  The
CIK is the hub around which the SKL revolves.  If the SKL does not have a CIK installed the SKL cannot 
be used since the CIK locks and unlocks the secure domain (KOV-21).  Therefore, it is of the utmost 
importance that the CIK be protected from damage and loss.  If you have data in your SKL and you 
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CIK 

 
 
 
 
 
 
 
 
 
 
 

Figure 12.  CIK Location. 
 
Universal Serial Bus (USB) Interfaces

.  They are located under the hinged door on the right side of 
e SKL just below the CIK.  The lower USB port is a mini-B and is used for an ActiveSync connection to 

e 

 
 

Figure 13.  USB Locations. 

WINDOWS CE.NET TASKBAR 

very similar to the taskbars on other Microsoft Windows operating 
ystems.  However, there are some differences that make this taskbar unique.  The taskbar features will 

 
 
There are two USB interfaces on the SKL
th
a PC.  It will be disabled for the production units.  The USB port above the mini-B is a mini-A, and can b
used for connections to an external mouse, or a mass storage device (for upgrading the SKL software).  
However, writing to a mass storage device has been disabled.  See Figure 13, USB Locations, below for 
the exact location of the USB ports. 

mini-A USB Port 

mini-B USB Port 
 

 

 
The Windows CE.Net Taskbar is 
s
be described below. 
 

 
 

Figure 14.  Windows CE.Net Taskbar. 

As you can see from the figure a skbars that you have seen on 
ther Windows operating systems.  However, there are subtle differences that will be pointed out to you in 

the next several paragraphs. 

 
bove the Taskbar looks similar to other ta

o
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Figure 15.  Start Button Icon. 
 

he Windows logo that is circled above is really the Start button.  It functions just like any other Start 
button on any other Windows taskbar
T

. 
 

 
 

Figure 16.  Active Program Icon. 
 

 Figure 16, the circled area will change depending on what program you have opened.  The depicted 
circled area indicates that the SKL 

 

In
UAS program is open. 

 
 

Figure 17.  Caps Lock. 
 

In Figure 17, when the Virtual Keyboard is open and the CAPS key is reverse video (black), the "A" will 
appear on the Taskbar in the position sh e until the CAPS key is toggled to 
lower case.  The Caps indicator will stay on the Taskbar even if you close the Virtual Keyboard. 

 

 
he circled area indicates the amount of battery power still available as a percentage of capacity for SKL 
perations.  At very low power, a Battery Warning Dialog box will appear alerting you it is time to exit all 

programs gracefully and power d g box by tapping on the X.  The 
arning Box will appear every 30 sec charge the battery, or convert 

ow above.  It will stay ther

 

  

Figure 18.  Battery Capacity Icon. 

T
o

own the SKL.  You may close this dialo
W onds until you replace the battery, re
to direct current from an electrical outlet. 
 

 
 
 
 
 

Figure 19  Time/Date Icon. 

he two taskbars pictured efault and shows the time 
 include incrementing seconds.  If you double tap on the time icon it will change to the date as shown in 

the second graphic above.  The time/d brary.  The Date/Time 
ature is further described later in Work Package 0007. 

  

 

 

 
T  above show the time and date.  The top one is the d
to

ate can only be set from within the Core Li
fe
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Figure 20.  Virtual Keyboard Icon. 
 
This is a feature that you would not normally find on any other Windows o

eyboard.  When you tap on this icon the Virtual Keyboard appears.  You can then tap on the keys to 
enter usernames, passwords, fill in ay be required during mission 
perations.  To close the Keyboard, tap on the keyboard icon again. 

perating system.  It is a Virtual 
K

 information, or any other data that m
o
 

 
 

Figure 21. Program Switching Icon. 
 
Since the Taskbar on the SKL is so small the way in which the program switching occurs is a little 

ifferent than the way a standard Windows computer would handle this.  On standard taskbars the actual 
program icon is displayed in the ta s opened each icon is displayed 

nd you can just click on the icon you wish to make that program active.  On the SKL Taskbar it is 
rams 

d
skbar and if you have multiple program

a
handled differently.  The area depicted in the circle when tapped on will display a list of active prog
that can be selected.  There are three programs that can be selected when all of them are open.  They 
are SKL Desktop, Core Library, and SKL UAS.  Simply select the program desired. 
 

 
 

Figure 22.  4-Way Button Control Icon. 
 
When this icon appears in the taskbar it indicates that you have depresse eral Purpose Button 4 at 

e bottom of the SKL screen.  When this button is depressed the Icon appears and the 4-Way Mouse 
Control Buttons are active.  You our styli are not working, lost, 
r broken.  To get rid of this icon, simply depress Button 4 again and it will go away. 

d Gen
th

 would generally use these buttons when y
o
 

 
 

Figure 23.  USB Connection Icon. 
 
When this icon appears in the taskbar it indicates that you have connected an USB device such as a 
ump/Flash Drive to the mini-A port.  This icon will go away when you have removed the USB device from 

the port. 

 Fuel Gauge icon is displayed in the task bar to indicate remaining battery capacity.  It ranges 
om 100% to 10%, in 10% increments as shown in Figure 24, Windows CE.Net Taskbar, below.  After 

til 1% is reached.  These increments change color as the 
mount of battery life diminishes.  It goes from green to yellow at 40% and from yellow to red at 10%.  It is 

n 
n 

J

 
Battery Fuel Gauge, Warnings, And Events   
 
A Battery
fr
10% it starts to count down in 1% increments un
a
highly recommended that when the battery capacity reaches the red area, that the SKL be powered dow
normally and the battery replaced with a fully charged battery.  Failure to follow this advice could result i
the loss of data and/or operational capability. 
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Figure 24.  Windows CE.Net Taskbar. 
 
A Low Battery Warning Dialog is displayed as depicted in Figure 25, Main Batteries Very Low, when the 
battery capacity reaches just 2% of capacity as depicted above. 

 
Figure 25.  Main Batteries Very Low. 

 
A Critical Low Battery Event Power Down Logout is generated when the battery capacity reaches 1% 
remaining.  This Critical Low Battery Power event triggers the applications on the SKL to automatically 
shutdown, and the security application eventually calls on the SKL to power itself down. 
 
Battery Removal 
 
The procedure to remove the battery from the SKL is the same whether the SKL is a V1 or V2 hardware 
device.  On either SKL, when the Power Push button is depressed and the screen goes black, you must 
wait for at least 30-45 seconds before removing the battery.  This is necessary to allow time for the SKL 
to finish processing and shutdown gracefully. 
 
 
END OF WORK PACKAGE 
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
WINDOWS CE.NET SOFTWARE OVERVIEW: 
 
 
SKL SOFTWARE OVERVIEW 
 
The SKL that is fielded to the U.S. Army has four basic software packages installed.  These are the 
Windows CE.Net operating system software, the Core Library program, the SKL UAS program, and SKL 
Database program. 
 
SKL SOFTWARE VERSIONS 
 
The version numbers for the information cited in this Technical Manual can be found in the following 
table, Table 1, SKL Software Version Numbers, below.  All references to any of the software products 
loaded on the SKL that appear in this Technical Manual will assume to be the versions listed in the table. 
 

Table 1.  SKL Software Version Numbers. 
 

SOFTWARE VERSION 
Windows CE.Net 4.20 
Core Library 2.0 
SKL UAS 4.0 
SKL Database 2.33 

 
WINDOWS CE.NET OVERVIEW 
 
The Windows CE.Net is a componentized Operating System (OS) used to create customized embedded 
devices.  It belongs to the Microsoft family of embedded operating systems.  Designed from the ground 
up with embedded devices in mind, Windows CE.Net combines an advanced, real-time operating system 
and powerful tools for rapidly building the next generation of smart, connected, and small footprint 
devices such as the SKL.  Built on its own code base, different from the desktop, Windows CE.Net 
provides a componentized, customizable, embedded OS that offers rich configuration and application 
options for the Simple Key Loader. 
 
Although the Windows CE.Net operating system software offers many networking and communications 
features, most if not all of them will not be available on the SKL.  This is because the SKL is used 
uniquely in the U.S. Army to meet the security requirements of its operational role.  The desktop of the 
Windows CE.Net operating system is very similar to the other Windows operating systems that you are 
acquainted with as shown in Figure 1, Windows CE.Net Desktop, below.  It is just smaller because of the 
screen size of the SKL. 
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Figure 1.  Windows CE.Net Desktop. 
 
As can be seen in the above figure, there are only three icons on the desktop.  The Calibrate Icon will 
allow you to calibrate your Inductive Stylus.  The Core Library Icon will take you to the Core Library 
program, and the SKL Settings icon will allow you to set some of the SKL controls to your particular taste. 
 
WINDOWS CE.NET FEATURES 
 
Some of the more visible Windows CE.Net features on the SKL are standard to Windows operating 
systems while others are unique to the Windows CE.Net OS.  They are explained below: 
 
Start Button 

The Start button on the SKL Windows CE.Net Operating System acts the same way as all other Windows 
operating systems.  It may have fewer selections than most but the selections it does have should be 
familiar to you.  If you tap on the Start button, the window in Figure 2, Start Button Selections, opens. 
 

 
 

Figure 2.  Start Button Selections. 
 
1. As can be observed in the figure above, you will only get one (1) selection when tapping on the Start 

button.  That is Programs.  If you select Programs you will get a window similar to the one in 
Figure 3, Programs, below. 
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Figure 3.  Programs. 
 
2. Listed under the Programs selection are Calibrate (which is a program to calibrate the Inductive 

Stylus), CoreLib (which is the Core Library that provides KOV-21 INFOSEC card functionality), and 
SKL Settings.  So you see the Programs area of the Start menu is very similar to normal Windows 
Operating Systems save some unique programs dedicated to the SKL. 

 
END OF TASK 
 
SKL Settings Menu 
 
The SKL Settings Menu allows the operator of the SKL to make two adjustments with regard to power 
consumption.  The first is how long the SKL waits during no usage time before powering down, and 
second is when the SKL's Backlight turns off through non-usage.  Both of these settings are important in 
maintaining the maximum amount of battery power during mission operations.  There are two different 
ways to access these settings.  The first is to select Start→Programs→SKL Settings as depicted below 
in Figure 4, Start→Programs→SKL Settings.  The second is to double-tap on the SKL Settings Icon that 
is located on the Windows CE.Net Desktop.  Either method will get you to the SKL Settings Menu. 
 

 
 

Figure 4.  Start→Programs→SKL Settings. 
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1. As a result of the above selection the window in Figure 5, SKL Settings, opens. 
 

 
 

Figure 5.  SKL Settings. 
 
2. The SKL Settings menu allows the operator to select the inactive power off setting and Backlight 

setting.  The default for this window is; neither the Power nor Backlight selections are checked and 0 
minutes are displayed and grayed out.  As depicted above both the Power and Backlight have been 
checked indicating they are now activated.  The Power Off time has been set to 60 minutes.  The 
Backlight turn off time has been set to 15 minutes.  Depending on your particular mission 
requirements with the SKL you should set these conditions accordingly.  When you have completed 
your settings, tap on the OK button in the upper right-hand corner of the window.  The SKL Setting 
window will close and the window that was open prior to starting this routine will re-open. 

 
END OF TASK 
 
END OF WORK PACKAGE 
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FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
INITIAL POWER UP AFTER DELIVERY OF SKL 
NORMAL POWER UP AND LOGGING ONTO THE SKL 
POWERING DOWN THE SKL FROM THE SKL UAS 
 
INITIAL POWER UP AFTER DELIVERY OF SKL 
 
1. Once the SKL is prepared for use as outlined in Work Package 0035, the initial power up sequence is 

simple.  Locate the Power Push button at the front upper right-hand corner of the SKL as shown in 
Figure 1, Power Push Button Location, below.  Press and hold the Power push button for 
approximately 3 seconds or until you see the system start to boot and then release the push button.  
The system should boot to the window in Figure 2, Default SSO Login. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

KOV-21 LED 

Power Push 
Button 

Figure 1.  Power Push Button Location. 
 

 
Figure 2.  Default SSO Login. 
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2. Observe the KOV-21 LED as depicted in Figure 1 above to make sure it is not flashing.  If it is 

flashing, see Work Package 0031.  As depicted above, a logon window has opened indicating that 
the default SSO account has a DEFAULTPIN as a password and that the DTD 2000 INFOSEC card 
is in an uninitialized state.  When the SKL is issued to your unit it will have a default administrative 
account already created.  The User ID for this account is SSO (all caps).  This window is asking you if 
you want to initialize the card and pair it to this host computer.  Tap on the OK button.  The window in 
Figure 3, Use External CIK, opens. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 3.  Use External CIK. 
 
3. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 4, Change 

Password, opens. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4.  Change Password. 
 
4. This window now allows the SSO to change the password from DEFAULTPIN to something else that 

will be associated with the KOV-21 INFOSEC card.  Type in the new password and then confirm it.  
The password must be at least 6 characters in length and no more than 12 characters.  There can be 
no spaces in the password.  Then tap on the OK button.  The window in Figure 5, Password 
Successfully Updated, opens.  Make sure that you write down the new password for the SSO account 
and store it appropriately. 
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Figure 5.  Password Successfully Updated. 
 
5. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 6, 

Progress, opens.  This window will only stay up momentarily and then the window in Figure 7, 
Information opens. 

 

 
 

Figure 6.  Progress. 
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Figure 7.  Information. 
 
6. This window is informing you that a new database flag has been turned on and that the user will be 

starting with a new database.  Tap on the OK button.  The window in Figure 8, Startup Information, 
opens. 

 

 
 

Figure 8.  Startup Information. 
 
7. This window is explained in detail on page 0006-8.  Tap on the OK button.  The window in Figure 9, 

SKL UAS Desktop, opens. 
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Figure 9.  SKL UAS Desktop. 
 
8. You have now created the SSO password, initialized the KOV-21 INFOSEC card and opened the 

SKL UAS program.  You can now exit out of the SKL UAS program back to the Core Library and add 
the user accounts that you will require for this SKL using the procedures in Work Package 0007.  You 
should also perform the procedure in Work Package 0007 to create another user account for the 
SSO.  You should never use the SSO account to perform work in the SKL UAS program.  Once these 
two procedures are accomplished, you may continue and open the SKL UAS program. 

 
END OF TASK 
 
NORMAL POWER UP AND LOGGING ONTO THE SKL 

1. This procedure is very similar to the Initial Power Up sequence.  The Power push button is located at 
the front upper right-hand corner of the SKL as shown in Figure 10, Power Push Button Location, 
below.  Press and hold the Power push button for approximately 3 seconds or until you see the 
system start to boot and then release the push button.  The system should boot to the window in 
Figure 11, Core Library Logon. 

 

KOV-21 LED 

Power Push 
Button 

Figure 10.  Power Push Button Location. 
 

0006-6 
UNCLASSIFIED/FOR OFFICIAL USE ONLY 



UNCLASSIFIED/FOR OFFICIAL USE ONLY 
 TM 11-5818-410-13&P 0006 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 11.  Core Library Logon. 
 
2. Observe the KOV-21 LED as depicted in Figure 10 above to make sure it is not flashing.  If it is 

flashing, see Work Package 0031.  As depicted above, a logon window has opened indicating that 
you must logon to the Core Library to proceed.   

 
NOTE 

 
The Keyboard can be moved by touching the title bar with the stylus and dragging 
the keyboard to the desired location. 
 

3. To enter the required information in the User ID and Password fields, follow the steps below: 
 

a. A blinking Cursor will be displayed in the User ID field. 
 

b. To enter alpha upper case keyboard characters, make sure the CAP key is toggled on (reverse 
video).  Then using the stylus, select each letter of the User ID.  You will notice that the selected 
letters appear in the User ID field of the Logon window.   
 

NOTE 
 
If numbers are required for either the User ID or Password fields, you can toggle 
the keyboard to display numeric characters by tapping the stylus on the CAP Key. 
 

c. Once the User ID has been entered, tap the stylus in the Password Field and a blinking Cursor 
will be displayed.  Now you can enter the password. 

 
d. Once the correct User ID and Password have been entered tap on the OK button.  The Logon 

window and virtual keyboard disappears if the User ID and Password where correct.  Then the 
window depicted in Figure 12, Progress appears briefly and then Figure 13, Startup Information 
opens. 
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Figure 12.  Progress. 
 

 
 

Figure 13.  Startup Information. 
 

d. This window displays the SKL Version and date, SKL Database Version, the highest Signal 
Operating Instructions (SOI) classification, and the highest key classification, the amount of Free 
Audit Space broken down into four different categories.  Total Bytes Free, Total Bytes Used, % of 
Bytes Free, and % of Bytes Used.  You should pay particular attention to the amount of Audit 
Bytes used as this will become an important number to know as explained later in this Work 
Package.  Tap on the OK button with the stylus.  The window in Figure 14, SKL UAS Main Menu 
is displayed.  The SKL UAS Main Menu has now been opened and is ready for use. 

 
NOTE 

 
The platforms depicted below are used throughout the TM as a guide to perform 
the operations available to the SKL operator.  Your data will undoubtedly display 
different platforms, equipment, key, and SOI. 
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NOTE 
 

For operational purposes, the SSO account should never be used to access and 
utilize the SKL UAS program.  Rather, create another user account and use it to 
perform your necessary mission with the SKL UAS program. 
 

 
Figure 14.  SKL UAS Main Menu. 

 
e. Since you are now into the SKL UAS program this would be a good time to set up your SKL the 

way that you want to view items in the trees.  This can be done from the Settings→Options menu 
which is described in detail in Work Package 0029. 

 
END OF TASK 
 
POWERING DOWN THE SKL FROM THE SKL UAS 
 
When the SKL is no longer needed for EKMS operations, it should be powered down and stored 
appropriately.  Make sure that if you have made changes to your Mission Database that you save the 
database before powering down.  To power down the SKL, from the SKL UAS follow the steps below. 
 

CAUTION 
 

You should never power down the SKL while the SKL UAS program is open or the 
KOV-21 card light is green (active).  Doing so may lead to a corrupted database. 

 
1. Exit the SKL UAS program by selecting File→Exit from the SKL main menu as shown in Figure 15, 

SKL UAS File Menu.  You may also tap the X button in the top right-hand corner of the SKL Main 
Menu with the Inductive Stylus to exit the application.   
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Figure 15.  SKL UAS File Menu. 

 

Figure 16.  Core Library Desktop. 
 

. The window depicted in Figure 1 d. 

 

 

6, Core Library Desktop, is now displaye2
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Figure 17.  Logout 

 
3. Once the Core Library Desktop opens, select Session→Logout as shown in Figure 17, Logout, 

above. 
 

4. Once the Logout selection is made the window depicted in Figure 18, Core Library Desktop, returns 
with an hour glass icon in place of the arrow. 

 
Figure 18.  Core Library Desktop. 

 
5. Once the hour glass icon has disappeared and the KOV-21 card light is out, the SKL can be 

powered down by pressing and holding the Power button until the power down sequence begins.  
The Power push button is depicted in Figure 19, Power Push Button.  The SKL should power down 
normally. 
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Power Push 
Button 

 
Figure 19.  Power Push Button. 

 
CAUTION 

 
On the V2 hardware version of the SKL only, do not attempt to power up the SKL 
within 10 seconds of powering it down or you will loose the database contained in 
the SKL. 

 
 
END OF TASK 
 
 
END OF WORK PACKAGE 
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
CORE LIBRARY 
 
 
CORE LIBRARY PROGRAM 
 
The Core Library provides KOV-21 Information Security (INFOSEC) card functions for the Site Security 
Officer (SSO) and for user accounts created by the SSO.  The application provides KOV-21 INFOSEC 
card, account and password maintenance, date and time setup, card reset, status monitoring, audit trail 
view and upload functions, and file download functions.  The Core Library also provides the capability to 
select and launch the SKL User Application Software (UAS).  The Core Library executable software 
resides and runs within the memory space and native Central Processing Unit (CPU) of the host SKL 
device.  The Core Library is the vehicle that is used to logon to the KOV-21 INFOSEC card.  Once the 
user is logged on to the KOV-21 card, the SKL UAS program is launched automatically.  The Core Library 
software has several features that are described in the following paragraphs.   
 
Accessing the Core Library Program 
 
The Core Library program can be accessed two different ways.  The first way is to just power up the SKL.  
The second way is to double-tap on the Core Library icon on the Windows CE.Net desktop with the 
Inductive Stylus.  The window in Figure 1, Core Library Logon, opens. 

 
Figure 1.  Core Library Logon. 

 
1. To get access to all the Core Library program features, you must logon to the KOV-21 INFOSEC 

card.  All actions on the SKL other than those directly Windows CE.Net related must begin by logging 
on to the KOV-21.  The SKL UAS program will not launch without logging on. 

 
2. As stated in Work Package 0006, the SKL is issued with an administrative account called SSO (all 

caps) already created.  The SSO must change the password for this account upon the initial power up 
and log on.  The SSO can then create up to 10 other user accounts. 
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NOTE 
 

The Keyboard can be moved by touching the title bar with the stylus and dragging 
the keyboard to the desired location. 

 
3. To enter the required information in the User ID and Password fields, follow the steps below. 
 

a. A Cursor will be displayed in the User ID field. 
 

b. To enter lower case characters and numbers, make sure the CAP key is toggled off.  To enter 
upper case and special characters, make sure the CAP key is toggled on (reverse video).  Then 
using the stylus, select each letter of your User ID.  You will notice that the letters appear in the 
User ID field of the Logon window. 
 

NOTE 
 
If numbers are required for either the User ID or Password fields, you can toggle 
the keyboard to display numeric characters by tapping the stylus on the CAP Key. 
 

c. Once the User ID has been entered, tap the stylus in the Password field, and a Cursor will be 
displayed.  Now you can enter the password for your account. 

 
CAUTION 

 
If you are logging in as the SSO, ten (10) consecutive SSO logon failures will result 
in the KOV-21 INFOSEC card being zeroized and reset.  This will cause the loss of 
all Mission Database items stored in the SKL, deletion of all user accounts, and the 
resetting of the SSO password. 

 
Figure 2.  Core Library Logon. 

 
4. Now using the stylus, tap on the OK button.  The Logon window closes and Figure 3, Startup 

Information, opens.  With this new change to the software the SKL UAS automatically opens once a 
valid logon is completed. 
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Figure 3.  Startup Information. 
 
5. The Startup Information window provides more information that the previous one.  It now gives you a 

complete picture of the Audit Free Space, which will be very valuable to you so that you know when 
to perform a Remote Audit Upload.  Once you are through looking at the information on the Startup 
Information window, tap on the OK button.  The window in Figure 4, SKL UAS Desktop opens. 

 

 
 

Figure 4.  SKL UAS Desktop. 
 
END OF TASK 
 
Accessing the Core Library Features 
 
Now that you have logged on to the Core Library to access the Core Library features you must exit the 
SKL UAS or use the Program Icon on the Taskbar to go back to the Core Library program.  Once you are 
back at the Core Library you have access to most of the menu selections.  There are four (4) main menu 
selections on the Core Library desktop as depicted below in Figure 5, The following Paragraphs address 
each of these selections as well as the sub-selections under each main heading.  There are some 
selections that are not to be used by the user.  Those selections will be identified. 
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Figure 5.  Core Library Desktop. 

 
Session Menu 
 
The Session menu has four (4) available selections.  These are: 
 

• Login (only available if you are not logged on) 
• Logout (only available if you are logged on) 
• Protocol 
• Reset Card. 

 
If you choose Login, then you will repeat the same steps that are called out in the second Paragraph of 
this Work Package.  To logout, select Logout from the Session Menu and you will be logged out of the 
Core Library.  However, you must first completely exit the SKL UAS program. 
 
Changing the Core Library Protocol.  This option allows for a choice of which protocol should be used 
to change the files in Core Library or upload Audit Data to the LCMS Workstation.  The SKL user will not 
be able to modify files stored in the SKL.  However, the user can change the protocol to upload Audit 
Data to the LCMS Workstation computer.  Depicted in Figure 6, Protocol, are the two different protocols 
that you may set on the SKL for completing tasks in the Core Library.  They are DS-101 and RS-232.  
The window defaults to DS-101.  If you select RS-232 as the protocol you wish to use, then you may also 
select the Timeout Value for this protocol based on the device you are connecting to.  There are three (3) 
selections you can make.  They are Slow, Medium, and Fast.  The default is Medium.  Make your 
selection based on what you want to do and then click on the OK button.  The Core Library Desktop re-
opens. 
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Figure 6.  Protocol. 
 
END OF TASK 
 
Resetting the KOV-21 INFOSEC Card.  This action is the equivalent to a power down operation, without 
the removal of power.  It will result in the card performing all its startup tests.  Following the reset 
operation, the user is logged off.  Although a user can run this test at any time, it should only be run when 
there is reason to believe that the KOV-21 card may have a problem or the software requests that it be 
reset.  Use the following steps to reset the KOV-21 card. 
 
1. From the Core Library Desktop, select Session→Reset Card.  The window in Figure 7, Confirm Card 

Reset, opens. 

 
 

Figure 7.  Confirm Card Reset. 
 
2. If you are sure that you want to continue, tap on the Yes button.  The window in Figure 8, Core Lib, 

opens. 
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Figure 8.  Core Lib. 

 
3. This window confirms that the card was reset.  It also informs you that the user has been logged off.  

If you want to continue operations, you will need to login again by selecting Login from the Session 
menu.  Tap on the OK button in the upper right-hand corner of the window.  The Core Library 
Desktop opens. 

 
END OF TASK 
 
Tools Menu 
 
The Tools Menu of the Core Library Desktop contains several selections to perform housekeeping 
functions that may be required by unit procedures and military regulations.  The two major sub-headings 
under the Tools Menu are “User” and “SSO”.  The following paragraphs will outline the procedures to use 
each selection under these two sub-headings. 
 
User Menu.  The Tools→User Menu has four (4) submenus that perform functions that an ordinary user 
has permission to perform.  The SSO account is a user account; therefore, the SSO account has access 
to all of these functions.  These functional areas are: 
 

• Change Password 
• Get Card Time/Date 
• Get Card Status 
• Card Self-Test 

 
The following paragraphs detail how to use each of these selections. 
 
     Change User Password.  To change the User password, the user must first be logged on.  If the user 
is not logged on, this selection is grayed out.  If you are logged on and want to change your password 
select Tools→User→Change Password.  The window in Figure 9, Change Password, opens. 
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Figure 9.  Change Password. 

 
1. This window has several areas that require information.  The User ID displays, in subdued form, the 

ID of the user that is logged on.  To change the password for the account displayed, you will need to 
enter the old password first using the Virtual Keyboard.  Then tap in the New Password field and 
enter the new password.  The new password must be at least 6 characters in length and no more 
than 12 characters.  Spaces are not allowed in passwords.  To confirm the new password, tap in 
the Confirm Password field and then re-enter your new password.  Then tap on the OK button.  The 
window in Figure 10, Password Successfully Updated, opens. 

 

 
Figure 10.  Password Successfully Updated. 

 
2. Now tap on the OK button in the upper right-hand corner of the window.  The Core Library Desktop 

opens. 
 
END OF TASK 
 
     Get Card Time/Date.  The KOV-21 INFOSEC card has its own date/time function aside from the 
date/time function of the Windows CE.Net operating system or (Host time).  The time/date that is shown 
in the Taskbar of the Windows CE.Net Desktop will be set to the KOV-21 card time/date each time the 
SKL is powered on.  Also the host time will be set to the KOV-21 card time as well.  Before using this 
procedure, you should make sure that the SSO has set the correct date and time for the KOV-21 
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INFOSEC card.  That procedure is addressed in below in the SSO Menu.  There are many ECUs that can 
be loaded using the SKL.  In many cases the time can also be loaded to the ECU along with the key and 
other data.  If you choose to load time along with the other data the time is pulled from the Host time and 
not from the KOV-21 card time.  Use the following procedure to first check the KOV-21 card date/time and 
then sync the Host time and date to the KOV-21 time and date.  
 

NOTE 
 

Refer to Work Package 0003 for a more thorough understanding of the KOV-21 
card time and the system (Host) time and how it can affect your communications. 

 
1. If you wish to know the date and time set in the KOV-21 INFOSEC card, select Tools→User→Get 

Card Time/Date.  The window in Figure 11, Get Card Date/Time, opens. 
 

 
 

Figure 11.  Get Card Date/Time. 
 
2. To find out the date and time that is set in the KOV-21 card select NO and then tap on the OK button.  

The window in Figure 12, KOV-21 Card Date and Time, opens.   
 

 
 

Figure 12.  KOV-21 Card Date and Time. 
 

0007-9 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0007 
 
3. This window shows you the current date and time that is set in the KOV-21 card.  You will see the 

time incrementing on the taskbar as the seconds go by.  The above window is a static display of the 
Date/Time only.  Tap on the OK button in the upper right-hand corner of the window.  The Figure 13, 
Core Library Desktop, returns.   

 

 
 

Figure 13.  Core Library Desktop. 
 
4. Now select Tools→User→Get Card Time/Date, the window in Figure 14, Get Card Date/Time with 

NO Selected, opens.  
 

 
 

Figure 14.  Get Card Date/Time with NO Selected. 
 
5. This window always opens with NO selected.  To change the selection to Yes, tap in the radio button 

to the left of the Yes, set host time/date to card time/date as depicted below in Figure 15, Get Card 
Date/Time with YES Selected.   
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Figure 15.  Get Card Date/Time with YES Selected. 
 
6. The above selection means that you want the Windows CE.Net operating system time (Host time) to 

be the same as the time in the KOV-21 INFOSEC card.  Now tap on the OK button.  The window in 
Figure 16, New System Clock Time, opens.  

 

 
 

Figure 16.  New System Clock Time. 
 
7. You will notice in the window depicted above that after you selected Yes on the previous window the 

system shows you the new system (Host) time.  Click on the OK button in the upper right-hand corner 
of the window.  The Core Library Desktop returns. 

 
END OF TASK 
 
     KOV-21 INFOSEC Card Status.  There may be instances when you will need to know the exact 
status of the KOV-21 INFOSEC card before proceeding to launch the SKL UAS.  Select 
Tools→User→Get Card Status.  The window in Figure 17, Card Status, opens. 
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Figure 17.  Card Status. 

 
In the figure above, the card status includes several elements of information.  These include Card Serial 
Number, Card State, Card Condition, Factory Setup, Zeroized Condition, Firmware Revision Number, and 
Free Audit Space.  Of these informational areas, four are of particular importance.  They are Card State, 
Card Condition, Zeroized Condition, and Free Audit Space.  The Card State should always be 
“Operational”.  The Card Condition should be “Initialized”.  The Zeroized Condition should be “Not 
Zeroized” for operational purposes.  The Free Audit Space should display enough space in bytes to 
complete the current mission of the SKL.  A completely empty Audit Log should show approximately 
2097152 bytes.  When you are through viewing the card status, tap on the OK button.  The Core Library 
Desktop returns. 
 
END OF TASK 
 
     KOV-21 INFOSEC Card Self-Test.  The KOV-21 INFOSEC card self-test routine is designed to pick 
up most anomalies that can be detected on the card.  The test should be run when you suspect that the 
card is not operating properly.  See Work Package 0031 for troubleshooting procedures for the KOV-21 
INFOSEC card.  It should be noted that once the test is started, a card-reset procedure will be 
accomplished which also means that the current user will be logged off.  To start the self-test of the 
KOV-21 INFOSEC card select Tools→User→Card Self-Test.  The window in Figure 18, Confirm Card 
Self-Test, opens. 
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Figure 18.  Confirm Card Self-Test. 

 
1. Read the Warning and then decide if it is prudent at this time to continue with the self-test.  If so, tap 

on the YES button.  The self-test will take several minutes to complete.  When the self-test is 
complete the window in Figure 19, Self Test Completed Successfully, opens. 

 

Figure 19.  Self Test Completed Successfully.   
 

. Tap on the OK button in th brary Desktop re-

 
ND OF TASK 

SO Menu.  The Tools→SSO menu has five (5) major functional management areas accessible only to 

• Set Card Time/Date 

ls 

 

 

2 e upper right-hand corner of the window.  The Core Li
opens.  Remember to logon if you want to continue with SKL operations. 

E
 
S
the SSO account.  These functional areas are: 
 

• User Management 
• Audit Functions 
• Firmware Contro
• File Controls 

0007-13 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0007 
 
The following paragraphs detail the procedures to use these selections.  These selections are only 

   Set the KOV-21 INFOSEC Card Time and Date.  Although the KOV-21 card’s date and time are set 
 

available if the SSO is logged in. 
 
  
in the factory you will always want to set the date and time to your operational settings.  Most units have a
Precision Lightweight GPS Receiver (PLGR) on hand to give them the precise date and time data to enter 
into the KOV-21 card.  Once you have that data, select Tools→SSO→Set Card Time/Date.  The window 
in Figure 20, Set Card Date/Time, opens. 
 

 
 

Figure 20.  Set Card Date/Time. 
 

. Depicted above are two areas that require configuring.  They are the Card Time and the Card Date.  
 

 

1
With the date and time information gained from the PLGR or some other reliable source, set the Card
Date first and then the Card Time.  Once they are set, tap on the OK button.  The window in 
Figure 21, New Card and Host Time, opens. 

 
 

Figure 21.  New Card and Host Time. 
 

. The window confirms the fact that the Card and Host time and date have been set.  You will also see 

 

2
the change immediately in the Taskbar of the Windows CE.Net OS.  Tap on the OK button in the 
upper right-hand corner of the window.  The Core Library Desktop reopens. 
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END OF TASK 

   User Management.  The User Management function under the SSO submenu has three (3) SSO 
e 

        Create or Re-Create a User Account.  The following procedure is used to create or re-create a 

ch 

er 

. To create or re-create a user account, select Tools→SSO→User Management→Create User.  The 

 

 
Figure 22.  Create User. 

2. Using the stylus enter the new user er ID.  Then enter 
the new user ID password and confirm the password.  The Password field must have a minimum of 6 

 

 
  
functions.  They are Create User, Delete User, and Change User Password.  Each of the following thre
paragraphs will address each of these functions. 
 
  
user account.  The only account that can create another user account is the SSO.  Make sure that you 
are logged on as the SSO before attempting this routine.  The SSO should create a user account for ea
person that is going to have access to the SKL UAS program.  This also includes the SSO.  The SSO 
should never use the SSO account to work in the SKL UAS program.  He/she should create anoth
user account for this purpose.  To create or re-create a user account, follow the steps below. 
 
1

window in Figure 22, Create User, opens. 

 
ID.  There cannot be any spaces in the us

characters and it can have a maximum of 12 characters.  There can be no spaces in the 
Password.  Now tap on the OK button.  The window in Figure 23, User Created, opens. 
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Figure 23.  User Created. 

 
3. This is a confirmation window that the account was created.  Tap on the OK button in the upper right-

hand corner to close the window.  The Create User window re-opens in case you want to add more 
users.  If not then tap on the Cancel button.  The Core Library Desktop re-opens. 

 
4. Now that the account is created, the account information can be provided to the user and inform the 

user to login to the KOV-21 card and then change the password. 
 
END OF TASK 
 
          Delete User Account.  There will be occasions when users of the SKL are no longer required to 
operate the system.  These occasions can be when operators rotate duty stations, change jobs within the 
unit, leave the service, or are relieved of their duties through disciplinary action.  When any of these 
circumstances arise, the SKL account associated with that individual must be removed from the SKL 
database.  Use the following procedure to delete a user account. 
 
1. From the Core Library Desktop, select Tools→SSO→User Management→Delete User.  The 

window in Figure 24, Delete User, opens. 
 

Figure 24.  Delete User. 
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2. Select the user account you want to delete from the drop-down menu.  Once you have selected the 

 
Figure 25.  Confirm Delete User. 

 
. If you are sure that the account displayed is the account to be deleted, tap on the Yes button.  The 

 

 
Figure 26.  User Removed. 

4. This is the confirmation window th m the database.  Tap on the OK 
button in the upper right-hand corner of the window.  The window in Figure 27, Delete User, re-opens. 

correct account to delete, tap on the OK button.  The window in Figure 25, Confirm Delete User, 
opens. 

3
window in Figure 26, User Removed, re-opens. 

 
at the account was deleted fro
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Figure 27.  Delete User. 

 
5. If you have no other accounts to delete, tap on the Cancel button or tap on the X button in the upper 

right-hand corner of the window to close the window and return to the Core Library Desktop. 
 
END OF TASK 
 
          Change a User’s Password.  This procedure allows the SSO to change any User’s password.  
This procedure can be used when the user forgets a password.  Use the following procedure to change a 
user’s password. 
 
1. From the Core Library Desktop select Tools→SSO→User Management→Change User Password.  

The window in Figure 28, Change Password, opens. 
 

Figure 28.  Change User Password. 
 

. Select the User ID for password change from the drop-down menu.  Once the correct User ID is 
rtual 

 

2
displayed, tap the Stylus in the New Password field to obtain a blinking cursor.  Then using the Vi
Keyboard input the new password for the User ID selected.  The password must have a minimum of 6 
characters and no more than 12 characters.  There can be no spaces in the password.  Tap in the 
Confirm field so that the cursor is now blinking in that field and then input the password again.  After 
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you have entered the new password and confirmed it, tap on the OK button.  The window in 
Figure 29, Confirm change of User's Password, opens. 

 

Figure 29.  Confirm Change of User's Password. 
 

. If you are sure of the action you are about to take, tap on the Yes button.  The window in Figure 30, 

 

 
Figure 30  Password Successfully Updated. 

4. This window alerts you tha ted.  Tap on the OK 
button in the upper right-hand corner of the window.  The Core Library Desktop re-opens. 

5. ged once 
they have logged on to the KOV-21 INFOSEC card. 

END

ons.  Since the KOV-21 card controls all audit functions for the SKL the Core Library is 
here all the audit tasks take place.  There are four (5) submenus under the Audit Functions menu.  They 

 

 

3
Password Successfully Updated, opens. 

 
t the User password has been successfully upda

 
Provide the new password to the user and inform the user that the password must be chan

 
 OF TASK 

 
     Audit Functi
w
are View Audit, Clear Audit, Upload Audit, Upload Audit DMD, and Remote Audit.  Each will be explained
in the following paragraphs. 

0007-19 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0007 
 
          View Audit.  The KOV-21 INFOSEC card has the ability to audit (record) the actions taken on the 
SKL in relation to the KOV-21 card itself.  The following are some of the more common events that are 

il was Initialized 
• When accounts are created. 

. 
s. 
hanged. 

 
. 

rd was zeroized. 
KL was connected to. 

t was changed to. 

dit Uploaded was performed. 
 
To w

SO→Audit Functions→View Audit.  The window in 
Figure 31, Audit Trail, opens. 

 

. Use the Slide Bars on the right side and the bottom of the window to get complete view of the Audit 
Log.  Once you are through viewing  button.  The Core Library Desktop 
re-opens. 

END
 
        Clear Audit.  Use the following procedure to clear the Audit Log. 

recorded in the Audit Log. 
 

• When the Audit Tra

• When an account was deleted. 
• When accounts are logged on
• Any unsuccessful logon attempt
• When an account password is c
• When and what key was received. 
• What device was used to receive the key.
• When and what key was transmitted
• When a key file was received. 
• When and what key was zeroized. 
• When the KOV-21 INFOSEC ca
• When and what kind of device the S
• When the date and time were changed and what i
• Any alarm codes. 
• When and what Key was updated. 
• When a Remote Au

vie  the Audit Log, use the following procedure. 
 
1. From the Core Library Desktop, select Tools→S

 

Figure 31.  Audit Trail. 
 
2

the Audit Log, tap on the OK

 
 OF TASK 
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NOTE 
 

Never clear any Audit Log without first performing a Remote Audit Upload to the 
LCMS Workstation.  You should alway  complete Audit Trail on the SKL.  
Use the Remote Audit Upload procedure in this Work Package to remotely upload 

 
1. Afte rom the 

CO .  From the Core Library Desktop, select Tools→SSO→Audit 
Functions→Clear Audit.  The window in Figure 32, Clear Audit Trail, opens. 

 

 
. If you are sure that you want to clear the Audit Log, then proceed by tapping on the Yes button.  The 

window in Figure 33, Audit Trail S

 
 Cleared. 

 
. This window informs you that the Audit Trail was successfully cleared.  Tap on the OK button in the 

upper right-hand corner of the window.  The Core Library Desktop re-opens. 
 

ND OF TASK 

s have a

the Audit Log. 

r you have uploaded the Audit Log, you can now clear it if you have received permission f
MSEC Custodian

 

Figure 32.  Clear Audit Trail. 

2
uccessfully Cleared, opens. 

 

Figure 33.  Audit Trail Successfully

3

E
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         Upload Audit.  The Uploading the Audit Log selection is intended to allow one SKL to upload its 

it Log to another SKL.  This function has not been cleared for use by NSA at t
 

Aud his time.   

udit DMD.  This function will not be used by the U.S. Army. 

ures below.  
his process must be coordinated with the LCMS Workstation operator. 

NOTE 

18000 bytes to the 
LCMS Workstation version 4.0.3.2 via the KP AUX port, this action may cause the 
KP to go into an alarm situation.  This is caused by the audit trail being too big.  If 
this situation occurs, you should get with your COMSEC Custodian and have the 

 
1. Mak

Too
Too it, opens. 

 
          Upload A
 
          Remote Audit.  To upload SKL Audit Data to the LCMS Workstation follow the proced
T
 

 
When remotely uploading the a SKL audit trail of more than 

audit trail reviewed before clearing it. 

e sure that you are logged on as the SSO.  From the Core Library Desktop, select 
ls→SSO→Audit Functions→Remote Audit as depicted below in Figure 34, 
ls→SSO→Audit Functions→Remote Aud

 

 
 

Figure 34.  Tools→SSO→Audit Functions→Remote Audit. 
 
2. As a result of selecting the above the window in Figure 35, Connect to LMD, opens. 
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Figure 35.  Connect To LMD. 

 
3. Using a standard Fill Cable, connect the SKL to the Auxiliary port on the KP and then to the Fill port 

on the SKL.  Once that is accomplished, tap on the OK button in the upper right-hand corner of the 
window.  The window in Figure 36, Status Report, opens. 

 

Figure 36.  Status Report. 
 

. The Status Report provides the operator of the SKL and LCMS Workstation with information relative 

 

 

4
to the Remote Audit Upload.  When the Remote Audit Upload is complete, the window in Figure 37, 
Remote Audit Trail Successfully Uploaded, opens. 
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Figure 37.  Remote Audit Trail Successfully Uploaded. 

 
5. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 38, Status 

Report, re-opens. 
 

Figure 38.  Status Report. 
 

. Now tap on the Abort button and then the OK button to close the Status Report window.  The window 

 

 

6
in Figure 39, Core Library Desktop, opens. 
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Figure 39.  Core Library Desktop. 
 
7. Depending on your individual unit procedures, you may now clear the Audit Log.  However, your unit 

may wish for the Audit Trail to stay in the SKL until the full mission of the SKL is finished. 
 
END OF TASK 
 
     Firmware Controls.  The Firmware Controls function is used to update and clone the Core Library 
firmware.  There are two (2) submenus under the Firmware Controls selection.  They are Updating Core 
Library Firmware and Cloning Core Library Firmware.  They are discussed below. 
 
          Updating the Core Library Firmware.  This function will only be accomplished by field users 
under very unusual circumstances.  Should this occur, instructions to update the firmware on the KOV-21 
INFOSEC card will be provided by CECOM. 
 
 
          Cloning the Core Library Firmware.  This function will only be accomplished by field users under 
very unusual circumstances.  Should this occur, instructions to Clone the Core Library firmware will be 
provided by CECOM. 
 
     File Controls.  File Controls deals exclusively with updating the software in the SKL.  There are two 
selections under the File Controls selection.  They are Download File and Software Update.  When there 
is a change to the software in the SKL your command will be notified and told where to go to get the 
update.  Specific instructions on how to update the software in the SKL will be provided by CECOM. 
 
Launch Menu.  The Launch Menu is used to launch the User Application Software (UAS) packages that 
are installed on the SKL.  With SKL UAS version 4.0, the SKL UAS will automatically launch once a user 
has successfully logged into the Core Library.  The Launch Menu is used when a user exits the SKL UAS 
and then wishes to re-start the SKL UAS.  To start the SKL UAS follow the steps below. 
 
1. From the Core Library Desktop, select Launch→Launch UAS.  The window in Figure 40, Launch 

UAS, opens. 

0007-25 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0007 
 

 
Figure 40.  Launch UAS. 

 
2. To continue to launch the SKL UAS tap on the OK button.  The window in Figure 41, Startup 

Information, opens. 
 

 
 

Figure 41.  Startup Information. 
 
3. This window provides several items of information that are useful to the SKL user.  They are:  the 

SKL version, the highest SOI classification, the highest key classification, and the Audit Free Space  
left in the SKL broken down into several different categories..  Once you have reviewed the 
information, tap on the OK button.  The window in Figure 42, SKL UAS Desktop, opens. 
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Figure 42.  SKL UAS Desktop. 
 
4. The SKL UAS program is now ready to be used.  The description of the menu items and the 

procedures to use the software package are contained below starting with Work Package 0008. 
 
END OF TASK 
 
Core Library Help Menu.  The Help Menu contains the About window, listing the version number of the 
Core Library.  There are no contextual help items in this menu. 
 
 
END OF WORK PACKAGE 
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
SKL UAS INTRODUCTION 
 
 
SKL USER APPLICATION SOFTWARE (UAS) 
 
The software in the SKL that interfaces with the ACES Workstation, the LCMS Workstation, and the End 
Cryptographic Units is called the SKL User Application Software (UAS).  The SKL UAS incorporates most 
of the functionality that is resident in the Common Tier 3 (CT3) software in the DTD.  The following 
paragraphs and Work Packages in Chapter 2 will provide detailed guidance on how to use the SKL UAS 
package.   
 
SKL Tree Tab View Structure 
 
The SKL UAS database provides a Tree Tab View structure for viewing Platforms, Equipment, Keys, and 
SOI.  The SKL UAS database is relational and uses the Platform record as the parent record and 
subsequent linked records as child records.  These child records are Equipment and Keys.  The Tree Tab 
view is very similar to the Windows Explorer that most people are very familiar with.  SKL Tab View 
descriptions are as follows: 
 
Platform (Plats) Tab.  The Platform is normally defined (created) on the Automated Communication 
Engineering Software (ACES) Workstation and downloaded to the SKL.  See Figure 1, Plats Tab, below. 
 
Platform-based operation may be further characterized as automatic or manual.  Automatic platform 
loading requires no operator selections at the SKL once the sequence has started.  Manual platform 
loading refers to the operator’s ability to pick and choose only those elements assigned to a platform, 
including the individual ECUs as well as fill locations, which are to be filled. 

 
Figure 1.  Plats Tab. 

 
Equipment (Eqs) Tab.  Equipment is represented by database records stored in the SKL.  Each 
equipment type contains the necessary information (profile) to fill a specific ECU.  A unique profile has 
been assigned to each ECU supported by the SKL.  A list of supported equipment with profiles for SKL 
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UAS v4.0 can be found below.  This profile provides ECU specific prompting for data download 
operations.  See Figure 2, Eqs Tab, below.  Table 1, SKL UAS v4.0 Supported Equipment provides a list 
of equipment that have profiles created for them. 
 

Figure 2.  Eqs Tab. 
 

Table 1.  SKL UAS v4.0 Supported Equipment. 
 

APX-118 CSEL HHR KG-40A KGV-88 KOV-17 MO-3 

 

APX-123/UPX-41 CSZ-1A KG66-A KGX-93 KS-10 NTDR 
ARC-164 GOE-2 KG-75 KGX-93A  KW-46 PSC-11
ARC-190 GPS MAGR T KG-81 KI-36 KW46-O PSC-5 
ARC-201 GPS-PLGR KG-84A   KIR-1C KY-100 PSC-5C
ARC-201A GRC-171 KG-84C KIT-1C KY-57 PSC-5D 
ARC-201D HGX-82 KG94-A KIV-114 KY-58 RT-1523 
ARC-210 HGX-83 KG-95 KIV-119 KY-68 RT-1523B 
ARC-220 KG-175 KGR-66 KIV-6 KY-90 RT-1794 
ARC-222 KG-194A  KIV-7  KGV-11A KY-99A TSC-154 
ARC-231 KG-235 KGV-23 KIV-77 N KYK-13 UNKNOW
ARC-234 KG-240 KGV-68 KIV-78 KYV-5  
C-11561 KG-250 KGV-8 KIV-7M KYX-15  

 
eys Tab.  Key tags are records containing Short Title, Edition, Text ID, Segment Number and other 

KL 
K
information related to the key.  Each key tag may or may not have an actual key assigned to it.  The S
has a Receive Key Needed function to receive key for those key tags without key.  See Figure 3, Keys 
Tab, below. 
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Figure 3.  Keys Tab. 

 Indicates a key has been received and stored in the Mission Database.  
 Indicates a key is needed from a key-generating source. 
 
Signal Operating Instructions (SOI) Tab.  SKL Signal Operating Instructions information can be viewed 
in the SOI Tab.  SOI data is received from the ACES Workstation, another SKL, or a DTD with CT3 
software, in a compressed format.  The SOI includes Network Groups, Networks, Call Signs, Call Words, 
Cue and Manual Frequencies, Suffixes, Expanders, Signs, Countersigns, Pyrotechnic and Smoke 
Signals, and Quick References.  The SOI Tab provides for the storage, retrieval, display, and deletion of 
SOI information.  See Figure 4, SOI Tab, below. 
 

Figure 4  SOI Tab. 
 

avigating the SKL UAS Desktop. 

he SKL UAS Main Menu is broken down into three major headings, four (4) tabs, and two Icons.  The 
 

 

N
 
T
following paragraphs will explain each of these areas.  If the SKL is not currently displaying the SKL UAS
Desktop, follow the steps in Work Package 0006 Powering Up and Logging onto the SKL, to open the 
SKL UAS Desktop as depicted in Figure 5, SKL UAS Desktop, below. 
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Figure 5.  SKL UAS Desktop. 
 

ile Menu 

. With the SKL UAS Desktop displayed as shown in Figure 5, SKL UAS Desktop above, select File by 

 

 

 

F
 
1

tapping once on File on the SKL UAS Desktop with the Inductive Stylus.  The window in Figure 6, 
SKL UAS File Menu, opens.  Also shown are the submenus of the File menu as depicted in Figures 7 
through 11 below. 

 

Figure 6.  SKL UAS File Menu. Figure 7.  File→Transmit Menu. 
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Figure 8.  File→Transmit→Load Mode 5 
IFF Menu. 

Figure 9.  File→Receive Menu. 

 
  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 10.  File→OTAD Menu. Figure 11.  File→Assign Menu. 
 
2. An explanation of each of the File menu’s selections is presented in Table 2, SKL UAS File Menu 

Description. 
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Table 2.  SKL UAS File Menu Description. 
 

File Menu Option Description 
Delete Platform, Equipment, Short 
Title, Edition, or Segment Changes to 
Unassign when a Platform or 
Equipment is expanded. 

The Delete function is a multi functional selection depending 
on what is highlighted in the trees.  If a Platform is highlighted 
then the Delete Platform function is available on the File 
menu.  If Equipment is highlighted then the Delete Equipment 
function is available on the File menu.  The same goes for the 
Short Title, Edition, and Segment.  
 
The Delete selection is replaced by the Unassign selection 
when a Platform is expanded or an Equipment, Location, Key 
Tag, Edition, or Segment is highlighted.  When selected, the 
Equipment, Location, Key Tag, Edition, or Segment will be 
unassigned from the Platform. 

  
Add Platform or Add Equipment The Add Platform function is available when the Plats Tab is 

selected and allows the user of the SKL to add a Platform to 
the database.  When the Eqs Tab is selected the Add 
Equipment function becomes available for the user to add 
Equipment to the database. 

  
Edit The Edit function when the Plats Tab is selected allows the 

user of the SKL to edit a Platform's attributes.  When the Eqs 
Tab is selected the Edit function allows the user to edit some 
of the Equipment attributes. 

  
Empty Quick Reference This function will allow the user of the SKL to empty all the 

items assigned to a Quick reference.  The Quick Reference is 
used for SOI functions only. 

  
Delete Database This function enables the deletion of all databases, selected 

databases, or selected items in one or more databases.  You 
may delete all or selected items in the Platform, Equipment, 
and Key databases.  Message data, Mission Date, and File 
Header information can be deleted also. 

  
Transmit This function provides the user with a selection of ten different 

Transmit functions. 
  
 Load This function is initiated from the Platform or Equipment tree 

at any level within the tree.  It is used to load ECUs. 
  
 Load Modern Keys This selection allows the user to load modern key such as 

TACLANE key. 
  
 Load Selected Keys This function is initiated from the Key tree only.  It is used to 

load specific keys into ECUs. 
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Table 2.  SKL UAS File Menu Description.  (continued) 
 

File Menu Option Description 
 Load Selected Locations The function allows the user to load key into a specific 

location on a specific piece of equipment. 
  
 Load EPLRS This function is used to load keys into the Enhanced Position 

Location Reporting System (EPLRS) equipment. 
  
 Load PRC-137 This function allows the user to load this specific equipment 

that contains modern key. 
  
 Load Benign Fill This function allows the user to load a Benign Fill key into 

Benign Fill capable equipment such as the TACLANE. 
  
 Load Mode 5 IFF Mode 5 IFF is the next generation of interrogation devices 

used by aircraft and ground elements to authenticate Friend 
or Foe forces. 

  
  Time of Day The Time of Day is required as part of the Mode 5 IFF 

equipment Fill. 
  
  Mission Data The Mission Data provides the keys and other required 

interrogation information for the Mode 5 IFF equipment. 
  
 Database This function is used to transmit databases.  It can transmit all 

or specifically selected Platforms, Equipment, Mission Dates, 
Keys, Files, Message Data, or transmit all the SOI Data. 

  
 ECU Commands This function allows the operator to send and view commands 

to an ECU to perform certain functions.   
  
Receive This function provides the user with a selection of five different 

Receive functions. 
  
 Database This function is used to receive all types of mission data from 

ACES, another SKL, or a CT3 DTD. 
  
 Key This function is used to receive Key independent of Platform 

or Equipment assignments.  After the receipt and storage is 
complete, the keys are visible in the Key tab. 

  
 Key Needed This function allows for the receipt of Key, which is then 

assigned to a pre-existing Key tag in the SKL database. 
  
 XML File XML is a simplified subset of Standard Generalized Markup 

Language (SGML).  Its primary purpose is to facilitate the 
sharing of data across different information systems, 
particularly systems connected via the Niprnet. 
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Table 2.  SKL UAS File Menu Description.  (continued) 
 

File Menu Option Description 
 87-27 File The 87-27 file type is a new capability for the ACES 

Workstation to distribute any database item in the form of a 
.DAT file. 

  
OTAD This function provides the user with a selection of five different 

Over-The-Air-Distribution (OTAD) operations. 
  
 Variable Generate This function allows the user to generate a variable from an 

ECU capable device. 
  
 Receive Variable This function allows the user to receive a variable from a 

distant SKL over a communications link. 
  
 Variable Update This function allows the user to update a variable already 

stored in the SKL from an ECU capable device. 
  
 Manual Rekey This function allows the user to manually have a distant ECU 

receive a variable over a communications link. 
  
 Automatic Rekey This function allows the user to automatically rekey an entire 

communications net. 
  

Create Key Tags The function allows the user to create a specific key tag that 
can then be assigned to an equipment location. 

  
Assign This function provides the user with a selection of four 

different Assign operations. 
  
 Key Tags This function allows the user to assign Key Tags to specific 

locations on specific equipment. 
  

 EP This function allows the user to assign Electronic Protection to 
specific locations on specific equipment. 

  
 Message Data This function allows the user to assign Message Data to 

specific Equipment that requires it. 
  
 Equipment This function allows the user to assign Equipment to 

Platforms. 
  
Save Database This function allows the user to save the current SKL 

database. 
  
Exit This function allows the user to exit the SKL UAS program. 
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END OF WORK PACKAGE 
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
 
FILE MENU 
 DELETE FUNCTION 
 
 
DELETE FUNCTION 
 
The Delete function under the File menu will change depending on the tab you have open and what you 
have highlighted.  The following paragraphs will explain all the different uses of the Delete function. 
 
Delete a Platform 
 
The Delete Option under the File Menu allows for the deletion of Platforms from the Mission Database.  
You can only select one item at a time for deletion.  To illustrate this function the following procedure will 
delete a single platform from the Mission Database. 
 
1. From the Plats Tab window highlight the platform that you want to delete as depicted in Figure 1, 

Plats Tab with Selected Item.  In the example below the TACFWD2 platform has been selected for 
deletion. 

 
Figure 1.  Plats Tab with Selected Item. 

 
2. Select File→Delete Platform from the Main Menu as shown in Figure 2, File→Delete Platform. 
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Figure 2.  File→Delete Platform. 

 
3. Once you have selected Delete Platform, the following window in Figure 3, Delete Selected 

TACFWD2, opens. 
 

Figure 3.  Delete Selected TACFWD2. 
 

. The Platform TACFWD2 has been selected for deletion.  The SKL prompts you for confirmation of the 

 

 

4
platform deletion.  Select Yes to delete the item or No to cancel the deletion process.  Once Yes is 
selected, then the window in Figure 4, Selected Platform(s) Deleted, opens. 
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Figure 4.  Selected Platform(s) Deleted. 

   
5. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 5, Plats 

Tab Minus Deleted Item, opens. 
 

Figure 5.  Plats Tab Minus Deleted Item. 
 

. You can see from the window above that the Platform TACFWD2 has been removed from the Plats 

 
ND OF TASK 

elete Equipment 

er the File Menu allows for the deletion of Equipment from the Mission Database.  

. From the Eqs Tab window highlight the equipment that you want to delete as depicted in Figure 6, 
Eqs Tab with Selected Item.  In the example below the SINCGARS equipment has been selected for 
deletion. 

 

6
Tab list.  This indicates that the item was deleted.  Now select File→Save Database to save the 
changes that have just been made. 

E
 
D
 

he Delete Option undT
You can only select one item at a time for deletion.  To illustrate this function the following procedure will 
delete equipment from the Mission Database. 
 
1
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2. Select File→Delete Equipment from the Main Menu as shown in Figure 7, File→Delete Equipment. 
 

 

 
3. Once you have selected Delete Equipm w in Figure 8, Delete Selected 

SINCGARS, opens. 
 

Figure 7.  File→Delete Equipment 

ent, the following windo

Figure 6.  Eqs Tab with Selected Item. 
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Figure 8.  Delete Selected SINCGARS. 

 
4. As depicted above the Equipment Single Channel Ground and Airborne Radio System (SINCGARS) 

has been selected for deletion.  The SKL prompts you for confirmation of the equipment deletion.  
Select Yes to delete the item or No to cancel the deletion process.  Once Yes is selected, then the 
window in Figure 9, Selected Equipment Deleted, opens. 

 

Figure 9.  Selected Equipment Deleted. 
 

. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 10, Eqs 

 

 

5
Tab Minus Deleted Item, opens. 
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Figure 10.  Eqs Tab Minus Deleted Item. 

 
6. You can see from the window above that the Equipment SINCGARS has been removed from the Eqs 

Tab list.  This indicates that the item was deleted.  Now select File→Save Database to save the 
changes that have just been made. 

 
END OF TASK 
 
Delete Key Tag 
 
The Delete Option under the File Menu allows for the deletion of a key tag from the Mission Database.  
You can only select one item at a time for deletion.  To illustrate this function the following procedure will 
delete a single key tag from the Mission Database.  The key tag encompasses all the attributes of a 
single COMSEC key.  Some of these attributes are the Short Title, Edition, Segment, Effective Date, 
Expiration Date, Type of Key, etc.  To delete a key tag follow the procedure below. 
 
1. From the Keys Tab highlight the Short Title of the Key Tag that you want to delete as depicted in 

Figure 11, Keys Tab with Selected Item.  In the example below the ETD8 5AT034 Short Title has 
been selected for deletion. 

 

 
Figure 11.  Keys Tab with Selected Item. 
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2. Select File→Delete Key Tag from the Main Menu as shown in Figure 12, File→Delete Key Tag. 
 

Figure 12.  File→Delete Key Tag. 
 

. Once you have selected Delete Key Tag, the following window in Figure 13, Delete Selected Short 

 

 
Figure 13.  Delete Selected Short Title. 

4. The Short title ETD8 5AT03  prompts you for confirmation 
of the Short Title deletion.  Select Yes to delete the item or No to cancel the deletion process.  Once 

 

 

3
Title, opens. 

 
4 has been selected for deletion.  The SKL

Yes is selected, then the window in Figure 14, Selected Short Title Deleted, opens. 
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Figure 14.  Selected Short Title Deleted. 

 
5. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 15, Keys 

Tab Minus Deleted Short Title, opens. 
 

Figure 15.  Keys Tab Minus Deleted Short Title. 
 

. You can see from the window above that the Short Title ETD8 5AT034 has been removed from the 

 
NOTE 

 
It should be noted here that when the Short Title was deleted, all the Key Tag 

 
ND OF TASK 

 

6
Keys Tab list.  This indicates that the item was deleted.  Now select File→Save Database to save 
the changes that have just been made.   

information associated with the Short Title was deleted as well. 

E
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Delete Edition 

he Delete Option under the File Menu allows for the deletion of an Edition from the Mission Database.  

. From the Keys Tab highlight the Edition of the Short Title that you want to delete as depicted in 
d for 

 

 
Figure 16.  Keys Tab with Edition Selected. 

2. Select File→Delete Editi File→Delete Edition, opens. 

 

. Once you have selected Delete Edition, the following window in Figure 18, Delete Selected Edition, 
opens. 

 
T
You can only select one item at a time for deletion.  To illustrate this function the following procedure will 
delete a single Edition from the Mission Database.   
 
1

Figure 16, Keys Tab with Edition Selected.  In the example below the Edition M has been selecte
deletion. 

 
on from the Main Menu as shown in Figure 17, 

 

Figure 17.  File→Delete Edition. 
 
3
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Figure 18.  Delete Selected Edition. 

 
4. The Edition M of Short Title ETD8 5AT034 has been selected for deletion.  The SKL prompts you for 

confirmation of the Edition deletion.  Select Yes to delete the item or No to cancel the deletion 
process.  Once Yes is selected, then the window in Figure 19, Selected Edition Deleted, opens. 

 

Figure 19.  Selected Edition Deleted. 
 

. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 20, Keys 

 

 

5
Tab Minus Deleted Edition, opens. 
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Figure 20.  Keys Tab Minus Deleted Edition. 

 
6. You can see from the window above that the Edition M under Short Title ETD8 5AT034 has been 

removed from the Keys Tab list.  This indicates that the item was deleted.  Now select File→Save 
Database to save the changes that have just been made.   

 
NOTE 

 
It should be noted that if this was the only Edition under this Short Title, the Short 
Title will be deleted and all the Key Tag information associated with the Short Title 
will be deleted as well. 

 
END OF TASK 
 
Delete Segment 
 
The Delete Option under the File Menu allows for the deletion of a Segment from the Mission Database.  
You can only select one item at a time for deletion.  To illustrate this function the following procedure will 
delete a single Segment from the Mission Database.   
 
1. From the Keys Tab highlight the Segment of the Edition of the Short Title that you want to delete as 

depicted in Figure 21, Keys Tab with Segment Selected.  In the example below the Segment 2-T000-
1-KY68 TEK has been selected for deletion. 
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Figure 21.  Keys Tab with Segment Selected. 
 

. Select File→Delete Segment from the Main Menu as shown in Figure 22, File→Delete Segment. 

 
Figure 22.  File→Delete Segment. 

3. Once you have selected Delet igure 23, Delete Selected 
Segment, opens. 

 

2
 

 
e Segment, the following window in F
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Figure 23.  Delete Selected Segment. 

 
4. The Segment 2-T000-1-KY68 TEK of Edition N of Short Title ETD8 5AT034 has been selected for 

deletion.  The SKL prompts you for confirmation of the Segment deletion.  Select Yes to delete the 
item or No to cancel the deletion process.  Once Yes is selected, then the window in Figure 24, 
Selected Segment Deleted, opens. 

 

Figure 24.  Selected Segment Deleted. 
 

. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 25, Keys 

 

5
Tab Minus Deleted Segment, opens. 
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Figure 25.  Keys Tab Minus Deleted Segment. 

 
6. You can see from the window above that the Segment 1-T000-1-KY68 TEK of Edition N under Short 

Title ETD8 5AT034 has been removed from the Keys Tab list.  This indicates that the item was 
deleted.  Now select File→Save Database to save the changes that have just been made.   

 
NOTE 

 
It should be noted that if this was the only Segment under the only Edition under 
this Short Title, the Short Title will be deleted and all the Key Tag information 
associated with the Short Title will be deleted as well. 

 
END OF TASK 
 
Delete Modern Key 
 
The deletion of Modern Key from the database is different procedurally than the other delete functions 
described previously in this Work Package.  Modern Key is unique and can only be deleted using a 
specific procedure.  Highlight the Modern Key on the Keys Tab as shown in Figure 26, below. 
 

 
 

Figure 26.  Modern Key Selected on Keys Tab. 
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1. Now select View→Keys→Modern Keys as shown below in Figure 27. 
 

 
 

Figure 27,  View→Keys→Modern Keys. 
 
2. As a result of the above selection, the window in Figure 28, Modern Keys opens. 
 

 
 

Figure 28.  Modern Keys. 
 
3. Select the Modern Key you wish to delete by placing a checkmark ( ) in the box to the left of the key.  

Then tap on the Delete button.  The window in Figure 29, Delete Selected Segments opens. 
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Figure 29.  Delete Selected Segments. 
 
4. Tap on the Yes button.  The window in Figure 30, Selected Modern Key(s) Deleted opens. 
 

 
 

Figure 30.  Selected Modern Key(s) Deleted. 
 
5. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 31, 

Modern Keys opens. 
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Figure 31.  Modern Keys. 
 
6. As can be observed from the window above, the selected key no longer appears in the Modern Keys 

list.  Tap on the Close button.  The window in Figure 32, Keys Tab opens. 
 

 
 

Figure 32.  Keys Tab. 
 
7. The Keys Tab no longer shows the deleted Modern Key.  Now select File→Save Database to save 

the changes that have just been made. 
 
END OF TASK 
 
END OF WORK PACKAGE 
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FILE MENU 
 UNASSIGN FUNCTION 
 
 
UNASSIGN FUNCTION 
 
The Unassign function under the File menu will change depending on the tab you have open and what 
you have highlighted.  The following paragraphs will explain all the different uses of the Unassign 
function. 
 
Unassign Equipment 
 
The Unassign Equipment selection is used to remove Equipment that is assigned to a particular Platform.  
Use the following steps to unassign Equipment from a Platform. 
 
1. Highlight the Equipment that you wish to unassign from the Plats Tab.  As depicted below in 

Figure 1, Equipment Highlighted, the Equipment SINCGARS assigned to Platform TACFWD2 has 
been selected for unassignment. 

 
Figure 1.  Equipment Highlighted. 

 
2. Now select File→Unassign Equipment as shown in Figure 2, File→Unassign Equipment, opens. 
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Figure 2.  File→Unassign Equipment. 
 
3. Once you have selected Unassign Equipment, the following window in Figure 3, Delete Selected 

Assignment, opens. 
 

Figure 3.  Delete Selected Assignment. 
 

. To delete the selected assignment, tap on the Yes button.  The window in Figure 4, Selected Item 

 

 

4
Unassigned Successfully, opens. 
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Figure 4.  Selected Item Unassigned Successfully. 

 
5. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 5, Plats 

Tab, opens. 
 

Figure 5.  Plats Tab. 
 

. Notice that the Equipment has been Unassigned from the Platform TACFWD2 since there in now no 

 
NOTE 

 
The process of unassigning equipment from a platform does not mean the 

 and 

 

ND OF TASK 

 

6
+ (plus sign) next to the Platform in this case.  However, if you had other Equipment assigned to this 
Platform then the + (plus sign) would still be there and you could open the Platform up and see that 
the specific Equipment you unassigned was gone.  Now select File→Save Database to save the 
changes that have just been made.   

equipment has been deleted from the database.  The equipment is still there
can be seen under the Eqs Tab. 

 
E
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Unassign Location 

he Unassign Location selection is used to remove Fill Location from a piece of equipment.  Use the 

. Highlight the Location on the equipment that you wish to unassign from the Eqs Tab.  As depicted 

 

 
Figure 6.  Location Highlighted. 

2. Now select File→Unassign Lo ssign Location. 

 

. Once you have selected Unassign Location, the following window in Figure 8, Delete Selected 
Assignment, opens. 

 
T
following steps to unassign a Location from Equipment. 
 
1

below in Figure 6, Location Highlighted, the Location C5 on the SINCGARS Equipment has been 
selected for unassignment. 

 
cation as shown in Figure 7, File→Una

 

Figure 7.  File→Unassign Location. 
 
3
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Figure 8.  Delete Selected Assignment. 

 
4. The SKL prompts you for confirmation of the assignment deletion.  Select Yes to delete the item or 

No to cancel the deletion process.  To delete the selected assignment, tap on the Yes button.  The 
window in Figure 9, Selected Item Unassigned Successfully, opens. 

 

Figure 9.  Selected Item Unassigned Successfully. 
 

. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 10, Eqs 

 

 

5
Tab, opens. 
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Figure 10.  Eqs Tab. 

 
6. Notice that the Location C5 has been Unassigned from the Equipment SINCGARS.  Now select 

File→Save Database to save the changes that have just been made.   
 

NOTE 
 

The process of unassigning a location from selected equipment does not mean 
that the location cannot be filled with other key.  The locations on individual 
equipment are still there as part of the equipment profile. 

 
 
END OF TASK 
 
Unassign Key Tag 
 
The Unassign Key Tag selection is used to unassign all Key Tag information from a location on 
equipment.  Use the following steps to unassign a Key Tag from selected Equipment. 
 
1. Highlight the Short Title on the equipment that you wish to unassign from the Eqs Tab.  As depicted 

below in Figure 11, Short Title Highlighted, the Short Title USKATT22222481 on the SINCGARS 
Equipment location C1 has been selected for unassignment. 
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Figure 11.  Short Title Highlighted. 

 
2. Now select File→Unassign Key Tag as shown in Figure 12, File→Unassign Key Tag. 
 

Figure 12.  File→Unassign Key Tag. 
 

. Once you have selected Unassign Key Tag, the following window in Figure 13, Delete Selected 

 

 

3
Assignment, opens. 
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Figure 13.  Delete Selected Assignment. 

 
4. The SKL prompts you for confirmation of the assignment deletion.  Select Yes to delete the item or 

No to cancel the deletion process.  To delete the selected assignment, tap on the Yes button.  The 
window in Figure 14, Selected Item Unassigned Successfully, opens. 

 

Figure 14.  Selected Item Unassigned Successfully. 
 

. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 15, Eqs 

 

 

5
Tab, opens. 
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Figure 15.  Eqs Tab. 

 
6. Notice that the Short Title USKATT22222481 on the SINCGARS Equipment location C1 has been 

unassigned.  Now select File→Save Database to save the changes that have just been made.   
 

NOTE 
 

The process of unassigning a Short Title from an equipment location does not 
mean the Short Title has been deleted from the database.  The Short Title is still 
there and can be seen under the Keys Tab. 

 
 
END OF TASK 
 
Unassign Edition 
 
The Unassign Edition selection is used to unassign an Edition from a Short Title assigned to a location on 
selected equipment.  Use the following steps to unassign an Edition from a selected location. 
 
1. Highlight the Edition in the Short Title assigned to a Location on selected equipment that you wish to 

unassign from the Eqs Tab.  As depicted below in Figure 16, Edition Highlighted, the Edition D of 
Short Title USKATA000012113 in Location C6 on the SINCGARS Equipment has been selected for 
unassignment. 
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Figure 16.  Edition Highlighted. 

 
2. Now select File→Unassign Edition as shown in Figure 17, File→Unassign Edition. 
 

Figure 17.  File→Unassign Edition. 
 

. Once you have selected Unassign Edition, the following window in Figure 18, Delete Selected 

 

 

3
Assignment, opens. 
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Figure 18.  Delete Selected Assignment. 

 
4. The SKL prompts you for confirmation of the Segment deletion.  Select Yes to delete the item or No 

to cancel the deletion process.  To delete the selected assignment, tap on the Yes button.  The 
window in Figure 19, Selected Item Unassigned Successfully, opens. 

 

Figure 19.  Selected Item Unassigned Successfully. 
 

. Tap on the OK button in th w in Figure 20, Eqs 

 

 

5 e upper right-hand corner of the window.  The windo
Tab, opens. 
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Figure 20.  Eqs Tab. 

 
6. Notice that the Edition D of Short Title USKATA000012113 in Location C6 on the SINCGARS 

Equipment has been Unassigned.  Now select File→Save Database to save the changes that have 
just been made.   

 
NOTE 

 
The process of unassigning an Edition from a location on selected equipment does 
not mean the Edition has been deleted from the database.  The Edition is still there 
and can be seen under the Keys Tab. 

 
 
END OF TASK 
 
Unassign Segment 
 
The Unassign Segment selection is used to unassign a Segment from an Edition of a Short Title assigned 
to a location on selected equipment.  Use the following steps to unassign a Segment from an Edition. 
 
1. Highlight the Segment in the Edition that is in the Short Title assigned to the Location on the 

Equipment that you wish to unassign from the Eqs Tab.  As depicted below in Figure 21, Segment 
Highlighted, Segment 1-T000-4-SEP of Edition A of Short Title ETD 39 5EG231 in Location C1 on the 
SINCGARS Equipment has been selected for unassignment. 
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Figure 21.  Segment Highlighted. 

 
2. Now select File→Unassign Segment as shown in Figure 22, File→Unassign Segment. 
 

 
Figure 22.  File→Unassign Segment. 

 
3. Once you have selected Unassign Segment, the following window in Figure 23, Delete Selected 

Assignment, opens. 
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Figure 23.  Delete Selected Assignment. 

 
4. The SKL prompts you for confirmation of the Segment deletion.  Select Yes to delete the item or No 

to cancel the deletion process.  To delete the selected assignment, tap on the Yes button.  The 
window in Figure 24, Selected Item Unassigned Successfully, opens. 

 

Figure 24.  Selected Item Unassigned Successfully. 
 

. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 25, Eqs 

 

 

5
Tab, opens. 
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Figure 25.  Eqs Tab. 

 
6. Notice that the Segment 1-T000-4-SEP of Edition A of Short Title ETD 39 5EG231 in Location C1 on 

the SINCGARS Equipment has been Unassigned.  Now select File→Save Database to save the 
changes that have just been made.   

 
NOTE 

 
The process of unassigning a Segment from a Short Title assigned to a location on 
selected equipment does not mean the Segment has been deleted from the 
database.  The Segment is still there and can be seen under the Keys Tab. 

 
 
END OF TASK 
 
 
END OF WORK PACKAGE 
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ADD AND EDIT FUNCTIONS 
 
The SKL UAS program allows the operator to add platforms and equipment to their database using a 
manual entry method.  Once the platform and equipment is added to the database it can be edited to 
change the name or attributes.  The following procedures will describe the actions to add or edit platforms 
and equipment. 
 
Add Platform 
 
The Add Platform function allows the user of the SKL to add a Platform to the Mission Database.  Follow 
the procedures below to add a platform to the mission database.  Start by making sure that you are on 
the Plats tab as depicted in Figure 1, Plats Tab, below. 
 

 
Figure 1.  Plats Tab. 

 
NOTE 

 
When platforms are added to the database, they will be put at the end of the Plats 
Tab unless you have selected to have the Plats Tab sorted alphabetically first.  The 
SKL UAS program puts the numerically numbered platforms before the 
alphabetical platforms when sorting is turned on. 

 
1. Now select File→Add Platform as depicted below in Figure 2.  File→Add Platform. 
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Figure 2.  File→Add Platform. 

 
2. As a result of the above selection the window in Figure 3.  Platform Name opens. 
 

Figure 3.  Platform Name. 
 
. Fill in the Platform Name and select a Distribution Path if desired.  You must also determine 

 
NOTE 

 
Bussed - The SKL will be connected to a Fill Port that is in the Platform but not part 

on-Bussed - The SKL will be connected to the equipment Fill Port and no Fill 

 

3
whether or not this platform is Bussed.  When finished, tap on the OK button.  The window in 
Figure 4, Plats Tab, re-opens. 

of the equipment.  An example of this is a helicopter where the equipment is in the 
rear but the Fill Port is located in the Cockpit.  Bussed is also used when activating 
the wakeup or handshake of a specific equipment Fill Location. 
 
N
Location wakeup or handshake is required. 
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Figure 4.  Plats Tab. 

 
. As can be observed from the depiction above, the Platform 1-M1-AAMS has been added to the Plats 

 
ND OF TASK 

dit Platform 

he Edit Platform selection allows the operator of the SKL to edit the Platform Name.  Use the following 
 

 
Figure 5.  Plats Tab with Platform Highlighted. 

1. Now select File→Edit P latform. 

4
Tab.  All Platforms added in this way are put at the top of the Plats Tab as long as sorting is turned on 
with no + sign.  If you do a refresh action the + sign will appear even though no equipment is 
assigned to it. 

E
 
E
 
T
procedure to Edit a Platform.  The first thing you want to do is to highlight the Platform you want to edit on
the Plats Tab as shown below in Figure 5, Plats Tab with Platform Highlighted. 
 

 
latform as depicted below in Figure 6, File→Edit P
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Figure 6.  File→Edit Platform. 

 
2. As a result of performing the above selection, the window in Figure 7, Platform Name, opens. 
 

Figure 7.  Platform Name. 
 

. From this window you can change the Platform Name and the Distribution Path if desired.  You 

 

 

3
may also change the Bussing characteristics of the platform.  Once you are finished editing the 
platform, tap on the OK button.  The window in Figure 8, Plats Tab, re-opens. 
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Figure 8.  Plats Tab. 

 
4. As depicted above you can see the platform name was changed from 1-M1-AAMS to 1-M1-

ABRAMS.  Now select File→Save Database. 
 
END OF TASK 
 
Add Equipment 
 
The Add function under the File menu allows the user of the SKL the capability to add equipment to the 
Mission Database.  The following procedures should be followed to add equipment to the Mission 
Database. 
 
1. To start the procedure, make sure that the Eqs Tab is open as shown below in Figure 9, Eqs Tab. 
 

NOTE 
 

When equipment is added to the database, they will be put at the end of the Eqs 
Tab unless you have selected to have the Eqs Tab sorted alphabetically first.  
The SKL UAS program puts the numerically numbered equipment before the 
alphabetical equipment when sorting is turned on. 
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Figure 9.  Eqs Tab. 

 
2. Now select File→Add Equipment as shown in Figure 10, File→Add Equipment. 
 

Figure 10.  File→Add Equipment. 
 

. Once you have selected Add Equipment, the following window in Figure 11, Equipment Name, 

 

 

3
opens. 
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Figure 11.  Equipment Name. 

 
4. On this window there are some fields that need to be filled out and two drop down lists to choose 

from.  Enter the Equipment Name, select the Equipment Type from the drop-down list, the 
Distribution Path is required and may be set to blank, and finally any specific Bus Address that is 
affiliated with this equipment type.  Once this information is entered, tap on the OK button.  The 
window in Figure 12, Eqs Tab, opens. 

 

Figure 12.  Eqs Tab. 
 

. You can now see from the Eqs Tab that the equipment SINCGARS B110 has been added to the 
st 

 

5
Mission Database at the bottom of the equipment list.  This means that sorting for the equipment li
is not turned on.  This equipment, however, is not assigned to any platform in the database nor does 
it have any Key Tag material assigned to it.  Now select File→Save Database to save the changes 
you have just made. 

 
ND OF TASK 

dit Equipment 

he Edit function under the File menu allows the user of the SKL the capability to edit equipment that is 
stored in the Mission Database.  The following procedures should be followed to edit equipment. 

E
 
E
 
T
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1. To start the procedure, make sure that the Eqs Tab is open and the equipment you wish to edit is 

highlighted as shown below in Figure 13, Eqs Tab with Equipment Highlighted. 

 
Figure 13.  Eqs Tab Highlighted. 

. As depicted above, the equipment SINCGARS B110 has been selected for editing.  Now select 
File→Edit Equipment

 

 
. Once you have selected Edit Equipment, the following window in Figure 15, Equipment Name, 

opens. 
 

 

with Equipment 
 
2

 as shown in Figure 14, File→Edit Equipment, below. 
 

Figure 14.  File→Edit Equipment. 

3
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Figure 15.  Equipment Name. 

 
4. The only areas that can be edited are the Equipment Name and Distribution Path.  You can only 

choose a Distribution Path that is already listed under the drop down menu to include a blank 
Distribution Path.  Make the changes you desire and then tap on the OK button.  The window in 
Figure 16, Eqs Tab, opens. 

 

Figure 16.  Eqs Tab. 
 

. As depicted above the Equipment Name was changed from SINCGARS B110 to CMDR RT1.  Now 

 
ND OF TASK 

ND OF WORK PACKAGE 

 

5
select File→Save Database to save the changes you have just made. 

E
 
 
E
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FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
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FILE MENU 
 EMPTY OR REMOVE A QUICK REFERENCE 
 
 
EMPTY OR REMOVE A QUICK REFERENCE 
 
There are two methods to remove an entry from the Quick Reference folder.  The first method will remove 
all Quick Reference entries.  The second method will remove just a single entry in the Quick Reference 
folder.  The following paragraphs provide the procedures to use each method. 
 
Empty All Quick Reference Entries 
 
1. To empty the Quick Reference folder of all entries, make sure that you have the SOI Tab open.  The 

window in Figure 1, SOI Tab, illustrates this. 
 

 
Figure 1.  SOI Tab. 

 
2. Now select File→Empty Quick Reference as depicted in window in Figure 2, File→Empty Quick 

Reference, below. 
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Figure 2.  File→Empty Quick Reference. 

 
c. Once you have selected Empty Quick Reference, the following window in Figure 3, Really 

Remove All Entries, opens. 
 

Figure 3.  Really Remove All Entries. 
 

d. The SKL prompts you for he Quick reference.  Select Yes 

 

 

confirmation to remove all entries from t
to delete the item or No to cancel the deletion process.  To remove all entries from the Quick 
Reference, tap on the Yes button.  The window in Figure 4, Operation Successful, opens. 
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Figure 4.  Operation Successful. 

 
e. Tap on the OK button in the upper right corner of the window with the Inductive Stylus.  The 

window in Figure 5, SOI Tab, opens. 
 

Figure 5.  SOI Tab. 
 

f. You will notice that there is no + (plus sign) to the left of the Quick Reference folder indicating that 

 
ND OF TASK 

emoving a Single Quick Reference Entry 

nce folder, you may need to remove just a single Quick 

. Make sure the SKL UAS is open to the SOI tab.  Tap on the + sign to the left of the Quick Reference 

 

 

there are no Quick Reference entries. 

E
 
R
 
 you have multiple entries in your Quick RefereIf

Reference entry while leaving the other entries present.  To remove a single Quick Reference entry, 
follow the procedures below. 
 
1

folder and select the net group which contains the net(s) you want to remove as shown in Figure 6, 
Quick Reference Item Selected. 
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Figure 6.  Quick Reference Item Selected. 

2. Now select View→Curren cted below in Figure 7, 
View→Current Selection, below. 

 

. Once you have selected View→Current Selection, the window in Figure 8, Net Info, opens. 
 

 
t Selection from the SKL UAS Main Menu as depi

 

Figure 7.  View→Current Selection. 
 
3
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Figure 8.  Net Info. 

 
4. As depicted in the window above, there is a Checkmark ( ) in the “Add to Quick Reference” box.  To 

remove this net from the Quick Reference folder, tap on the Checkmark to remove it and then tap on 
the OK button.  The window in Figure 9, SOI Tab with Quick Reference Expanded, opens. 

 

Figure 9.  SOI Tab With Quick Reference Expanded. 
 

. As can be seen from the windo n removed from the 

 
ND OF TASK 

ND OF WORK PACKAGE 

 

5 w above the Net C/1-12 in Time Period 5 has bee
Quick Reference.  Since there was only one entry under Time period 5, it was removed from the 
Quick Reference entries.  Now select File→Save Database to save the changes to the Mission 
Database that has just been made. 

E
 
 
E
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FILE MENU 
 DELETE DATABASE 
 
 
DELETE A DATABASE 
 
As with the expired keys, you can delete an entire database or an individual database item from the SKL.  
This is another of the housekeeping functions that allow you to maintain the SKL in a current and 
manageable configuration.  Follow the procedure below to delete a database. 
 
1. To delete a database select File→Delete Database from the SKL Main Menu as depicted in Figure 

1, File→Delete Database, opens. 
 

Figure 1.  File→Delete Database. 
 

. As a result of selecting File→Delete Database, the window in Figure 2, Database Options, opens. 

 

2
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Figure 2.  Database Options. 

 
3. The Delete Database Wizard window provides a list of databases that are candidates for deletion on 

the Database Options screen.  This window defaults to all databases selected.  You may select 
just one database item by tapping on the Deselect All button and then select an individual database 
by putting a Checkmark ( ) to the left of the desired database with the Inductive Stylus.  For this 
example we have selected the Platform database to the deleted as shown in Figure 3, Delete 
Platform Database, below. 

 

 
Figure 3.  Delete Platform Database. 

 
4. Once the required selection has been made, tap on the Next>> button.  The window in Figure 4, 

Platform Selection, opens. 
 

0013-3 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0013 
 

 
Figure 4.  Platform Selection. 

 
5. From this window you can further select which Platform you wish to delete.  All Platforms are selected 

by default.  You may tap on the Deselect All button to remove all the Checkmarks and then select 
which Platform you wish to delete.  We have selected the multiple Platforms to delete as depicted in 
Figure 5, Platforms Selected, below. 

 

Figure 5.  Platforms Selected. 
 

. Now tap on the Next>> button.  The window in Figure 6, Finish, opens. 

NOTE 
 

This procedure will only delete the selected platform database.  The equipment 
ed. 

 

 

6
 

and keys associated with the selected platform will remain in the SKL until delet
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Figure 6.  Finish. 

 
7. If you are sure that you want to delete the selected database(s), tap on the Delete button.  The 

window in Figure 7, Delete Database Confirmation, opens.   
 

 
 

Figure 7.  Delete Database Confirmation. 
 
8. This window allows the SKL user to validate the deletion of the selected database items.  Tap on OK 

in the upper right-hand corner to confirm the deletion or tap on the X in the upper right-hand corner of 
the window to cancel the deletion process.  The database will automatically be saved.  As a result 
of the continuation of the deletion process the window in Figure 8, Selected Databases Deleted, 
opens. 
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Figure 8.  Selected Databases Deleted. 
 

i. This is a confirmation window that the selected database(s) was deleted.  Tap on the OK button.  
The SKL returns to the tab that you had open when you started the deletion process. 

 
END OF TASK 
 
 
END OF WORK PACKAGE 
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FILE MENU 
 TRANSMIT/LOAD 
 
 
TRANSMIT 
 
The Transmit selection under the File Menu has ten (10) submenu selections.  They are Load, Load 
Modern Keys, Load Selected Keys, Load Selected Locations, Load EPLRS, Load PRC-137, Load Benign 
Fill, Load Mode 5 IFF, Database, and ECU Commands.  This particular Work Package 0014 will only 
address the first five submenu selections.  The last five selections will be discussed in the next Work 
Package 0015. 
 
Load 
 
The Load selection is the best way to load equipment with data and COMSEC key.  When the Load 
selection is made it performs an automatic load of the equipment based on data and key assignments 
that have been specifically made for that Platform and Equipment.  There are three (3) available Load 
options.  They are; Load a Platform, Load Equipment Assigned to a Platform, and Load Assigned Key.  
Each of these Load functions is described in the following paragraphs. 
 
Load a Platform.  The Load Platform procedure is the best way to load all the equipment assigned to the 
platform.  It is automatic and requires very little operator interaction.  All data and COMSEC keys will be 
loaded to the correct equipment locations assigned to the platform.  The platform in the example below is 
the Commander’s HMMV SINCGARS radio.  The windows may be different for other equipment.  For 
other platforms, follow the prompts given on the Load ECU Wizard (Profile) window. 
 
1. From the Plats Tab select the desired platform to load as shown in Figure 1, Plats Tab with 

Platform Selected, below. 
 

 
Figure 1.  Plats Tab with Platform Selected. 
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NOTE 
 
The windows shown below are for the SINCGARS Radio only and are provided as 
an example of loading Key by Selecting a Platform. 

 
2. From the SKL UAS Main Menu, select File→Transmit→Load.  The window in Figure 2, SINCGARS 

Mode, opens. 
 

Figure 2.  SINCGARS Mode. 
 

. In this procedure we are going to select “Integrated COMSEC (ICOM) Transfer”.  When the ICOM 

 

 
Figure 3.  SINCGARS Mode ICOM Selected. 

4. The decision to load the t e operator.  If the 

 

3
Transfer is selected, the “Include Time” field opens and is available to be selected as shown in 
Figure 3, SINCGARS Mode ICOM Selected, below. 

  
ime from the SKL into the SINCGARS is up to th

SINCGARS is of the ASIP family then Time must be included.  If the SKL’s time has been set using a 
ct 

 

PLGR then it would be a good idea to go ahead and include the time in the load.  Once the corre
selections are made tap on the OK button.  The window in Figure 4, Load ECU Wizard, opens. 
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Figure 4.  Load ECU Wizard. 

5. This window displays the Equipm nd the Equipment Name.  Connect 
the SKL to the Fill port on the SINCGARS radio and then tap on the Next>> button.  The window in 

 

 

. The Load ECU Wizard Profiles window will only display those steps you are required to take based 
on the Profile Modes that is c file Modes is set to "Detailed" 
then you will see most if not all steps required for you to take.  If the Profile Modes is set to 

tton as 
 

 
 
 

 

 
ent Type you are about to load a

Figure 5, Load ECU Wizard Profiles, opens. 

Figure 5.  Load ECU Wizard Profiles. 
 
6

urrently selected on your SKL.  If the Pro

"Condensed", then you will see only a minimum amount of steps.  See Work Package 0029 Options 
for more information on the Profile Modes.  Follow the instructions in the Profile window for your 
equipment.  Once all the settings and actions have been accomplished, tap on the Send bu
shown in Figure 5.  The SKL will also display any errors that may occur during the load routine.  Once
the ECU has received its load, the window in Figure 6, Reload Equipment opens. 
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7. Now you have to make a deci nt assigned to the Platform then 

you should select No.  If however there were multiple equipment assigned to the Platform and you 
wish to load all of them at this tim f you selected Yes you would see 
the window in Figure 3 open again and you would follow the steps 4-6 above for each equipment that 

 

 

 
8. Tap on the OK button to close the di ow.  The SKL returns to the Plat Tab. 

END OF TASK 

ad equipment 
at has been assigned to a specific platform.  The platform may have multiple pieces of equipment 

d you may only want to load one specific piece of equipment from that platform. 

 
 

Figure 6.  Reload Equipment. 

sion.  If there was only one equipme

e, then you should select Yes.  I

you are loading that is assigned to the Platform.  If you select No then the window in Figure 7, 
Operation Successful opens. 

Figure 7.  Operation Successful. 

alog wind
 

 
Load Equipment Assigned to a Platform.  This procedure allows the SKL operator to lo
th
assigned to it an
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NOTE 
 

The windows shown below are for the SINCGARS ICOM radio only and are 
provided as an example of loading Equipment Assigned to a Platform. 

. From the Plats tab, select the equipment you want to load from the expanded platform as depicted in 
Figure 8, Plats Tab with Equipment Selected,

 

 
2. You will notice in the above wind quipment has been selected.  Also 

notice that it has several fill location edure, all of these locations will be filled with data 
and COMSEC key autom pment selected (highlighted), select 
File→Transmit→Load as depicted in Figure 9, File→Transmit→Load, below. 

 

 
3. As a result of selecting the Load 0, SINCGARS Mode, opens. 
 

 
1

 below. 
 

Figure 8.  Plats Tab with Equipment Selected. 

ow that the SINCGARS RT2 e
s.  With this proc

atically.  With the SINCGARS RT2 equi

 

Figure 9.  File→Transmit→Load. 

 function, the window in Figure 1

0014-6 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0014 
 

 

 
4. Now select the type of Mode that SINCGARS now fielded to the U.S. 

Army are ICOM SINCGARS radio fer.  The window in Figure 11, 
SINCGARS Mode ICOM Selected, opens. 

 
ected. 

 
5. You will notice that the Include Time b ve.  If the SKL's time was loaded using a 

PLGR or some  include the time in the loading 
process.  If the SINCGARS st be included.

Figure 10.  SINCGARS Mode. 

 your SINCGARS radio is.  Most 
s; therefore, select ICOM Trans

Figure 9.  SINCGARS Mode ICOM Sel

ox becomes acti
 extremely reliable time source then you may wish to

 is of the ASIP family then Time mu   If you do, then put a 
Checkmark ( ) in the Include Time box and tap on the OK button.  The window in Figure 12, 
Connect To opens.  
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Figure 12.  Connect To. 

 
6. This window displays the Equipment Type you are about to load and the Equipment Name.  Follow 

the instructions in the TIP area and then tap on the Next>> button.  The window in Figure 13, Load 
ECU Wizard Profiles, opens. 

 

Figure 13.  Load ECU Wizard Profiles. 
 

. The Load ECU Wizard Profiles window will only di required to take based 

Options 

The 

 
NOTE 

 
The subsequent windows that open will vary depending on the equipment that you 

 

 

7 splay those steps you are 
on the Profile Modes that is currently selected on your SKL.  If the Profile Modes is set to "Detailed" 
then you will see most if not all steps required for you to take.  If the Profile Modes is set to 
"Condensed", then you will see only a minimum amount of steps.  See Work Package 0029 
for more information on the Profile Modes.  Follow the instructions in the Profile window for your 
equipment.  Once all the settings and actions have been accomplished, tap on the Send button.  
window in Figure 14, Status, opens. 

are trying to load. 
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Figure 14.  Status. 

 
8. In this particular case, the SKL is informing you to press the Load Button on the SINCGARS RT2 

equipment.  Therefore, press the Load button on the equipment.  The window in Figure 15, Reload 
Equipment, opens. 

 

Figure 15.  Reload Equipment. 
 

. This window gives you the opportunity to determine if you need to reload the equipment or not.  For 
.  

s 

 

 

9
instance, you may have forgotten to set the Channel switch to MAN as directed in the Profile window
As such the load most probably did not occur properly.  Therefore you would want to correct that 
oversight and reload the equipment.  However, if you believe that you have followed the procedure
correctly then tap on the No button.  The window in Figure 16, Operation Successful, opens. 
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Figure 16.  Operation Successful. 

 
10. The appearance of this window indicates that the load operation was successful.  Tap on the OK 

button in the upper right-hand corner of the window.  The SKL closes this window and the Plats tab 
re-opens.  You need to check the equipment you just loaded to make sure that it can communicate 
inside its net. 

 
END OF TASK 
 
Load Assigned Key.  This procedure will allow you to load a single assigned Key to a Fill Location on 
Equipment assigned to a Platform.  This feature can save time and ensure that the right key gets to the 
right Fill Location on the right Equipment assigned to the right Platform. 
 
1. From the Plats tab, expand the Platform, Equipment, Fill Location, Short Title, and Edition so that 

you can see the Key assigned to the Fill Location as depicted in Figure 17, Plats Tab Expanded, 
below. 

 

Figure 17.  Plats Tab Expanded. 
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NOTE 

The windows shown below are for the Equipment KY58 only, and are provided as 
an example of loading assigned Key to a specific Fill Location on Equipment 

 
2. You ndow that there are two Editions of Short Title USKATA00001266 

assigned to LOC1 on the KY58.  Once you have selected the correct Platform, Equipment, Fill 
cted 

 

 
ad. 

3. As a result of selecting the Loa indow in Figure 19, Load ECU 
Wizard, opens. 

 

. This window displays the Equipment Type you are about to load and the Equipment Name.  Connect 
the SKL to the Fill Connector on xt>> button.  The window in 
Figure 20, Load ECU Wizard Profile

 

 

assigned to a Platform. 

 will notice in the above wi

Location, Short Title, Edition, and Key select File→Transmit→Load from the Main Menu as depi
below in Figure 18, File→Transmit→Load, below. 

Figure 18.  File→Transmit→Lo
 

d function from the Main Menu, the w

 

Figure 19.  Load ECU Wizard. 

the KY58 and then tap on the Ne
s, opens. 

 
4
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files. 

 
5. The Load ECU Wi y those steps you are required to take based 

on the Profile Modes that is currently selected on your SKL.  If the Profile Modes is set to "Detailed" 
then you will see most if not all steps required for you to take.  If the Profile Modes is set to 
"Condensed", then you will s  Work Package 0029 Options 
for more information on the Profile Modes.  Follow the instructions in the Profile window for your 

 

 

 

 
Figure 21.  Status. 

 
 

Figure 20.  Load ECU Wizard Pro

zard Profiles window will only displa

ee only a minimum amount of steps.  See

equipment.  Once all the settings and actions have been accomplished, tap on the Send button.  The
window in Figure 21, Status, opens. 

NOTE 

The subsequent windows that open will vary depending on the equipment that you 
are trying to load. 

 
NOTE 

 
Refer to the equipment Technical Manual for the location of the Mode switch and 
the Rotary switch. 

 

0014-12 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0014 
 

NOTE 
Refer to the equipment T f the Initiate button. 

 
6. The SKL is now telling you to press Init pment.  Press the Initiate button on 

the Receiving Equipment.  The win , opens. 
 

 

hat you will know 
how to answer the question.  If you don't see the indicator come on or flash, then chances are 
that the load failed and you shoul r, if you see the indicator come on or 
flash, then tap on the Yes d Equipment, opens.   

 

 
8. 

e load 
d re-load 

the equipment.  However, if you believe that you have followed the procedures correctly then tap on 
the No button.  The window in Figure 24, Operation Successful, opens. 

 

echnical Manual for the location o

iate on the Receiving Equi
dow in Figure 22, Check Parity

Figure 22.  Check Parity. 
 
7. On the KY58 there is an indicator lamp that will turn on if the key was received and the parity 

check was successful.  Make sure that you are looking at that indicator so t

d select No.  Howeve
button.  The window in Figure 23, Reloa

 
Figure 23.  Reload Equipment. 

This window gives you the opportunity to determine if you need to reload the equipment or not.  For 
instance, you may have forgotten to set the Rotary switch to the correct position.  As such th
most probably did not occur properly.  Therefore you would want to correct that oversight an
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Figure 24.  Operation Successful. 

 
. The appearance of this window indicates that the load operation was successful.  Tap on the OK 

 
END
 
Load Modern Key 
 
The Army now has a limited numbe rs (INEs) that use Modern Key.  There 
are specific attributes a rent than an ordinary TEK or KEK.  The 
procedures to load Modern Key are provi  will use the TACLANE as the INE to 
load the Modern Key into. 
 
1. Open the Keys Tab, then select ys as shown in Figure 25, 

File→Transmit→Load Modern Ke
 

9
button in the upper right-hand corner of the window.  The SKL closes this window and the Plats tab 
re-opens.  Now you should do a commo check on the KY58 to make sure that the key loaded 
properly and the equipment is operationally functional. 

 OF TASK 

r of ECUs and In Line Encrypto
ttached to Modern Key which make it diffe

des below.  This procedure

File→Transmit→Load Modern Ke
ys below. 

 
 

Figure 25.  File→Transmit→Load Modern Keys. 
 
2. As a result of the above selection, the window in Figure 26, Selected Modern Keys opens. 
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Figure 26.  Selected Modern Keys. 
 
3. Select the Modern Key you wish to load and then click on the OK button.  The window in Figure 27, 

Key Load Settings opens. 
 

 
 

Figure 27.  Key Load Settings. 
 
4. The window will allow you to select which type of protocol to use to transmit the Modern Key.  For the 

TACLANE we have chosen the RS-232 protocol.  Once the protocol and other selections are made, 
tap on the OK button.  The win  opens. dow in Figure 28, Ready to Send Key
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Figure 28.  Ready To Send Key. 
 
5. This window just allows you to verify the key you are about to load.  The Display for Every Key 

selection should always be checked so that this window appears.  Tap on the OK button.  The 
window in Figure 29, Status opens. 

 

 
 

Figure 29.  Status. 
 
6. Depending on what Protocol you selected the information shown on the Status window could cha

Once the connection is made and the key is loaded to the INE TACLANE, the window in Figure
Operation Successful opens. 

nge.  
 30, 
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Figure 30.  Operation Successful. 

7. t 
cked out to make sure that it can perform its mission. 

END OF TASK 
 
Load Selected Keys 
 
The Load Selected Keys option really concern ed key that may be in the Mission Database.  
You should never use this option to load ke   The Load Selected 
Keys option only becomes en the Keys tab is open.  The Keys tab will display 
both assigned and unassigned key.  If tion, be aware that you will not get a 
Profile window to assist you with the eq n loading assigned key.  Therefore, 
you must be thoroughly familiar with the  the key into.  Use the following 
procedure to load unassigned key into e
 
1. Start by selecting the Keys tab as d b, below.  It does not make any 

difference, which Short Title is highli Tab. 
 

 
Now tap on the OK button in the upper right-hand corner of the window to dismiss it.  The equipmen
you just loaded should be che

 

s unassign
y that is assigned to equipment.

available to be selected wh
you decide to use this op
uipment setup as you do whe
 equipment you are loading
quipment. 

epicted in Figure 31, Keys Ta
ghted when you open the Keys 

 
Figure 31.  Keys Tab. 

 

0014-17 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0014 
 
2. With the Keys tab open, select File→Transmit→Load Selected Keys as shown in Figure 32, Load 

 

 
Figure 32.  Load Selected Keys. 

3. Once you have made the selection Lo  window in Figure 33, Key Load Select 
Keys, opens. 

 
ys. 

. This window is where you select which unassigned key you wish to load.  It defaults to no keys 
selected.  Select the unassigne above.  Then tap on the OK 
button.  The window in Figure 34, DS-102 opens. 

Selected Keys, below. 

 
ad Selected Keys, the

 

Figure 33.  Key Load Select Ke
 
4

d key you wish to load as depicted 
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Figure 34.  DS-102 Figure 36.  RS-232 

L 
 the unassigned key.  The following paragraphs will 

explain in detail each of the above figures. 
 

a. In Figure 34 above there are only two (2) active fields that can be selected.  The first is the 
Protocol field.  This figure shows that the DS-102 protocol was selected.  The second field is the 
Activate Mode field.  This field allows you to select what type of DS-102 emulation you want the 
SKL to perform.  There are ten different selections that can be made.  You must chose carefully 
so that the right emulation is selected for the loading of the unassigned key. 

 
b. In Figure 35 above, once the DS-101 protocol is selected there are five (5) additional active fields 

that can be selected.  These are Bus Address, Send WakeUp, Send Tag, Mode, and Timeout.  
The Bus Address defaults to 255.  If the receiving device has the ability to display the Key Tag 
information, you will want to select Send Tag.  The Send WakeUp selection should be selected if 
the target device requires it.  Once the Send WakeUp is selected the Seconds field opens.  This 
field defaults to 5 seconds.  You can change this based on the receiving device’s requirements.  
Finally, you must select the type of Mode this load is performing.  The default is Fill.  The other 
selection is Issue.  If you are filling a device so that it can communicate with other devices, then 
select Fill.  If you are giving this key to a device so that it can then load another device, then you 

st sele n to 
receivin ents.  In selec col, 

aud Rate, Send Tag, Mode, and Timeout.  The Activate 
n 

 

 

Figure 35.  DS-101 
 
5. Even though the above figures are titled Key Load Settings, what you are really doing with this 

window is selecting an emulation mode for the SKL.  Once the emulation mode is chosen, the SK
will act just like the mode that was selected to load

should select Issue.  The Timeout value 
make here depends on the 

has Slow, Medium, and Fa
g equipment requirem

ctions.  The selectio
ting the DS-101 proto

you are saying to the SKL to emulate a DS-101 device to load the unassigned key into the 
equipment or issue the key to another SKL attached to the equipment. 

 
c. In Figure 36 above there are five (5) active fields that can be selected once the RS-232 protocol 

is selected.  These are Activate Mode, B
Mode has two selections, RS232 and STE.  The Send Tag and Mode fields were explained i
Paragraph b above.  The Baud Rate field allows you to select a baud rate based on the receiving
equipment's capabilities.  The range in this field is 1200 to 9600 baud.  The Timeout field was 
explained in Paragraph b above.  In selecting the RS-232 protocol, you are saying to the SKL to 
emulate a RS-232 device to load the unassigned key into the equipment. 

Once you have made your emulation selections, tap on the OK button.  The window in Figure 37, 
Ready to Send Key, opens. 
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Figure 37.  Ready To Send Key. 

 
6. This

Title  eck box which when selected 
will display this window ed mode.  If you don’t want to see 
this window for each key selected ) from the box.  Once you have 
determined your selections and verifie n the OK button.  The window in 
Figure 38, Status, opens. 

 

 

 
nt Technical Manual for the location of the Initiate button. 

7. Depending on the emulation mode that you chose for the SKL to follow, various messages can 
appear on the Status window.  In this case the Status window is telling the operator to "Press the 
Initiate Button".  Locate the Technical Manual for the equipment you are loading unassigned key into 
to locate the position of the Initiate button.  Once you have pressed the Initiate button the window in 
Figure 39, Operation Successful, opens. 

 

 window displays the key you have selected to load into the equipment.  It displays the Short 
 Edition, Segment, and Text, ID of the key selected.  It also has a ch

 for every key to be loaded in the unassign
, then remove the Checkmark (

d the key to be loaded, tap o

 
Figure 38.  Status. 

NOTE 

Refer to the equipme
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Figure 39.  Opera ful. 

. Now tap on the OK button in the upper right-han rner of the window to close it.  The SKL UAS 
Des

Loa
 
The SKL gives the user the option of loading key in

qu g procedure to Load Selected Locations. 
 

1. From the Plats tab, select want to load from the expanded 
platform as depicted in Figure 40, ent Fill Location Selected, below. 

 

 Tab with Equipment Fill Location Selected. 

 

tion Success
 
8 d co

ktop returns to the Keys Tab. 
 
END OF TASK 
 

d Selected Locations 

to a specific Fill Location on a specific piece of 
ipment on a specific Platform.  Use the followinE

the equipment and Fill location you 
Plats Tab with Equipm

 
Figure 40.  Plats
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NOTE 
 
The windows shown below are for the SINCGARS radio only and are provided as 

probably will be different. 
 
2. You will notice in the above wind SINCGARS RT2 equipment for 

the CDR HMMV Platform has been re, only the C1 Fill Location will be 
filled with COMSEC key automatic ht) a location on the equipment 
before you can use this procedu 2 C1 equipment Fill location selected 
(highlighted), select File→Transmit  as depicted in Figure 41, 
File→Transmit→Load Selected Lo

 

Figure 41.  File Load Selected Locations. 
 
3. As a tion(s), 

ope
 

 
Figure 42.  Select Location(s). 

 

an example of loading a specific Fill location on Equipment assigned to a Platform.  
If you are loading any other piece of Equipment some of the windows could and 

ow that the Fill Location C1 of the 
selected.  With this procedu

ally.  You must select (highlig
re.  With the SINCGARS RT
→Load Selected Locations

cations, below. 

 
→Transmit→

 result of selecting the Load Selected Locations, the window in Figure 42, Select Loca
ns. 
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4. From this window you may select a single location to fill or multiple locations to fill.  Once you 

have made your selections, tap on the  in Figure 43, SINCGARS Mode, 
opens. 

 

5. Since this procedure depicts loading the SINCGARS radio, the user must tell the SKL which 
SINCGARS Mode will be loade  time is to be included in the 
loading process.  Most if not all SINCG  now ICOM type radios.  Therefore, 
tap on the ICOM Transfer radio button n if you want to include the time in 
the transfer, tap in the box next to If the SINCGARS is of the ASIP family then Time 

OK button.  The window

 
Figure 43.  SINCGARS Mode. 

 

d.  You must also tell the SKL if the
ARS radios in the Army are
as depicted above and the

Include Time.  
must be included.  The window in Fig ens. 

 

 
Figure 44.  Load ECU Wizard. 

6. This window displays the Equipment Type you are about to load and the Equipment Name.  Follow 
the instructions in the TIP area and then tap on the NEXT>> button.  The window in Figure 45, Load 
ECU Wizard Profiles, opens. 

 

ure 44, Load ECU Wizard, op
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Figu es. 

ased 
ed" 

p on the Send button.  The 
window in Figure 46, Status, opens. 

 

 
The subsequent windows tha e equipment that you 
are trying to load. 
 

 
Figure 46.  Status. 

 
NOTE 

 
Refer to the equipment Technical Manual for the location of the Load button. 

 
8. This window informs you to press the Load button on the SINCGARS radio.  Follow the instructions 

and then tap on the Continue button.  The window in Figure 47, Status, opens. 

re 45.  Load ECU Wizard Profil
 
7. The Load ECU Wizard Profiles window will only display those steps you are required to take b

on the Profile Modes that is currently selected on your SKL.  If the Profile Modes is set to "Detail
then you will see most if not all steps required for you to take.  If the Profile Modes is set to 
"Condensed", then you will see only a minimum amount of steps.  See Work Package 0029 Options 
for more information on the Profile Modes.  Follow the instructions in the Profile window for your 
equipment.  Once all the setting and actions have been accomplished, ta

NOTE 

t open will vary depending on th
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Figure 47.  Status. 

 
9. The Status window is alerting you that it sending TEK #1.  After the transfer is complete the window i

Figure 48, Reload Equipment, opens. 

NOTE 

The subsequent windows that open will vary depending on the equipment that you 
are trying to load. 

n 

 

 

 

 
10. If you have confidence that tly, then tap on the NO button.  If you 

feel that you made a mistake du nd the key in not in the location it should 
be, tap on the YES button.  For this demonstration we will choose the NO button.  The window in 
Figure 49, Operation Successful, open

 

Figure 48.  Reload Equipment. 

 you have loaded the radio correc
ring the loading procedure a

s.   
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ful. 

 
1. The appearance of this window indicates that the load operation was successful.  Tap on the OK 

button in the upper right-hand corner of L closes this window and the Plats tab 
re-opens.  Now to verify the load was correct you need to do a radio check to make sure you can 

 
ND OF TASK 

 
oad EPLRS 

 
In order  Position Location Reporting System (EPLRS) radio set, the SKL must have 
received from the EPLRS Net Control Station KOK-13 the required keys for each radio set that your SKL 
is required to load.  Once these keys nto the SKL the SKL can now load 
the EPLRS radio sets.  To do this sele LRS as depicted below in Figure 50, 
File→Transmit→Load EPLRS, below. 

 
1. indow in Figure 51, Loading EPLRS TEK and IKEK, 

opens. 
 

Figure 49.  Operation Success

1
 the window.  The SK

communicate on the channels that you loaded. 

E

L

 to load an Enhanced

 (IKEK and TEK) are received i
ct File→Transmit→Load EP

 
Figure 50.  File→Transmit→Load EPLRS. 

As a result of selecting Load EPLRS, the w
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Figu EK. 

um, 

e 
to 99.  The Load Next Week's TEK is a simple check 

box.  The SKL operator determines whether or not to load next week's TEK into the EPLRS radio set.  
eys area of the window will allow the SKL operator to select which key or keys to load to 

the EPLRS radio set.  If this is the initial load of the EPLRS radio set then you should select IKEK and 
e all selections have been made tap on the Load button.  The window in Figure 52, Load 

ECU Wizard, opens. 

 

 
3. This window displays the Equipme ss, and any Tips for the 

operator of the SKL to make loadin sier.  After reading the information on 
this window tap on the Next>> button.  The window in Figure 53, Status, opens. 

 

re 51.  Loading EPLRS TEK and IK
 
2. There are four areas of information that must be selected on this window.  They are DIVID, Seg N

Load Next Week's TEK, and Select Keys.  The DIVID is alphabetic and can be from A to G.  The 
number chosen here corresponds to the Division the particular EPLRS radio set is assigned to.  Th
Segment Number is numeric and can be from 1 

The Select K

TEK.  Onc

 

Figure 52.  Load ECU Wizard. 

nt Type, Equipment Name, Bus Addre
g the EPLRS radio set ea
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Figure 53.  Status. 

 
4. Now press the Initiate button on the EPLRS radio.  When the SKL is trough transmitting the window 

in Figure 54, Check Parity opens. 
 

 

 
5. You need to verify the load status of th o set.  This is done through a parity check.  If the 

parity check was successful, sele s not successful, select No and 
attempt the procedure agai  button, the window in Figure 55, Disconnect 
SKL, opens. 

 

 
 

 
 
 
 

Figure 54.  Check Parity. 

e EPLRS radi
ct Yes.  If the parity check wa

n.  In this case tap on the Yes

 
 

 
 

 

0014-28 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0014 
 

 
Figure 55.  Disconne KL. 

gure 56, Reload Equipment opens. 
 

ct S
 
6. Disconnect the SKL from the EPLRS radio set and then tap on the OK button in the upper right-hand 

corner of the window.  The window in Fi

 
 

Fig t. ure 56.  Reload Equipmen
 
7. You have already disconnected from the EPLRS radio set at this point.  You should always select 

NO even if you received an indication of a bad load to the EPLRS radio set.  Then you should 
attempt the load procedure from the beginning again.  The window in Figure 57, Operation 
Successful opens. 
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ful. 

8. Tap on the OK button in the uppe w.  The tab you had opened when 
you started this procedure opens.  A good parity check indicates a good load into the EPLRS radio 

 
ND OF TASK 

 
 
END OF WORK PACKAGE 
 
 

Figure 57.  Operation Success
 

r right-hand corner of the windo

set. 

E
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

SKL UAS TRANSMIT/LOAD TRKEK FUNCTION 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
 
TRANSMIT/LOAD TrKEK FUNCTION 
 
 
TRANSMISSION KEY ENCRYPTION KEYS (TrKEKs) 
 
A Transmission Key Encryption Key is one that encrypts other keys prior to them being transmitted or 
loaded.  In the case of the SKL, the TrKEK can be Filled as well as Issued.  In order for the TrKEK to 
work the way it was intended to work, it must be filled into the SKL by the KOK-22 (KP) or another SKL 
through the Load procedure.   
 
Fill Another SKL with a TrKEK 
 
If a master SKL has been Filled and Issued a TrKEK, it can now Fill another SKL through the Load 
command procedure.  This will allow a second SKL to be able to send and receive encrypted key.  To Fill 
another SKL with a TrKEK follow the procedure below.  On the master SKL, select the Keys Tab and 
scroll until you find the TrKEK Short Title and expand it and the Edition out to reveal the actual key.  
Make sure the key is highlighted as depicted below in Figure 1, TrKEK Expanded. 
 

 
Figure 1.  TrKEK Expanded. 

 
. With the TrKEK highlighted, select File→Transmit→Load as depicted in Figure 2, 

 

1
File→Transmit→Load, below. 
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Figure 2.  File→Transmit→Load. 

 
2. As a result of this above selection the window in Figure 3, Key Load Settings, opens. 
 

 
 

Figure 3.  Key Load Settings. 
 
3. You will notice that all of the information is already filled in for you.  Of particular note though is the 

Mode.  Make sure Fill is selected in the Mode Field.  That is because you are filling this TrKEK into 
the SKL and not issuing it to the SKL.  Fill is always the default.  Tap on the OK button.  The window 
in Figure 4, Connect to Receive Equipment, opens. 

 

0014.1-3 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0014.1 
 

 
Figure 4.  Connect to Receive Equipment. 

 
4. Prepare the receiving SKL by following the procedures in Work Package 0016-22, steps 1-6.  

Connect the sending SKL to the receiving SKL using the standard Fill Cable.  When finished, 
tap on the OK button.  The window in Figure 5, Operation Successful, opens. 

 

Figure 5.  Operation Successful. 
 

. A Status window opens giving you the st  Then you will get an Operation 

t 

 
 

ND OF TASK 

ND OF WORK PACKAGE 

 

5 atus of the Load operation. 
Successful window as depicted above.  Tap on the OK button in the upper right-hand corner of the 
window.  The SKL returns to the Keys Tab.  Disconnect the Fill Cable.  On the receiving SKL selec
View→Keys→TrKEK.  You should see the new TrKEK as a fill item in the receiving SKL.  On the 
receiving SKL the TrKEK is automatically saved to the database.  The operation is now complete.

 
E
 
 
E
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

SKL UAS TRANSMIT/LOAD FUNCTION (PART 2 OF 2) 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
 
FILE MENU 
 TRANSMIT/LOAD 
 
 
TRANSMIT 
 
The Transmit selection under the File Menu has ten (10) submenu selections.  They are Load, Load 
Modern Keys, Load Selected Keys, Load Selected Locations, Load EPLRS, Load PRC-137, Load Benign 
Fill, Load Mode 5 IFF, Database, and ECU Commands.  This particular Work Package 0015 will only 
address the last five submenu selections.  The first five selections are discussed in the previous Work 
Package 0014. 
 
Load the PRC-137 Radio 
 
The AN/PRC-137 radio is used in special circumstances by special U.S. Army units.  It is a unique radio 
in that it loads its keys using files rather than using a Platform loading procedure similar to the 
SINCGARS radio.  Use the following procedure to load an AN/PRC-137 radio.   
 
1. Select File→Transmit→Load PRC-137 as depicted below in Figure 1, File→Transmit→Load 

PRC-137. 
 

 
 

Figure 1.  File→Transmit→Load PRC-137. 
 
2. As a result of selecting Load PRC-137, the window in Figure 2, Select TrKEK, opens. 
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Figure 2.  Select TrKEK. 

 
3. The AN/PRC-137 requires that a Transmission Key Encryption Key (TrKEK) be loaded.  Select the 

TrKEK from the list and then tap on the Next>> button.  The window in Figure 3, Select Key File, 
opens. 

 

Figure 3.  Select Key File. 
 

. This window lists all key files stored in t

 

 

4 he Mission Database of the SKL.  Since the AN/PRC-137 is 
loaded using files rather than keys, select the appropriate file as depicted above and then tap on 
the Next>> button.  The window in Figure 4, Load Second Key File, opens. 
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Figure 4.  Load Second Key File. 

 
5. This window allows you to load a second key file if there is one available.  In the depiction above, we 

have selected "No Selection".  Therefore, make your own selection based on what is stored in the 
SKL's Mission Database and then tap on the Transmit button.  The window in Figure 5, Load ECU 
Wizard, opens. 

 

Figure 5.  Load ECU Wizard. 
 

. Connect the SKL to the AN/PRC-137.  Then follow the directions on the window and then tap on the 

 

 

6
Next>> button.  The window in Figure 6, Status, opens. 
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Figure 6.  Status. 

 
7. This window will provide you with a complete status of the loading procedure for the AN/PRC-137.  

Once the procedure is completed the window in Figure 7, Operation Successful, opens. 
 

Figure 7.  Operation Successful. 
 

. Tap on the OK button in the upper right-hand corner of the window.  The window closes and the SKL 

 
ND OF TASK 

oad Benign Fill 

enign Fill (BF) is the NSA-designed process for loading application keys and data into an ECU using 

ince this implementation is so new there are no instructions on how to use it in the SKL at this time.  As 
Benign Fill keying is implemented further in the U.S. Army this task will be updated to show how Benign 
Fill can be loaded in BF capable ECUs. 
 

 

8
UAS Desktop opens with the Keys Tab displayed. 

E
 
L
 
B
public key cryptography techniques.  Benign Fill is designed so that the application keys are never red 
except in the device where they are generated and in the ECU where they are used.  NSA is requiring 
most new ECUs to implement BF. 
 
S
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Load Mode 5 IFF 
 
Mode 5 IFF (Identification Friend or Foe) uses an electronic radio based identification system utilizing 

ansponders.  These transponders are on aircraft and ground based systems such as those found in 
rpose of the Mode 5 IFF system is to be able to identify which aircraft are friendly and 

hich are not.  This is done through a series of interrogation commands that are encrypted.  If the 

ange 

he following set of procedures should be followed to load key into the Mode 5 equipment, issue 

oad Mode 5 IFF Key 

 procedure “Load Selected 
ey” (Work Package 0014).  Follow the steps in that procedure to load the required key into the Mode 5 

 the ability to change the Time of Day in the Mode 5 equipment so that the transponders can 
ync up with each and interrogation can take place.  Use the following procedure to change the Time of 

tr
ADA units.  The pu
w
responses are correct then the aircraft is considered friendly, if they are not, then the aircraft is 
considered hostile. 
 
The SKL has routines to load the equipment used in the Mode 5 based systems and the ability to ch
the time of day and issue commands to the ECUs. 
 
T
commands to that equipment and to set the time of day in the equipment. 
 
L
 
The procedure to load key into Mode 4/5 IFF equipment is the same as the
K
equipment. 
 
Load Mode 5 IFF Time of Day 
 
The SKL has
s
Day in the Mode 5 equipment. 
 
1. Select File→Transmit→Load Mode 5 IFF→Time of Day as shown below in Figure 8, Time of Day. 
 

 
 

Figure 8.  Time of Day. 
 
2. As a result of the above selection the window in Figure 9, Enter Bus Address opens. 
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Figure 9.  Enter Bus Address. 
 
3. Now you must enter a Bus Address for the equipment you are attempting to change the Time of Day 

on.  Tap on the Down Arrow and select the correct Bus Address.  Then tap on the OK button.  The 
window in Figure 10, Activating Wakeup opens. 

 

 
 

Figure 10.  Activating Wakeup. 
 
4. Once the Wakeup of the equipment has been accomplished, the window in Figure 11, Enter Time of 

Day opens. 
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Figure 11.  Enter Time of Day. 
 
5. Enter the correct time by using the up and down arrows.  When the time is correct, tap on the OK 

button.  The window in Figure 12, Operation Successful opens. 
 

 
 

Figure 12.  Operation Successful. 
 
6. Tap on the OK button to finish the procedure.  You have now just successfully changed the time of 

day in the Mode 5 IFF equipment. 
 
Load Mode 5 IFF Mission Data 
 
Mode 5 IFF Mission Data allows the user to input specific data requirements into the Mode 5 equipment.  
These data requirements are essential to making the Mode 5 IFF system function properly.  Use the 
following procedure to enter the Mission Data into the Mode 5 IFF equipment. 
 
1. Select File→Transmit→Load Mode 5 IFF→Mission Data as shown below in Figure 13, Mission 

Data. 
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Figure 13.  Mission Data. 
 
2. As a result of the above selection the window in Figure 14, Mission Data Input opens. 
 

 
 

Figure 14.  Mission Data Input. 
 
3. Insert the PIN by activating the virtual keyboard.  Once finished close the Virtual Keyboard.  Then 

using the down-arrow select the correct Mission Code and National Origin.  Then tap on the OK 
button.  The window in Figure 15, Activating Wakeup opens. 
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Figure 15.  Activating Wakeup. 
 
4. Once the Mode 5 equipment receives the wakeup signal, the Mission Data is sent to the equipment.  

Once the load is complete, the window in Figure 16, Operation Successful opens. 
 

 
 

Figure 16.  Operation Successful. 
 
5. Tap on the OK button to close out the procedure. 
 
Transmit Database 
 
There are four (4) different methods of transmitting a database.  The first is to transmit all the databases 
that are stored in the SKL.  The second is to transmit a selected database excluding the SOI database.  
The third is to transmit the SOI database by itself.  The fourth method of transmitting a database is by 
using the SINCGARS Broadcast Mode.  Associated with transmitting databases is the Transfer Mode you 
are going to use.  The following paragraphs will lead you through the steps of transmitting databases. 
 
Transmit All Databases.  This feature allows the user of the SKL to transfer all the database information 
contained in the SKL to another device.  This includes all assigned and unassigned database items.  This 
procedure will work from any tab.  Follow the procedures below to accomplish this action. 
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NOTE 
 

The DTD with CT3 loaded is the only entity that uses Mission Dates.  When 
attempting to transmit the Mission Date, you must select either a Platform, 
Equipment, or Key along with the Mission Date for this procedure to work.  The 
SKL will then put a date starting with the effective date of the first key assigned 
and then include every other date for the period of time that the key is effective.  
For instance, if you have a TEK that is good for 30 days and your have a KEK that 
is good for 90 days and their effective dates are the same, the SKL will include 90 
Mission Dates for these two keys.  If you have a TEK that has three segments and 
each segment is good for 30 days, then your SKL will process 90 Mission Dates 
and transmit that data to the receiving device along with all the other data 
associated with the Platform, Equipment, or Key.  As you can readily see from the 
data provided above, the transmission time for this particular procedure can be 
lengthy.   

 
1. From the SKL UAS Main Menu, select File→Transmit→Database.  The window in Figure 17, 

Database Transmit Wizard, opens. 
 

 
 

Figure 17.  Database Transmit Wizard. 
 
2. With all the Database Options selected by default, tap on the Mission Date to remove the 

checkmark as this operation is transferring the database to another SKL.  Now tap on the Next>> 
button.  The window in Figure 18, Transfer Mode, opens. 
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Figure 18.  Transfer Mode. 
 
3. Now select the target device that will receive the databases.  The example depicted below in 

Figure 19, Transfer Mode (SKL), has another SKL selected 
 

 
 

Figure 19.  Transfer Mode (SKL). 
 
4. The selection of the SKL for the transfer mode indicates that your transmitting SKL will be directly 

connected to another SKL.  Now tap on the Next>> button.  The window in Figure 20, Database 
Transmit Wizard Finish, opens. 
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Figure 20.  Database Transmit Wizard Finish. 

 
5. Connect the Transmitting SKL to the Receiving SKL using a standard Fill cable.  Then tap on the 

Transmit button to transmit the Databases.  The window in Figure 21, Status, opens. 
 

Figure 21.  Status. 
 

. You will see a Progress window open and once the messages are built you should see messages on 

 

 

6
the Status window indicating the progress of the transmit process.  On the Receiving SKL’s Status 
window you should see the items being received.  When the Transmit process is completed the 
window in Figure 22, Operation Successful, opens.  
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Figure 22.  Operation Successful. 

 
7. Tap on the OK button in the upper right-hand corner of the window.  The SKL UAS Desktop returns.  
 
END OF TASK 
 
Transmit Selected Database(s).  There will be times when you will want to transmit only selected 
databases to another device.  To transmit selected databases to another device, follow the procedure 
below. 
 

NOTE 
 

The DTD with CT3 loaded is the only entity that uses Mission Dates.  When 
attempting to transmit the Mission Date, you must select either a Platform, 
Equipment, or Key along with the Mission Date for this procedure to work.  The 
SKL will then put a date starting with the effective date of the first key assigned 
and then include every other date for the period of time that the key is effective.  
For instance, if you have a TEK that is good for 30 days and your have a KEK that 
is good for 90 days and their effective dates are the same, the SKL will include 90 
Mission Dates for these two keys.  If you have a TEK that has three segments and 
each segment is good for 30 days, then your SKL will process 90 Mission Dates 
and transmit that data to the receiving device along with all the other data 
associated with the Platform, Equipment, or Key.  As you can readily see from the 
data provided above, the transmission time for this particular procedure can be 
lengthy.   

 
1. Select File→ Transmit→Database from the SKL UAS Main Menu.  The window in Figure 23, 

Database Transmit Wizard, opens. 
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Figure 23.  Database Transmit Wizard. 

 
2. As depicted in the window above, by default, all the databases are selected.  Tap on the Deselect All 

button to remove the Checkmarks from all the databases as shown in Figure 24, Database Transmit 
Wizard (Deselected), below. 

 

Figure 24.  Database Transmit Wizard (Deselected). 
 

. Now select only one database you wish to transmit by tapping in the box to the left of the database 

 

 

 

3
you wish to transmit.  The example depicted in Figure 25, Database Transmit Wizard Selected 
Database, shows just Platform selected.  This will allow you to transmit all items assigned to the
Platform i.e., Equipment, Key Tags, EP Data, etc. 
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Figure 25.  Database Transmit Wizard Selected Database. 

 
4. Now tap on the Next>> button to continue with the transmit process.  The window in Figure 26, 

Transfer Mode, opens. 
 

 
 

Figure 26.  Transfer Mode. 
 
5. Select the target device that is the intended destination.  In the example depicted below, the SKL is 

chosen as shown in Figure 27, Transfer Mode SKL Selected. 
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Figure 27.  Transfer Mode SKL Selected. 
 
6. Now tap on the Next>> button.  The window in Figure 28, Platform Selection, opens. 
 

Figure 28.  Platform Selection. 
 

. The Platform Selection window defaults to all platforms.  If you wish to transmit only selected 
it.  

 

 

7
platforms, tap on the Deselect All button and then select each platform that you wish to transm
Otherwise, leave the default as it is to transmit all platforms.  Once you have made your platform 
selection, tap on the Next>> button.  The window in Figure 29, Finish, opens. 
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Figure 29.  Finish. 

 
8. Connect the Transmitting SKL to the Receiving SKL using a standard Fill cable.  The SKL is now 

ready to transmit the selected databases.  Tap on the Transmit button.  The window in Figure 30, 
Status, opens. 

 

Figure 30.  Status. 
 

. The Status window shows the operator that the SKL is processing messages during the transmit 
 

 

 

9
operation.  In the case depicted above there are 227 messages to process.  This number will vary
depending on what you have selected for transmission.  When finished, the window in Figure 31, 
Operation Successful, opens. 

0015-18 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0015 
 

 
Figure 31.  Operation Successful. 

 
10. When the operation completes, you should receive a message like the one depicted above.  Tap on 

the OK button in the upper right-hand corner of the SKL window.  The Status window closes and the 
SKL returns to the SKL UAS Main Menu tab that you had open when the process began. 

 
END OF TASK 
 
Transmit the SOI Database.  The SKL has the ability to transmit all the database elements that are 
stored in the SKL.  The following procedure documents the steps required to transmit the SOI database to 
another device. 
 
1. From the SKL UAS Main Menu, select File→ Transmit→Database.  The window in Figure 32, 

Database Transmit Wizard, opens. 
 

Figure 32.  Database Transmit Wizard. 
 

NOTE 
 

You may select Cancel at anytime during the transmit operation to terminate the 

 

process. 
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2. The Database Transmit Wizard defaults to selecting all the databases for transmit.  To transmit just 

, 

 

 
Figure 33.  Database Transmit Wizard Modified. 

3. Now tap on the Next>> indow in Figure 34, 
Transfer Mode, opens. 

the SOI database, tap on the Deselect All button with the Inductive Stylus.  This will remove the 
Checkmarks from all the databases.  Then put a Checkmark ( ) in the box to the left of the SOI 
selection.  When finished, the Database Transmit Wizard should look like the window in Figure 33
Database Transmit Wizard Modified. 

 
 button to continue with the transmit process.  The w

 

 
 

Figure 34.  Transfer Mode. 

4. Now you must select how to transf lts to CT3 meaning that the database 
will be transferred to a CT3 device.  Select the transfer mode from the list and tap on the Radio 

 

 
er the SOI database.  It defau

button next to your selection as depicted in the example in Figure 35, Transfer Mode (SKL), below. 
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Figure 35.  Transfer Mode (SKL). 
 
5. The selection of the SKL for the transfer mode indicates that your transmitting SKL will be directly 

connected to another SKL.  Now tap on the Next>> button.  The window in Figure 36, SOI Selection, 
opens. 

 

Figure 36.  SOI Selection. 
 

. This window allows you to select the SOI files that you want to send.  It defaults to all.  If you want to 

 

 

 

6
send the first five (5) Time Periods then deselect the file A 001005.SOI.  Conversely, if you want to 
send just Time Periods 6-10 then deselect the file A 006010.SOI.  In this example all Time Periods 
are selected for transfer.  Once you have made the correct selection, tap on the Next>> button.  The
window in Figure 37, Finish, opens. 
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Figure 37.  Finish. 

 
7. Connect the Transmitting SKL to the Receiving SKL using a standard Fill cable.  Then tap on the 

Transmit button to send the SOI Database.  Multiple messages will appear in the Status area of the 
window during the transmit process.  You can still cancel the operation at this time by tapping on the 
Cancel button.  When the operation finishes, the window in Figure 38, Operation Successful, opens. 

 

Figure 38.  Operation Successful. 
 

. Tap on the OK button in the upper right-hand corner of the SKL window.  The Status window closes 

 
ND OF TASK 

ransmitting Database(s) Using the SINCGARS Broadcast Mode.  This procedure allows the SKL at 

 

• Move the handset on the NCS SINCGARS radio to the Aud/Fill connector. 
cable. 

 

8
and the SKL returns to the SKL UAS Main Menu. 

E
 
T
the SINCGARS Net Control Station (NCS) radio to transmit a database(s) to multiple SKLs situated with 
the Outstation SINCGARS radios at the same time.  There are several actions that must take place at the
transmitting SKL's location before the procedure can begin.  These are: 
 

• Connect the SKL to the SINCGARS radio's Aud/Data connector using a Fill 
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• Set the data rate on the NCS SINCGARS radio by pressing the DATA button on the keypad and 
then the CHG button repeatedly until 1200 is displayed on the radio. 

• Inform the net members of their Broadcast ID number.  (The NCS designates Broadcast IDs for 
the net members.)  All receiving SKLs should have a separate Broadcast ID number.  (There is a 
maximum of 16 Broadcast IDs per net.) 

• Pre-read all the steps in the procedure prior to actually performing the Broadcast process. 
 
1. From the main menu select File→Transmit→Database.  The window in Figure 39, Database 

Options, opens.  
 

 
Figure 39.  Database Options. 

 
2. On the NCS SKL select the type of database(s) you intend to broadcast.  The Database Options 

window opens with all databases selected.  If you want to just transmit selected databases, tap on the 
Deselect All button and then select which database you want to transmit.  The NCS operator should 
consider the size of the database before selecting multiple items.  The more items selected, the 
longer the broadcast will take to complete.  For our example we have chosen just the Platform 
database to transmit.  Once you have made your selections tap on the Next>> button.  The window in 
Figure 40, Transfer Mode, opens. 

 

 
 

Figure 40.  Transfer Mode. 
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3. The Transfer Mode window opens with CT3 selected.  Change the mode on the NCS SKL by tapping 

on the radio button next to SINCGARS as shown above and then tap on the Next>> button.  The 
window in Figure 41, Select Broadcast ID, opens. 

 

 
 

Figure 41.  Select Broadcast ID. 
 
4. On the NCS SKL highlight each broadcast ID number you wish to transmit to and then tap on 

the > button to move the numbers from the Available IDs to the Selected IDs column.  Then select the 
Target Device, (i.e., CT3 or SKL) as depicted above.  After all the Broadcast IDs and Target Device 
has been selected, tap on the OK button.  The window in Figure 42, Platform Selection, opens. 

 

Figure 42.  Platform Selection. 
 

. The Platform Selection window opens with all Platforms selected.  If you want just selected Platforms, 

 

 

 

 

5
then tap on the Deselect All button and then select which Platform(s) you wish to transmit.  In this 
case we have chosen to transmit the TACFWD Platform and have put a Checkmark ( ) in the box
next to the TACFWD Platform.  Then tap on the Next>> button.  The window in Figure 43, Finish, 
opens. 
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6. The NCS operator will now call all the Outstation(s) and tell them to prepare their SKL to receive a 
database(s) using the SINCGARS mode.  Tell them once they are at the Receive Database window 

ll 

 

 

. On the NCS SKL Status window you will temporarily see "Building data" and then "Broadcasting 
data".  The NCS and net member's SK andshake and all selected data will be 
broadcasted.  Once the Broadcast operation is finished the window in Figure 45, Operation 

 
 
 

Figure 43.  Finish. 
 

to tap on the Receive Button.  The Outstation(s) SKL will display "Receive in progress...".  Wait for a
net members’ SKL to display the "Receive in progress".  On the NCS SKL tap on the Transmit 
button.  The window in Figure 44, Status, opens. 

Figure 44.  Status. 
 
7

Ls will electronically h

Successful, opens. 
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Figure 45.  Operation Successful. 

. On the NCS SKL, tap on the OK button in the upper right-hand corner of the window.  The SKL 
returns to the tab that was ope .  The Outstation(s) SKLs should 
have received the database(s) and saved them into their Mission Database.  Call each outstation to 

n 

 
END
 

ransmit ECU Commands 

he SKL UAS v4.0 is capable of sending commands to five (5) different types of equipment.  As new 
s enter the force, they are having the capability to receive commands to do 

uch things as Zeroize EEPROM slots, set up Station IDs, Station Addresses, and Zeroize RAM on DS-

 
8

n when the Broadcast process started

confirm that they received the database.  For those that did not receive the database the operatio
will have to be repeated for just those outstations. 

 OF TASK 

T
 
T
equipment for communication
s
101 devices.  The device shown below for the purposes of addressing this capability in this TM is the 
Joint Tactical Information Distribution System (JTIDS).  To start the procedure to issue commands to the 
JTIDS equipment select File→Transmit→ECU Commands.  The window in Figure 46, ECU Command 
Wizard, opens as shown below. 
 

 
 

Figure 46.  ECU Command Wizard. 
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1. This window will allow the use to send commands to, what type 

of command to send, select the Bus Address of the equipment (if any), and if you select either the 

U 

 

r to select which equipment they want 

KGV-23 equipment or the command Set Station ID another field will appear on this window below the 
Bus Address called Station ID..  To select equipment tap on the Down Arrow to the right of the EC
field.  As drop-down menu appears as shown in Figure 47, ECU Selection, below. 

 
 

Figure 47.  ECU Selection. 

2. As depicted above there are five (5  the SKL can send commands to at 
the present time.  They are ADDI, JTIDS, KGV-23, RT-1794, and Mode 5 IFF.  For the purposes of 

 

 
) different types of equipment

this procedure we have chosen JTIDS.  Now tap on the Down Arrow to the right of the Command 
field and a drop-down menu will appear as shown in Figure 48, Command Selection, below. 

 
 

Figure 48.  Command Selection. 

3. As depicted above the JTIDS e ands that can be sent to the 
JTIDS equipment.  For this procedure we have chosen Zeroize EEPROM.  As a result of that 

 

 
quipment has six (6) different comm

command selection the window in Figure 49, Available Locations, opens. 
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Figure 49.  Available Locations. 

 
4. Since Zeroize EEPROM was chosen, the bottom half of the window changes to allow the operator to 

select which location in the EEPROM they wish to zeroize.  In the case of JTIDS, there are nine (9) 
different Fill Locations that can be chosen.  As depicted above, Fill Loc E5 was chosen to be 
zeroized.  To accomplish this, highlight the Fill Loc you want to zeroize and then click on the > to 
move that location to the Selected Loc(s) column.  Once you have finished your selections, tap on the 
Next>> button.  The window in Figure 50, Connect To, opens. 

 

Figure 50.  Connect To. 
 

. Connect the SKL to the JTIDS using a standard Fill cable.  Then tap on the Send button.  The 

 

5
window in Figure 51, Status, opens. 
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Figure 51.  Status. 
 

. The Status window will give the user of the SKL the exact status of the procedure that is being 
pens. 

 

 
Figure 52.  Operation Successful. 

 
ND OF TASK 

ND OF WORK PACKAGE 

 

6
performed.  Once the procedure is completed, the window in Figure 52, Operation Successful, o

 

E
 
 
E
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
 
FILE MENU 
 RECEIVE 
 
 
RECEIVE 
 
The Receive selection under the File Menu has five (5) submenu selections.  They are Database, Key, 
Key Needed, XML File, and 87-27 File.  This Work Package will only address the first two submenu 
selections.  The last three selections are discussed in Work Package 0017. 
 
Receive Database 
 
There are several different methods in which to receive a database into the SKL.  Each Method will be 
explained in the following paragraphs. 
 
Receiving Database(s).  The SKL has the ability to receive databases.  In the receive function, the 
selection of databases is up to the transmitting device.  Use the following procedure to receive a 
database(s). 
 

 
 

Figure 1.  File→Receive→Database. 
 
1. As depicted above, on the SKL UAS Main Menu, select File→Receive→Database.  The window in 

Figure 2, Receive Database, opens. 
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Figure 2.  Receive Database. 

 
2. This window has two parts.  The first is the Source of the database.  It defaults to Workstation 

(RS-232).  The second is the Profile.  The Profile prompts the operator of the receiving SKL what to 
do in order to receive the database.  Tap on the Source down arrow as depicted in Figure 3, Receive 
Database Sources. 
 

 
 

Figure 3.  Receive Database Sources. 
 

3. Select the source from the drop-down menu.  For this example we have selected another SKL as 
shown in Figure 4, Receive Database Source SKL. 
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Figure 4.  Receive Database Source SKL. 

 
4. Once selection of the source has been made, the Profile area will tell the SKL operator what to do.  

Now tap on the Receive button.  The Figure 5, Status, opens. 
 

Figure 5.  Status. 
 

. This window provides status on the receive operation.  When the receive operation is complete, the 

 

 

5
program will autosave the changes to the database.  The window in Figure 6, Operation Successful, 
opens. 
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Figure 6.  Operation Successful. 

 
6. Tap on the OK button in the upper right-hand corner of the window to close it.  The window in 

Figure 7, Receive Database, opens. 
 

 
Figure 7.  Receive Database. 

 
7. With the receive operation complete, tap on the Close button.  The system returns to the SKL UAS 

Main Menu with the tab displayed which had been selected at the start of the receive operation as 
depicted in Figure 8, Plats Tab. 
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Figure 8.  Plats Tab. 

 
END OF TASK 
 
Receiving Database from Workstation (RS-232) Source.  There are several different interface 
protocols that the SKL can use to send and receive information.  They are RS-232, DS-101, and DS-102.  
The following procedure outlines the steps required to receive a database using the RS-232 protocol.  
The SKL display can be open to any tab; in this case the Plats tab is open as shown in Figure 9, Plats 
Tab. 
 

 
Figure 9.  Plats Tab. 

 
1. From the SKL UAS Main Menu, select File→Receive→Database.  The window in Figure 10, Receive 

Database, opens. 
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Figure 10.  Receive Database. 

 
2. This window has two parts.  The first part Source, allows you to select the sending device.  The 

second part is the Profile field.  This field provides additional instructions for the SKL user.  This 
window defaults to the Workstation (RS-232).  Connect the SKL to the Workstation using the RS-232 
cable.  Once the two devices are physically connected tap on the Receive button with the Inductive 
Stylus.  The window in Figure 11, Status, opens informing the user as to the status of the receive 
operation from the Workstation (RS-232). 

 

Figure 11.  Status. 
 

. The Status window displays the incremental progress of the receive operation from the Workstation 

 

 

3
(RS-232).  If the receive operation is successful, the Status window will indicate this by displaying 
“Finished processing”.  When the receive operation is complete, the program will autosave the 
changes to the database.  The window in Figure 12, Operation Successful, opens. 
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Figure 12.  Operation Successful. 

 
4. Tap on the OK button in the upper right-hand corner of the window to close it.  The window in 

Figure 13, Receive Database, opens. 
 

 
Figure 13.  Receive Database. 

 
5. If you have other items to receive, then you will want to tap on the Receive button and the receive 

process will continue on.  If you have no more items to receive, tap on the Close button.  The window 
in Figure 14, Plats Tab, opens. 

 

0016-8 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0016 
 

 
Figure 14.  Plats Tab. 

 
6. The figure depicted above shows the Plats Tab.  That is only because that is the tab that was open 

when this process began.  If you were on the Keys Tab, then that tab would re-open at the end of this 
process. 

 
END OF TASK 
 
Receiving a Database Using the SINCGARS Broadcast Mode.  The transmitting device (SKL) can 
send a database(s) to multiple SKLs within a communications network at the same time providing that the 
transmitting SINCGARS radio can communicate with Outstation(s) radios.  This procedure provides the 
steps the receiving SKL must perform to receive a database(s) from the transmitting SKL.  There are 
certain pre-conditions that must be met before the receive procedure can commence.  These are: 
 

• Move the handset of the SINCGARS radio to the Aud/Fill connector. 
• Connect the SKL via the Fill cable to the Aud/Data connector of the SINCGARS radio. 
• Set the data rate by pressing the Data button on the keypad and then the CHG button repeatedly 

until 1200 is displayed on the radio. 
• Know or request the broadcast ID number from the NCS. 

 
1. From the main menu select File→Receive→Database.  The window in Figure 15, Receive 

Database, opens. 
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Figure 15.  Receive Database. 
 
2. Tap on the Down Arrow to display the source list.  Select SINCGARS, from the source list.  As a 

result of selecting SINCGARS the window in Figure 16, Broadcast ID, opens. 

 
Figure 16.  Broadcast ID. 

 
3. Once SINCGARS is selected the Broadcast ID field opens.  Tap on the Down Arrow of the 

Broadcast ID field and select the Broadcast ID.  This is a designated ID for your particular 
SINCGARS radio.  Each SINCGARS in the net will have its own Broadcast ID.  In this case we have 
selected 3 as our ID.  Once the ID is selected the window in Figure 17, Profile, opens. 
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Figure 17.  Profile. 

 
4. Connect the SKL to the Aud/Data connector on the SINCGARS radio and wait for the NCS to 

prepare their SKL to send the database(s).  The NCS will then give you an instruction to tap on the 
Receive button.  After the Receive button has been selected, a Status window opens and will display 
"Receive in progress" and then display the incoming data from the NCS.  When the receive 
operation is complete, the program will autosave the changes to the database.  The window in 
Figure 18, Operation Successful, opens. 

 

 
Figure 18.  Operation Successful. 

 
5. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 19, 

Receive Database, opens.   
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Figure 19.  Receive Database. 

 
6. If you are instructed that there is another database to follow, then tap on the Receive button again 

and the process will continue.  If you are finished receiving databases tap on the Close button.  For 
this depiction we have elected to tap on the Close button.  The SKL returns to the tab that was open 
when you started the receive process.  This concludes the procedure to receive a database(s) using 
the SINCGARS broadcast mode. 

 
END OF TASK 
 
Receiving Key 
 
Two methods of receiving key into the SKL are outlined below.  The first is receiving a key from a device 
using a DS-101 protocol.  An example of this type of device would be the DTD.  The second is receiving a 
key from a device using a DS-102 protocol.  An example of this type of device is the KYK-13.  Each of 
these receive functions is discussed below. 
 
Receiving Key from a DS-101 Device.  Two pieces of equipment use the DS-101 protocol and are used 
to download key.  They are the DTD and the KOK-22 Key Processor (KP).  Follow the procedures below 
to receive key from a DS-101 device. 
 

 
 

Figure 20.  File→Receive→Key. 
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1. From the SKL UAS Main Menu, select File→Receive→Key as depicted above.  The window in 

Figure 21, Select Key Source, opens. 
 

Figure 21.  Select Key Source. 
 

. Use the Scroll Bar on the right side of the window to see all the selections.  For this example we have 

 

 
Figure 22.  Receive Key Profile. 

3. The Receive Key Profile window re required to take based on the 
Profile Modes that is currently selected on your SKL.  If the Profile Modes is set to "Detailed" then you 

lect the 

 

2
selected the DTD as our key source.  Once the DTD is highlighted, tap on the Next>> button.  The 
window in Figure 22, Receive Key Profile, opens. 

 
 will only display those steps you a

will see most if not all steps required for you to take.  If the Profile Modes is set to "Condensed" then 
you will see only a minimum amount of steps.  (See Work Package 0029 Options for more 
information on the Profile Modes.)  Follow the instructions in the Profile window for your equipment.  
Connect the DTD to the SKL and prepare the DTD for Transmit operations.  On the DTD se
correct Key to transmit and continue with the operation on the DTD.  Do not tap on the Finish button 
until after you have pressed the Down-Arrow on the DTD.  The Status window on the SKL opens 
showing the progress of the Receive Key operation.  Once completed, you should see the window in 
Figure 23, Key Prompting, displayed. 
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Figure 23.  Key Prompting. 
 

. This window is reminding you that the Date, Rate, and Period for the Key just received is set to Per 
Segment.  If this is not what you w ration and go to the 
Settings→Options→Keys tab to change it to either Short Title or Edition.  Tap on the OK button, the 

 

 

 
. Once the receive procedure is completed, the window in Figure 25, Receive Edition, opens. 

 

4
ant it to be then you must abort this ope

window in Figure 24, Status opens. 

Figure 24.  Status. 

5
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Figure 25.  Receive Edition. 
 
6. The Receive Edition window provides information about the key that was just received from the DTD.  

The information consists of the Short Title, Edition, Text ID, Effective Date, Supersession Rate, and 
Cryptoperiod.  The Effective Date, Supersession Rate, and Cryptoperiod can be changed to meet the 
needs of the mission the key will be used for.  Tap on the OK button.  The window in Figure 26, 
Operation Successful, opens. 

 

Figure 26.  Operation Successful. 
 

. Tap on the OK button in the top right-hand corner of the SKL window.  The keys are automatically 

 

 

7
saved to the database.  Once the save is complete, the window in Figure 27, Keys Tab, opens.  It 
should be noted here that the SKL will display the last Tab open prior to commencing the Receive 
Key operation.   
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Figure 27.  Keys Tab. 
 
8. As depicted above the Keys tab was open when this procedure commenced and you can see the 

new key that was received.  You can expand the Short Title to see the Edition and Key attributes.   
 
END OF TASK 
 
Receiving Key from a DS-102 Device.  There is a number of equipment using DS-102 protocol from 
which key can be received by the SKL.  Some of the more common ones are KYK-13, KYX-15, and the 
RT-1523 (SINCGARS Radio).  For this example, the KYK-13 will be used to demonstrate how to receive 
key from a DS-102 device.  Select File→Receive→Key from the SKL UAS Main Menu.  The window in 
Figure 28, Select Key Source, opens. 
 

 
Figure 28.  Select Key Source. 

 
1. From the list presented, use the scroll bar to locate the KYK-13 and highlight it as shown in Figure 29, 

Select Key Source (KYK-13), below. 
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Figure 29.  Select Key Source (KYK-13). 

 
2. Now tap on the Next>> button.  The window in Figure 30, Receive Key (Key Tag Information) opens. 
 

NOTE 
 

The window that opens next may be different than what is displayed in this 
example depending on the DS-102 device that you select. 
 

 
 

Figure 30.  Receive Key (Key Tag Information). 
 
3. This key tag information is for entry of applicable key tag data.  There are three areas where the 

virtual keyboard is required.  They are the Short Title, Edition, and Segment Range, which have been 
filled in as depicted above.  The CT3 Key Type, Key Use, Effective Start Date, Supersession Rate, 
and Crypto Period are drop-down menus that are used to select the appropriate information.  The 
Clear All button when tapped will clear all the information from only the Short Title and Edition fields.  
The Template button is used to select a saved template that will populate all the fields with the 
required information.  The Copy Key Tag button when selected will allow you to copy key tag 
information from an existing key tag that is stored in your SKL.  The key tag field characteristics are 
defined below: 

 
a. The Short Title field has a 24-character limit. 
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b. The Edition field has a 6-character limit. 
 

c. The Segment Range fields can accommodate a range from 1-99 segments. 

. The CT3 Key Type field has a drop-down menu to choose from. 

. The Key Use field has a drop-down menu. 
 

f. The Effective Start Date field has a down arrow that when selected opens up a calendar to 

 
g. The Supersession Rate field has a drop-down menu. 

 
h. The Crypto Period field has a drop-down menu. 

 
 

IP:  If default key tag values are in the Short Title and Edition fields, delete them by using the 

 
IP:  To use a field setting template, select Template and choose the appropriate template name 

 
Once all the correct information has been entered in this window, tap on the Next>> button.  The 

 
Figure 31.  Receive Key (Key Tag Information 2). 

 
. There are two informational fields called Register Number and Text ID.  Use the virtual keyboard to fill 

has 

 
a. Enter the Register Number.  This is a numeric number starting at 0 (zero). 

. Select a Classification from the drop-down menu. 

 
d
 
e

choose the correct date. 

T
backspace key. 

 

T
(if any are listed on the Template list).  This action enters the default values defined in the 
template in the Key Tag Information fields.   

window in Figure 31, Receive Key (Key Tag Information 2), opens. 

4
in the required information in these fields as depicted above.  The other field, Classification has a 
drop-down menu from which to select the appropriate classification for the key.  This window also 
a button called “Save as Template”.  This is used to save the information you have entered in these 
windows to a template that can be used later to populate the fields in these windows when another 
key is received.  The field characteristics are defined below: 

 
b
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c. Enter a Text ID.  This field has a 16-character limit. 

You can now save all the information that has been entered in the Key Tag Information pages to a 

 

 
Figure 32.  Save Template. 

5. Fill in the new template name usin ed above and then tap on the OK 
button.  The window in Figure 33, Template List Updated, opens. 

 
ted. 

. Tap on the OK button in the upper right-hand corner of the small window.  The window in Figure 34, 
Key Tag Information Filled In, 

 

template or you can skip the template process and continue with the Receive Key process.  In this 
example we have chosen to Save as Template.  Therefore, tap on the Save as Template button.  
The window in Figure 32, Save Template, opens. 

 
g the virtual keyboard as depict

 

Figure 33.  Template List Upda
 
6

opens. 
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Figure 34.  Key Tag Information Filled In. 

 
7. Now tap on the Next>> button.  The window in Figure 35, Receive Key Profile KYK-13, opens. 
 

Figure 35.  Receive Key Profile KYK-13. 
 

. The Receive Key Profile window will only display those steps you are required to take based on the 
u 

elected 

 

 

 

8
Profile Modes that is currently selected on your SKL.  If the Profile Modes is set to "Detailed" then yo
will see most if not all steps required for you to take.  If the Profile Modes is set to "Condensed", then 
you will see only a minimum amount of steps.  See Work Package 0029 Options for more information 
on the Profile Modes.  Follow the instructions in the Profile window for your equipment.  Once you 
have followed the instructions, tap on the Finish button.  The window in Figure 36, Operation 
Successful, opens only if you have selected to receive only one segment of key.  If you have s
to receive more than one segment, then the above window reopens with “Set to desired position on 
KYK-13” displayed.  Change the Position Switch on the KYK-13 to the next position that has key.  
Then tap on the Finish button again.  This process would continue until all keys are received for the
segments desired. 
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Figure 36.  Operation Successful. 

 
9. Tap on the OK button in the upper right-hand corner of the SKL window.  The keys will be 

automatically saved in the database.  The window in Figure 37, Keys Tab with New Short Title 
Displayed, opens.  If another tab is displayed, select the Keys Tab. 

 

Figure 37.  Keys Tab with New Short Title Displayed. 
 

0. Depicted above, the new Short Title ETD 5 6AB033 is available.  Expand the Short Title to display the 

 

 

1
segments as shown in Figure 38, 1BDE CMD TEK Expanded, below. 
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Figure 38.  1BDE CMD TEK Expanded. 

 
11. You can now see that the keys are present in the SKL. 
 
END OF TASK 
 
Fill the SKL with a TrKEK.  The procedure to fill a TrKEK into the SKL is no different than receiving any 
other key.  This fill operation is normally done the first time using the KOK-22 (KP).  Therefore, select 
File→Receive→Key as depicted below in Figure 39, File→Receive→Key. 
 

Figure 39.  File→Receive→Key. 
 

. As a result of selecting the above, the window in Figure 40, Select Key Source, opens. 

 

1
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Figure 40.  Select Key Source. 

 
2. Scroll down the list and highlight the KOK-22 (KP), and then tap on the Next>> button.  The window 

in Figure 41, Profile, opens. 
 

Figure 41.  Profile. 
 

. The KP operator will do the steps necessary on the LCMS Workstation to fill the TrKEK into your 

 

 

3
SKL.  After all the steps in the Profile have been accomplished, tap on the Finish button.  The 
window in Figure 42, SKL, opens. 
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Figure 42.  SKL. 
 

. This window comes up when you are receiving a key to let you know how the SKL Options are set up 

 

 
Figure 43.  Receive More Keys. 

5. Since this is the only key to be r  button.  The window in Figure 44, 
Receive Edition-DS100-1 Tag, opens. 

4
for the Key’s Date, Rate, and Period.  In this case it is set up for Short Title.  Acknowledge the 
window by tapping on the OK button.  The window in Figure 43, Receive More Keys opens. 

 
eceived from the KP, tap on the No
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Figure 44.  Receive Edition-DS100-1 Tag. 
 
6. This window provides the user of the SKL some basic information about the key that was just 

received from the KP.  It provides the Short Title, Edition, and Text ID.  These fields are not 
changeable.  There are three Input fields that must be correctly filled in.  The first is the Effective 
Date.  It is a drop-down menu where you can select the Effective Date.  The next field is the 
Supersession Rate.  This too is a drop-down menu and you may choose the Supersession Rate that 
you wish for the TrKEK.  Finally the Cryptoperiod field needs to be correctly filled in.  It too has a 
drop-down menu from which to choose the Cryptoperiod of the TrKEK.  Once these fields are 
correctly populated, tap on the OK button.  The window in Figure 45, Operation Successful, opens. 

 

Figure 45.  Operation Successful. 
 

. Now the TrKEK is filled into the SKL.  You cannot go to the Keys Tab and expect to see the Short 

 

 

 
ND OF TASK 

 

7
Title of the TrKEK.  It will not be there since this was a load operation into the SKL.  However, you 
can view the TrKEK by selecting View→Keys→TrKEK.  This is the only place that you can see the
Short Title, Edition, Text ID, Effective Date, Supersession Rate, and Cryptoperiod of a filled TrKEK.  
This TrKEK resides in a different area of the SKL.  This SKL is now ready to receive keys that are 
encrypted by this TrKEK from the KP or another source that has the same TrKEK.  The TrKEK was
automatically saved to the database. 

E
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Issue a TrKEK to the SKL.  There is a difference between filling the SKL with a TrKEK and issuing a 

to 

EK 

ND OF TASK 

eceiving Multiple Keys from the KOK-22 Key Processor (KP).  This particular procedure has been 

e 

TrKEK to the SKL.  If the TrKEK is issued to the SKL like any other key, then it is available to be filled in
another SKL so it too will be able to send and receive encrypted key.  The procedure to issue the TrKEK 
to the SKL is the same as in the Receive Key procedure in this Work Package except that you would 
choose the KOK-22 (KP) rather than the DTD.  The only difference between this operation and the 
previous operation is that the KP operator will distribute the TrKEK to the SKL rather than fill the TrK
into the SKL. 
 
E
 
R
written to ensure that when the SKL is receiving multiple keys from the KP that the operator of the SKL 
knows how to complete the process without receiving an error message.  This procedure does not involv
the Key Needed procedure.  From the SKL UAS Main Menu select File→Receive→Key.  The window in 
Figure 46, Select Key Source, opens. 
 

 
Figure 46.  Select Key Source. 

 
. Highlight the KOK-22(KP) and then tap on the Next>> button.  The window in Figure 47, Receive 

 

 
Figure 47.  Receive Key Profile. 

1
Key Profile, opens. 
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2. The Receive Key Profile window will onl required to take based on the 

Profile Modes that is curren s is set to "Detailed" then you 
will see most if not all steps requi s is set to "Condensed" then 
you will see only a minimu e 0029-Options for more information 
on the Profile Modes.  Follow the in ow for your equipment.  Once you 
have connected the SKL to the KP with a Fill cable, you may inform the KP operator to press the Start 
button on the LCMS Workstation.  Then tap on the  button.  The window in Figure 48, Key 
Prompting, opens. 

 

y display those steps you are 
tly selected on your SKL.  If the Profile Mode

red for you to take.  If the Profile Mode
m amount of steps.  See Work Packag

structions in the Profile wind

Finish

 
 

Figure 48.  Key Prompting. 
 
3. This window is reminding you that the Date, Rate, and Period for the Key just received is set to Per 

Edition.  If this is not what you want it to be then you must abort this operation and go to the 
Settings→Options→Keys tab to change it to either Short Title or Segment.  Tap on the OK button, the 
window in Figure 49, Status opens. 

 

Figure 49.  Status. 
 
4. The status window opens showing you the status of the download process.  In the example we have 

elected to receive two (2) keys from the KP.  The LCMS Workstation Operator will now perform some 
actions on the KP that will permit the first key to be downloaded to the SKL.  As a result of those KP 
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actions the first key is download igure 50, Do you wish to receive 
more keys, opens. 

 

 
5.  

 

Figure 51.  Do you Wish to Receive more Keys. 

As a result of selecting P to issue the second 

 

ed to the SKL and the window in F

 
Figure 50.  Do you Wish to Receive more Keys. 

We have received only one of two keys we require.  So therefore, tap on the Yes button.  The window
in Figure 51, Do you wish to receive more keys, opens. 

 

 
6. Yes and the KP operator performing actions on the K

key the window depicted above is asking whether you want to continue to receive.  We have now 
received all of the keys we require.  Therefore, tap on the NO button, the window in Figure 52, 
Receive Edition DS100-1 Tag, opens. 
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Figure 52.  Receive Edition DS100-1 Tag. 
 
7. This window shows you the first Short Title that you received and the attributes of that Short Title.  It

also allows you to set the Effective Date, Supersession Rate, and the Cryptoperiod.  This informati
you should get from your COMSEC Custodian.  Make the recommended changes and then tap
the OK button.  The window in Figure 5

 
on 

 on 
3, Receive Edition DS100-1 Tag, opens. 

 

 
 

Figure 53.  Receive Edition DS100 ag. 
 

. This window shows you the second Short Title that you received and the attributes of that Short Title.  

 

-1 T

8
It also allows you to set the Effective Date, Supersession Rate, and the Cryptoperiod.  This 
information you should get from your COMSEC Custodian.  Make the recommended changes and 
then tap on the OK button.  The window in Figure 54, Operation Successful opens. 
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Figure 54.  Operation Successful. 

 
Now tap on the OK button in the upper right-hand corner of the window.  The keys will autom
be saved to the database.  Once the SKL UAS Desktop opens, go to the Keys Tab as depicted in 
Figure 54, Keys Tab, below. 

9. atically 

 

 
 

Figure 55.  Keys Tab. 
 
10. Scroll down the list of keys in the SKL and make sure that the keys you received from the KP are 

listed.  The procedure to receive multiple keys from the KP is completed at this time. 
 
END OF TASK 
 
 
END OF WORK PACKAGE 
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
 
FILE MENU 
 RECEIVE 
 
 
RECEIVE 
 
The Receive selection under the File Menu has five (5) submenu selections.  They are Database, Key, 
Key Needed, XML File, and 87-27 File.  This Work Package 0017 will only address the last three 
submenu selections.  The first two selections were discussed in Work Package 0016. 
 
Receive Key Needed 
 
Key Needed is a process where the Key Tag is in the SKL but the actual Key is not.  The way to 
determine if the key is there or not is to open the Short Title then open the Edition to show the Segment.  
If there is a key symbol in front of the Key Tag then the key is there.  If there is a symbol showing a piece 
of paper with SEG on it, then the key is not present and you will have to perform a Key Needed operation 
for that Key Tag.  The two symbols are shown and explained on the following page. 
 
When using the Key Needed procedure, it looks to resolve all key needed Short Titles regardless of the 
number of different sources that are displayed on the Select Key Source window.  Two methods of 
performing Receive Key Needed functions are addressed.  The first is receiving a key needed from a 
device using a DS-101 protocol.  The second is receiving a key needed from a device using a DS-102 
protocol. 
 

 
 

 

Figure 1.  Plats Tab Expanded. Figure 2.  Segment Info 1. 
 
In Figure 1 there are three key tags assigned to the SINCGARS RT1 radio displayed.  Channels 1 and 2 
display the short title, edition, and segment information.  Location C1 also displays a Key symbol next to 
segment 1-T000-0-DIV TEK this key symbol indicates that the key variable has been received from the 
key-generating source.  Location C2 displays Seg symbol next to segment 1-T001-0-1BDE TEK.  This 
symbol indicates that the key variable has not been received.  Prior to attempting to load the specific 
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equipment (SINCGARS RT1), a Key Needed operation should be performed for all equipment fill 
locations that have the Seg symbol displayed.  The generating source for the Seg symbol can viewed as 
shown in Figure 2 above.  In this depiction, the KOK-22(KP) is displayed as the key source for key 
segment 1-T001-0 1BDE TEK.  As long as the key has not been received, the key source can be 
changed.  The operator will connect the SKL to the indicated key source when performing the Key 
Needed procedure. 
 
 Indicates a key has been received and stored in the Mission Database. 
 
 Indicates a key is needed from a key-generating source. 
 
Receiving Key Needed from a DS-101 Device.  Two pieces of equipment that use the DS-101 protocol 
and are used to perform a Key Needed operation are the DTD and the KOK-22 Key Processor (KP).  
When using this procedure, the key tag attributes of Short Title, Edition #, and Segment Information, in 
the transmitting device, must match the key tag in the SKL exactly.  Any deviation and the procedure will 
fail.  Follow the procedures below to perform a Key Needed operation from a DS-101 device.  From the 
SKL UAS Main Menu, select File→Receive→Key Needed as shown below in Figure 3, 
File→Receive→Key Needed. 
 

 
 

Figure 3.  File→Receive→Key Needed. 
 
1. As a result of this selection above, the window in Figure 4, Select Key Source, opens. 
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Figure 4.  Select Key Source. 
 
2. This window displays all key sources from which key is needed not all key generating devices.  The 

sources for keys are defined as part of a database download from an ACES Workstation.  For the 
current example the KOK-22 (KP) is our source for a Key Needed operation.  Make sure the KOK-22 
(KP) is highlighted and then tap on the Next>> button.  The window in Figure 5, Receive Key Profile, 
opens. 

 

 
 

Figure 5.  Receive Key Profile. 
 
3. The Receive Key Profile window will only display those steps you are required to take based on the 

Profile Modes that is currently selected on your SKL.  If the Profile Modes is set to "Detailed" then you 
will see most if not all steps required for you to take.  If the Profile Modes is set to "Condensed" then 
you will see only a minimum amount of steps.  See Work Package 0029 Options for more information 
on the Profile Modes.  Follow the instructions in the Profile window for your equipment.  Connect the 
KOK-22 to the SKL and prepare the KOK-22 for Transmit operations.  On the KOK-22 select the 
correct Key to transmit and continue with the operation on the KOK-22.  Do not tap on the Finish 
button until after you have pressed Transmit on the KP.  The Status window opens showing the 
progress of the Receive Key operation.  Once completed, you should see the window in Figure 6, All 
Key Tags Resolved. 
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Figure 6.  All Key Tags Resolved. 
 
4. This window is telling you that all the key tags that have the KOK-22 (KP) as their source have been 

resolved.  If you had ten key tags with the same source then you would have received ten keys.  
However, in this example we only had one key tag with a source of KOK-22 (KP).  Tap on the OK 
button in the upper right-hand corner of the SKL window.  The window in Figure 7, Operation 
Successful, opens. 

 

 
Figure 7.  Operation Successful. 

 
5. Tap on the OK button in the upper right-hand corner of the SKL window.  The received key(s) are 

automatically saved to the database.  The SKL UAS Main Menu opens.  Now open the Keys Tab if 
not already open as depicted in Figure 8, Keys Tab, below. 
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Figure 8.  Keys Tab. 
 
6. From the Keys Tab, make sure that the key just received is listed. 
 
END OF TASK 
 
Receiving Key Needed from a DS-102 Device.  There are a number of equipment using DS-102 
protocol from which a Key Needed operation can be performed by the SKL.  Some of the more common 
ones are KYK-13, KYX-15, and the RT-1523 (SINCGARS Radio).  For this procedure, the KYK-13 will be 
used to demonstrate how to perform a Key Needed operation from a DS-102 device.  From the SKL UAS 
Main Menu, select File→Receive→Key Needed.  The window in Figure 9, Select Key Source, opens. 
 

 
Figure 9.  Select Key Source. 

 
1. This window displays all key sources from which key is needed not all key generating devices.  The 

sources for keys are defined as part of a database download from an ACES Workstation in most 
cases.  As depicted above, there is one Key Source Equipment displayed.  The Key Needed process 
will try to continue to resolve all Keys Needed once the process is started.  Highlight the KYK-13 and 
then tap on the Next>> button.  The window in Figure 10, Select Key Tag, opens. 
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Figure 10.  Select Key Tag. 

 
2. This window allows you to select the Short Title for the key to be received.  In this example, there is 

only one Short Title displayed because only one Short Title has the KYK-13 defined as the source for 
its key.  Select the Short Title by tapping on the Checkbox to the left of the Short Title name.  Then 
tap on the Next>> button.  The window in Figure 11, Profile, opens. 

 

Figure 11.  Profile. 
 

. The Receive Key Profile window will only display those steps you are required to take based on the 
u 

 

 

3
Profile Modes that is currently selected on your SKL.  If the Profile Modes is set to "Detailed" then yo
will see most if not all steps required for you to take.  If the Profile Modes is set to "Condensed", then 
you will see only a minimum amount of steps.  See Work Package 0029-Options for more information 
on the Profile Modes.  Follow the instructions in the Profile window for your equipment.  Once you 
have followed the instructions, tap on the Finish button.  The window in Figure 12, All Key Tags 
Resolved, opens.   

0017-7 
UNCLASSIFIED// FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0017 
 

 
 

Figure 12.  All Key Tags Resolved. 
 
4. This window is telling you that all the key tags that have the KYK-13 as their source have been 

resolved.  Tap on the OK button in the upper right-hand corner of the window.  The window in 
Figure 13, Operation Successful, opens. 

 

 
Figure 13.  Operation Successful. 

 
5. Tap on the OK button in the upper right-hand corner of the SKL window.  The received key(s) are 

automatically saved to the database.  Now open the Keys Tab and expand the key just received to 
make sure that it is listed as shown in Figure 14, Keys Tab Expanded, below.   

 

0017-8 
UNCLASSIFIED// FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0017 
 

 
 

Figure 14.  Keys Tab Expanded. 
 
6. From the Keys Tab, make sure that the key just received is listed. 
 
END OF TASK 
 
Receiving Duplicate Mission Database Items.  During any receive operation, the possibility exists that 
an item may be received that duplicates an item already stored in the SKL Mission Database.  These 
items can be Platforms, Equipment, Key, or SOI.  The following procedure illustrates what happens when 
a duplicate item is received.  For this depiction we have chosen the Receive Key function.  However, the 
process is the same with the other database items with the exception of how some of the wording is 
reflected in the windows and what windows are used.  The whole point of this procedure lies with the 
Duplicate window shown below.  From the SKL UAS Main Menu, select File→Receive→Key Needed as 
depicted in Figure 15, below. 
 

 
 

Figure 15.  File→Receive→Key. 
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1. As a result of the selection above, the window in Figure 16, Select Key Source, opens. 
 

 
Figure 16.  Select Key Source. 

 
2. On this window select the source of the key you are about to receive.  In this case select a DS-101 

device.  Once you have made your selection, tap on the Next>> button.  The window in Figure 17, 
Receive Key Profile, opens. 

 

 
Figure 17.  Receive Key Profile. 

 
3. The Receive Key Profile window will only display those steps you are required to take based on the 

Profile Modes that is currently selected on your SKL.  If the Profile Modes is set to "Detailed" then you 
will see most if not all steps required for you to take.  If the Profile Modes is set to "Condensed", then 
you will see only a minimum amount of steps.  See Work Package 0029-Options for more information 
on the Profile Modes.  Follow the instructions in the Profile window for your equipment.  The profile 
window will provide specific prompts depending on the key source selected.  Once you have followed 
the steps in the profile, tap on the Finish button.  The window in Figure 18, Status, opens.  If there is 
not a duplicate Key Tag, then the process finishes normally.  However, if there is duplicate Key Tag, 
the window in Figure 19, Duplicate Key Tag, opens. 
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Figure 18.  Status. 

 

 
Figure 19.  Duplicate Key Tag. 

 
4. This window will appear when duplicate Key Tag information is received from a transmitting device.  If 

you select Accept, then the process will delete the old key tag and any assignment to a particular 
piece of equipment.  If you select Reject, then the process will not store the key tag or any 
assignment of that key tag to any equipment.  If you select Accept All, then all current duplicate key 
tags and any assignments they may have to any equipment will be deleted and the new key tag(s) 
will take their place.  If you select Reject All, then the process will not store any of the incoming 
duplicate key tag(s) and any assignments to particular equipment.  For this example select Accept.  
The window in Figure 20, Operation Successful, opens.  This window will appear for all duplicate 
items such as Platforms, Equipment, or SOI. 
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Figure 20.  Operation Successful. 

 
e. Tap on the OK button in the upper right-hand corner of the SKL window.  The received key(s) are 

automatically saved to the database.  The SKL main menu returns. 
 
END OF TASK 
 
Receive XML File 
 
The XML file is a new capability that the SKL has with this latest version of the SKL UAS.  It is a file that 
will originate at the LCMS Workstation and then transferred to the ACES Workstation to use in creating 
planning data and Loadsets.  The file can contain either encrypted or unencrypted keys.  The file will be 
received into the SKL via the USB mini-A port using a Jump Drive.  The following procedure will guide 
you through the steps necessary to receive an XML file from the Jump Drive.  
 
1. Insert the USB Jump Drive into the Mini-A port of the SKL.  From the SKL UAS Desktop, select 

File→Receive→XML File as shown below in Figure 21, File→Receive→XML File. 
 

 
 

Figure 21.  File→Receive→XML File. 
 
2. As a result of the above selection the window in the Figure 22, XML File Selection opens. 
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Figure 22.  XML File Selection. 
 

NOTE 
 

All XML files must reside on the root of the USB Jump Drive.  They cannot be in 
any folder whatsoever for they will not appear on the window in Figure 22 above. 

 
3. From this window you can select which XML file you wish to receive into the SKL.  You will notice at 

the bottom in the Taskbar there is an icon showing the USB Jump Drive is attached to the SKL.  
Select the file you wish to receive and tap on the OK button.  The keys will be received into the SKL 
and then they will be automatically saved to the database.  Once the keys are received and saved the 
window in Figure 23, Operation Successful opens. 

 

 
 

Figure 23.  Operation Successful. 
 
4. The keys have been received at this point and they have been saved.  Tap on the OK button to close 

the window.  Now open the Keys Tab to view the keys just received from the XML file as shown 
below in Figure 24, Keys Tab.  
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Figure 24.  Keys Tab. 
 
END OF TASK 
 
Receive 87-27 File 
 
The 87-27 file type is a new capability for the ACES Workstation to distribute any database item in the 
form of a .DAT file.  The .DAT file is commonly referred to as an 87-27 file.  These files must be 
downloaded from the ACES Workstation to a Jump Drive connected to the USB port on the workstation.  
They can be either on the root of the Jump Drive or in a folder on the Jump Drive.  This method of 
transferring a database from ACES to the SKL is going to become the common way of transfer over the 
FILL Port because this method is extremely fast.  Use the following procedure to receive an 87-27 file into 
the SKL.  For this procedure we have elected to receive an SOI into the SKL. 
 
1. Insert the Jump Drive with its Mini-A adapter into the Mini-A USB port on the SKL.  From the SKL 

UAS Desktop, select File→Receive→87-27 File as shown below in Figure 25. 
 

 
 

Figure 25.  File→Receive→87-27 File. 
 
2. You will notice the USB Icon in the Taskbar indicating that the SKL has sensed that there is a USB 

device attached to the system.  As a result of the selection above the window in Figure 26, Browse 
opens. 
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Figure 26.  Browse. 
 
3. You can now browse to the USB Drive by tapping on the Folder with the Up-Arrow.  Then browse 

the drive for the .DAT file you are looking for.  In this scenario we are looking for an SOI.  Therefore, 
highlight the correct file and then tap on the OK button in the upper right-hand corner of the window.  
The window in Figure 27, Status opens. 

 

 
 

Figure 27.  Status. 
 
4. After the SKL processes the received information it is saved automatically to the database.  Remove 

the USB Jump Drive from the SKL at this time.  When the processing is finished the window in 
Figure 28, Edition opens. 
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Figure 28.  Edition. 
 
5. Highlight the Edition to be displayed and tap on the OK button.  The window in Figure 29, Operation 

Successful opens. 
 

 
 

Figure 29.  Operation Successful. 
 
6. Tap on the OK button.  The window in Figure 30, SOI Displayed opens. 
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Figure 30.  SOI Displayed. 
 
7. As can be seen from the window above the SOI Tab now shows the SOI for Time Periods 1-5 that 
were selected previously.  If you tap on the + sign to the left of Group you will see all the Groups 
displayed.  Also your Pyro and Smoke signals and meanings are now available to be referenced. 
 
END OF TASK 
 
 
END OF WORK PACKAGE 
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
 
FILE MENU 
 OVER THE AIR DISTRIBUTION (OTAD) 
  VARIABLE GENERATE 
  RECEIVE VARIABLE 
  VARIABLE UPDATE 
  MANUAL REKEY 
  AUTOMATIC REKEY 
 
 
OVER THE AIR DISTRIBUTION (OTAD 
 
Over the Air Distribution (OTAD) provides a means to change the traffic encryption key in remote crypto-
equipment by sending a new key directly to the remote crypto-equipment over the communication path it 
secures.  The OTAD selection encompasses five (5) different procedures that allow the user of the SKL to 
have maximum flexibility in performing the mission.  This Work Package will describe the procedure to 
follow for the first three OTAD procedures, VG, RV, and VU.  The Manual Rekey (MK) procedure will be 
in Work Package 0019 and the Automatic (AK) procedure will be in Work Package 0020.  The five sub-
menus under the OTAD selection are: 
 

• Variable Generate (VG) 
• Receive Variable (RV) 
• Variable Update (VU) 
• Manual Rekey (MK) 
• Automatic Rekey (AK) 

 
Variable Generate (VG) 
 
Variable Generate allows the SKL operator to generate a key with user specific attributes.  This OTAD 
option provides the operator with a way to generate a key and store it in the SKL for later distribution to 
an ECU.  Follow the procedure below to generate a key variable. 

 
Figure 1.  File→OTAD→Variable Generate. 
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1. From the SKL UAS Main Menu select File→OTAD→Variable Generate as depicted above.  The 

window in Figure 2, Key Tag Information, opens. 
 

 
 

Figure 2.  Key Tag Information. 
 
2. Before you can generate a key you must enter key tag data.  There are three areas where the virtual 

keyboard is required.  They are the Short Title, Edition, and Segment Range that have been filled in 
as depicted above.  The CT3 Key Type, Key Use, Effective Start Date, Supersession Rate, and 
Crypto Period are drop-down menus that are used to select the appropriate information.  The Clear 
All button when tapped will clear all the information from only the Short Title and Edition fields.  The 
Template button is used to select a saved template that will populate all the fields with the required 
information.  The Copy Key Tag button when selected will allow you to copy key tag information from 
an existing key tag that is stored in your SKL.  The key tag field characteristics are defined below: 

 
• The Short Title field has a 24-character limit. 

 
• The Edition field has a 6-character limit. 

 
• The Segment Range fields can accommodate a range from 0-99 segments. 

 
• The CT3 Key Type field has a drop-down menu to choose from. 
 
• The Key Use field has a drop-down menu. 

 
• The Effective Start Date field has a down arrow that when selected opens up a calendar to 

choose the correct date. 
 

• The Supersession Rate field has a drop-down menu. 
 

• The Crypto Period field has a drop-down menu. 
 

 
TIP:  If default key tag values are in the Short Title and Edition fields, delete them by using the 
backspace key. 

 
 
TIP:  To use a field setting template, select Template and choose the appropriate template name 
(if any are listed on the Template list).  This action enters the default values defined in the 
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template in the Key Tag Information fields.   
Once all the correct information has been entered in this window, tap on the Next>> button.  The window 
in Figure 3, Key Tag Information #2, opens. 
 

Figure 3.  Key Tag Information #2. 
 

. This is window # 2 of the Key Tag Information.  Use the virtual keyboard to fill in the required 

 the key.  

 
• Enter the Register Number.  This is a numeric number starting at 0 (zero). 

 
• Select a Classification from the drop-down menu. 

 
• Enter a Text ID.  This field has a 16-character limit. 

You can now save all the information that has been entered in the Key Tag Information pages to a 

 

3
information in the Register Number and Text ID fields as depicted above.  The other field, 
Classification has a drop-down menu from which to select the appropriate classification for
This window also has a button called “Save as Template”.  This is used to save the information you 
have entered in these windows to a template that can be used later to populate the fields in these 
windows when another key is received.  The field characteristics are defined below: 

 

template or you can skip the template process and continue with the Receive Key process.  In this 
example we have chosen to Save as Template.  Therefore, tap on the Save as Template button.  
The window in Figure 4, Save Template, opens.   
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Figure 4.  Save Template. 

 
4. Use the Virtual Keyboard to fill in the New Template Name as depicted above.  Then tap on the OK 

button.  The window in Figure 5, Template List Updated, opens. 
 

Figure 5.  Template List Updated. 
 

. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 6, Key Tag 

 

 

5
Information 2, opens. 
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Figure 6.  Key Tag Information 2. 

 
6. Tap on the Next>> button.  The window in Figure 7, Variable Generate Profile, opens. 
 

Figure 7.  Variable Generate Profile. 
 

NOTE 
 

Refer to the VG equipment Technical Manual for location of all relevant switches 

 
. The Variable Generate Profile window will only display those steps you are required to take based on 

nt.  

 

 

and buttons and how to prepare the equipment for a VG operation. 

7
the Profile Modes that is currently selected on your SKL.  If the Profile Modes is set to "Detailed" then 
you will see most if not all steps required for you to take.  If the Profile Mode is set to "Condensed" 
then you will see only a minimum amount of steps.  See Work Package 0029 Options for more 
information on the Profile Modes.  Follow the instructions in the Profile window for your equipme
This window provides the profile to generate a variable.  Follow the steps and when finished, tap on 
the Finish button.  The window in Figure 8, Status, opens. 
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Figure 8.  Status. 

 
8. This status window keeps you informed as to the progress of the variable generate operation.  When 

finished, the window in Figure 9, Operation Successful, opens. 
 

Figure 9.  Operation Successful. 
 

. Now tap on the OK button in the upper right-hand corner of the window.  The Variable Generate 
hen 

 

 

9
operation is complete.  To view the key just generated, tap on the Keys tab if not already open.  T
scroll down to see the key just received as depicted below in Figure 10, New Key Received. 
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Figure 10.  New Key Received. 

 
10. Expand the Short Title and Edition of the received key to make sure that you have the key as 

depicted above.  Now select File→Save Database.  Once the database has been saved the SKL 
UAS Desktop returns. 

 
END OF TASK 
 
Receive Variable (RV) 
 
The RV function provides the capability to receive a key into the SKL from another SKL or DTD using RV 
capable communications equipment.  Follow the procedure below to receive a variable.  From the SKL 
UAS Main Menu select File→OTAD→Receive Variable.  The window in Figure 11, RV Key Tag 
Information, opens. 
 

 
 

Figure 11.  RV Key Tag Information. 
 
1. Before you can generate a key you must enter key tag data.  There are three areas where the virtual 

keyboard is required.  They are the Short Title, Edition, and Segment Range that have been filled in 
as depicted above.  The CT3 Key Type, Key Use, Effective Start Date, Supersession Rate, and 
Crypto Period are drop-down menus that are used to select the appropriate information.  The Clear 
All button when tapped will clear all the information from only the Short Title and Edition fields.  The 
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Template button is used to select a saved template that will populate all the fields with the required 
information.  The Copy Key Tag button when selected will allow you to copy key tag information from 
an existing key tag that is stored in your SKL.  The key tag field characteristics are defined below: 

 
• The Short Title field has a 24-character limit. 

 
• The Edition field has a 6-character limit. 

 
• The Segment Range fields can accommodate a range from 0-99 segments. 

 
• The CT3 Key Type field has a drop-down menu to choose from. 

 
• The Key Use field has a drop-down menu. 

 
• The Effective Start Date field has a down arrow that when selected opens up a calendar to 

choose the correct date. 
 

• The Supersession Rate field has a drop-down menu. 
 

• The Crypto Period field has a drop-down menu. 
 

 
TIP:  If default key tag values are in the Short Title and Edition fields, delete them by using the 
backspace key. 

 
 
TIP:  To use a field setting template, select Template and choose the appropriate template name 
(if any are listed on the Template list).  This action enters the default values defined in the 
template in the Key Tag Information fields.   

 
Once all the correct information has been entered in this window, tap on the Next>> button.  The window 
in Figure 12, RV Key Tag Information #2, opens. 

 
Figure 12.  RV Key Tag Information #2. 

 
2. This is window # 2 of the Key Tag Information.  Use the virtual keyboard to fill in the required 

information in the Register Number and Text ID fields as depicted above.  The other field, 
Classification has a drop-down menu from which to select the appropriate classification for the key.  
This window also has a button called “Save as Template”.  This is used to save the information you 
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have entered in these windows to a template that can be used later to populate the fields in these 
windows when another key is received.  The field characteristics are defined below: 
 
• Enter the Register Number.  This is a numeric number starting at 0 (zero). 

 
• Select a Classification from the drop-down menu. 

 
• Enter a Text ID.  This field has a 16-character limit. 
 

You can now save all the information that has been entered in the Key Tag Information pages to a 
template or you can skip the template process and continue with the Receive Key process.  In this 
example we have chosen to Save as Template.  Therefore, tap on the Save as Template button.  The 
window in Figure 13, Save Template, opens.  Using the Virtual Keyboard complete the information fields 
on this window.  When finished close the Virtual Keyboard.  You can now save this information as a 
template if you wish by tapping on the Save as Template button.  Or if this is a one time event, tap on the 
Next>> button.  In this depiction we have chosen to Save as Template.   
 

 
Figure 13.  Save Template. 

 
3. Use the Virtual Keyboard to fill in the New Template Name as depicted above.  Then tap on the OK 

button.  The window in Figure 14, Template List Updated, opens. 
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Figure 14.  Template List Updated. 

 
4. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 15, RV 

Key Tag Information #2, opens. 
 

Figure 15.  RV Key Tag Information #2. 
 

. Now with the template saved, tap on the Next>> button.  The window in Figure 16, RV Profile, opens. 

 

5
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Figure 16.  RV Profile. 

 
NOTE 

 
Refer to the RV equipment Technical Manual for location of all relevant switches 
and buttons and how to prepare the equipment for a RV operation. 

 
6. The Receive Variable Profile window will only display those steps you are required to take based on 

the Profile Modes that is currently selected on your SKL.  If the Profile Modes is set to "Detailed" then 
you will see most if not all steps required for you to take.  If the Profile Modes is set to "Condensed" 
then you will see only a minimum amount of steps.  See Work Package 0029-Options for more 
information on the Profile Modes.  Follow the instructions in the Profile window for your equipment.  
Prepare the RV equipment for an RV operation and make sure that you establish communications 
with the distant end RV partner.  Once all RV preparations have been completed, tap on the Finish 
button.  The window in Figure 17, Status, opens. 

 

Figure 17.  Status. 
 

. This window gives you the status of the RV operation.  When the RV operation is finished, the 

 

 

7
window in Figure 18, Load Key Received, opens. 
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Figure 18.  Load Key Received. 

 
8. This window gives you the opportunity to Store the Key & Load it or just Store the Key.  If you want to 

load the key into the equipment at this time, select your equipment from the drop-down list and then 
tap on the Store Key & Load button.  Then follow the profile for loading the key into that particular 
equipment.  In our depiction, we have elected not to load the equipment at this time.  So tap on the 
Store Key Only button.  The window in Figure 19, Operation Successful, opens. 

 

 
Figure 19.  Operation Successful. 

 
9. Tap on the OK button in the upper right-hand corner of the window.  The key will automatically be 

saved to the database.  The tab you had open when the RV operation began returns.  Now you must 
validate that the key was actually received.  Tap on the Keys Tab and scroll down to the bottom of the 
list.  You should see the Short Title of the key received as depicted below in Figure 20, Keys Tab with 
RV Key. 
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Figure 20.  Keys Tab with RV Key. 

 
END OF TASK 
 
Variable Update (VU) 
 
The VU function provides the capability to send a KEK to a VU-capable device that then performs a 
deterministic update of the key and returns the revised key to the SKL.  The SKL retains the original and 
updated KEK.  With the exception of the segment number and suffix fields, which are updated by one, the 
tag of the original is applied to the updated KEK.  Follow the procedure below to generate a Variable 
Update.  From the SKL UAS Main Menu select File→OTAD→Variable Update.  The window in 
Figure 21, VU Selected Key(s), opens. 
 

 
Figure 21.  VU Selected Key(s). 

 
1. To see other attributes of the key, scroll to the right to see the Text ID, Effective Date, and Expiration 

Date.  Tap on the box to the left of the key that you want to update.  Then tap on the Next>> button.  
The window in Figure 22, VU Generated Key(s), opens. 
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Figure 22.  VU Generated Key(s). 

 
2. As depicted above, use the scroll bar to move to the right and see the new updated segment.  To 

modify any attributes of the Short Title, double-tap on the Short Title.  The window in Figure 23, 
Modify VU Key Tag, opens. 

 

Figure 23.  Modify VU Key Tag. 
 

. This window provides the means for you to change the Text ID, Effective Date, and Expiration Date.  

 

 

3
Make any desired changes to the Text ID using the Virtual Keyboard and the Drop Down arrows to 
make changes to the Effective and Expiration dates.  Then tap on the OK button.  The window in 
Figure 24, VU Generated Key(s), reopens. 
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Figure 24.  VU Generated Key(s). 

 
4. Connect to generating source and then tap the Finish button.  The window in Figure 25, Operation 

Successful, opens. 
 

Figure 25.  Operation Successful. 
 

. Now tap on the OK button in the upper right-hand corner of the window.  The Key is automatically 
b 

 

 

 

5
saved to the database.  The SKL UAS Desktop opens showing the last tab selected.  If the Keys Ta
was not the last tab open before this process started, then tap on the Keys Tab to open it and scroll to
the Short Title just updated.  Open up the Short Title all the way to see the key attributes as depicted 
in the window in Figure 26, Keys Tab, opens. 
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Figure 26.  Keys Tab. 
 

. As depicted above, there are now two keys shown for the Short Title ETD 19 5AP254.  This verifies 

 
ND OF TASK 

ND OF WORK PACKAGE 

 

6
that the VU was successful.  The VU operation is complete.   

E
 
 
E
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

SKL UAS MANUAL REKEY FUNCTION 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
 
FILE MENU 
 OVER THE AIR DISTRIBUTION (OTAD) 
  VARIABLE GENERATE 
  RECEIVE VARIABLE 
  VARIABLE UPDATE 
  MANUAL REKEY 
  AUTOMATIC REKEY 
 
 
OVER THE AIR DISTRIBUTION (OTAD) 
 
Over the Air Distribution (OTAD) provides a means to change the traffic encryption key in remote crypto-
equipment by sending a new key directly to the remote crypto-equipment over the communication path it 
secures.  The OTAD selection encompasses five (5) different procedures that allow the user of the SKL to 
have maximum flexibility in performing the mission.  The first three procedures are found in Work 
Package 0018.  The Automatic (AK) procedure is located in Work Package 0020.  This Work Package will 
describe the Manual Rekey (MK) procedures.  There are two MK procedures that will be described.  The 
first is Manual Rekey.  The second is Manual Rekey, Receive Variable (MK-RV).  The five sub-menus 
under the OTAD selection are: 
 

• Variable Generate (VG) 
• Receive Variable (RV) 
• Variable Update (VU) 
• Manual Rekey (MK) 
• Automatic Rekey (AK) 

 
Each of these selections has unique characteristics concerning electronic key. 
 
Manual Rekey (MK) 
 
The MK procedure allows the NCS to send a TEK to the net members ECU equipment.  In this case the 
SINCGARS radio.  The NCS should call the net members and inform them to prepare their equipment for 
receiving a TEK and tell them how and when to switch to the new TEK.  The old TEK may be deleted 
from the net member’s equipment.  However, this will be determined by the type of ECU equipment the 
net member has.  This procedure is the Manual Rekeying of a single SINCGARS radio or multiple radios 
within a communications net.  Follow the below listed steps to accomplish an MK. 
 

NOTE 
 

Prior to starting the MK, the NCS should view the SKL database for the required 
TEK, and KEK, and advise net members to standby and prepare to receive a new 
TEK. 

 
There are five important things to do before starting the MK procedure.  They are listed below: 
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• Know the NCS' KEK short title and text ID. 
• Know the Outstation's KEK short title and text ID. 
• Know what channel on the Outstation's radio that the TEK is going to be stored. 
• Pre-read all steps prior to actually performing the MK operation. 
• Know the new or replacement TEK Short Title and key attributes. 

 
1. Select File→OTAD→Manual Rekey (MK) on the SKL as shown in Figure 1, File→OTAD→MK, 

below. 

 
Figure 1.  File→OTAD→MK. 

 
2. Once the MK selection is made the window in Figure 2, OTAD MK Select Equipment, opens. 
 

Figure 2.  OTAD MK Select Equipment. 
 

. This is the window where you select the equipment you want to perform the MK on.  For this example 

 

 

3
we have selected RT-1523B.  Tap on the Next>> button.  The window in Figure 3, Perform MK-RV, 
opens. 
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Figure 3.  Perform MK-RV. 

 
4. The MK-RV is used to transmit a TEK to a remote SKL via a radio net.  Since this is an MK operation, 

tap on the NO button.  The window in Figure 4, Generate New Replacement TEK, opens. 
 

NOTE 
 

The COMSEC custodian normally generates all TEKs.  Only generate a new TEK 
when authorization has been given.  If authorization has been given select Yes 
below and follow the prompts to Variable Generate (VG) a new TEK. 

 

Figure 4.  Generate New Replacement TEK. 
 

. If the new replacement TEK is in the key database tap on the NO button and proceed to the next 

 

 

 

5
step.  The window in Figure 5, Select an Outstation KEK, opens.  However, if you do not have the 
new TEK in the database and you have been given permission to generate a new TEK, select Yes 
and do the Variable Generate (VG) procedure located in Work Package 0018.  Once you have the 
new TEK in your database, the MK process continues with the window in Figure 5, Select Outstation
KEK. 
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Figure 5.  Select Outstation KEK. 

 
6. Select the KEK that is stored in channel 6 of the Outstation's radio.  The tap on the Next>> button.  

The window in Figure 6, Select Replacement TEK, opens. 
 

Figure 6.  Select Replacement TEK. 
 

. Tap on the new replacement TEK and then tap on the Next>> button.  The window in Figure 7, Load 

 

 

7
Outstation KEK to NCS, opens. 
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Figure 7.  Load Outstation KEK to NCS. 

 
8. Connect the SKL to the Aud/Fill connector on the NCS SINCGARS radio.  Then tap on the Next>> 

button.  The window in Figure 8, Load Outstation KEK to NCS Profile, opens. 
 

Figure 8.  Load Outstation KEK to NCS Profile. 
 
. The OTAD Manual Rekey Load Outstation KEK to NCS window is really a Profile window and will 

ted 

 

d 

 

 

9
only display those steps you are required to take based on the Profile Modes that is currently selec
on your SKL.  If the Profile Modes is set to "Detailed" then you will see most if not all steps required 
for you to take.  If the Profile Modes is set to "Condensed", then you will see only a minimum amount
of steps.  See Work Package 0029-Options for more information on the Profile Modes.  Follow the 
instructions in the Profile window for your equipment.  Set the NCS SINCGARS radio to CT, LD, an
the Channel Selector on an operational channel.  Then tap on the Finish button.  The window in 
Figure 9, Ready to Send Key, opens. 
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Figure 9.  Ready to Send Key. 

 
10. Review the Outstation KEK attributes and then tap on the OK button.  The window in Figure 10, 

Status, opens. 
 

Figure 10.  Status. 
 

1. Press the Load button on the NCS SINCGARS radio keypad.  You should see the following and take 

 
a. The SKL Status window will temporarily display "Load in progress", "Press STO and 

 
b. H-TEK will be displayed on the NCS SINCGARS radio. 

 
c. Press [STO] and then the [6] button on the NCS SINCGARS radio keypad.  This action stores 

 
12. he window in Figure 11, Pre-Steps MK Operation, opens. 

 

1
the action in c below: 

location", and finally "Operation Complete". 

the Outstation SINCGARS radio's KEK in channel 6 of the NCS SINCGARS radio. 

T
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Figure 11.  Pre-Steps MK Operation. 

 
13. Perform the following Pre-steps in the MK Operation: 
 

a. Call the Outstation SINCGARS radio and tell them to go to channel 6. 
 

b. Set the NCS SINCGARS radio to channel 6. 
 

c. Perform a radio check between the NCS and the Outstation using channel 6. 
 

d. Tell the Outstation to set the Function Switch to LD, COMSEC to RV, and DATA to Off. 
 

e. Tell the Outstation to press CMSC and then press CHG until you see the channel you wish to 
store the new TEK in i.e., RK1, RK2, RK3, RK4, or RK5. 

 
f. Tell the Outstation that after MK to set Function Switch to SQ On, return to original channel, and 

set COMSEC to CT. 
 
g. Tell Outstation to standby for a Manual Rekey.  **Wait for a response from the Outstation. 
 
h. On the SKL, tap on the Finish button.  The window in Figure 12, Status, opens. 

 

Figure 12.  Status. 
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14. The SKL temporarily displays "MK in progress" for approximately 15 seconds.  Then the window in 

Figure 13, Post-Steps MK Operation, o

 
ation. 

5. Perform the following Post-Steps in the MK Operation: 
 

a. Set the NCS SINCGARS radio to the original channel, the COMSEC to CT, and the Function 

 

 
c. On the SKL, tap on the Finish button.  The window in Figure 14, Poll Net, opens. 

 

 

pens. 
 

Figure 13.  Post-Steps MK Oper
 
1

switch to SQ ON. 

b. Perform a radio check with the Outstation. 

Figure 14.  Poll Net. 
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16. Perform the following to determine if you need to perform the MK operation again: 
 

NOTE 
 

Follow either step (16a) or step (16b) depending on whether or not the TEK was 
pre-loaded in the NCS radio. 

 
a. If the NCS SINCGARS radio did not pre-load the TEK, tell the Outstation operator to scroll 

COMSEC CMSC to the new TEK and press the handset for the presence of the TEK.  Then scroll 
back to the original TEK.  Then ask the Outstation operator if they heard a solid tone or a beep 
and a rush in the handset. 

 
• If a solid tone was heard, then on the SKL tap on the Yes button to retry the MK. 

 
• If a beep and a rush was heard, then on the SKL tap on the No button and go to the next 

step. 
 

b. If the NCS SINCGARS radio had pre-loaded the TEK, tell the Outstation operator to scroll 
COMSEC CMSC to the new TEK.  Advise the Outstation operator that if unable to communicate 
to scroll back to the original TEK position. 

 
c. Press CMSC and CHG on the NCS radio until the new TEK position is displayed.  Perform a 

radio check with the Outstation operator. 
 

• If the radio check is successful, then on the SKL tap on the No button and go to the next 
step. 

 
• If the radio check is unsuccessful, then on the SKL tap on the Yes button to retry the MK 

operation and scroll the COMSEC back to the original TEK. 
 

d. If the MK was successful and you selected No for the MK retry, the window in Figure 15, Select 
Original KEK for Reload to NCS, opens. 

 
Figure 15.  Select Original KEK for Reload to NCS. 

 
17. Select the original NCS SINCGARS radio KEK and then tap on the Finish button.  The window in 

Figure 16, Load Original KEK Back to NCS, opens. 
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Figure 16.  Load Original KEK Back to NCS. 

 
18. Verify that the SKL is still connected to the Aud/Fill connector of the SINCGARS radio and then tap 

on the Next>> button.  The window in Figure 17, Load Original KEK Back to NCS Profile, opens. 
 

Figure 17.  Load Original KEK Back to NCS Profile. 
 

9. Set the NCS SINCGARS radio to CT, LD, and clear the COMSEC alarm by pressing the handset 

 

 

1
switch twice.  Then tap on the Finish button.  The window in Figure 18, Ready to Send Key, opens. 
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Figure 18.  Ready to Send Key. 

 
20. Review the NCS KEK attributes and then tap on the OK button.  The window in Figure 19, Status, 

opens. 
 

Figure 19.  Status. 
 

1. Press the Load button on the NCS SINCGARS radio keypad.  You should see the following and take 

 
a. The SKL Status window will temporarily display "Load in progress", "Press STO and 

 
b. H-TEK will be displayed on the NCS SINCGARS radio. 

 
c. Press STO and then the 6 button on the NCS SINCGARS radio keypad.  This action stores the 

 

 

 

2
the action in c below: 

location", and finally "Operation Complete". 

NCS' SINCGARS radio's KEK in back in channel 6.  The MK process continues with the window
in Figure 20, Reminder, below. 
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Figure 20.  Reminder. 

 
22. This window reminds you to load the replacement TEK into the NCS so that you can communicate 

with the outstations.  Tap on the OK button in the upper right-hand corner of the window.  The 
window in Figure 21, Operation Successful, opens concluding the MK procedure. 

 

Figure 21.  Operation Successful. 
 

3. Tap on the OK button in the upper right-hand corner of the window.  The SKL UAS desktop returns. 

ND OF TASK 

anual Rekey (MK) Receive Variable (RV).  The MK RV procedure allows the NCS to send a TEK to an 

 
his 

 

2
 
E
 
M
Outstation(s) SKL.  The Outstation(s) will need to prepare their SINCGARS radio and SKL to receive the 
TEK.  The NCS will need to tell the Outstation(s) the TEK’s key attributes (short title, edition, segment, 
and text ID).  The NCS should not send the TEK to the Outstation(s) SKL prior to the Outstation(s) 
selecting finish on their SKL.  Follow the steps below to send a TEK from the NCS' SKL through the
SINCGARS radio to the Outstation(s) SKL.  There are certain requirements that must be met before t
procedure can be started.  They are: 
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• Know the NCS SINCGARS radio KEK's short title and text ID. 

KL by performing the OTAD RV procedure. 

 
. From the main menu, select File→OTAD→Manual Rekey (MK).  The window in Figure 22, Select 

 

 
Figure 22.  Select Equipment. 

 
. This is the window where you select the equipment to perform the MK RV on.  We have selected the 

 

 
Figure 23.  Perform MK-RV. 

3. Tap on the Yes button.  The windo  Replacement TEK, opens. 

• Know the Outstation(s) KEK's short title and text ID. 
• Call the Outstation(s) and tell them to prepare their S
• Pre-read all steps prior to actually performing the MK. 

1
Equipment, opens. 

2
RT-1523B as depicted above.  Now tap on the Next>> button.  The window in Figure 23, Perform 
MK-RV, opens. 

 
w in Figure 24, Generate New
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NOTE 

The COMSEC custodian normally generates all TEKs.  Only generate a new TEK 
when authorization has been given.  If authorization has been given select Yes 

 

 
nt TEK. 

. If you need to generate the new TEK, select Yes and then run the Variable Generate procedure found 
in Work Package 0018.  e MK RV procedure 
continues with the window below.  If you have already generated the new TEK and it is in your 

 

 

 
. Select the KEK for the Outstation(s) from the list and then tap on the Next>> button.  The window in 

Figure 26, Select Replacemen

 

below and follow the prompts to Variable Generate (VG) a new TEK. 

Figure 24.  Generate New Replaceme
 
4

When you have the new TEK in your database, th

Mission Database, tap on the No button.  The window in Figure 25, Select Outstation KEK, opens. 

Figure 25.  Select Outstation KEK. 

5
t TEK, opens. 
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Figure 26.  Select Replacement TEK. 

 
6. Select the replacement TEK you are going to send to the Outstation(s) SKLs and then tap on the 

Next>> button.  The window in Figure 27, Load Outstation KEK to NCS, opens. 
 

Figure 27.  Load Outstation KEK to NCS. 
 
. Connect the SKL to the Aud/Fill port on the NCS SINCGARS radio and then tap on the Next>> 

 

 

7
button.  The window in Figure 28, Load Outstation KEK to NCS Profile, opens. 
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Figure 28.  Load Outstation KEK to NCS Profile. 

 
8. Perform the following on the NCS SINCGARS radio. 
 

a. Set COMSEC switch to CT. 
 

b. Set FUNCT switch to LD. 
 

c. Depress the handset key - switch twice to clear the alarm tone.  
 
9. Now tap on the Finish button.  The window in Figure 29, Ready to Send Key, opens. 
 

Figure 29.  Ready to Send Key. 
 
0. Review the attributes of the Outs the right key.  If correct, tap on 

 

 

1 tation KEK to make sure you have 
the OK button.  The window in Figure 30, Status, opens. 
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Figure 30.  Status. 

 
11. Perform the following on the NCS SINCGARS radio. 
 

a. Press the LOAD button on the keypad. 
 

b. The SKL Status window will temporarily display "Load in progress" and then "Press STO and 
location" and finally "Operation Complete". 

 
c. On the NCS SINCGARS radio H-TEK will be displayed. 

 
d. On the NCS SINCGARS radio, press the STO button and then the 6 button on the keypad.  This 

will store the Outstation(s) KEK into channel 6 of the NCS SINCGARS radio. 
 
12. After these steps have been completed, the window in Figure 31, Pre-Steps MK-RV Operation, 

opens. 
 

Figure 31.  Pre-Steps MK-RV Operation. 
 

3. Perform the following steps in order. 

a. Call the Outstation(s) and tell them to go to channel 6. 
 

 

1
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b. Set the NCS SINCGARS radio to channel 6. 
 

 
d then the CHG button until their SINCGARS 

display reads OFF. 
 

e. tap on the Receive button on their SKLs.  **Wait for response from 
Outstation(s). 

 
f. CGARS SKL, tap on the Finish button. 

 progress" and then "Operation 
Complete".  The window in Figure 32, Post-Steps MK-RV Operation, opens. 

 

 
ation. 

4. Perform the following steps in order. 
 

a. Tell Outstation(s) to set their SINCGARS radio COMSEC switch to CT and the Function switch to 

 
c. Set the NCS SINCGARS radio COMSEC switch to CT and the Function switch to SQ ON. 

 
d. Set the NCS SINCGARS radio to the original channel. 

 
e. Perform a radio check with the Outstation(s). 

 
f. Tap on the Finish button on the NCS SKL.  The window in Figure 33, Poll Net, opens. 

 

c. Perform a radio check with the Outstation(s). 

d. Tell Outstation(s) to press the DATA button an

Tell Outstation(s) to 

On the NCS SIN
 

g. The NCS SINCGARS SKL will temporarily display "MK in

Figure 32.  Post-Steps MK-RV Oper
 
1

SQ ON. 
 

b. Tell Outstation(s) to return to the original channel on their SINCGARS radio. 
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Figure 33.  Poll Net. 

 
15. Call the Outstation(s) and ask if they received the TEK into their SKL.  If any Outstation(s) reports 

back to the NCS that their SKL did not receive the TEK, then advise those Outstation(s) to prepare 
the RV procedure on their SKL again and then tap on the Yes button to retry the MK.  If the 
Outstation(s) reported back to the NCS that they received the TEK into their SKL then tap on the No 
button.  The window in Figure 34, Select Original KEK for Reload to NCS, opens. 

 

 
Figure 34.  Select Original KEK for Reload to NCS. 

 
16. Select the NCS KEK from the list and tap on the Finish button.  The window in Figure 35, Load 

Original KEK Back to NCS, opens. 
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Figure 35.  Load Original KEK Back to NCS. 

 
17. Verify that the SKL is still connected to the Aud/Fill connector of the NCS SINCGARS radio, and then 

tap on the Next>> button.  The window in Figure 36, Load Original KEK Back to NCS Profile, Opens. 
 

 
Figure 36.  Load Original KEK Back to NCS Profile. 

 
18. Perform the following on the NCS SINCGARS radio. 
 

a. Set COMSEC switch to CT. 
 

b. Set FUNCT switch to LD. 
 

c. Depress the handset key- switch twice to clear the alarm tone.  
 
19. Now tap on the Finish button.  The window in Figure 37, Ready to Send Key, opens. 
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Figure 37.  Ready to Send Key. 

 
20. Review the attributes of the NCS KEK to make sure you have the right key.  If correct, tap on the OK 

button.  The window in Figure 38, Status, opens. 
 

 
Figure 38.  Status. 

 
21. Perform the following on the NCS SINCGARS radio. 
 

a. Press the LOAD button on the keypad. 
 

b. The SKL Status window will temporarily display "Load in progress" and then "Press STO and 
location" and finally "Operation Complete". 

 
c. On the NCS SINCGARS radio H-TEK will be displayed. 

 
d. On the NCS SINCGARS radio, press the STO button and then the 6 button on the keypad.  This 

will store the Outstation(s) KEK into channel 6 of the NCS SINCGARS radio. 
 
22. After these steps have been completed, the window in Figure 39, Operation Successful, opens. 
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Figure 39.  Operation Successful. 

 
23. Tap on the OK button in the upper right-hand corner of the window.  The SKL returns to the tab you 

had open when you started the MK-RV procedure. 
 
END OF TASK 
 
Generic Manual Rekey (MK).  This procedure should be used to perform an Over-Air-The-Distribution 
(OTAD) Manual Rekey (MK) of communications equipment not listed on the OTAD Select Equipment 
window.  This procedure is designed to rekey equipment in a net having no Net Control Station (NCS).  
This procedure could also be called simply “Net Rekey”. 
 
Use the following procedure to rekey a net using the Generic MK process. 
 
1. Connect the SKL to a communications device within the net to be Rekeyed. 
 
2. On the SKL select File→Transmit→OTAD→Manual Rekey.  The window in Figure 40, Select 

Equipment opens. 
 

 
 

Figure 40.  Select Equipment. 
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3. From the list presented select Generic MK and tap on the Next>> button.  The window in Figure 41, 

Perform MK-RV Opens. 
 

 
 

Figure 41.  Perform MK-RV. 
 
4. Since this operation is about rekeying a net, tap on the No button.  The window in Figure 42, 

Generate New Replacement TEK opens. 
 

 
 

Figure 42.  Generate New Replacement TEK. 
 
5. If the replacement TEK currently does not reside in the SKL this procedure should not have been 

attempted to begin with.  However, if a replacement TEK needs to be generated the selection here 
would be Yes.  However, for this demonstration we are selecting No.  The window in Figure 43, Load 
Outstation KEK to NCS opens. 
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Figure 43.  Load Outstation KEK to NCS. 
 
6. Since this procedure concerns only a net rekey there is no NCS so therefore tap on the No button.  

The window in Figure 44, Select Replacement TEK opens. 
 

 
 

Figure 44.  Select Replacement TEK. 
 
7. From the list of keys provided, select the replacement TEK and then tap on the Next>> button.  The 

window in Figure 45, Pre-Steps MK Operation opens. 
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Figure 45.  Pre-Steps MK Operation. 
 
8. Follow all the pre-steps and then tap on the Finish button.  The window in Figure 46.  MK in Progress 

opens. 
 

 
 

Figure 46.  MK in Progress. 
 
9. Once the process is complete, the window in Figure 47, MK Completed opens. 
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Figure 47.  MK Complete. 
 
10. The MK has completed but there are some housekeeping functions that need to be accomplished 

before the process is truly complete.  Tap on the Finish button.  The window in Figure 48, Poll Net 
opens. 

 

 
 

Figure 48.  Poll Net. 
 
11. This window comes up as a result of this being an OTAD procedure.  Since this is a Generic MK of a 

net only, there is no way to Poll the net.  Therefore tap on the No button.  The window in Figure 49, 
Load Original KEK to NCS opens.  If there is a device in the net that did not get the replacement TEK, 
the procedure will have to be run again. 
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Figure 49.  Load Original KEK Back to NCS. 
 
12. Since a KEK was never utilized in this Generic MK procedure, tap on the No button.  The window in 

Figure 50, Load Replacement TEK to NCS opens. 
 

 
 

Figure 50.  Load Replacement TEK to NCS. 
 
13. In actuality what you are doing here is to load the replacement TEK into the device the SKL is 

connected to since there is no NCS in this type of net.  Tap on the OK button.  The window in 
Figure 51, Operation Successful opens. 
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Figure 51.  Operation Successful. 
 
14. Tap on the OK button to complete the procedure to rekey a net. 
 
 
END OF TASK 
 
 
END OF WORK PACKAGE 
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OVER THE AIR DISTRIBUTION (OTAD) 
 
Over the Air Distribution (OTAD) provides a means to change the traffic encryption key in remote crypto-
equipment by sending a new key directly to the remote crypto-equipment over the communication path it 
secures.  The OTAD selection encompasses five (5) different procedures that allow the user of the SKL to 
have maximum flexibility in performing the mission.  This Work Package will describe the Automatic 
Rekey (AK) procedure.   
 
Automatic Rekey (AK) 
 
The Automatic Rekey (AK) uses a rekey procedure that allows the NCS to update the net members TEK.  
When the net members receive a COMSEC message from the NCS, the net member's equipment TEK 
and KEK is automatically updated to the next variable.  To accomplish this AK procedure, the NCS will 
have to be familiar with the communications net equipment, the OTAR switch settings, and menu 
programming.  The NCS should refer to the correct equipment technical manual for specific OTAR 
procedures.  The following AK procedure uses the RT-1523B SINCGARS radio as the equipment for the 
communications net.  There are certain requirements that must be met before this procedure can be 
started.  They are: 
 

• Know the SINCGARS NCS KEK's short title and text ID. 
• Know the current and replacement TEK's short title and text ID. 
• Know the Outstation(s) KEK's short title and text ID.  
• Know that the TEK on the Outstation(s) SINCGARS operational channel will be replaced, and 

that the replaced TEK will have to be stored on a separate channel on the SINCGARS NCS 
radio. 

• Know what spare channel on the SINCGARS NCS radio that the new TEK is to be stored. 
• Pre-read all steps of this procedure prior to actually performing the AK. 

 
Once you are confident that you know the information cited above you can begin the procedure. 
 
1. Select File→OTAD→Automatic Rekey (AK) from the main menu as depicted below in Figure 1, 

Automatic Rekey (AK). 
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Figure 1.  File→OTAD→Automatic Rekey (AK). 

 
2. As a result of selecting Automatic Rekey (AK), the window in Figure 2, Select an Equipment, opens. 
 

Figure 2.  Select an Equipment. 
 

. Since this procedure is using the SINCGARS radio to demonstrate the AK procedure, the RT-1523B 

 
NOTE 

 
The COMSEC custodian normally generates all TEKs.  Only generate a new TEK 

 

 

3
has been selected the as depicted above.  You should select the equipment you need to perform an 
AK on.  Then tap on the Next>> button.  The window in Figure 3, Generate New Replacement TEK, 
opens. 

when authorization has been given.  If authorization has been given select Yes 
below and follow the prompts to Variable Generate (VG) a new TEK. 
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Figure 3.  Generate New Replacement TEK. 

 
4. If you do not have the new TEK in the database and you have been given permission to generate a 

new TEK, select Yes and do the Variable Generate (VG) procedure located in Work Package 0018.  
Once you have the new TEK in your database, the process continues with the window below.  If the 
new replacement TEK is in the key database tap on the NO button and proceed to the next step.  The 
window in Figure 4, Select One or More Outstation KEK(s), opens 

 

Figure 4.  Select One or More Outstation KEK(s). 
 

. Select the KEK that are stored on 

 

 

5 channel 6 of the Outstation(s) SINCGARS radio as depicted above.  
Then tap in the Next>> button.  The window in Figure 5, Select a Replacement TEK, opens. 
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Figure 5.  Select a Replacement TEK. 

 
6. Select the replacement TEK as depicted above and then tap on the Finish button.  The window in 

Figure 6, Pre-Steps AK Operation, opens. 
 

 
Figure 6.  Pre-Steps AK Operation. 

 
7. Communicate with the Outstation(s) and tell them to standby for an AK.  Make sure that you wait 

and get a response from all net members.  Once all net members have acknowledged, tap on the 
Finish button.  The window in Figure 7, Status, opens. 
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Figure 7.  Status. 

 
8. On the SKL attached to the NCS SINCGARS radio, the Status window temporarily displays "AK in 

progress" and then "Operation Complete".  The window in Figure 8, AK Completed, opens. 
 

 
 

Figure 8.  AK Completed. 
 
9. Tap on the Finish button.  The window in Figure 9, All Outstations Successfully Rekeyed opens. 
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Figure 9.  All Outstations Successfully Rekeyed. 

 
10. The NCS will attempt to Poll the Net to determine if any Outstation did not receive the updated TEK.  

If the NCS cannot communicate with the Outstation(s), then the No button should be selected so that 
the AK process can be repeated.  If the NCS can communicate with all the Outstation(s) then tap on 
the Yes button.  The window in Figure 10, Load Replacement TEK to NCS, opens.   

 

Figure 10.  Load Replacement TEK to NCS. 
 

1. Connect the SKL to the NCS SINCGARS radio Aud/Fill connector and then tap on the Next>> 

 

 

1
button.  The window in Figure 11, Load Replacement TEK to NCS Profile, opens. 
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Figure 11.  Load Replacement TEK to NCS Profile. 

 
12. Perform the following on the NCS SINCGARS radio. 
 

a. Set the COMSEC switch to CT. 
 

b. Set the FCTN switch to LD. 
 

c. Depress the Handset switch twice to clear the alarm tone. 
 
13. Once these conditions have been met tap on the Finish button.  The window in Figure 12, Ready to 

Send Key, opens. 
 

Figure 12.  Ready to Send Key. 
 

4. Review the key attributes of the replacement TEK, and if correct tap on the OK button.  The window 

 

 

1
in Figure 13, Status, opens. 
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Figure 13.  Status. 

 
15. On the NCS SINCGARS radio, press the Load button on the keypad.  The SKL attached to the NCS 

will temporarily display "Press STO and location" and then "Operation Complete".  On the NCS 
SINCGARS radio, H-TEK is displayed.  Press STO and the channel number that the key is to be 
stored in i.e., 1, 2, 3, 4, or 5.  The window in Figure 14, Variable Update, opens. 

 

Figure 14.  Variable Update. 
 

6. This process will update the Outstation(s) KEK.  Select the Outstation(s) KEK and then tap on the 

 

 

1
Next>> button.  The window in Figure 15, Generated KEK(s), opens. 
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Figure 15.  Generated KEK(s). 

 
17. This window shows you the generated KEK.  As depicted in the window above the segment has 

changed from 1 to 2.  If you use the scroll bar at the bottom of the window, you can see the Text ID, 
Effective, and Expiration Dates.  If you wish to change the Text ID or the Effective or Expiration 
Dates, double-tap on the Short Title.  The window in Figure 16, Modify VU Key Tag, opens. 

 

Figure 16.  Modify VU Key Tag. 
 

8. From this window you can change the Text ID, the Effective Date, and the Expiration Date of the KEK 

 

 

1
that was just created.  Once you have made your changes, tap on the OK button.  The window in 
Figure 17, Generated KEK(s), returns. 
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Figure 17.  Generated KEK(s). 

 
19. Tap on the Finish button.  The window in Figure 18, Status, opens. 
 

Figure 18.  Status. 
 

0. The SKL connected to the NCS SINCG orarily "VU in progress".  Then 

 

 

2 ARS radio will display temp
the system automatically saves the key to the database.  The window in Figure 19, Operation 
Successful, opens. 

0020-11 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0020 
 

 
Figure 19.  Operation Successful. 

 
21. Once the database is saved the final action of the AK procedure is complete.  Tap on the OK button 

in the upper right-hand corner of the window to close it.  The Outstation(s) KEK was updated and the 
updated KEK has been stored in the database of the SKL.   

 
END OF TASK 
 
 
END OF WORK PACKAGE 
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CREATE KEY TAGS 
 
A new Key Tag can be manually created in the SKL without the use of other systems or equipment.  The 
newly created Key Tag has all the user provided short title information as well as the receive key profile 
settings of the key generating device defined by the user.  Once the Key Tag has been created, then a 
Key Needed procedure can be performed using the key-generating device defined by the user in the Key 
Tag.  To create a Key Tag, follow the procedures below. 
 

Figure 1.  File→Create Key Tags. 
 

. From the SKL Main Menu, select File→Create Key Tags as depicted above.  The window in 

 

 

1
Figure 2, Select Key Source, opens. 
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Figure 2.  Select Key Source. 

 
2. Scroll down the list of key sources and select the one you want to provide the key variable.  As 

depicted above, the KYK-13 is selected.  Once you have selected a key source tap on the Next>> 
button.  The window in Figure 3, Key Tag Information, opens 

 

 
 

Figure 3.  Key Tag Information. 
 
3. The Key Tag Information window is used for the entry of applicable Key Tag data.  There are three 

areas where the virtual keyboard is required.  They are the Short Title, Edition, and Segment Range 
that have been filled in as depicted above.  The CT3 Key Type, Key Use, Effective Start Date, 
Supersession Rate, and Crypto Period are drop-down menus that are used to select the appropriate 
information.  The Clear All button when tapped will clear all the information from only the Short Title 
and Edition fields.  The Template button is used to select a saved template that will populate all the 
fields with information that may be edited to fit the mission parameters.  The Copy Key Tag button 
when selected will allow you to copy Key Tag information from an existing Key Tag that is stored in 
your SKL.  The Key Tag field characteristics are defined below: 

 
a. The Short Title field has a 24-character limit. 

 
b. The Edition field has a 6-character limit. 

 
c. The Segment Range fields can accommodate a range from 0-99 segments. 
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d. The CT3 Key Type field has a drop-down menu to choose from. 
 

e. The Key Use field has a drop-down menu. 
 

f. The Effective Start Date field has a down arrow that when selected opens up a calendar to 

 
g. The Supersession Rate field has a drop-down menu. 

 
h. The Crypto Period field has a drop-down menu. 

 
 

IP:  If default key tag values are in the Short Title and Edition fields, delete them by using the 

 
IP:  To use a field setting template, select Template and choose the appropriate template name 

 
. Once all the correct information has been entered in this window, tap on the Next>> button.  The 

 

 
Figure 4.  Key Tag Information 2. 

5. There are two informational fie ID.  Use the virtual keyboard to fill 
in the required information in these fields as depicted above.  The other field, Classification has a 

e 2 

 
g at 0 (zero). 

. 
 

choose the correct date. 

T
backspace key. 

 

T
(if any are listed on the Template list).  This action enters the default values defined in the 
template in the Key Tag Information fields.   

4
window in Figure 4, Key Tag Information 2, opens. 

 
lds called Register Number and Text 

drop-down menu from which to select the appropriate classification for the key.  This window also has 
a button called “Save as Template”.  This is used to save the information you have entered in thes
windows to a template that can be used later to populate the fields in these windows when another 
Key Tag is created.  The field characteristics are defined below: 

a. Enter the Register Number.  This is a numeric number startin
 

b. Select a Classification from the drop-down menu. 
 

c. Enter a Text ID.  This field has a 16-character limit
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6. You can now save all the information that has been entered in the Key Tag Information pages to a 

is 

 

 
Figure 5.  Save Template. 

7. Fill in the new template name using cted above and then tap on the OK 
button.  The window in Figure 6, Template List Updated, opens. 

 
ted. 

. Tap on the OK button in the upper right-hand corner of the small window.  The window in Figure 7, 
Key Tag Information 2, re-open

 

template or you can skip the template process and continue with the Create Key Tag process.  In th
example we have chosen to Save as Template.  Therefore, tap on the Save as Template button.  
The window in Figure 5, Save Template, opens. 

 
 the virtual keyboard as depi

 

Figure 6.  Template List Upda
 
8

s 
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Figure 7.  Key Tag Information 2. 

 
9. Now tap on the Finish button.  The window in Figure 8, Keys Tab, opens. 
 

Figure 8.  Keys Tab. 
 

0. As depicted above in the Keys Tab, the A have been 

 

 

ND OF TASK 

ND OF WORK PACKAGE 

 

1 Short Title ETD 34 5ASB034 and Edition 
expanded to show the Segment 1-T000-4-1BDE CMD TEK.  This is the Key Tag that was created.  
As depicted above you only have a Segment and not the actual Key.  Therefore you would now do a
Key Needed Procedure to receive the actual Key for the Short Title and Edition.  Now select 
File→Save Database. 

 
E
 
 
E
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ASSIGN 
 
Some Key Tags, Electronic Protection (EP), Message Data, and Equipment that reside in the SKL 
database can only be loaded to their respective equipment if they are assigned to that equipment or 
platform.  When Short Titles, EP Data, Message Data, and Equipment are received into the SKL, they 
may not be assigned to any equipment fill location(s) or Platforms.  An example of this is when you 
perform an OTAD Receive Variable, Receive Selected Database, Receive Key, or Create Key Tag 
operation.  The following four procedures will describe the Assign function in the SKL UAS program. 
 
Assign Key to an Equipment Fill Location 
 
To assign key to an equipment fill location follow the procedure below. 
 

 
Figure 1.  Eqs Tab. 

 
. To assign a key to an equipment fill location, first tap on the Eqs Tab as depicted above.  Then locate 

ets 

 

1
the equipment that you want to assign the key to.  In the depiction above, we have selected the 
SINCGARS equipment and expanded it to show that there are no Key Tags assigned, only hops
are assigned to locations H1, H5, and H6.  Then select File→Assign→Key Tags as shown in 
Figure 2 below. 
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Figure 2.  File→Assign→Key Tags. 

 
2. As a result of performing the above operation the window in Figure 3, Assign Key Tags, opens. 
 

Figure 3.  Assign Key Tags. 
 

. Select the Short Title that will be assigned to the equipment fill location.  As depicted above, the Short 

 

 

3
title ETD 39 5EG231 has been selected.  Once the Short Title is highlighted, tap on the Next>> 
button.  The window in Figure 4, Select a Location, opens. 
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Figure 4.  Select a Location. 

 
4. This window displays the type of equipment and all available fill locations that the selected key can be 

assigned to.  Select a location by highlighting it and then tap on the Finish button.  The window in 
Figure 5, Eqs Tab, re-opens. 

 

Figure 5.  Eqs Tab. 
 

. As depicted above, the SINCGARS equipment has been expanded to show that fill location C1 is 

 
ND OF TASK 

ssign EP Data to an Equipment Fill Location 

have the ability to now assign Electronic Protection 

 

5
populated with Short Title ETD 39 5EG231, Edition A, and 3 keys.  Now select File→Save 
Database.  This will complete the assignment of key to a fill location on a selected piece of 
equipment.  You will follow these same steps over again to assign another key to a location. 

E
 
A
 

s part of this management capability of the SKL you A
(EP) data directly to an Equipment Fill Location.  Follow the procedure below to accomplish this 
assignment. 
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1. Select the Eqs Tab and select (highlight) the equipment or Fill Location you wish to assign EP data 

to, as depicted in Figure 6, Eqs Tab Expanded, below. 
 

Figure 6.  Eqs Tab Expanded. 
 

. In the depiction above, with TACFWD RT1 selected there are four Key Locations and three EP 
re 7, 

 
Figure 7.  Assign EP. 

3. As a result of the above selection, the lect an EP, opens. 

 

2
Locations assigned to this Equipment.  Now select File→Assign→EP as depicted below in Figu
Assign EP. 

 
 window in Figure 8, Se
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Figure 8.  Select an EP. 
 
4. Now select the Hopset that you wish to assign to the Equipment and tap on the Next>> button.  The 

window in Figure 9, Select a Location, opens. 
 

Figure 9.  Select a Location. 
 

. Now select the location on the RT1523 radio that you want the Hopset assigned to.  Once you have 
 

 

 

5
made your selection tap on the Finish button.  The window in Figure 10, Assigned Hopset, opens.  In
this depiction we have selected H6. 

0022-6 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0022 
 

 
Figure 10.  Assigned Hopset. 

 
6. You can now see that a Hopset has been assigned to Fill Location H6.  You will follow the same 

procedure to add EP data to other Hopset locations. 
 
END OF TASK 
 
Assign Message Data 
 
There is equipment in the Army inventory that uses Message Data as part of their operational capability.  
Therefore, when Message Data is received into the SKL unassigned, it must be assigned to the 
equipment that it is intended for.  In the example below, the SCAMP PSC-11 uses Message Data as part 
of its operational capability.  Follow the procedure below to assign Message Data to Equipment. 
 

Figure 11.  Plats Tab Expanded. 
 

. Expand the Plats Tab and select (highlight) the Equipment the Message Data is intended for as 
s 

 

 

1
depicted in Figure 11, Plats Tab Expanded, above.  Now select File→Assign→Message Data a
depicted below in Figure 12, File→Assign→Message Data. 
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Figure 12.  File→Assign→Message Data. 

 
. As a result of selecting Message Data, the window in Figure 13, Assign Message Data, opens. 

 
Figure 13.  Assign Message Data. 

3. From this window, select the c ext>> button.  The window in 
Figure 14, Select a Location, open

 

2
 

 
orrect Message and then tap on the N

s. 
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Figure 14.  Select a Location. 

 
4. Select the location you want the Message Data to go into and then tap on the Finish button.  The 

window in Figure 15, Plats Tab with Message Data Assigned, opens. 
 

Figure 15.  Plats Tab with Message Data Assigned. 
 

. You can now see in the window depicted above that the Message Data have been assigned to the 

 
ND OF TASK 

ssign Equipment to a Platform 

he Platform is the highest echelon in the tree structure of the SKL.  Therefore it would seem logical that 

b 

 

 

5
SCAMP PSC-11. 

E
 
A
 
T
there would be something assigned against each Platform displayed on the Plats Tab.  Use the following 
procedure to assign Equipment to a Platform.  Start by making sure you have the Plats Tab open and 
the Platform you want to assign Equipment to highlighted, as depicted below in Figure 16, Plats Ta
with Platform Highlighted. 
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Figure 16.  Plats Tab with Platform Highlighted. 
 
1. Now select File→Assign→Equipment as depicted below in Figure 17, File→Assign→Equipment. 
 

Figure 17.  File→Assign→Equipment. 
 

. As a result of selecting the above, the window in Figure 18, Assign Equipment, opens. 

 

2
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Figure 18.  Assign Equipment. 
 
3. From the list presented, select the Equipment you wish to assign to the Platform.  Then tap on the OK 

button.  The window in Figure 19, Plats Tab, opens. 
 

 
 

Figure 19.  Plats Tab. 
 
4. As depicted above another SINCGARS radio was added to the 1-M1-ABRAMS Platform. 
 
 
END OF TASK 
 
 
END OF WORK PACKAGE 
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SAVE DATABASE 
 
The Save Database function allows the operator to save changes to the original Mission Database.  
These changes can be the form of deleting items or database(s) that are no longer required to perform 
the mission of the SKL.  They can be additions to the database(s) in the form of new keys, SOI, 
Platforms, and Equipment.  Once these new items or deleted items are confirmed as being resident or not 
resident in the database the actions must be saved in order for the additions or deletions to be 
permanent.  The following short procedure will guide you through the Save Database function.  
 
1. Select File→Save Database from the Main Menu as depicted in Figure 1, File→Save Database, 

below. 
 

Figure 1.  File→Save Database. 
 

. As a result of selecting the above, the window in Figure 2, Progress, opens.   

 

2
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Figure 2.  Progress. 
 
3. Once the Mission Database has been saved the SKL returns to the tab you had open prior to saving 

the database. 
 
END OF TASK 
 
EXIT 
 
The Exit selection allows for the orderly closing of the SKL UAS.  You should never shutdown the SKL 
without first exiting the SKL UAS program.

 
Figure 3.  File→Exit. 

 
1. Select File→Exit from the Main Menu as depicted above.  The window in Figure 4, Save Database, 

opens if there has been changes to the database that were not saved previously. 
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Figure 4.  Save Database. 
 
2. If you had made changes to the Mission Database and had not saved those changes before exiting 

the SKL UAS, then you will receive the window as depicted above.  If however, you did save the 
database, then you will not get this window.  In this case we forgot to save the Mission Database and 
therefore need to tap on the Yes button.  The window in Figure 5, Core Library Desktop, opens.   

 

Figure 5.  Core Library Desktop. 
 

. From the Core Library Desktop, you can now select Session→Logout and then shutdown the SKL 

 

ND OF TASK 

ND OF WORK PACKAGE 

 

3
or you can Logon a new user and then start the SKL UAS again. 

 
E
 
 
E
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DATABASE MANAGEMENT 
 
This procedure will lead you through all the steps necessary to create a Platform, Equipment, and Key 
Tags.  It will then show you how to assign the Key Tag(s) you just created to the proper Equipment 
locations and finally assign the Equipment you created to the Platform you created.  All of these tasks are 
in the Technical Manual in various Work Packages in Chapter 2.  This procedure is designed to combine 
all of those individual procedures into one continuous procedure so that you the operator of the SKL can 
accomplish this type of Database Management with little or no effort.  To start, follow the procedures 
below to add a Platform to the Mission Database.  Start by making sure that you are on the Plats tab 
as depicted in Figure 1, Plats Tab, below.  To make this procedure clear, we are starting with no Mission 
Database in the SKL so that you can clearly see the creation of all the items that make up the Platform. 
 

Figure 1.  Plats Tab. 
 

. Now select File→Add Platform as depicted below in Figure 2, File→Add Platform. 

 

1
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Figure 2.  File→Add Platform. 

 
2. As a result of the above selection the window in Figure 3, Platform Name, opens. 
 
 

Figure 3.  Platform Name. 
 
. Fill in the Platform Name.  You must also dete r not this platform has a bussed 

 
, 

 

 

3 rmine whether o
capability.  Since the mission database is empty, you cannot select a Distribution Path, since that
comes from the ACES Workstation.  When finished, tap on the OK button.  The window in Figure 4
Plats Tab, re-opens. 
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Figure 4.  Plats Tab. 

 
4. As can be observed from the depiction above, the Platform CMD HMMV has been added to the Plats 

Tab.  There is no + sign to the left of the new platform because the CMD HMMV Platform has no 
equipment assigned to it.  Select File→Save Database.  Next we need to create Equipment. 

 
5. Make sure that the Eqs Tab is open as shown below in Figure 5, Eqs Tab. 
 

Figure 5.  Eqs Tab. 
 

. You can see that there is no equipment in the Mission Database.  Now select File→Add Equipment 

 

 

6
as shown in Figure 6, File→Add Equipment. 
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Figure 6.  File→Add Equipment. 

 
7. Once you have selected Add Equipment, the following window in Figure 7, Equipment Name, opens. 
 

Figure 7.  Equipment Name. 
 

. On this window there are some fields that need to be filled out and two drop down lists to choose 
s 

nce 

 

 

8
from.  Enter the Equipment Name, then select the type of equipment it is, and finally any Bu
Address that is affiliated with this equipment type.  The Distribution Path cannot be selected 
since there is no Mission Database.  The Distribution Path comes from the ACES Workstation.  O
this information is entered, tap on the OK button.  The window in Figure 8, Eqs Tab, opens. 
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Figure 8.  Eqs Tab. 

 
9. You can now see from the Eqs Tab that the equipment KY57-01 has been added to the Mission 

Database on the Eqs Tab.  This equipment however, is not assigned to any platform in the database 
nor does it have any Key Tag material assigned to it.  Now select File→Save Database to save the 
changes you have just made. 

 
10. From the SKL Main Menu, select File→Create Key Tags as depicted below in Figure 9.  As a result 

of this selection the window in Figure 10, Select Key Source, opens. 
 
 
 
 
 

Figure 9.  File→Create Key Tag. 
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Figure 10.  Select Key Source. 

 
11. Scroll down the list of key sources and select the one to which you want to provide the key variable.  

As depicted above, the KOK-22 is selected.  Once you have selected a key source tap on the 
Next>> button.  The window in Figure 11, Key Tag Information, opens 

 

 
 

Figure 11.  Key Tag Information. 
 
12. The Key Tag Information window is used for the entry of applicable Key Tag data.  There are three 

areas where the virtual keyboard is required.  They are the Short Title, Edition, and Segment Range 
that have been filled in as depicted above.  The CT3 Key Type, Key Use, Effective Start Date, 
Supersession Rate, and Crypto Period are drop-down menus that are used to select the appropriate 
information.  The Clear All button when tapped will clear all the information from only the Short Title 
and Edition fields.  The Template button is used to select a saved template that will populate all the 
fields with the required information.  The Copy Key Tag button when selected will allow you to copy 
Key Tag information from an existing Key Tag that is stored in your SKL.  The Key Tag field 
characteristics are defined below: 

 
a. The Short Title field has a 24-character limit. 

 
b. The Edition field has a 6-character limit. 
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c. The Segment Range fields can accommodate a range from 0-99 segments. 
 

d. The CT3 Key Type field has a drop-down menu to choose from. 
 

e. The Key Use field has a drop-down menu. 
 

f. The Effective Start Date field has a down arrow that when selected opens up a calendar to 
choose the correct date. 

 
g. The Supersession Rate field has a drop-down menu. 

 
h. The Crypto Period field has a drop-down menu. 

 
 
TIP:  If default key tag values are in the Short Title and Edition fields, delete them by using the 
backspace key. 

 
 
TIP:  To use a field setting template, select Template and choose the appropriate template name 
(if any are listed on the Template list).  This action enters the default values defined in the 
template in the Key Tag Information fields.   

 
13. Once all the correct information has been entered in this window, tap on the Next>> button.  The 

window in Figure 12, Key Tag Information 2, opens. 
 

Figure 12.  Key Tag Information 2. 
 

4. There are two informational fields called Register Number and Text ID.  Use the virtual keyboard to fill 

as 

 
a. Enter the Register Number.  This is a numeric number starting at 0 (zero). 

 
b. Select a Classification from the drop-down menu. 

 
c. Enter a Text ID.  This field has a 16-character limit. 

 

1
in the required information in these fields as depicted above.  The other field, Classification, has a 
drop-down menu from which to select the appropriate classification for the key.  This window also h
a button called “Save as Template”.  This is used to save the information you have entered in these 
windows to a template that can be used later to populate the fields in these windows when another 
Key Tag is created.  The field characteristics are defined below: 
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15. red in the Key Tag Information pages to a 

 

 
Figure 13.  Keys Tab. 

 
6. As depicted above the Keys Tab opened as a result of selecting Finish on the previous window.  As 

 

 
Figure 14.  Eqs Tab. 

17. Now we must assign this Key Tag to a n.  First tap on the Eqs Tab as depicted 
above.  Then locate the equipment that you want to assign the key to.  In the depiction above, 

 

You can now save all the information that has been ente
template or you can skip the template process and continue with the Create Key Tag process.  
Therefore, tap on the Finish button.  The window in Figure 13, Keys Tab, opens. 

1
shown the Short Title ETD 10 5AT56 is now in the Mission Database.  Now select File→Save 
Database. 

 
n equipment fill locatio

we have selected the KY-57 equipment.  Then select File→Assign→Key Tags as shown below in 
Figure 15, File→Assign→Key Tags. 
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Figure 15.  File→Assign→Key Tags. 

 
18. As a result of performing the above operation the window in Figure 16, Assign Key Tags, opens. 
 

Figure 16.  Assign Key Tags. 
 

9. Select the Short Title that will be assigned to the equipment fill location.  As depicted above, we have 

 

 

1
selected ETD 10 5AT56.  Once you have highlighted the Short Title you want, tap on the Next>> 
button.  The window in Figure 17, Select a Location, opens. 
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Figure 17.  Select a Location. 

 
20. This window displays the type of equipment and all available fill locations that the selected key can be 

assigned to.  Select a location by highlighting it and then tap on the Finish button.  The window in 
Figure 18, Eqs Tab, re-opens. 

 

Figure 18.  Eqs Tab. 
 

1. As depicted above the KY-57 equipment has been expanded to show the fill location 1, with Short 
ll 

 

 

2
Title ETD 10 5AT56 assigned to the KY-57 equipment.  Now select File→Save Database.  This wi
complete the assignment of key to a fill location on a selected piece of equipment. 
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Figure 19.  Plats Tab. 

 
22. The next step in the process is to assign the equipment we have created to the platform we created.  

Make sure you are on the Plats Tab as depicted above in Figure 19.  Plats Tab.  Now select 
File→Assign→Equipment as depicted below in Figure 20, File→Assign→Equipment. 

 

Figure 20.  File→Assign→Equipment. 
 

3. As a result of selecting the above, the window in Figure 21, Assign Equipment, opens. 

 

2
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Figure 21.  Assign Equipment. 

 
24. From the list presented, select the Equipment you wish to assign to the Platform.  Then tap on 

the OK button.  The window in Figure 22, Plats Tab, opens. 
 

Figure 22.  Plats Tab. 
 

5. As depicted above the KY-57 was added to the CDR HMMV Platform.  The Platform has been 
, 

s, 

 
6. There are other aspects of Database Management such as Unassigning Equipment from Platforms 

 
ND OF TASK 

END OF WORK PACKAGE 

 

2
expanded out to show all the elements of the Platform (i.e., Equipment, Fill Location, Short Title
Edition, and Segment).  You still do not have the actual key for this Fill Location.  You must now 
perform a Key Needed operation or Receive Key operation and assign the actual key to the Fill 
Location noted above.  This concludes the Database Management procedure of adding Platform
Equipment, and Key Tags and then assigning the Key Tags to the Equipment Fill Locations, and 
finally assigning the Equipment to the Platform.   

2
and Unassigning Key Tags from Equipment.  Also you can assign EP Data to specific Fill Locations 
on certain equipment.  You may also edit Platforms, Equipment, and Key Tags.  All of these other 
Database Management functions are listed in Chapter 2 of this TM. 

E
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VIEW MENU 
 INTRODUCTION 
 
 
VIEW MENU 
 
1. Select View by tapping once on View on the SKL UAS Desktop with the Inductive Stylus.  The 

window in Figure 1, SKL UAS View Menu, opens.  Also shown are the Keys and SOI submenus in 
Figure 2 and Figure 3. 

 

 
 

Figure 1.  SKL UAS View Menu. Figure 2.  View→Keys Menu 
 

Figure 3.  View→SOI Menu. 
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2. An explanation of each of the View menu’s selections is presented in Table 1, SKL UAS View Menu 

 
Table 1.  SKL UAS Vi  Menu Description. 

 
View Menu Option Description 

Description. 

ew

Find This function only search ible in the tree. es for text vis
  

Current Selection This function displays additional information for Platforms, 
 Equipment, Key Edition and Segment information, and SOI

Net and Time Period information. 
  

File Header This function displays a split screen showing File information 
in the top frame and encrypted Keys assigned in the bottom 
frame.  File Header information contains the information on 
the receiving device specific directory, filename, and file 
extension for the originating file. 

  
Keys This function allows the user to eral different types of  view sev

keys and also provides a matching function. 
  
 Expired Keys his function provides a quick access to view and delete T

expired keys. 
  
 Matching Keys he Matching Keys selection is designed to allow the operator T

to discover any Keys Tags within the Mission Database that 
are identical. 

  
 Modern Keys his function provides the user with the means to view any T

Modern keys in the database. 
  
 TrKEKs his function allows the user to view and delete TrKEKs that T

have been issued to the SKL. 
  
 Benign Fill his Function provides the means to view any Benign key that T

is in the database. 
  
SOI his function allows the user to view the Signal Operating T

Instructions (SOI). 
  
 All Net Names his function is used to view a list of all net names stored in T

the SKL SOI database. 
  

 Filter on Time Period his function is used to view a single time period when the T
desired time period is selected. 
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Table 1.  SKL UAS View Menu Description.  (continued) 
 

View Menu Option Description 

 Select SOI Edition This function permits only one edition to be viewed from the 
SOI tree at a time.  Use Select SOI Edition to select the SOI 
edition to be viewed.  The selected edition controls SOI data 
displayed for Group, Expander/Suffix, Time Period, Net, 
Smoke/Pyrotechnics, and Sign/Countersign data. 

  

 Suffix/Expander This function allows the user to select a single Time Period 
and to view either Suffixes or Expanders. 

  

Host Configuration Registers ctor Use Only For Contra

  

Summary Status This window provides the SKL Version, SKL Database 
cation 

s 

Version, Highest SOI classification, Highest Key classifi
loaded in the SKL.  It also shows the amount of Free Audit 
Space divided into 4 different categories of information.  Thi
window also shows running totals for items loaded into the 
database.   

  

KLS This function allows the user to view the status of a key load 
to an ECU. 

  
Move Up The function allows the user to scroll up the tree view 

structure. 

  

Move Down ction allows the user to scroll down the tree view The fun
structure. 

  

Refresh This function allows the user to refresh the display. 

  

Expand Tree ction allows the user to expand out all the child nodes This fun
under a selected tree node. 

  

Tree This function allows the user to select any one of the 4 trees. 
 
 
END OF WORK PACKAGE 
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VIEW MENU 
 FIND 
 CURRENT SELECTION 
 FILE HEADER 
 
 
FIND 
 
The Find function allows the user to locate and view selected Mission Database items without selecting 
the Main Menu Tabs or expanding the Menu Trees.  Under the Find selection the user can search for 
Platform, Equipment, Key, and SOI Mission Database information.  If searching for SOI information, the 
specific SOI edition must be selected prior to using the Find function.  Use the following procedure to find 
and view selected Mission Database items. 
 

Figure 1.  View→Find. 
 

. Select View→Find as depicted above.  The window in Figure 2, Find, opens. 

 

1
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Figure 2.  Find. 

 
2. The Find window has two tabs.  They are Find and Results.  The Find tab allows the user to search 

for specific Mission Database items, and the Results tab displays the Mission Database information 
or attributes that were found during the search.  Tap on the Down Arrow in the Search Category field 
and the window in Figure 3, Search Category Selection Menu, opens.  

 

Figure 3.  Search Category Selection Menu. 
 

. The SKL Operator can select a category and then search for a specific Mission Database item 
  

 

 

3
associated with the selected category.  As depicted above, the SOI Suffix category was selected.
Once the category is selected, the window in Figure 4, Find, opens. 
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Figure 4.  Find. 

 
4. In the Name field using the virtual keyboard, type the name of the SOI Suffix you want the search 

function to find.  Make sure that there is a Checkmark ( ) in the "Match Whole Word Only" field.  
Whole Word means that it will search on the entire word that is inserted into the Name field, not just 
part of it.  Then tap on the Find button.  The SKL will search the category for the specific item listed in 
the sub-fields and display them under the Results Tab as shown in Figure 5, Results Tab, below.  

 

Figure 5.  Results Tab. 
 

. As depicted above the Results tab displays all time periods and suffix numbers for the name NCS.  

 
ND OF TASK 

URRENT SELECTION 

he Current Selection option under the View Menu provides the user with additional information about a 

teps 

selected as shown in Figure 6, Plats Tab. 

 

5
To search for other items tap on the Find tab, or tap on the Cancel button to exit the Find function. 

E
 
C
 
T
platform, equipment, or key.  This selection can be very useful if the operator needs to know all the 
specific information about an item in the Mission Database.  The following procedure describes the s
necessary to view this information.  In the example below, the SKL UAS is open with the Plats tab 
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1. Highlight a platform as shown above a menu select View→Current Selection.  
The Platform window will open as shown in Figure 7, Platform. 

 

2. The additional information for the chos d in this window.  There are three areas 
of information.  They are Platform Name, ether or not the platform is on a 

 

Figure 6.  Plats Tab. 
 

nd then from the main 

 

Figure 7.  Platform. 
 

en Platform is displaye
 Distribution Path, and wh

buss or not.  When through viewing the information, tap the Inductive Stylus on Close button.  The 
SKL UAS Main Window returns as shown in Figure 8, Plats Tab. 
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Figure 8.  Plats Tab. 

 
3. Select the Eqs tab.  A window similar to the one in Figure 9, Eqs Tab, opens. 
 

Figure 9.  Eqs Tab. 
 
. Highlight the piece of equipment that you wish to view.  Once the equipment is highlighted, select 

 

 

4
View→Current Selection from the Main Menu.  A window similar to the one in Figure 10, Equipment 
Name, opens. 
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Figure 10.  Equipment Name. 

 
5. This window will provide the Equipment Name, Equipment Type, Distribution Path, and the Bus 

Address.  When finished viewing the information tap on the Close button.  The window in Figure 11, 
Eqs Tab, opens. 

 

Figure 11.  Eqs Tab. 
 

. Select the Keys tab.  A window similar to the one in Figure 12, Keys Tab, opens. 

 

6
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Figure 12.  Keys Tab. 

 
7. Highlight the Edition of the Short Title you wish to examine by tapping on the + sign next to the Short 

Title as shown in Figure 12 above.  In the case above, Edition M of USKATA00001268 is highlighted.  
When viewing the information about the Edition of a key, it depends on whether or not the key has 
been received or there is just a segment present.  Then select View→Current Selection from the 
Main Menu.  The window Figure 13, Edition Info, Key Source Open, is displayed. 

 

  
Figure 13.  Edition Info, Key Source Open. Figure 14.  Edition Info, Key Source Closed. 

 
8. The fields in these windows are Edition Info and Key Source.  The Key Source has a drop-down 

window that will allow the operator to select something other than the KOK-22 Key Processor (KP) as 
a key source for this segment if the key has not been received into the SKL.  If the operator changes 
the Key Source for the segment, the OK button must be selected to save the new Key Source.  In 
Figure 14 you can see that the Key Source is grayed out and cannot be changed.  This means that 
the key has already been received into the SKL.  Tap on the OK button to save the selection if you 
have changed the key source and return to the Keys Tab as shown in Figure 15, Keys Tab. 
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Figure 15.  Keys Tab. 

 
9. Now tap on the + sign next to the Edition to view the Segments.  The window in Figure 16, Keys Tab - 

Segments, opens. 

 
Figure 16.  Keys Tab - Segments. 

 
0. If the Segment is not highlighted, highli ent highlighted, select 

 

1 ght it with the stylus.  With the segm
View→Current Selection.  The window in Figure 17, Segment Info 1, opens. 
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Figure 17.  Segment Info 1. 
 
11. Looking at the Segment Info 1 window, there are several fields of information.  These include the 

Short Title, Edition, Segment Number, Key Use, CT3 Key Type, Key Source, Effective Date, 
Expiration Date, and Classification.  Of these, the only field that is changeable is the Key Source.  
However, this field can only be changed if the actual key for this short title has not been received into 
the SKL.  Once the Key is received the Key Source field cannot be changed.  Tap the Next>> button 
with the Inductive Stylus.  The window in Figure 18, Segment Info 2, opens. 

 

Figure 18.  Segment Info 2. 
 

2. The Segment Info 2 window provides additional information on the key.  This information includes the 

nt Info 1 

 

 

1
Register Number, Text ID, Designator, Suffix, Data Type, and Decrypt Location.  All of this 
information is fixed and cannot be changed.  You may select <<Back to return to the Segme
window or in the case of this example, tap the Close button to exit the window.  The window in 
Figure 19, Keys Tab – Segments, opens. 
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Figurer 19.  Keys Tab – Segments. 

 
END OF TASK 
 
FILE HEADER 
 
File Headers contains a Key or group of Keys that are contained in an individual file that was received 
into the SKL from the LCMS Workstation (KOK-22).  In the LCMS Workstation, File Headers can only be 
transmitted to Elements such as organizations that have a SKL, DTD, or another LCMS Workstation.  
 
1. To view File Headers, select View→File Header as shown in Figure 20, View→File Header, below. 
 

 
Figure 20.  View→File Header. 

 
2. As a result of selecting View→File Header, the window in Figure 21, File Header, opens. 
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Figure 21.  File Header. 

 
3. This window has two parts to it.  The top part lists the file name of the File Header.  In this case it is 

1BDE04.TNG.  The bottom part of the window lists all the key(s) that are contained in the file.  In this 
case there are multiple keys associated with this File Header.  If you have a need to delete a File 
Header, all the key(s) must first be deleted before the File Header can be removed.  To do this, follow 
the procedures in Work Package 0009.  Once you are finished viewing the File Header and its 
contents, tap on the Close button.  The SKL UAS Desktop returns.  

 
END OF TASK 
 
 
END OF WORK PACKAGE 
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
 
VIEW MENU 
 KEYS 
 
 
KEYS 
 
The Keys selection under the View Menu has five (5) sub-selections.  They are Expired Keys, Matching 
Keys, Modern Keys, TrKEKs (Transmission Key Encryption Keys), and Benign Fill.  In the following 
paragraphs each of these selections will be explained. 
 
Expired Keys 
 
To assist in keeping the SKL Mission Database free of unnecessary data the SKL includes some 
housekeeping functions.  One of the functions allows the operator to view and delete expired keys from 
the database.  Each of the keys to be deleted must be viewed to confirm that the Key Tag needs to be 
removed from the database. 
 
1. To start the process, you can be on any tab.  Then select View→Keys→Expired Keys as depicted in 

Figure 1, View→Keys→Expired Keys, below. 
 

 
 

Figure 1.  View→Keys→Expired Keys. 
 
2. As a result of the above selection the window in Figure 2, Expired Keys, opens.  
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Figure 2.  Expired Keys. 

 
3. If there are any expired keys in the SKL Mission Database, they will be displayed in the window 

above.  The window displays the expired key tags with or without key material.  Use the scroll bar at 
the bottom of the window to view the Short Title, Edition, Text ID, Segment Number, and Expiration 
Date.  From this information you can determine the need to delete any Short Title shown in the list.  
To delete a Short Title(s) put a Checkmark ( ) in the box to the left of the Short Title to be deleted 
and then tap on the Delete button or you may elect to delete all the expired keys in which case you 
would tap on the Delete All button.  In the example, the Delete All button was selected.  The window 
in Figure 3, Delete Selected Segments Confirmation, opens. 

 

Figure 3.  Delete Selected Segments Confirmation. 
 

. This window gives you one last chance to verify the need to delete the selected Segment(s)/keys.  If 

 

 

4
you want to continue with the deletion, tap the Yes button with the Inductive Stylus.  If you want to 
cancel the deletion tap on the No button.  If yes was selected, the Segment(s) and keys will be 
deleted.  The window in Figure 4, Selected Expired Key(s) Deleted, opens. 
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Figure 4.  Selected Expired Key(s) Deleted. 

  
5. Tap on the OK button in the upper right-hand corner of the window.  The window in Figure 5, Expired 

Keys, opens 
 

Figure 5.  Expired Keys. 
 

. You can now browse the Keys tab and you will find there are no more expired keys present in your 
 

 

 

6
database.  Now tap on the Close button.  The tab you had opened when you started this procedure
returns. 
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Figure 6.  Keys Tab. 

 
7. As depicted above there are no more expired keys shown on the Keys Tab.  Now select File→Save 

Database.  This will ensure that they are permanently removed from the Mission Database. 
 
END OF TASK 
 
Matching Keys 
 
The Matching Keys procedure under the Keys menu is designed to allow the operator to discover any 
keys within the Mission Database that are identical.  This does not mean Key Tag data; it is the actual key 
itself.  The possibility could exist that you can have the same identical key in the Mission Database under 
two or more Short Titles.  Use the following procedure to discover if the SKL Mission Database has any 
Matching Keys. 
 
1. Select the Keys tab and expand it until the key you want to check a match on is highlighted as 

depicted below in Figure 7, Keys Tab Expanded. 
 

Figure 7.  Keys Tab Expanded. 
 

. Once you have the key highlighted, select View→Keys→Matching Keys as depicted below in 
Figure 8, View→Keys→Matching Keys. 

 

2
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Figure 8.  View→Keys→Matching Keys. 
 
3. Once you have made the a hing Keys, opens. 

 

4. As depicted above there are three e same key.  It is not a good practice 
to have the same key associated with se.  First, you must 

 
END

Modern keys function allows the operator to identify all the Modern Key(s) that are in the 
erator to delete any Modern key(s) not required for any current or 

se unique keys, from the SKL UAS main menu select View→Keys→Modern Keys as 
shown in Figure 10 below. 

bove selection the window in Figure 9, Matc

Figure 9.  Matching Keys. 
 

other Short Titles that have th
multiple Short Titles in your databa

determine which Short Title is required to have this key.  Once that determination is made then you 
should delete the other Short Titles by either choosing Delete or Delete All.  Once you are finished, 
select File→Save Database. 

 OF TASK 
 
Modern Keys 
 
The viewing of 

ission Database.  It also allows the opM
future mission. 
 
1. To view the
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Figure 10.  View→Keys→Modern Keys. 

2. As a result of the above sel s opens. 
 

ection, the window in Figure 11, Modern Key
 

 
 

Figure 11.  Modern Keys. 

3. This window will provide you with a odern Keys you have in the 
database.  You may determine that a Modern key needs to be deleted from the database because it 

en tap 

 
END

gives the operator the ability to view or delete a filled TrKEK that has been deemed unusable.  
o view a filled TrKEK follow the procedure below. 

 in Figure 12, View→Keys→TrKEK. 

 
ll the information about the M

is no longer required.  To accomplish this, put a Checkmark ( ) to the left of the KMID and th
on the Delete button.  When through viewing the keys tap on the Close button.  The SKL UAS 
Desktop returns. 

 OF TASK 
 
TrKEKs 
 
The SKL 
T
 
1. Select View→Keys→TrKEK as depicted below
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Figure 12.  View→Keys→TrK
 
2. As a result of the above action, ens. 

 

. From this window you can view the attributes of the TrKEK to include the Short Title, Edition, Text ID, 
Segment Number, and Expiration Dat the SKL UAS Desktop and the tab you 
had open when you started this procedure.  Now select File→Save Database. 

END
 

enign Fill 

BD 

ND OF TASK 

 PACKAGE 

EK. 

 the window in Figure 13, TrKEKs, op
 

Figure 13.  TrKEKs. 
 
3

e.  The SKL returns to 

 
 OF TASK 

B
 
T
 
E
 
 
END OF WORK
 

0027-8 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0028 
 

OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

SKL UAS SOI, SUMMARY STATUS, KEY LOAD STATUS, AND REMAINING VIEW MENU 
FUNCTIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
 
 
 
 
 

0028-1 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0028 
 

OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
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VIEW MENU 
 SIGNAL OPERATING INSTRUCTIONS (SOI) 
 SUMMARY STATUS 
 KEY LOAD STATUS 
 MOVE UP 
 MOVE DOWN 
 REFRESH 
 EXPAND TREE 
 TREE 
 
 
SOI 
 
The SOI function under the View Menu allows the operator several different options when it comes to 
Signal Operating Instructions.  The SOI selection has four (4) submenus from which to choose.  They are:  
All Net Names, Filter on Time Period, Select SOI Edition, and Suffix/Expander.  Normally the submenus 
would be discussed in order from top to bottom.  However, before the SOI selection can utilized, the 
Edition of SOI must first be selected.  Therefore, the first submenu item that will be discussed will be 
Select SOI Edition. 
 
Select SOI Edition 
 
To view SOI information, the SOI Edition must first be activated.  If an SOI Edition is not activated the SOI 
will not be available for viewing.  Most of the time there will be only one SOI Edition in the SKL.  However 
there could be multiple SOI Editions loaded into SKLs located at higher echelon command levels.  If you 
select the SOI Tab, and see an Edition, that means that the Edition shown is active.  To use any of the 
selections under the SOI heading the SOI tab must be open as shown in Figure 1, SOI Tab, below. 

 
Figure 1.  SOI Tab. 
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1. From the SKL UAS Main Menu, select View→SOI→Select SOI Edition as depicted below in 

Figure 2, View→SOI→Select SOI Edition. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 2.  View→SOI→Select SOI Edition. 
 
2. As a result of the above action, the window in Figure 3, Edition, opens. 
 

Figure 3.  Edition. 
 

. This Edition window has several elements.  In the top white box are listed two file names.  The first 

ure 4, 

 

 

3
file name A 001005.SOI, contains all the SOI information for the selected Edition for time periods 1-5.  
The second file name A 006010.SOI, contains all the SOI information for the selected Edition for time 
periods 6-10.  The Edition Information area of the window contains the File Name selected, the 
Edition, Classification, and the number of time periods covered by the file.  To activate the SOI 
Edition, highlight the file you want to activate and then tap on the OK button.  The window in Fig
SOI Tab, opens. 
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Figure 4.  SOI Tab. 
 
4. The SOI tree should be ordered as displayed in the figure above; Edition, Group, Pyro, Smoke, and 

Quick Reference.  When Group is selected it should contain all the net groups resident in the SOI.  
There can be multiple net groups in the SOI.  To see the net groups under the Group heading, tap on 
the + sign to the left of the Group.  The window in Figure 5, SOI Group Expanded, opens. 

 

Figure 5.  SOI Group Expanded. 
 

. As depicted above, the Group has been expanded and there are three SOI groups available for 
en 

 
ND OF TASK 

ll Net Names 

he All Net Names option under the SOI selection will allow you to view the net names under a selected 

. With the SOI tab open, select a Net Group as depicted in Figure 6, Net Group Selected, below. 

 

5
viewing.  They are 1-12th INF-STD, 1BDE-STD, and 285th AR-STD.  Now that the Edition has be
activated, the other options under the SOI selection can be utilized. 

E
 
A
 
T
SOI group. 
 
1
 

0028-4 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0028 
 

 
Figure 6.  Net Group Selected. 

 
. With your net group now highlighted, select View→SOI→All Net Names as depicted below in 

 

 
Figure 7.  View→SOI→All Net Names. 

3. As a result of selecting the a s. 

2
Figure 7, View→SOI→All Net Names. 

 
bove the window in Figure 8, Group, open
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Figure 8.  Group. 
 
4. This window displays all the nets assigned under the 285th AR net group.  Now select the desired net 

from the list.  Tap the Show Net button.  The window in Figure 9, Net Info, opens. 
 

 
Figure 9.  Net Info. 

 
5. This window provides all the information about the net.  To add the net to the Quick Reference 

Folder, simply put a Checkmark ( ) in the box to the left of “Add to Quick Reference” and tap the OK 
button.  The window in Figure 10, Group, re-opens. 
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Figure 10.  Group. 
 
6. Tap on the Close button.  The window in Figure 11, SOI Tab, reopens. 
 

Figure 11.  SOI Tab. 
 

ND OF TASK 

ilter on a Time Period 

he Filter on Time Period function allows the operator of the SKL to filter out Time Periods in a SOI that 

 

E
 
F
 
T
are not required for current viewing. 
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Figure 12.  SOI Group Expanded. 

 
1. Select the Time Period you want to filter from the SOI Tab as depicted in Figure 12, SOI Group 

Expanded, above.  Then select View→SOI→Filter on Time Period from the SKL UAS Main Menu as 
shown below in Figure 13, Filter on Time Period. 

 

Figure 13.  Filter on Time Period. 
 

. As a result of selecting Filter on Time Period, the window in Figure 14, Time Period Filtered, opens. 

 

2
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Figure 14.  Time Period Filtered. 

 
3. Notice that the Time Periods under the 285th AR net group have been reduced to the first Time 

Period.  To remove the filter, highlight the Group and then select Settings→Show All from the SKL 
UAS Main Menu.  The window in Figure 15, SOI Groups Expanded, opens. 

 

Figure 15.  SOI Groups Expanded. 
 

. You can now see that the filter has been removed and the other Time Periods are displayed. 

ND OF TASK 

uffix/Expander 

iewing Suffix and Expanders can be accomplished several different ways.  The first way is to expand the 

 

4
 
E
 
S
 
V
SOI Group and select a Time Period and then use the View→Current Selection option.  The other way is 
to select the Time Period as depicted in Figure 15 above.  Then select View→SOI→Suffix/Expander 
from the Main Menu as depicted below in Figure 16, View→SOI→Suffix/Expander, opens. 
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Figure 16.  View→SOI→Suffix/Expander. 

 
1. As a result of the above action the window in Figure 17, Suffix/Expander, opens. 
 

Figure 17.  Suffix/Expander. 
 

. This window allows you to view both the Suffixes and Expanders for each of the 5 Time Periods.  To 
 

 

 

2
view the Expanders tap the radio button to the left of Expander.  To view the Suffixes/Expanders for a
different Time Period tap on the Down Arrow and select the Time Period you wish to view.  When 
finished viewing the Suffixes/Expanders tap on the Close button.  The window in Figure 18, SOI 
Groups Expanded, returns. 
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Figure 18.  SOI Groups Expanded. 

 
END OF TASK 
 
Adding Nets to the Quick Reference 
 
Adding nets that you frequently require information on to your Quick Reference in the SOI is a good way 
of managing those nets.  The following procedure will show you how to add a net to the Quick Reference 
folder. 
 
1. With the SOI tab open, select a Net Group as depicted in Figure 19, Net Group Selected, below. 
 

Figure 19.  Net Group Selected. 
 

. With your net group now highlighted, select View→SOI→All Net Names as depicted below in 

 

 

2
Figure 20, View→SOI→All Net Names. 
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Figure 20.  View→SOI→All Net Names. 

 
3. As a result of selecting the above the window in Figure 21, Group, opens. 
 

Figure 21.  Group. 
 

. This window displays all the nets assigned under the 285th AR net group.  Now select the desired net 

 

 

4
from the list.  Tap the Show Net button.  The window in Figure 22, Net Info, opens. 
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Figure 22.  Net Info. 
 
5. This window provides all the information about the net.  To add the net to the Quick Reference 

Folder, put a Checkmark ( ) in the box to the left of “Add to Quick Reference” and tap the OK button.  
The window in Figure 23, Group re-opens. 

 

Figure 23.  Group. 
 

. Tap on the Close button.  The window in Figure 24, SOI Tab, reopens. 

 

6
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Figure 24.  SOI Tab. 
 
7. There is now a + sign to the left of the Quick Reference folder indicating that the Quick Reference 

folder has an entry.  Tap the + sign to the left of 285th AR net group to expand the folder.  The 
window in Figure 25, 285th AR Net Group Expanded, opens. 

 

Figure 25.  285th AR Net Group Expanded. 
 

. Now tap on the + sign to the left of Time Period 1.  The window in Figure 26, Time Period 1 

 

 

8
Expanded, opens. 
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Figure 26.  Time Period 1 Expanded. 

 
9. You will notice in the window above, that the net 3/B/285 has an asterisk (*) next to it.  This indicates 

that the net also appears under the Quick Reference folder.  Tap on the + sign to the left of the Quick 
Reference folder to expand it.  Then continue to expand until the Nets are displayed.  The window in 
Figure 27, Quick Reference Expanded, opens. 

 

Figure 27.  Quick Reference Expanded. 
 

0. As depicted above the 285th AR net group for Time Period 1 has been added to the Quick Reference 

 
ND OF TASK 

OI Pyro Selection 

he Pyro selections under the SOI tab are locked in and cannot be changed.  The designations of each of 

OI. 

. To view the Pyro information, make sure that you are on the SOI tab as shown in Figure 28, SOI Tab, 
below. 

 

1
folder.  Now you can easily retrieve information for this net for the first time period.  To add additional 
nets to the Quick Reference folder just follow the steps 1-6 above. 

E
 
S
 
T
the pyrotechnics listed are created in the ACES Workstation based on information received from the 
G3/S3.  Use the following procedures to view the meanings of each of the pyrotechnics listed in the S
 
1
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2. Click on the + sign to the left of Pyro to ons as shown in Figure 29, Pyro 
Selections, below. 

 

. To see what a particular Pyro selection means, highlight any of the selections available and then 
select View→Current Selection. /Smoke Info, opens.    

Figure 28.  SOI Tab. 
 

 open the Pyro selecti

 

Figure 29.  Pyro Selections. 
 
3

  The window in Figure 30, Pyro
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Figure 30.  Pyro/Smoke Info. 

 
4. As depicted above the meaning of the Green Star Parachute is listed.  After you have reviewed the 

meaning of the Pyro selection, tap on the OK button.  The SOI Tab reopens. 
 
END OF TASK 
 
SOI Smoke Selection 
 
The Smoke selections under the SOI tab are locked in and cannot be changed.  The designations of each 
of the Smoke Signals listed are created in the ACES Workstation based on information received from the 
G3/S3.  Use the following procedures to view the meanings of each of the Smoke Signals listed in the 
SOI. 
 
1. To view the Smoke Signal information, make sure that you are on the SOI tab as shown in Figure 31, 

SOI Tab, below. 
 

Figure 31.  SOI Tab. 
 

. Click on the + sign to the left of Smoke to open the Smoke signal selections as shown in Figure 32, 

 

 

2
Smoke Signal Selections, below. 
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Figure 32.  Smoke Signal Selections. 

 
. To see what a particular Smoke Signal selection means, highlight any of the selections available and 

 

 
Figure 33.  Pyro/Smoke Info. 

4. As depicted above the meaning o ter you have reviewed the meaning 
of the Smoke Signal selection, tap on the OK button.  The SOI Tab reopens. 

END

RATION REGISTERS 

or for configuration and troubleshooting purposes.  The SKL 

mary Status window is to provide a detailed synopsis of the contents and 
lassification of the SKL mission database in one location for easy viewing.  It will also provide the user 

with the status of the Audit Trail such as how much of the space has been used and how much is left. 

3
then select View→Current Selection.  The window in Figure 33, Pyro/Smoke Info, opens.    

 
f the Green Smoke is listed.  Af

 
 OF TASK 

 
HOST CONFIGU
 
This function is only used by the contract

perator will have no access to this function. o
 
SUMMARY STATUS 
 
The purpose of the Sum
c
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1. To look at the Summary Status, select View→Summary Status from the SKL Main Menu as 

depicted in Figure 34, View→Summary Status. 

 
 Status. 

 
. As a result of the above action the window in Figure 35, Summary Status, opens. 

 

Figure 34.  View→Summary

2

 
 

Figure 35.  Summary Status. 
 
. The Summary Status window allows a user to view the following information:  SKL Version, SKL 

Database Version, Highest SOI C lassification.  It will show the Audit 
Free Space in the SKL in four (4) different categories.  It also will display the number of Platforms, 

K, 
, 

gh 
ary 

 
END OF TASK 

3
lassification, and Highest Key C

Equipment, Segments, Message Data, Keys (i.e., N/A, FireFly, KEK, KPK, MSK, QKEK, TEK, TS
TrKEK, IKEK, Seed, ICOM TSK, Non-ICOM TSK, WOD, MWOD, Training WOD, Thorton OTAR KEK
Thorton KEK Paper Tape, DTD GOE-2 TEK, DTD GOE-2 KEK, Usable GOE-2 TEK, and Usable 
GOE-2 KEK), Keys Needed, Keys Expired, Electronic Protection, File Headers, Benign Fill 
Messages, and Mission Dates.  Use the scroll bar on the right side of the window to move up or down 
the window and the scroll bar at the bottom to move left to right in the window.  Once you are throu
viewing the information, tap on the Close button with the Inductive Stylus to close the Summ
Status window. 
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KEY
 

he Key Load Status (KLS) function on the SKL allows the operator to view the status of a COMSEC key 
 End Cryptographic Unit (ECU) such as the AN/PSC-5.  The U.S. Army will only use this 

Therefore it will not be explained in detail in this TM. 

 

N 

e. 

. 

EE 

pen to it fullest 
iew. 

REE 

enu selection will allow the SKL operator to select the tree that needs to be open.  This function is 
sed in conjunction with the Navigation/Control Panel to move from tree to tree. 

 LOAD STATUS (KLS) 

T
load to a special
procedure very infrequently.  
 
MOVE UP 
 
This menu selection will allow the SKL operator to scroll up the tree view structure.
 
MOVE DOW
 
This menu selection will allow the SKL operator to scroll down the tree view structur
 
REFRESH 
 
This menu selection will allow the SKL operator to refresh the tab that is currently open
 
EXPAND TR
 
This menu selection will allow the SKL operator to expand the tab tress that is currently o
v
 
T
 
This m
u
 
 
END OF WORK PACKAGE 
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OPERATOR MAINTENANCE 
OPERATION UNDER USUAL CONDITIONS 

FOR 
TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 

SIMPLE KEY LOADER (SKL) 
SKL UAS VERSION 4.0 

 
 
SETTINGS MENU 
 DATE LOAD 
 OPTIONS 
 FILTER 
 SHOW ALL 
 FONT 
RECEIVE AND LOAD ICONS 
 
 
SETTINGS MENU 
 
1. Select Settings by tapping once on Settings on the SKL UAS Desktop with the Inductive Stylus.  The 

window in Figure 1, SKL UAS Settings Menu, opens. 
 

Figure 1.  SKL UAS Settings Menu. 
 

. An explanation of each of the Settings menu’s selections is presented in Table 1, SKL UAS Settings 

 

 

2
Menu Description. 
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Table 1.  SKL UAS Settings Menu Description. 
 

Settings Menu Option Description 
Date Load This Function sets the date range limits for the Key and/or 

Key Tags to be displayed in the trees. 
  

Options The Options window has six (6) different tabs on it that allow 
the operator of the SKL to preset display options, create 
unique messages for the ARC-210, define how the equipment 
profiles are displayed, define either the Short Title, Edition, or 
Segment for editing when receiving keys, setup how the trees 
will be displayed, and finally when to issue empty File 
Headers. 
 
Each of these areas will be explained in detail in the following 
pages. 
 

  
Filter By default all Platforms, Equipment, and SOI information is 

displayed when each of the tabs are opened.  The purpose of 
the Filter function is to limit what you want to see on each tab. 

  
Show All Turns off any filters that may have been previously applied.  

This action allows all database items to be displayed in the 
respective tabs. 

  
Font Allows the user to customize the font, size, color, bold, and 

italics options. 
 
Date Load 
 
The Date Load function allows the operator of the SKL to load selected keys by filtering the key 
segment's effective and expiration dates.  This filtering gives the communications planner or COMSEC 
Custodian the choice of having multiple key segments in the SKL and insuring that the operator will only 
download keys that are effective during a specific system date or a manually chosen date.  There are two 
ways that the filter can be enabled.  The first is to filter keys everyday by the use of the system date.  The 
second method is to manually set start and end dates of the key segment's effective and expiration dates.  
When the Date Load function is enabled, keys that have an effective and expiration date outside of the 
system date or the manually selected date range cannot be viewed nor can they be downloaded to an 
ECU. 
 
Before you commence the Date Load function, you need to view the effective and expiration dates of all 
key segments that are to be filtered.  Use the following procedure to view the key segments. 
 
1. Highlight the key segment as depicted in Figure 2, Plats Tab Expanded, below. 
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Figure 2.  Plats Tab Expanded. 

 
2. With the segment highlighted, select View→Current Selection from the SKL Main Menu.  The 

window in Figure 3, Segment Info 1, opens. 
 

Figure 3.  Segment Info 1. 
 

. As depicted above the effective and expiration dates of the segment can be seen.  Do steps a-c for 
it 

s. 
 

ND OF TASK 

sing the System Date to Apply the Date Load Filter.  The system date can be used to filter key 
e 

 

 

3
each segment that you wish to filter.  Write down the information for each segment so that you have 
available to you when you start the filtering process.  Once you have viewed and collected the 
information on the last segment you wish to filter, tap on the Close button.  The Plats Tab return

E
 
U
segments on a daily basis.  When the "Always use system date" is selected, the only keys that can b
viewed and downloaded are keys in which the effective date and the expiration date includes the system
date.  If the system date is not within this range then the key is filtered.  Use the following procedure to 
apply a Date Load filter using the system date.   
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NOTE 
 

If there is no Checkmark ( ) next to the Data Load menu item, it means that the 

 

 
Figure 4.  Settings→Date Load. 

1. As a result of selecting Settings ow in Figure 5, Date Load 
Filter, opens. 

 

. The default for this window is to have a Checkmark ( ) in the box next to “Always use system date”.  
You will notice the Start Load Date rayed out.  The “Always use system 
date” will use the System (Host) date to filter the keys.  Tap on the OK button to close the window.  

 

Date Load Filter is not active. 

 
→Date Load from the Main Menu the wind

 

Figure 5.  Date Load Filter. 
 
2

 and the End Load Date are g

The Figure 6, Plats Tab Expanded, opens. 
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Figure 6.  Plats Tab Expanded. 

 
3. The Key Tags in this example; KAAA and T000 are displayed because the System (Host) date falls 

between the Effective and Expiration dates of the Key Tag. 
 
END OF TASK 
 
Using a Fixed Start and End Date to Apply the Date Load Filter.  Date Load filtering using a start and 
end date will only display key segments and allow the operator to load key segments when the start and 
end calendar date crosses over or falls between the key segment effective and expiration dates.   
 
1. Select Setting→Date Load from the Main Menu.  The window in Figure 7, Date Load Filter, opens. 
 

Figure 7.  Date Load Filter. 
 

. The Date Load Filter window default te".  Use the Stylus to tap on the 
nd 

 

2 s to "Always use system da
Checkmark ( ) to remove it.  Then tap on the Down Arrow in both date fields and select a start a
end date.  The window in Figure 8, Date Load Filter Start and End Dates, opens. 
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Figure 8.  Date Load Filter Start and End Dates. 

 
3. As depicted above the Start Date is 7 February 2006 and the End Date is 14 February 2006.  Now 

tap on the OK button.  The window in Figure 9, Plats Tab Expanded, opens. 
 

Figure 9.  Plats Tab Expanded. 
 

. The Plats Tab now shows only two key segments that fit the filtering criteria of 7 February 2006 and 

 
. Another scenario that could happen when using Start and End dates is something called crossover.  

 

 

4
14 February 2006.  They are KAAA a three month KEK and T000 a one month TEK. 

5
Select Settings→Date Load.  The Figure 10, Date Load Filter Crossover, is depicted below. 
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Figure 10.  Date Load Filter Crossover. 

 
6. As depicted above the Start date is 24 January 2006 and the End date is 14 February 2006.  Now the 

filtering criterion has changed.  Once the dates have been established, click on the OK button.  When 
the Start and End dates cross the key segments' Effective or Expiration dates, multiple key segments 
can be displayed.  As depicted below in Figure 11, Plats Tab Expanded, not only is KAAA KEK 
displayed but also two TEKs (T000-6 and T000-7) are displayed because the Start or End date fall 
between the key segments' Effective and Expiration dates, or the key segments' Effective and/or 
Expiration dates falls between the Date Load Filters Start and End dates. 

 

Figure 11.  Plats Tab Expanded. 
 

ND OF TASK 

isable the Date Load Filter.  If you want to disable the filtering of the Key segments, select 
u may 

 

E
 
D
Settings→Show All from the Main Menu.  This action will remove the filter on anything that yo
have filtered.  See Figure 12, Plats Tab Expanded Unfiltered, and all the Key segments displayed. 
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Figure 12.  Plats Tab Expanded Unfiltered. 

 
END OF TASK 
 
Options 
 
The Options window with its tabs can provide the SKL operator with all the necessary controls to setup 
the SKL UAS Tabs to visually display data in the way they would like to see it.  The following paragraphs 
detail how to set up each of the Options tabs and how each setting affects the way information is 
presented on the windows.   
 
Keys Display.  Displaying Segment Information is very important for the operator to understand what 
keys are in the Mission Database and what equipment they are for.  The following paragraphs will explain 
the Options Key Display tab and what you will see given what you choose on this tab.  To change the way 
the keys are displayed select Settings→Options→Keys Display tab. 
 
1. If you choose to select only the Designator as shown in Figure 13, Keys Display-Designator Only the 

SKL UAS tabs will display the key information as shown in Figure 14, Designator Only Displayed 
below. 

 

  
 

Figure 13.  Keys Display-Designator Only. Figure 14.  Designator Only Displayed. 
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2. If you choose to just to select the Suffix to be displayed as shown in Figure 15, Keys Display-Suffix 

Only the SKL UAS tabs will display the key information as shown in Figure 16, Suffix Only Displayed 
below. 

 

  
 

Figure 15.  Keys Display-Suffix Only. Figure 16.  Suffix Only Displayed. 
 
3. If you choose to just to select the Text ID to be displayed as shown in Figure 17, Keys Display-Text 

ID Only the SKL UAS tabs will display the key information as shown in Figure 18, Text ID Only 
Displayed below. 
 

 

  
 

Figure 17.  Keys Display-Text ID Only. Figure 18.  Text ID Only Displayed. 
 
4. If you choose to just to select the Segment to be displayed as shown in Figure 19, Keys Display-

Segment Only the SKL UAS tabs will display the key information as shown in Figure 20, Segment 
Only Displayed below. 
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Figure 19.  Keys Display-Segment Only. Figure 20.  Segment Only Displayed. 
 
5. Ideally you should want to see all the information about the key segment that you can so that you can 

be better informed as to exactly what keys you have in your SKL and that they are assigned to the 
right equipment.  It is highly recommended that you check all the selections except KMID as that is 
used for Modern Key only.  Your selection should look like that in Figure 21, Keys Display; your SKL 
UAS tabs will display the segment information as shown in Figure 22, Full Segment Displayed below. 

 

 
 

 

Figure 21.  Keys Display. Figure 22.  Full Segment Displayed. 
 
6. You can readily see the effects of being able to see the Segment information.  A small diagram 

(Figure 22) has been included explaining what each part of the Segment information is. 
 
7. The KMID selection is used for Modern Key only.  There will be very few SKLs that will hold Modern 

key at the present time.  However, as more and more equipment is fielded requiring Modern Key fill, 
the SKL will be the device that will key up these devices with Modern Key.  Therefore, if your unit 
uses Modern Key to fill equipment, then you should make sure the KMID selection is checked. 

 
END OF TASK 
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ARC-210.  The ARC-210 tab under the Options window will allow you to create default B1 & B2 Message 
Data for the ARC-210 radio.  To create these two messages, select Settings→Options→ARC-210.  The 
window in Figure 23, ARC-210 Data opens. 
 

 
 

Figure 23.  ARC-210 Data. 
 
1. To create the ARC-210 Message Data, tap on the button in the center of the window.  The window in 

Figure 24, Message Data Created opens. 
 

 
 

Figure 24.  Message Data Created. 
 
2. The Message Data has been successfully created.  Tap on the OK button.  The ARC-210 tab re-

opens.  You cannot display the Message Data; you only know that it is there by selecting 
View→Summary Status.  Scroll down and look for Messages.  You should see 2 messages. 

 
END OF TASK 
 
Setting the Equipment Profile Mode.  The Profile Modes tab of the Options window is used to select 
either a Detailed or Condensed mode of key operation.  The Detailed Mode equates to the Standard 
Mode in the current DTD (CT3) and the Condensed Mode equates to the Expert Mode in the current DTD 
(CT3).  If you select Detailed as shown in Figure 25, Detailed Option Selected, then your Profile window 
will look similar to that shown in Figure 26, Detailed Profile Window.   
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Figure 25.  Detailed Option Selected. Figure 26.  Detailed Profile Window. 
 
You can readily see the advantages of selecting the Detailed Equipment Profile Instruction Mode.  The 
Profile window will tell you exactly what to do with the equipment you are loading. 
 
If you select Condensed, as shown in Figure 27, Condensed Option Selected, then you will see a Profile 
window similar to the one shown in Figure 28, Condensed Profile Window. 
 

 
 

Figure 27.  Condensed Option Selected. Figure 28.  Condensed Profile Window. 
 
As depicted in Figure 28, there are very limited instructions for you to follow.  To use this mode you must 
be very familiar with the equipment you are loading so that you can accomplish a correct load of the 
mission data.   
 
END OF TASK 
 
Keys Prompt.  The Keys Prompt tab has three selections that you can make.  The first is called Short 
Title.  When this selection is made it means that a prompt will come up for every Short Title received and 
that every Segment of each Short Title will update automatically based on the information the Short Title 
has.   
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Figure 29.  Short Title. Figure 30.  SKL. Figure 31.  Receive Edition. 
 

1. The second selection is Edition.  The prompt will come up on every Edition for every Short Title.  The 
Segments will update automatically based on the information given for the Edition. 

 

 
 

 

 

Figure 32.  Edition. Figure 33.  SKL. Figure 34.  Receive Edition. 
 

2. The third selection is Segment.  A prompt will come up on each and every Segment that is received 
into the SKL regardless of the Edition or Short Title.  You will have to manually set the Effective Date, 
Supersession Rate, and Cryptoperiod for each Segment. 
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Figure 35.  Segment. Figure 36.  SKL. Figure 37.  Receive Edition. 
 
 
END OF TASK 
 
Tree Sort.  The Tree Sort tab allows the operator of the SKL to define how the trees should be sorted.  In 
Figure 38 below the Tree Sort tab is displayed. 
 

 
 

Figure 38.  Tree Sort Tab. 
 
As can be seen from the figure above the tab has three selections.  They are Sort Platforms, Sort 
Equipment, and Sort Keys.  The sorting once selected is done alphabetically starting with numerical 
numbers first and then alphabetical characters next.  If you do not want your trees sorted simply remove 
the checkmarks and the items in each tree will be sorted by first in.  First in means that the first platform 
received or created will be first then the second and so forth disregarding any type of sorting. 
 
END OF TASK 
 
Key Load.  Figure 39, Key Load Tab gives the user the option of selecting whether or not they wish to 
issue the File Header along with an unencrypted key.  The default is not checked.  Certain equipment 
when issued unencrypted key cannot accept a File Header.  This checkbox allows the user to send a File 
Header when issuing unencrypted key to certain equipment by adding the checkmark. 
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Figure 39.  Key Load Tab. 
 
END OF TASK 
 
Audit.  The Audit Tab, Figure 40, Audit Tab allows the user to either enable or disable the Audit Warning 
Notice that is displayed once the audit trail reaches a defined threshold.  Currently for Army users this 
selection should always be enabled.  The default is enabled. 
 

 
 

Figure 40.  Audit Tab. 
 
END OF TASK 
 
Filter 
 
The SKL database can sometimes be very large and cumbersome to navigate.  To help alleviate the 
navigational problems that can come with large Mission Databases, the SKL UAS has a Filter function 
that can be set for the Plats Tab and Eqs Tab.   
 
Filter Platforms. 

 
1. To filter a platform, make sure that the Plats Tab is selected as shown in Figure 41, Plats Tab. 
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Figure 41.  Plats Tab. 
 

. As depicted in the above figure, there are many platforms listed.  To filter the list to a specific platform 

 

 
Figure 42.  Filter Plats. 

3. As depicted above, all Platforms are  filtering will take place.  All of these 
Platforms will be displayed.  To display just an individual Platform from the list, place a Checkmark 

 
e the 

Deselect All option, and then select the desired platform for filtering. 
 

 

2
or group of platforms select Settings→Filter from the Main Menu.  The window in Figure 42, Filter 
Plats, should open. 

 
selected and therefore no

( ) in the box next to the Platform you want to filter by tapping with the Inductive Stylus.  For this 
example CDR HMMV has been selected as shown in Figure 43, Filter Plats Single Platform.   

TIP:  If all the platforms are selected and the user only wants to select a single platform, us
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Figure 43.  Filter Plats Single Platform. 

 
4. Once the Platform is selected, tap the OK button.  Notice that when the Plats Tab reopens, only the 

Platform that was selected will be shown in the tree.  In this example only the CDR HMMV Platform is 
visible in Figure 44, Plats Tab Filtered. 

 

Figure 44.  Plats Tab Filtered. 
 
. As shown above, the only platform available for selection is CDR HMMV.  That is because CDR 

 
r.  

 

 

5
HMMV was selected as the filtered Platform.  Select Settings from the Main Menu.  Note that the
Filter selection has a Checkmark ( ) to the left of it indicating that the Plats Tab has an active Filte
See Figure 45, Settings - Filter Active. 
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Figure 45.  Settings - Filter Active. 

 
6. To return the Plats Tab to its original display, select Show All from the Settings menu.  The 

Checkmark ( ) is removed from the Filter selection and the Plats Tab is displayed showing all the 
platforms as depicted in Figure 46, Plats Tab Unfiltered. 

 

Figure 46.  Plats Tab Unfiltered. 
 

ND OF TASK 

ilter Equipment. 

. To filter at the equipment level, make sure that the Eqs tab is selected as shown in Figure 47, Eqs 

 

 

E
 
F
 
1

Tab. 
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Figure 47.  Eqs Tab. 

 
2. Once you are on the Eqs Tab, select Settings→Filter from the Main Menu.  The window in 

Figure 48, Equipment Filter, opens. 
 

Figure 48.  Equipment Filter. 
 

. From this window an Equipment Nam ow defaults to all 
 the 

 

 

3 e can be selected for filtering.  The wind
equipment selected.  Tap on the Deselect All button and then put a Checkmark ( ) in the box to
left of the Equipment Name you want to filter, as shown in Figure 49, Equipment Name Selected.  
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Figure 49.  Equipment Name Selected. 

 
4. Once the item(s) have been selected tap on the OK button.  The window in Figure 50, Eqs Tab 

Filtered opens showing just the filtered item. 
 

Figure 50.  Eqs Tab Filtered. 
 

. To display all the Equipment again, select Settings from the Main Menu.  The window in Figure 51, 

 

 

5
Settings - Filter, opens. 
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Figure 51.  Settings - Filter. 

 
6. Notice that Filter has a Checkmark ( ) to the left indicating that the filter is active for the Eqs Tab.  To 

display all the equipment in the Eqs Tab, Select Show All.  The window in Figure 52, Eqs Tab 
Unfiltered, returns. 

 

Figure 52.  Eqs Tab Unfiltered. 
 

ND OF TASK 

how All 

he Show All function allows an operator of the SKL to remove any filters that may have been applied to 

ND OF TASK 

ont 

aragraph describes the procedures necessary to change the Font, Font Style, Font Size, and Font 

 

E
 
S
 
T
the Mission Database.  To perform this function, select Settings→Show All. 
 
E
 
F
 

his pT
Color of the text when viewing data in the Plats, Eqs, Keys, and SOI trees.  There are 2 different Fonts 
(Courier New and Tahoma), 2 different Font Styles (Bold and Italic), 11 different Font Sizes, and 16 

0029-22 
UNCLASSIFIED/FOR OFFICIAL USE ONLY 



 UNCLASSIFIED//FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P 0029 
 
different Font Colors that can be selected.  Each user of the SKL can use the font settings that allow 
to view the data clearly.  The SKL should be at the SKL Main Menu as shown in Figure 53, Plats Tab. 
 

them 

NOTE 
 

Changes made to the Font settings will only apply to the selected tab, i.e., Plats, 

 

 
Figure 53.  Plats Tab. 

1. To change the way the text appears i he tab tree that you want to change (in 
this case the Plats tab), and then using the Inductive Stylus tap on Settings→Font as shown below 

 

 

. As a result of the above, the window in Figure 55, Select Font, opens. 
 

Eqs, Keys, or SOI. 

 
n a selected tab, select t

in Figure 54, Settings→Font.   

Figure 54.  Settings→Font. 
 
2
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Figure 55.  Select Font. 

 
3. Use the Select Font window to make the selections you want and then tap on the OK button with the 

Inductive Stylus to apply the selections made to the Plats tab.  The window in Figure 56, SKL Main 
Menu Plats returns showing the changes to the text.  In this case the font size and font type was 
changed. 

 

Figure 56.  SKL Main Menu Plats. 
 

ND OF TASK 

ECEIVE AND LOAD ICONS 

he Receive and Load icons shown in Figure 57, Receive and Load Icons, can be used as a shortcut to 

 

E
 
R
 
T
receive a database or to load highlighted items on the Plats, Eqs, and Keys tabs. 
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Figure 57.  Receive and Load Icons. 

 
END OF TASK 
 
END OF WORK PACKAGE 
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OPERATION UNDER UNUSUAL CONDITIONS 
 
 
Not applicable to the SKL. 
 
END OF TASK 
 
END OF WORK PACKAGE 
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TROUBLESHOOTING PROCEDURES 
 
 
INTRODUCTION 
 
This Chapter provides information about the SKL Help Desk and defines recommended troubleshooting 
procedures that should be followed to correct a specific fault with the SKL.. 
 
Help Desk 
 
There is a Help Desk that will provide assistance when needed.  Once a failure is experienced and 
cannot be resolved at the operator level, the user will call the SKL Help Desk at commercial number (Toll 
Free) (866) 651-1199.  The Help Desk will determine if the failure is hardware or software related. 
 
If the problem is software or operational related, the Help Desk will provide assistance in resolving the 
problem.  If the failure is determined to be hardware related, the user will be told to follow guidelines in 
the Warranty Bulletin TB 11-7010-410-24. 
 
Troubleshooting Procedures 
 
SKL troubleshooting is limited to the inspection, self-test, battery replacement, and use of fault isolation 
flow charts for Simple Key Loader.  In the event of a malfunction, the operator should ensure that 
components of the Simple Key Loader are properly connected, power cables are plugged into the correct 
power source outlets or that the Lithium-Ion Battery is charged and correctly installed, and that the SKL 
main power button is depressed to turn ON the device.  Refer to the following problem-solving guides for 
assistance.  The operator should attempt to operate a failed SKL component a second time.  If the SKL 
does not respond as expected, use the fault isolation flow charts to try and determine the faulty 
component.  If the malfunction persists after correctly using the fault isolation flow charts, the problem 
should be reported to the Field maintenance for further troubleshooting and repair. 
 
There are many troubleshooting techniques that can be used on computer systems.  They all work to 
some degree.  However, the following techniques should always be used when attempting to troubleshoot 
the Simple Key Loader. 
 
1. Check the obvious – This is the first rule of troubleshooting the Simple Key Loader.  Make sure that 

power is connected and turned on or the Battery is fully charged and installed correctly and securely, 
the external connections are firmly seated if any.  Then use the fault isolation flow charts to try to 
isolate the problem, before calling on the Field Maintainer.  Once the obvious has been checked and 
the problem still persists, move on to the second rule of troubleshooting the SKL. 

 
2. Contact the Field Maintainer – This is the second rule of troubleshooting the SKL.  The Field 

Maintainer has more tools with which to troubleshoot the SKL.  The Field maintenance technicians 
are your best bet to solve the problem correctly the first time if rule one has not solved your problem. 

 
3. Contact the SKL Help Desk – This is the Third rule of troubleshooting the SKL.  If the Field 

Maintainer cannot resolve the problem then the SKL Help Desk should be called.  There are experts 
located at the Help Desk that will be able to help in the resolution of the problem.  The SKL Help Desk 
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will help the user determine if there is a hardware problem and direct the user to the Warranty 
Bulletin.   

 
4. Test only one thing at a time – This is the fourth rule of troubleshooting the SKL.  If you change 

several things and then try to restart the SKL only to discover that it won’t boot, how will you know 
which change caused the new problem?  Also, if changing multiple items somehow fixes the original 
problem, what have you learned about it?  If the problem recurs, how are you going to fix it then?  
This leads up to the fourth rule of troubleshooting. 

 
5. Document the problem as well as the solution – This is the fifth rule of troubleshooting the Simple 

Key Loader.  One thing about computers in general: if it happened once, it can (and probably will) 
happen again.  If you’ve already isolated and repaired a problem once, why go through all the 
troubleshooting again?  Write down what the problem is, what was done just before the problem 
occurred, and what you did to fix it. 

 
Troubleshooting fault isolation flow charts are reliable only when certain conditions are met.  If the fault is 
found to be outside of the troubleshooting flow charts, it must be assumed that the preconditions were not 
met.  The following assumptions for maintenance are: 
 
1. One problem at a time.  It must be assumed that only one fault or failure caused the problem. 
 
2. All switches and controls are properly set for normal operation.  Improperly set switches and controls 

may simulate a malfunction. 
 
3. All cables, adapters, connections, and terminations are in good condition and connected correctly.  

Open signal paths due to defective cables, adapters, and connectors account for many faults.  Cables 
and connectors must be checked in all situations. 

 
4. No operator error exists.  All operators must follow the standard and approved hardware/software 

operating procedures. 
 
The following fault isolation flow charts are provided to support problem solving at the operator level.   
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Battery Charger Has A Flashing Amber LED When A Battery Is Inserted 
 

WARNING 
 

A flashing amber LED indicates the battery is faulty.  Immediately remove the 
battery from the battery charger.  Failure to remove the faulty battery can cause the 
battery pack to be overcharged, or charged with extremely high current, abnormal 
chemical reaction can occur in it, possibly leading to acid leakage, overheating, 
smoke emission, bursting and/or ignition.  This condition can lead to possible 
personal injury if not corrected immediately. 

 
Basic troubleshooting steps: 1.  Immediately remove the battery from the Battery Charger Station. 

2.  Mark, label, or identify the battery in such a way to show that it is        
“Failed” and is not be used. 

  
Probable Fault: Battery Pack has failed. 
  
Corrective Actions: Document the fault, troubleshooting steps taken (and results, if any).  

Then deliver the battery pack to your Field Maintainer for battery pack 
replacement and disposal. 

 
Battery Charger LED Is Not Lit 
 

WARNING 
 

Do not use an apparently damaged or deformed battery pack.  Otherwise, acid 
leakage, overheating, smoke emission, bursting, and/or ignition of the battery pack 
may occur.  This condition can lead to possible personal injury if not corrected 
immediately. 

 
Basic troubleshooting steps: See Figure 1, Battery Charger LED is not Lit. 
  
Probable Fault: If all steps fail to correct the problem, the probable faulty component is 

the battery charger, AC/DC power supply, or AC power cord. 
  
Corrective Actions: Document the fault, troubleshooting steps taken (and results, if any) 

and deliver the battery charger, AC/DC power supply, and AC power 
cord to the Field Maintainer. 
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Start Is AC Power
Available?

Obtain a Suitable
Power Source.

Is any Damage
Evident?

Inspect the Battery
 Pack and Battery

 Charger Contacts for
Damage, Dirt, or

Corrosion.  See WP 0033.

Do Not Continue!
Return the Damaged

Component to the
Field Maintainer.

Is any Damage
Evident?

Verify the Battery Pack
is Properly Inserted

into the Battery
Charger.  See

WP 0035.

Is Battery
Charger LED

On?

End Process

Return the Damaged
Component to the
Field Maintainer.

Visually Inspect
All Plugs, Cables
and Connectors

For Damage.  See
WP 0034.

no

no

no

no

yes

yes

yes

yes

 
 
 
 
 
 
 
 
 
 
 
 

Figure 1.  Battery Charger LED is not Lit. 
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SKL Will Not Power On 
 

WARNING 
 

Do not use an apparently damaged or deformed battery pack.  Otherwise, acid 
leakage, overheating, smoke emission, bursting, and/or ignition of the battery pack 
may occur.  This condition can lead to possible personal injury if not corrected 
immediately. 
 

Basic troubleshooting steps: See Figure 2, SKL Will not Power On. 
  
Probable Fault: If all steps fail to correct the problem, the probable faulty component is 

the SKL. 
  
Corrective Actions: Document the fault, troubleshooting steps taken (and results, if any) 

and deliver the SKL to the Field Maintainer. 
 

Start
Install a Fully

Charged Battery.
See WP 0035.

Inspect the Battery
and SKL Contacts
for Damage, Dirt,
or Corrosion.  See

WP 0033.

Does the SKL
Power On?

End Process

Is any Damage
Evident?

If Available, Install
the Battery

Eliminator or AA
Battery Pack.  See

WP 0035.

Do Not Continue!
Return the Damaged

Component to the
Field Maintainer.

Does the SKL
Power On?

Return the SKL
to the Field
Maintainer.

End Process

Is the Battery
Pack Charged?

no

no

no

yes

yes

yes

yes

 
Figure 2.  SKL Will not Power On. 
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User Cannot Logon To The Core Library 
 

NOTE 
 

If the user fails to logon after ten consecutive attempts, the user account is deleted. 
 
Basic troubleshooting steps: See Figure 3, User Cannot Logon to the Core Library. 
  
Probable Fault: If all steps fail to correct the problem, the probable faulty component is 

the SKL. 
  
Corrective Actions: Document the fault, troubleshooting steps taken (and results, if any) 

and deliver the SKL to the SSO or the Field Maintainer. 

Start

Power Off and
Power On the SKL.

Logon to Core
Library.  See WP 0006.

Was Logon 
Successful?

KOV-21 LED
Flashing?  See

WP 0006.
See WP 0031.

End Process

Return the SKL
to the SSO.

Can SSO
Logon?

Check Status of
the User Account.

Have SSO Create
Your User Logon

and Password.  See
WP 0007.

Return the SKL
to the Field
Maintainer.

Was User Logon
Successful?

End Process

no

no

no

no yes

yes

yes

yes

 
Figure 3.  User Cannot Logon to the Core Library. 
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KOV Activity Light Indicator LED Is Not Lit 
 
Basic troubleshooting steps: See Figure 4, KOV Activity Light Indicator LED is not Lit. 
  
Probable Fault: 1.  If all steps fail to correct the fault, the probable faulty component is 

the SKL.  
2.  If the SKL is fully operational and the KOV indicator light is not lit, the 

fault is most likely the LED internal to the SKL.   
  
Corrective Actions: Document the fault, troubleshooting steps taken (and results, if any) 

and deliver the SKL to the Field Maintainer. 

Start Is the SKL
Operational?

Power Off and
Power On the SKL.

Document the Fault
and Return the SKL

to the Field
Maintainer.

Is KOV-21 LED
Lit?

Return the SKL
to the Field
Maintainer.

End Process

no

no

yes

yes

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4.  KOV Activity Light Indicator LED is not Lit. 
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KOV Activity Light Indicator LED Is Flashing 
 
Basic troubleshooting steps: See Figure 5, KOV Activity Light Indicator LED is Flashing. 
  
Probable Fault: The SKL has been “zeroized”.  This is most likely the result of an 

intentional (active) Zeroization.  The SSO did not logon successfully 
after 10 consecutive attempts. 

  
Corrective Actions: Document the fault, troubleshooting steps taken (and results, if any) 

and deliver the SKL to the SSO. 
 

Power Off and 
Power On the SKL.

See WP 0006.

Is KOV-21 LED
Flashing? End Process

Is Default SSO
Logon

Displayed?

Use the Procedure
in WP 0006 to
Reset the SSO

Password.

Logon with the SSO
or Other User

Account and see
if the SKL UAS
Launches.  See

WP 0006.

Is KOV-21 LED
Flashing?

Return the SKL
to the Field
Maintainer.

End Process

no

no

no

yes

yes

yes

Start

 
 

Figure 5.  KOV Activity Light Indicator LED is Flashing. 
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SKL UAS Does Not Start 
 
Basic troubleshooting steps: See Figure 6, SKL UAS does not Start. 
  
Probable Fault: If all steps fail to correct the problem, the probable faulty component is 

the SKL.   
  
Corrective Actions: Document the fault, troubleshooting steps taken (and results, if any) 

and deliver the SKL to the SSO or Field Maintainer. 
 

Start

Does the SKL UAS
Auto Launch?

Do Progress &
Startup Screens

Appear?

Is SKL UAS
Desktop Displayed?

Logon Onto the
Core Library.  See

WP 0006.

Document the Fault
and Return the SKL

to the Field
Maintainer.

Document the Fault
and Return the SKL

to the Field
Maintainer.

Document the Fault
and Return the SKL

to the Field
Maintainer.

Document the Fault
and Return the SKL

to the Field
Maintainer.

End Process

yes

yes

yes

yes

yes

no

no

no

no

no

Are You Logged On
To the Core

Library?

Are There Any
Error Screens?

 
 

Figure 6.  SKL UAS does not Start. 
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Unable To Transmit Or Receive Data 
 
Basic troubleshooting steps: See Figure 7, Unable to Transmit or Receive Data. 
  
Probable Fault: If all steps fail to correct the problem, the probable faulty component is 

the SKL. 
  
Corrective Actions: Document the fault, troubleshooting steps taken (and results, if any) 

and deliver the Fill Cable or SKL to the Field Maintainer. 
 

Replace Fill Cable
with known Good

Cable and Re-
Attempt the Transmit,

Receive, or OTAD 
Procedure.

Was Transfer of
Data Successful?

Return the SKL
to the Field
Maintainer.

Turn in Original
Fill Cable to Field

Maintainer.

End Process

no

yes

Start

 
 

Figure 7.  Unable to Transmit or Receive Data. 
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Stylus Inoperative 
 
Basic troubleshooting steps: See Figure 8, Stylus Inoperative. 
  
Probable Fault: 1.  If one stylus is inoperative, the fault is the stylus.  

2.  If both styli are inoperative, the fault is either both styli are faulty or 
the SKL is faulty. 

  
Corrective Actions: Document the fault, troubleshooting steps taken (and results, if any) 

and deliver the faulty stylus or SKL to the Field Maintainer. 
 

Start
Are Both Styli

Inoperative?  See
WP 0033.

Return the Defective
Stylus to the

Field Maintainer.

Press Button 4 on the
Navigation and Control

Panel and Operate
the SKL in the Mouse
Mode.  See WP 0004.

Document the Fault
and Return the

Damaged Component(s)
to the Field
Maintainer.

End Process

no

yes

 
Figure 8.  Stylus Inoperative. 
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ECU Equipment Is Loaded With Incorrect Time 
 
Basic troubleshooting steps: See Figure 9, ECU Equipment is Loaded with Incorrect Time. 
  
Probable Fault: 1.  The User has not performed the task Tools→User→Get Card 

Time/Date. 
2.  The SSO has not performed the task Tools→SSO→Set Card 
Time/Date. 

  
Corrective Actions: Follow the Troubleshooting Flow Chart below to correct the Host PC 

time.  If after following the instructions to change the time, and the 
incorrect time is still loaded to the ECU, send the SKL to the Field 
Maintenance. 

 

Start

Perform the "Get Card
Time/Date" Procedure
and Select NO.  See

WP 0007.

Is the KOV-21
Card Time
Correct?

Have SSO Set the
Time/Date on the

KOV-21 Card.  See
WP 0007.

Set Host PC Time/Date
to KOV-21 Time/Date.

See WP 0007.

Reload ECU and
Check the Time

on the ECU.

Did that Fix
the Problem?

Return the SKL
to the Field
Maintainer.

End Process

no

no

yes

yes

 
 

Figure 9.  ECU Equipment is Loaded with Incorrect Time. 
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Key Variables Displayed Indicate They Have Expired When In Fact They Have Not 
 
Basic troubleshooting steps: See Figure 10, Incorrect Key Variable Information Displayed. 
  
Probable Fault: The KOV-21 INFOSEC card may have the wrong Time and Date. 
  
Corrective Actions: Follow the Troubleshooting Flow Chart below to remove the expired 

condition from current key variables.  If after following the instructions to 
set the correct time and date on the KOV-21 card, the key variables still 
show an expired condition, send the SKL to the Field Maintainer. 

 

Start

Are Key Effective and
Expiration Dates

correct?  See
WP 0026.

Get New Key
With Correct

Dates.

Exit the SKL UAS.
Perform the Procedure

"Get Time/Date" in
Core Library.  See

WP 0007

Have SSO Reset the
KOV-21 Card Date/

Time using Procedure
"Set Card Time/Date
in Core Library.  See

WP 0007.

Use Logon Procedure 
in WP 0007.  Then

Display the Key
Segments.

SSO should Logoff.
User should Logon.

Return the SKL
to the Field
Maintainer.

End Process

yes

yes

yes

no

no

no

Is Host Date/Time
Correct?

Are Key Segments
Displayed
Correctly?

 
 

Figure 10.  Incorrect Key Variable Information Displayed. 
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During A Load Operation An Error Occurs Stating "There Is No Item Selected” 
 
Basic troubleshooting steps: See Figure 1, There is no Item to Load. 
  
Probable Fault: 1.  There is no Platform database resident in the SKL. 

2.  The Platforms are there but just cannot be seen. 
  
Corrective Actions: Follow the Troubleshooting Flow Chart below to correct the loading 

problem.  If after following the instructions and you still cannot load 
equipment, send the SKL to the Field Maintainer. 

 

Start

When Performing a
Load Operation an
error occurs stating
"There is no Item

Selected"

Platform Database
Resident in SKL?

On the Plats
Tab, are all Platforms

Displayed?

With the Plats Tab
open, Select

Settings - Show - All.

Load Platform
Databases into SKL.

See WP 0016.

Did that fix
the Problem?

Return the SKL
to the Field
Maintainer.

Did that fix
the Problem?

End Process

nono

no

noyes

yes

yes

 
 
 
 
 

Figure 11.  There is No Item Selected. 
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During A Load Operation An Error Occurs Stating "No Item Found To Load” 
 
Basic troubleshooting steps: See Figure 12, No Item Found to Load. 
  
Probable Fault: 1.  View the equipment fill location for the presence of a key tag and key 

variable. 
2.  Reset the Date Load date to cover the effective and expiration date 
of the key tags. 

  
Corrective Actions: Follow the Troubleshooting Flow Chart below to correct the loading 

problem.  If after following the instructions and you still cannot load 
equipment, send the SKL to the Field Maintainer. 

 

Start

When performing
a  Load Operation

an error occurs
stating "No Item
Found to Load" 

Are Key Tags and
Variables present in

Equipment Fill
Locations?

Reset the Date Load
date to cover the Effective
and Expiration Date of the
Equipment Key Tags by
selecting Settings - Date 

Load.  See WP 0029.

Perform a Key Needed
operation for all Key
Tags missing Key

Variables.  See
WP 0017.

Did that fix the Problem?

Return the SKL
to the Field
Maintainer.

End Process
yes

yes

yes

no

no

no

Did that fix the Problem?

 
 

Figure 12.  No Item Found to Load. 
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During A Transmit Operation There Is Minimum Or Limited Instructions On The Profile Window 
 
Basic troubleshooting steps: See Figure 13, Minimum or Limited Instructions. 
  
Probable Fault: This condition is most likely caused by the SKL being in a Condensed 

Instruction Mode. 
  
Corrective Actions: Follow the Troubleshooting Flow Chart below to correct the lack of 

information on the Profile window.  If after following the instructions and 
you still cannot see the instructions, send the SKL to the Field 
Maintainer. 

 

Start
There are minimum

or limited instructions
in the Profile Window.

The SKL is most likely
in a Condensed

Instruction Mode.  Set
the Mode to Detailed

by selecting Settings - 
Options - Profile Modes.

See WP 0029.

Did that fix
the Problem?

Return the SKL
to the Field
Maintainer.

End Process

no

yes

 
Figure 13.  Minimum or Limited Instructions on the Profile Window. 
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Key Tag Or Key Variable Attributes Are Not Displayed 
 
Basic troubleshooting steps: See Figure 14, Key Tag or Key Variables not Displayed. 
  
Probable Fault: This condition is most likely caused by the SKL variable options not 

being selected. 
  
Corrective Actions: Follow the Troubleshooting Flow Chart below to correct the lack of 

information concerning the Key Tag or Key Variable.  If after following 
the instructions and you still cannot see the desired information, send 
the SKL to the Field Maintainer. 

 
Start

The SKL is not
displaying the Key

Segement
Attributes.

Select the Display
Options you want from
the Settings - Options -

Keys Display Menu.
See WP 0029.

Are the Key Attributes
Displayed?

Return the SKL
to the Field
Maintainer

End Process

yes

yes

no

no
Have the Settings -

Options - Keys Display, been
Selected for the

Segments?

 
 

Figure 14.  Key Tag or Key Variable Attributes are not Displayed. 
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Stylus Will Not Point To Intended Object 
 
Basic troubleshooting steps: See Figure 15, Stylus will not Point to Intended Object. 
  
Probable Fault: This condition is most likely caused by the Stylus being out of 

calibration. 
  
Corrective Actions: Follow the Troubleshooting Flow Chart below to correct the Stylus' 

pointing problems.  If after following the instructions and you still cannot 
point to the intended object, send the SKL or Stylus to the Field 
Maintainer. 

 

Start
Stylus will not point

at the Intended
Object.

The Stylus is most
likely out of

Calibration.  On the 
Windows Desktop,
Double-Tap on the

Calibration Icon and
follow the steps to 

Calibrate the Stylus.
See WP 0004

Return the SKL
to the Field
Maintainer.

End Process

no

yes

Did that fix the
Problem?

 
Figure 15.  Stylus will not Point to Intended Object. 
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Cannot Logon To The Core Library With A Valid Account And Password 
 
Basic troubleshooting steps: See Figure 16, Cannot Logon to the Core Library. 
  
Probable Fault: This condition is most likely caused by not having a CIK in the SKL. 
  
Corrective Actions: Follow the Troubleshooting Flow Chart below to correct the specific 

logon failure as noted in the Flow Chart.  If after following the 
instructions and you still cannot Logon, send the SKL to the Field 
Maintainer. 

 

Start

Power Off and Power
On the SKL. See 

WP 0006.  Logon to
the Core Library.
See WP 0007.

Was Logon
Successful?

Remove and Reinstall
the CIK.  See WP 0035.

Logon to the Core
Library.  See WP 0007.

End Process

Was Logon
Successful?

Return the SKL
to the SSO.

End Process

Can SSO
Logon?

Have SSO reset your
User ID and

Password.  See
WP 0007

End Process

Return the SKL
to the Field
Maintainer.

no

no

no

yes

yes

yes

 
Figure 16.  Cannot Logon to the Core Library. 
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SKL Display Is Black 
 
Basic troubleshooting steps: See Figure 17, SKL Display is Black. 
  
Probable Fault: This condition is most likely caused by depressing button 3 changing 

the display to Night Vision Mode. 
  
Corrective Actions: Follow the Troubleshooting Flow Chart below to correct display 

characteristics.  If after following the instructions and you still cannot 
change the display characteristics, send the SKL to the Field 
Maintainer. 

 

Start
While using the SKL
the Display is Black 
and difficult to see.

This failure is most
likely caused by the SKL

being in Night Vision
Googles Mode.  Press

Button 3 on the
Navigation/Control
Panel to return the 

Display to normal mode.
See WP 0004.

Did that fix the
Problem?

Return the SKL
to the Field
Maintainer.

End Process

no

yes

 
 

Figure 17.  SKL Display is Black. 
 
END OF TASK 
 
END OF WORK PACKAGE
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OPERATOR MAINTENANCE 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
 

 
ERROR/INFORMATION MESSAGES 
 
 
Core Library and SKL UAS Error/Information Messages 
 
There are a number of error messages that will come up identifying to the user an incorrect action or an 
error while attempting a process.  The error messages below are by no means all of the error messages 
contained in the software for the Core Library and SKL UAS.  These are however some of the most 
common messages seen.  An explanation will be given as to why the error message was generated and 
what you must do to eliminate the error message. 
 

 
 

Figure 1.  Enter Valid User ID and Password. 
 
1. The error message displayed above is telling the user of the SKL that they must enter a valid User ID 

and Password to gain access to the system.  Make sure that you have a valid account created for you 
and that you know the correct password for the account.  If you cannot remember the User ID and/or 
Password, contact the SSO and have them reset your account.  If you do not have an account and 
require an account have the SSO create one for you.  To dismiss the window tap on the OK button. 

 

 
 

Figure 2.  Create User Failed. 
 
2. The error message displayed above is telling the SSO of the SKL that they must enter a valid User ID 

and Password to create a new account.  Spaces are not allowed in the User ID.  The Password field 
must have a minimum of 6 characters and no more than 12 characters.  To dismiss the window tap 
on the OK button. 
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Figure 3.  New Password and Confirm do not Match. 
 
3. The error message displayed above is telling the SSO of the SKL that they must enter the same 

Password twice and they must match to create a new account.  Or the Password chosen for the 
account is an illegal Password or there is no User ID associated with the Password.  To dismiss the 
window tap on the OK button. 

 

 
 

Figure 4.  There is no Item Selected. 
 
4. The error message displayed above is telling the user of the SKL that during the procedure 

File→Transmit→Load, no key variable is assigned to the Fill locations on the equipment.  Make sure 
that you select the type of database you wish to load or insure that your SKL has the correct 
database items in it before starting the mission.  To dismiss the window tap on the OK button. 

 

 
 

Figure 5.  No Items Found to Process. 
 
5. The error message displayed above is telling the user of the SKL that during the procedure 

File→Transmit→Load, no database was selected or there are no Key Variables assigned to 
equipment Fill locations.  To resolve this error condition either select a database or assign keys to the 
equipment Fill locations.  Therefore no action was performed.  To dismiss the window tap on the OK 
button. 

 

 
 

Figure 6.  No IKEK Found. 
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6. The Information message displayed above is telling the user of the SKL that during the procedure 

File→Transmit→Load EPLRS that the IKEK for a particular Division ID was not found in the 
database.  To correct this condition, make sure that you have the necessary keys in your SKL UAS 
database before attempting to load the EPLRS equipment.  To dismiss the window tap on the OK 
button. 

 

 
 

Figure 7.  No TEK Found. 
 
7. The error information displayed above is telling the user of the SKL that during the procedure 

File→Transmit→Load EPLRS that the TEK for a particular Division ID and Segment # was not found 
in the database.  To correct this condition, make sure that you have the necessary keys in your SKL 
UAS database before attempting to load the EPLRS equipment.  To dismiss the window tap on the 
OK button. 

 

 
 

Figure 8.  No TrKEKs Exist. 
 
8. The error message displayed above is telling the user of the SKL that during the procedure 

File→Transmit→Load, the key variable is encrypted and no decryptor (TrKEK) is loaded in the SKL.  
To resolve this error condition, fill the SKL with the correct TrKEK from the LCMS Workstation.  To 
dismiss the window tap on the OK button. 

 

 
 

Figure 9.  Resolve All Keys Before Loading. 
 
9. The error message displayed above is telling the user of the SKL that during the procedure 

File→Load that there are key tags assigned to equipment that you are attempting to load that do not 
have any keys.  To resolve this error condition, make sure that you have all Key Tags resolved 
(containing key) before you attempt to perform the Load procedure.  To dismiss the window tap on 
the OK button.   
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Figure 10.  No Key(s) Needed. 
 
10. The error message displayed above is telling the user of the SKL that during the procedure 

File→Receive→Key Needed, that there is no created Key Tag in the database that requires key.  To 
resolve this error condition, make sure that you have created a Key Tag or download a Key Tag from 
the ACES Workstation before attempting to use this procedure.  To dismiss the window tap on the 
OK button. 

 

 
 

Figure 11.  No KEK(s) Found For OTAD. 
 
11. The error message displayed above is telling the user of the SKL that during the procedure 

File→OTAD→Variable Update (VG) that there are no KEK(s) in the database to complete the 
procedure.  To resolve this error condition, make sure that you have the correct keys in the database 
for the procedure you are attempting to complete.  To dismiss the window tap on the OK button. 

 

 
 

Figure 12.  Equipment Location Does Not Match Key Type. 
 
12. The information message displayed above is telling the user of the SKL that during the procedure 

File→Assign→Keys that there are no keys in the database that correspond to the location on the 
equipment that the user is attempting to assign.  To correct the condition, make sure of what each 
location on the equipment you are attempting to assign key to, will take.  Not all equipment locations 
are TEKs or KEKs.  Refer to the Technical Manual for the equipment you are attempting to load.  To 
dismiss the window tap on the OK button. 

 

 
 

Figure 13.  No Expired Keys Exist. 
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13. The error message displayed above is telling the user of the SKL that during the procedure 

View→Keys→Expired Keys that there are no expired keys in the database or the KOV-21 card date is 
incorrect.  If the KOV-21 card is wrong go to Core Library and ask the SSO to change it to the correct 
date/time.  To dismiss the window tap on the OK button. 

 

 
 

Figure 14.  No Keys Found To Load. 
 

14. The information message displayed above is telling the user of the SKL that during the procedure 
File→Transmit→Load Modern Keys that there are no Modern Keys in the database.  To resolve this 
condition, make sure that you have the correct keys in the database for the procedure you are 
attempting to complete.  To dismiss the window tap on the OK button. 

 

 
 

Figure 15.  Attributes Do Not Match. 
 
15. The information message displayed above is telling the user of the SKL that during the procedure 

File→Receive→Key Needed from the LCMS Workstation, that the Short Title attributes you are 
attempting to resolve in the SKL through the Key Needed procedure does not match the Short Title 
attributes being downloaded from the LCMS Workstation.  To resolve this condition make sure that 
the attributes of the Key Tag in the SKL match exactly to the Key being downloaded from the LCMS 
Workstation.  To dismiss the window tap on the OK button. 

 

 
 

Figure 16.  There is no Record. 
 
16. The information message displayed above is telling the user of the SKL that during the procedure 

View→SOI→Suffix/Expander that there is no SOI in the database for you to view.  To resolve this 
condition, either download an SOI from the ACES Workstation or another SKL/DTD.  To dismiss the 
window tap on the OK button. 
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Figure 17.  Audit Trail Upload Warning. 
 
17. The information message displayed above is telling the user of the SKL that the Audit Trail in the SKL 

has reached its limit for uploading to the LCMS Workstation version 5.0.  If you no longer wish to see 
this Warning message, you can stop it from appearing by selecting Settings→Options→Audit.  For 
Army users of the SKL this is not a recommended course of action.  You should follow the guidance 
of the warning message.  To dismiss the window tap on the Close button. 

 
 
END OF WORK PACKAGE 
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PMCS INTRODUCTION 
 
 
INTRODUCTION 
 
The operator is required to perform a prescribed series of Preventive Maintenance Checks and Services 
(PMCS) for the AN/PYQ-10 (C), Simple Key Loader (SKL).  The PMCS procedures constitute systematic 
care, servicing, and inspection of all AN/PYQ-10 (C) SKL components, to maintain the system in good 
operating condition and to reduce down time by detecting and correcting system troubles.  The checks 
and services are critical to ensure the combat-serviceability and mission-readiness of the AN/PYQ-10 (C) 
Simple Key Loader.  Operator PMCS for the AN/PYQ-10 (C), SKL components is listed in the table and 
figures of this section. 
 
When performing PMCS always observe the WARNINGS and CAUTIONS appearing at the beginning of 
this manual and in the PMCS tables.  WARNINGS and CAUTIONS appear before applicable procedures.  
Additionally, the operator must observe any WARNINGS on plates and decals attached to the equipment.  
Observe all safety notes to prevent serious injury to personnel and damage to equipment. 
 
Routine Services 
 
Routine checks and services are not listed in the PMCS tables.  Routine services should be performed 
before and after deployment and before storage.  These checks and services include the following: 
 

• Cleaning • Checking for loose or broken knobs 
• Dusting • Checking for damaged connectors 
• Checking for frayed cables • Checking for any physical damage 
• Checking O-Rings for damage • Checking Lanyards for damage 

 
O-Ring Inspection Criteria 
 
There are three O-Rings on an operational SKL.  Figure 1 and 2 indicate where each O-Ring is located.  
Each one of these O-Rings is important to the safe operation of the SKL.  Therefore you should inspect 
all the O-Rings periodically for damage.  Use Figure 3, O-Ring Criteria, below to help you determine if the 
O-Ring needs to be replaced. 
 

  
 

Figure 1.  Battery Receptacle O-Ring. Figure 2.  Side Door O-Rings. 

O-Rings 

O-Ring 
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Figure 3.  O-Ring Criteria. 
 

nce you have determined that an O-Ring needs to be replaced, notify Field Maintenance and they will 

ND OF TASK 

ND OF WORK PACKAGE 

 

O
validate that the O-Ring needs replacing and then replace the O-Ring. 
 
 
E
 
E
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PMCS INSTRUCTIONS 
 
 
PREVENTATIVE MAINTENANCE CHECKS AND SERVICES (PMCS) 
 
PMCS must be performed at specified intervals as shown in the following PMCS table.  When operational 
requirements preclude doing PMCS at the specified time, perform only those services that can be 
performed on a non-interference basis and follow-up subsequent to mission completion.  Deficiencies that 
cannot be corrected should be documented and reported to unit maintenance personnel.  
The following items explain the columns in the PMCS tables: 
 
1. ITEM NUMBER column.  Numbers in this column are for reference.  When completing the DA Form 

2404, Equipment Inspection, and Maintenance Worksheet, or DA Form 5988E (Automated), include 
the item number for the check/service indicating a fault.  Item numbers also appear in the order that 
the checks and services are to be completed for the intervals listed. 

 
2. INTERVAL column.  This column specifies when the procedure is to be done.  BEFORE (B) 

procedures must be completed prior to operating the SKL for its intended mission.  DURING (D) 
procedures must be completed during the time of operation or using the equipment for its intended 
mission.  Procedures with no interval indicated (A) must be done immediately after operating or using 
the equipment.  Other procedures should be completed at the stated intervals. 

 
3. ITEM TO BE CHECKED OR SERVICED column.  This column provides the location and the item to 

be checked or serviced.  The item location is underlined. 
 
4. PROCEDURE column.  This column indicates the procedure that must be done (check or service) to 

the item, to know if the equipment is ready or available for its intended mission or for operation.  The 
procedure must be done at the stated interval. 

 
5. EQUIPMENT NOT READY/AVAILABLE IF column.  Information in this column identifies what faults 

will keep the equipment from being capable of performing its primary mission.  If the check and 
service procedures show faults listed in this column, do not operate the equipment.  Follow standard 
operating procedures for maintaining the equipment or reporting the failure. 

 
NOTE 

 
Be sure to observe all notes and special instructions that appear in the PMCS 
tables. 

 
The following PMCS figure and table provide instruction for performing operator PMCS on the Simple Key 
Loader.  Each system hardware component is addressed individually. 
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WARNING 
 

Trichlorotrifluoroethane, trichloroethane, and similar chemical solvents will no 
longer be used for ordinary cleaning of equipment.  These substances threaten 
public health and the environment by destroying ozone in the earth's upper 
atmosphere.  Suitable non-hazardous cleaning materials will be used instead, such 
as a clean cloth, water, and mild detergent. 

 
PMCS applies to all components of the AN/PYQ-10 (C) Simple Key Loader.  Each component has its own 
separate component listing which includes cables, adapters, and other items required to support the 
proper operation of each particular component.  
 
Table 1, PMCS Instructions, lists PMCS requirements for the AN/PYQ-10 (C) Simple Key Loader.  See 
item numbers in Figure 1, PMCS Requirements for the AN/PYQ-10 (C) Simple Key Loader, for reference.  
The table separates the procedures by equipment group. 
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Figure 1.  PMCS Requirements for the AN/PYQ-10 (C) Simple Key Loader. 
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Table 1.  PMCS Instructions. 
 

Item 
No. 

Interval 
 
   B        D        A 

Item To Be Checked Or 
Serviced 

Procedure Equipment Not 
Ready/Available 

If 
1 B D A SKL Exterior Inspect for dirt, oil, 

grease, and 
fingerprints.  Clean as 
required.  Inspect LCD 
for cracks, chips, and 
surface irregularities.  
Notify Field 
Maintenance (FM) if 
LCD is cracked, 
chipped, or has surface 
irregularities. 

LCD is cracked 
to the point that 
the image cannot 
be seen. 

       
2 B D A Stylus Inspect for dirt, oil, 

grease, or other foreign 
material that could 
render the Stylus 
unusable. 

Stylus cannot be 
used to make 
selections within 
any of the 
software 
components 
loaded on the 
SKL. 

       
1, 3, 
5, and 
6 

B D A Connectors/Plugs/Jacks 
Connector /Plug/Jack Pins 
 
 
 
 
 
 
 
 
 
 
Connector/Plug/Jacks 
Insulating Bodies 

Inspect connectors, 
plugs, and jacks for 
damaged, broken, 
missing, or corroded 
pins and contacts.  
Notify FM to treat 
corrosion, if required.  
Notify FM for 
replacement if pins are 
damaged, broken, or 
missing pins. 
 
Inspect the insulating 
bodies of all 
connectors, plugs, and 
jacks for cracks, 
breakage, or exposed 
wiring.  Notify FM for 
replacement if required. 

Any 
connector/plug/ 
Jack pins are 
damaged, 
missing, or 
severely 
corroded. 
 
 
 
 
 
The insulating 
body on any 
connector, plug, 
or jack has 
broken insulation 
or has wiring 
exposed. 

       
5 B  A AC Power Connector Inspect connector for 

damaged, bent, or 
corroded pins. 

AC adapter 
connector is 
unserviceable 
due to pins being 
damaged, bent, 
missing, or 
corroded. 
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Table 1.  PMCS Instructions.  (continued) 
 

Item 
No. 

Interval 
 
  B         D        A 

Location or Item to 
Check/Service 

Procedure Not Fully Mission 
Capable If 

4 B  A Rechargeable Battery 
Pack/ Rechargeable 
Battery Pack Exterior 

Inspect the exterior of 
the battery pack for 
dents, cracks, unusual 
bumps and swelling, or 
liquid leakage.  Inspect 
battery pack 
connectors for bent, 
broken, missing, or 
corroded contacts.  
Notify FM to exchange 
any defective battery. 

Battery pack has 
dents, cracks, 
unusual bumps 
and swelling, or 
liquid leakage.  
Battery pack 
contacts are bent, 
broken, missing, 
or corroded. 

       
6 B  A Battery Charger Station/ 

Battery Charger Station 
Exterior 

Inspect Battery 
Charger connectors, 
and contacts for 
damaged, broken, 
missing, or corroded 
pins and contacts.  
Notify FM to treat 
corrosion, if required.  
Notify FM for 
replacement if 
pins/contacts are 
damaged, broken, or 
missing pins. 

Any 
connector/contacts
are damaged, 
missing, or 
severely corroded. 

       
7 B  A USB Adapter Inspect the USB 

adapter’s port 
connectors for broken, 
missing, or corroded 
pins and contacts.  
Notify FM for 
replacement if 
pins/contacts are 
damaged, broken, or 
missing pins. 

Any 
connector/contacts
are damaged, 
missing, or 
severely corroded. 

 
 
END OF TASK 
 
END OF WORK PACKAGE 
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INITIAL SETUP 
Tools and Special Tools  References: 
 None     SF 361, Transportation Discrepancy Report 
      WP 0035 
 
 
SERVICE UPON RECEIPT OF EQUIPMENT 
 
Checking Unpacked Equipment 
 
The first step in the initial setup procedure is to unpack all SKL components.  Carefully unpack each 
component, remove any protective wrapping, and inspect for damage, (e.g., broken or bent connectors or 
cables).  If damage is detected, an assessment should be made to determine the extent of damages and 
possible adverse effect on system operations.  Damaged equipment components should be replaced, if 
possible, prior to system set up and operation.  Be sure to retain all protective wrappings and containers 
for further use as necessary.  It is recommended that the initial setup and start-up of the SKL be done 
using a stable power source.  Place the hardware components on a level surface near an AC power 
outlet.  Assemble the SKL on a flat surface. 
 
1. Inspect the equipment for damage done in shipment.  Report damage on SF-361 (Transportation 

Discrepancy Report). 
 
2. Check the equipment against the packing slip to make sure the equipment is complete.  Report all 

discrepancies in accordance with the instructions given in DA PAM 750-8. 
 
Standard AN/PYQ-10 (C) Simple Key Loader Configuration 

The standard AN/PYQ-10 (C) Simple Key Loader configuration will include the following items: 
 

• Simple Key Loader (SKL) 
• Stylus (2ea) 
• Battery Pack (2ea), 1ea High Capacity Lithium Ion Battery and 1ea Standard Lithium Ion Battery 
• Battery Charger Assembly 
• Crypto Ignition Key (CIK) 
• USB Adapter 

 
END OF TASK 
 
END OF WORK PACKAGE 
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INSTALLATION INSTRUCTIONS 
 
 
ASSEMBLING THE AN/PYQ-10(C) SIMPLE KEY LOADER 
 
Once you have unpacked the SKL (IAW Work Package 0034) and checked the components for damage 
and completeness, it is now time to assemble the SKL into a functional hand-held computer system.  The 
following procedure should be used to assemble the SKL and charge the battery. 
 
Standard AN/PYQ-10(C) Simple Key Loader Configuration 

The standard AN/PYQ-10 (C) Simple Key Loader configuration will include the following items: 
 

• Simple Key Loader (SKL) 
• Stylus (2ea) 
• Battery Pack (2ea), 1ea High Capacity Lithium Ion Battery and 1ea Standard Lithium Ion Battery 
• Battery Charger Assembly 
• Crypto Ignition Key (CIK) 
• USB Adapter 

 
Assembling the Battery Charger 
 
1. First install the Lithium-Ion Battery into the Battery Charger Station following the steps below.  Use 

Figure 1, Attaching the Battery to the Battery Charger Station, as a guide while following the 
instructions below. 

 
a. Take the battery in your hand and place the top end of the battery into the space provided on the 

front of the Battery Charger Station. 
 

b. Then drop the battery down so that the screw of the knurled knob mates with the threaded 
embedded nut and tighten the knurled knob in a clock-wise rotation until finger tight. 

 
 
 
 
 
 
 
 

Figure 1.  Attaching the Battery to the Battery Charger Station. 

Lithium-Ion 
Battery 

Battery 
Charger 
Station 

 
2. Follow the steps below to finish assembling the Battery Charger.  Use Figure 2, Battery Charger 

Assembly, as a guide while following the instructions below. 
 

a. Connect the DC power cord to the Battery Charger Station. 
 

b. Connect the female end of the AC Power cord to the AC/DC Converter. 
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AC Power 
Cord 

DC Power 
Cord 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 2.  Battery Charger Assembly. 
 

c. Now plug the male end of the AC Power cord into an AC outlet.  You should see an orange light 
at the top of the Battery Charger Station indicating that the Battery is being charged.  A fully 
discharged battery will take > 2 hours to fully charge.  When the light on the Battery Charger 
Station turns green it means that the battery is fully charged. 

 
END OF TASK 
 
Installing and Removing the Crypto Ignition Key (CIK) 
 
1. While the battery is being charged, the CIK if not already installed in the SKL can be installed.  Locate 

the CIK that came with your SKL and follow the instructions below to install it.  Figure 3, CIK 
Installation, will provide you with a visual reference to follow the instructions. 

 
CAUTION 

 
Never attempt to remove or insert the CIK while power in applied to the SKL.  Failure to 
follow these instructions may result in a CIK failure and/or KOV-21 Card failure. 

 
2. With the SKL facing you, open the CIK Access Door on the right side of the SKL. 
 
3. Pick up the CIK with the rounded end between your fingers.  Insert the CIK into the CIK slot.  The CIK 

is reversible and can be inserted either way.  Make sure the CIK is firmly seated in the CIK slot. 
 
4. Close and secure the CIK Access door.  
 
5. To remove the CIK, open the CIK Access Door and grab the CIK with your thumb and index finger 

and pull the CIK from the CIK slot. 
 
6. Close the CIK Access Door. 
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CIK
CIK Access 
Door  

 
Figure 3.  CIK Installation. 

 
END OF TASK 
 
Installing the Lithium-Ion Battery into the SKL 
 
To make the SKL operational, portable, and battlefield-useful, the Lithium-Ion Battery must be installed 
onto the SKL.  The following procedure describes the steps to install the battery into the SKL. 
 
1. When charging is complete (a green light on Battery Charger), remove the Lithium-Ion Battery from 

the Battery Charger Station by turning the thumbscrew counterclockwise until free and lifting the 
battery from the Battery Charger Station. 

 
2. Take the Battery in your hand and with the knurled knob at the bottom, place the top end of the 

Battery into the space provided on the back of the SKL as shown in Figure 4, Battery Installation. 
 
3. Then drop the Battery down so that the screw of the knurled knob mates with the threaded embedded 

nut and tighten the knurled knob in a clock-wise rotation until tight.  Do not use any tool to tighten the 
screw as this action can strip the threads on the housing. 
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Figure 4.  Battery Installation. 

 
END OF TASK 
 
Assembling the Optional Battery Eliminator 
 
The Battery Eliminator is an optional item listed on the Components of End Item List.  If the unit orders 
this item and wishes to use it with the SKL, the procedures to assemble and install the Battery Eliminator 
are provided below. 
 

CAUTION 
 

If you are changing the Battery Eliminator for the Battery and you have data stored 
in the SKL that you do not want to lose, you must make the change within 2 
minutes or you run the risk of losing your database. 

 
1. To assemble the Battery Eliminator, use Figure 5, Assembling the Battery Eliminator, as a guide while 

following the instructions below. 
 
2. Connect the female end of the AC Power cord to the AC/DC Converter.  Do not connect the male 

end of the AC Power cord to AC power at this time. 
 
3. Connect the DC power cord to the Battery Eliminator.  Make sure to route the DC power cord through 

the slot provided so that the SKL will lay flat when the Battery Eliminator is in use. 
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AC Power 
Cable 

Battery Eliminator
AC/DC Power 
Converter 

DC Power Cable 

Figure 5.  Assembling the Battery Eliminator. 
 
4. Now connect the Battery Eliminator to the SKL the same way that you would connect the Lithium-Ion 

Battery.   
 
5. Once the Battery Eliminator is installed on to the SKL, turn the SKL over so that the face of the SKL is 

facing you.  Now plug the male end of the AC Power cord into an AC outlet.  You may now power up 
the SKL using the Battery Eliminator as your power source. 

 
END OF TASK 
 
Assembling the Optional AA Battery Pack 
 
The AA Battery Pack is an optional power source for the SKL.  It uses 8 AA batteries that are housed in a 
battery case that is water tight and can be mated to the back of the SKL in the same manner as the 
Lithium-Ion Battery Pack.  Use the following procedure to install the batteries in the AA Battery Pack and 
then install the AA Battery Pack to the back of the SKL. 
 
1. Open the AA Battery Pack by releasing the latches on the side of the Battery Pack.  Install the AA 

batteries according to the diagram inside the AA Battery Pack making sure to get the polarity of the 
AA Batteries correct.  You must install eight (8) AA batteries into the AA Battery Pack for it to work 
and provide proper emergency power to the SKL.  Figure 6, AA Battery Placement shows how the 
batteries are to be inserted. 
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Figure 6.  AA Battery Placement. 

 
2. Close the AA Battery Pack after the batteries have been installed correctly.  Then mate the AA 

Battery Pack to the back of the SKL as shown in Figure 7, AA Battery Pack Installation, below. 
 

 
Figure 7.  AA Battery Pack Installation. 

 
3. Make sure the hinge for the AA Battery Pack is on your right side when mating the battery pack to the 

battery housing.  Then tighten the knurled knob clockwise until finger tight.  Once the AA Battery Pack 
is installed, turn on the SKL and check for correct SKL operation.  

 
END OF TASK 
 
 
END OF WORK PACKAGE 
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MAINTENANCE INSTRUCTIONS 
 
 
MAINTENANCE PROCEDURES 
 
Field maintenance for the AN/PYQ-10 (C), Simple Key Loader (SKL) consists of the Field maintenance 
representative verifying the device and/or components are defective before these items are evacuated for 
warranty service.  The Field Maintainer is also authorized to replace certain parts on the SKL that are 
defective or missing.  See the Maintenance Allocation Chart (MAC) for a determination of what these 
parts are. 
 
Replacing the SKL Battery Receptacle O-Ring 
 
There is an O-Ring on the backside of the SKL at the bottom of the battery receptacle area.  This O-Ring 
mates up to the Lithium-Ion Battery.  This O-Ring forms a moisture barrier around the contacts of the 
battery and battery receptacle.  This O-Ring will wear out over time and through use; therefore, it will 
need to be replaced periodically.  Use the following procedure to replace the O-Ring on the Battery 
Receptacle. 
 
1. Turn the SKL over so that the back of the SKL is facing you.  Make sure that the Lithium-Ion battery is 

removed from the SKL.  Use the Pliers and Alignment Tool shown in the Additional Authorized List 
(AAL) (WP 0045 Items 6 & 7) to remove the O-Ring from the SKL Battery Receptacle.  Look at the 
picture in Figure 1, SKL Battery Receptacle O-Ring Replacement, below. 

O-Ring 

Figure 1.  SKL Battery Receptacle O-Ring Replacement. 
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CAUTION 
 

Do not use any metal object to remove the O-Ring from the SKL Battery Receptacle 
area.  Using a metal object to remove the O-Ring could damage the surface that the 
O-Ring mates with causing the O-Ring to prematurely fail. 

 
2. Work the Alignment Tool under the O-Ring so that it can be stretched over the battery contacts and 

removed. 
 
3. Once the O-Ring has been removed from the SKL Battery Receptacle, use a clean cloth and clean 

the area the O-Ring was removed from prior to installing a new O-Ring. 
 
4. Now locate the new O-Ring.  It should look like the one depicted in Figure 2, SKL Battery Receptacle 

O-Ring, below. 
 
 
 

Figure 2.  SKL Battery Receptacle O-Ring. 
 
5. Once the new O-Ring has been located, inspect the O-Ring for any damage prior to installation. 
 
6. With clean hands, take the new O-Ring and gently stretch it and place it in the space provided in the 

SKL Battery Receptacle area.  Using your fingers make sure the new O-Ring is seated properly.  Do 
not use any adhesive to retain the O-Ring.  It should stay in the space provided without any adhesive. 

 
7. Take a clean cloth and gently wipe the battery contacts and surrounding area to remove any dirt, 

grease, or other substances.  The SKL Battery Receptacle is now ready for use. 
 
END OF TASK 
 
Replacing the Side Door Radial and Face Seal O-Rings 
 
The door on the right side of the SKL provides a moisture barrier for the USB ports and the CIK.  This 
moisture barrier is made up of two O-Rings mating together.  The first one is on the SKL housing and is 
called the Radial O-Ring.  The second one is on the door and it is called the Compression O-Ring.  These 
O-Rings will wear out over time and through use; therefore, they will need to be replaced periodically.  
Replace these O-Rings in pairs. 
 
Replacing the Side Door Radial O-Ring. 
 
1. Open the side door of the SKL.  Use the Pliers and Alignment Tool shown in the Additional 

Authorized List (AAL) (WP 0045 Items 6 & 7) to remove the Radial O-Ring from the SKL Side Door 
Housing.  Look at the picture in Figure 3, SKL Side Door Radial O-Ring Replacement, below to help 
you with this procedure. 
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Figure 3.  SKL Side Door Radial O-Ring Replacement. 
 

CAUTION 
 

Do not use any metal object to remove the O-Ring from the SKL Side Door 
Housing.  Using a metal object to remove the O-Ring could damage the surface 
that the O-Ring mates with causing the O-Ring to prematurely fail. 

 
2. Work the Alignment Tool under the O-Ring so that it can be stretched enough to remove it. 
 
3. Once the O-Ring has been removed from the SKL Side Door Housing, use a clean cloth and clean 

the area the O-Ring was removed from prior to installing a new O-Ring. 
 
4. Now locate the new O-Ring.  It should look like the one depicted in Figure 4, SKL Side Door Radial 

O-Ring, below. 
 
 
 
 

Figure 4.  SKL Side Door Radial O-Ring. 
 
5. Once the new O-Ring has been located, inspect the O-Ring for any damage prior to installation. 
 
6. With clean hands, take the new O-Ring and gently stretch it and place it in the space provided in the 

SKL Side Door Housing area.  Using your fingers make sure the new O-Ring is seated properly.  Do 
not use any adhesive to retain the O-Ring.  It should stay in the space provided without any adhesive. 

 
7. Take a clean cloth and gently wipe the Radial O-Ring to remove any dirt, grease, or other 

substances. 
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END OF TASK 
 
Replacing the Side Door Face Seal O-Ring. 
 
1. Open the side door of the SKL.  Use the Pliers and Alignment Tool shown in the Additional 

Authorized List (AAL) (WP 0045 Items 6 & 7) to remove the Face Seal O-Ring from the SKL Side 
Door.  Look at the picture in Figure 5, SKL Side Door Face Seal O-Ring Replacement, below to help 
you with this procedure. 

 

 

Side Door 
Face Seal O-Ring 

Figure 5.  SKL Side Door Face Seal O-Ring Replacement. 
 

CAUTION 
 

Do not use any metal object to remove the O-Ring from the SKL Side Door 
Housing.  Using a metal object to remove the O-Ring could damage the surface 
that the O-Ring mates with causing the O-Ring to prematurely fail. 

 
2. Work the Alignment Tool under the O-Ring so that it can be stretched enough to be removed. 
 
3. Once the O-Ring has been removed from the SKL Side Door, use a clean cloth and clean the area 

the O-Ring was removed from prior to installing a new O-Ring. 
 
4. Now locate the new O-Ring.  It should look like the one depicted in Figure 6, SKL Side Door Face 

Seal O-Ring, below. 
 
 
 
 

Figure 6.  SKL Side Door Face Seal O-Ring. 
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5. Once the new O-Ring has been located, inspect the O-Ring for any damage prior to installation. 
 
6. With clean hands, take the new O-Ring and gently stretch it and place it in the space provided on the 

SKL Side Door.  Using your fingers make sure the new O-Ring is seated properly.  Do not use any 
adhesive to retain the O-Ring.  It should stay in the space provided without any adhesive. 

 
7. Take a clean cloth and gently wipe the Radial O-Ring to remove any dirt, grease, or other 

substances. 
 
END OF TASK 
 
Replacing The Fill Port Dust Cover 
 
The SKL Fill Port is protected by a Urethane Dust Cover that keeps out moisture, dirt, and other 
undesirable substances.  This Urethane Dust Cover can be damaged through use.  Use the following 
procedure to replace the Fill Port Dust Cover  
 
1. If the Fill Port Dust Cover is missing or damaged were it will not perform its protective function, then 

replacement is required.   
 
2. Now locate the new Fill Port Dust Cover that was ordered.  It should look like the one in Figure 7, Fill 

Port Dust Cover, below. 

 
Figure 7.  Fill Port Dust Cover. 

 
3. Follow along with the steps below using Figure 8, Installation of Fill Port Dust Cover, as your guide.   
 

a. Remove the Urethane cap if still on the fill port.  Using your fingers un-screw the knurled nut in a 
counter-clockwise motion as shown in item 1 below.  

 
b. Once the knurled nut is removed, lift the Fill Port cover or what is left of the cover off of the 

threaded post as shown in item 2 below. 
 

c. Insert the new Fill Port cover over the threaded post making sure that the cover opening is facing 
up and then using your fingers screw the knurled nut in a clockwise motion as shown in item 3 
below. 

 
d. Once the nut is finger tight, put the Fill Port cover over the Fill port as shown in item 4 below. 
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Figure 8.  Installation of the Fill Port Dust Cover. 
 

ND OF TASK 

eplacing The Zeroize Button Cover 

he Zeroize Button Cover provides security against accidental zeroization of the SKL UAS database.  It 

 In the 

CAUTION 
 

You will need to be very careful when replacing the Zeroize Button Cover so as to 

 
 

. The Zeroize Button Cover is held in place by an E-Ring.  This E-Ring provides the necessary 
 

ake 

 

 
Figure 9.  Zeroize Button Cover. 

E
 
R
 
T
also provides a limited barrier to the elements.  The Zeroize Button Cover should be inspected for 
workability and damage during normal PMCS and before any mission where the SKL will be used. 
event that the Zeroize Button Cover does not work properly or the cover is damaged, it should be 
replaced.  Follow the procedures below to replace the Zeroize Button Cover. 
 

not accidentally depress the Zeroize Button.  Depressing the Zeroize Button will 
cause the SKL to immediately begin an irrevocable zeroization process.  It does 
not matter if the SKL is powered up or powered down, the process will be 
accomplished, and all data stored in the SKL UAS database will be erased.

1
pressure on the Zeroize Button Cover so that it will not swing open without assistance.  This is
important since the cover protects the Zeroize Button from accidentally being depressed.  First m
sure you have a new Zeroize Button Cover before starting this procedure.  It should look like the one 
in Figure 9, Zeroize Button Cover, below. 
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2. Once you have the new cover, in the AAL (WP0045, Item 8) to 

remove the E-Ring that holds the cover in place, making sure that the cover if not missing is, covering 

 

 
. Now that the E-Ring is removed, remove the washer under the E-Ring.  The cover can now be 

removed.  Using your fingers lift t e Zeroize Button Cover Post as 
shown in Figure 11, Zeroize Button Cover Removal, below. 

 
 

val. 

. Using a clean cloth and being careful not to depress the Zeroize Button, clean the post of any dirt, oil, 
or grease. 

use the Flat Tip Screwdriver shown 

the Zeroize Button.  Remove the E-Ring as shown in Figure 10, E-Ring Removal, below. 

Figure 10.  E-Ring Removal. 

3
he cover straight up and off of th

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 11.  Zeroize Button Cover Remo
 
4
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5. Now take the new Zeroize Button Cover and using your fingers gently lower the cover over the post 

making sure to cover the Zeroize Button as shown in Figure 12, Zeroize Button Cover Installation, 

 

6. Using a clean cloth, clea .  Take the washer and 
position it over the post.  Then take the E-Ring and position it so that the opening of the E-Ring fits 

 

 

 

below. 

Figure 12.  Zeroize Button Cover Installation. 
 

n the E-Ring and washer of any dirt, oil, or grease

snugly against the post.  Take Flat Tip Screwdriver and push the E-Ring onto the post and over the
washer.  See Figure 13, E-Ring Installation, below. 

Figure 13.  E-Ring Installation. 
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7. Once the E-Ring is in place open the Zeroize Button Cover and check for ease of movement and that 

 
ND OF TASK 

eplacing The Stylus Lanyard 

ach Inductive Stylus is secured to the SKL through the use of a lanyard.  If the lanyard is cut or 
The 

. The first step is replacing the Lanyard is the removal of the old lanyard from the SKL and stylus.  To 

 
. Make sure that you have the new Lanyard and Split Rings.  They should look like the ones in 

 
nyard and Split Rings. 

3. Starting on the Stylus first, ta  it through a Split Ring and then 
feed the lanyard through the attachment ring on the Stylus (see 1 below).  Then loop the Lanyard 

 

when closing the Zeroize Button Cover there is a click indicating that the cover is securely closed.  If 
the cover passes these simple tests the cover has been replaced correctly. 

E
 
R
 
E
otherwise damaged so that the stylus is no longer secured to the SKL lanyard must be replaced.  
following procedures should be followed to replace the stylus lanyard. 
 
1

remove the lanyard, cut the lanyard from both the SKL and the stylus. 

2
Figure 14, Lanyard and Split Rings, below. 

Figure 14.  La
 

ke the new Lanyard and feed one end of

back through the Split Ring (see 2 below).  Slide the Split down the Lanyard toward the attachment 
ring on the Stylus allowing sufficient clearance to allow the Lanyard to move freely on the attachment 
ring and then take the Short Nosed Pliers shown in the AAL (WP0045, Item 7) and crimp the Split 
Ring to secure the Lanyard to the Stylus Attachment Ring making sure not to sever the Lanyard (see 
3 below).  See Figure 15, Lanyard Replacement on Stylus, below. 
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Figure 15.  Lanyard Replacement on Stylus. 

 
4. Now take the other end of the Lanyard and feed it through the other Split Ring and then feed the 

lanyard through the attachment ring on the SKL (see 1 below).  Then loop the Lanyard back through 
the Split Ring (see 2 below).  Slide the Split down the Lanyard toward the attachment ring on the SKL 
allowing sufficient clearance to allow the Lanyard to move freely on the attachment ring.  Take the 
Short Nosed Pliers shown in the AAL (WP0045, Item 7) and crimp the Split Ring to secure the 
Lanyard to the Stylus Attachment Ring making sure not to sever the Lanyard (see 3 below).  Use the 
diagram in Figure 16, Lanyard Replacement on the SKL, below to guide you through the procedure. 

 

Figure 16.  Lanyard Replacement on the SKL. 
 

. Now cut off any excess Lanyard material at both the Stylus and SKL attachment points to clean up 

 
ND OF TASK 

eplacing The AA Battery Pack O-Ring (Optional Item) 

k.  This O-Ring forms a moisture barrier for 

 

 
5

the installation. 

E
 
R
 

here is an O-Ring on the on the inside of the AA Battery PacT
the batteries when the AA Battery Pack cover is closed.  This O-Ring will wear out over time; therefore, it 
will need to be replaced periodically.  Use the following procedure to replace the O-Ring on the AA 
Battery Pack. 
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1. Open the cover of the AA Battery Pack.  Use the Pliers and Alignment Tool shown in the Additional 

Authorized List (AAL) (WP 0045 Items 6 & 7) to remove the O-Ring from the AA Battery Pack.  Look 
at the picture in Figure 17, AA Battery Pack O-Ring Replacement, below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

AA Battery Pack 
O-Ring 

Figure 17.  AA Battery Pack O-Ring Replacement. 
 

CAUTION 
 

Do not use any metal object to remove the O-Ring from the AA Battery Pack.  
Using a metal object to remove the O-Ring could damage the surface that the O-
Ring mates with causing the O-Ring to prematurely fail. 

 
2. Work the Alignment Tool under the O-Ring so that it can be stretched enough to remove it. 
 
3. Once the O-Ring has been removed from the AA Battery Pack, use a clean cloth and clean the area 

the O-Ring was removed from prior to installing a new O-Ring. 
 
4. Now locate the new O-Ring.  It should look like the one depicted in Figure 18, AA Battery Pack O-

Ring, below. 
 
 
 
 
 
 

Figure 18.  AA Battery Pack O-Ring. 
 
5. Once the new O-Ring has been located, inspect the O-Ring for any damage prior to installation. 
 
6. With clean hands, take the new O-Ring and gently stretch it and place it in the space provided on the 

AA Battery Pack.  Using your fingers make sure the new O-Ring is seated properly.  Do not use any 
adhesive to retain the O-Ring.  It should stay in the space provided without any adhesive.   

 
END OF TASK 
 
 
END OF WORK PACKAGE 
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FIELD MAINTENANCE 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
 

 
INTRODUCTION 
 
 
SCOPE 
 
This RPSTL lists and authorizes spares and repair parts; special tools; special test, measurement, and 
diagnostic equipment (TMDE); and other special support equipment required for performance of field 
maintenance of the Transfer Unit, Cryptographic Key AN/PYQ-10(C), also referred to as the Simple Key 
Loader (SKL).  It authorizes the requisitioning, issue, and disposition of spares, repair parts, special tools 
as indicated by the source maintenance and recoverability (SMR) codes. 
 
GENERAL 
 
In addition to the Introduction work package, this RPSTL is divided into the following work packages.   
 
1. Repair Parts List Work Package.  Work packages containing lists of spares and repair parts 

authorized by this RPSTL for use in the performance of maintenance.  These work packages also 
include parts that must be removed for replacement of the authorized parts.  Parts lists are composed 
of functional groups in ascending alphanumeric sequence, with the parts in each group listed in 
ascending figure and item number sequence.  Sending units, brackets, filters, and bolts are listed with 
the component they mount on.  Bulk materials are listed by item name in FIG. BULK at the end of the 
work packages.  Repair parts kits are listed separately in their own functional group and work 
package.  Repair parts for reparable special tools are also listed in a separate work package.  Items 
listed are shown on the associated illustrations. 

 
2. Special Tools List Work Package.  Not applicable. 
 
3. Cross-Reference Indexes Work Packages.  There are 2 cross-reference indexes work packages in 

this RPSTL; the National Stock Number (NSN) Index work package and the Part Number (P/N) Index 
work package.  The National Stock Number Index work package refers you to the figure and item 
number.  The Part Number Index work package refers you to the figure and item.   

 
EXPLANATION OF COLUMNS IN THE REPAIR PARTS LIST AND SPECIAL TOOLS LIST WORK 
PACKAGES 
 
Item No.  (Column (1).  Indicates the number used to identify items called out in the illustration. 
   
SMR Code.  (Column (2).  The Source, Maintenance, and Recoverability (SMR) code is a 5-position 
code containing supply/requisitioning information, maintenance level authorization criteria, and disposition 
instructions, as shown in the following breakout: 
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Table 1.  SMR Code Explanation. 
 
 Source Maintenance Recoverability  
  
  Code       Code        Code 
 
 
 
 XX XX X 
 
 
 
 1st two positions. 3rd position. 4th position. 5th position. 
  
 How you get an item. Who can install, Who can do Who determines 
  replace or use complete repair* disposition action 
  the item. (see note) on on an unserviceable  
   the item item.  
 
 

NOTE 
 

* Complete Repair:  Maintenance capacity, capability, and authority to perform all 
the corrective maintenance tasks of the “Repair” function in a use/user 
environment in order to restore serviceability to a failed item. 

 
Source Code.  The source code tells you how you get an item needed for maintenance, repair, or 
overhaul of an end item/equipment.  Explanations of source codes follow: 

 
Code  Application/Explanation 
   
PA 
PB 
PC** 
PD 
PE 
PF 
PG 
PH 
PR 
PZ 

 Stocked items; use the applicable NSN to request/requisition items with 
these source codes.  They are authorized to the level indicated by the 
code entered in the 3rd position of the SMR code.  
 
 
 
NOTE:  ** Items coded PC are subject to deterioration. 

 
 

 
KD 
KF 
KB 

 Items with these codes are not to be requested/requisitioned 
individually.  They are part of a kit which is authorized to the 
maintenance level indicated in the third position of the SMR code.  The 
complete kit must be requisitioned and applied. 
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MO-Made at Field 
(service)/ AMC level 
 
MF-Made at 
Field/ASB level 
 
MH-Made at below 
depot sustainment 
level 
 
ML-Made at 
Specialized Repair 
Activity (SRA)/ TASMG 
 
MD-Made at 
Depot 
 
MG- Navy only. 

  
 
 
 
Items with these codes are not to be requested and/or 
requisitioned individually.  They must be made from bulk 
material which is identified by the part number in the 
Description and Usable On Code (UOC) column and listed 
in the Bulk Material group of the repair parts list.  If the item 
is authorized to you by the 3rd position character of the 
SMR code, but the source code indicates it is made at a 
higher level, order the item from the higher level of 
maintenance. 

 
 

 
AO-Assembled by 
Field (service)/AMC 
level 
 
AF-Assembled by 
Field/ASB level 
 
AH-Assembled by 
Below depot 
Sustainment level 
 
AL-Assembled by 
Specialized Repair 
Activity (SRA)/TASMG 
 
AD-Assembled by 
Depot 
 
AG-Navy only 
 

  
 
 
 
 
Items with these codes are not to be 
requested/requisitioned individually.  The parts that make 
up the assembled item must be requisitioned or fabricated 
and assembled at the level of maintenance indicated by the 
source code.  If the 3rd position character of the SMR code 
authorized you to replace the item, but the source code 
indicates the item is assembled at a higher level, order the 
item from the higher level of maintenance. 

 
Code Explanation 
  
XA - Do not requisition an "XA" - coded item.  Order its next higher assembly, refer to NOTE below. 

  
XB - If an item is not available from salvage, order it using the CAGE and part number given. 

  
XC - Installation drawings, diagrams, instruction sheets, field service drawings; identified by 

manufacturer's P/N. 
  

XD - Item is not stocked.  Order an XD-coded item through local purchase or normal supply channels 
using the CAGEC and P/N given, if no NSN is available. 
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NOTE 
 

Cannibalization or controlled exchange, when authorized, may be used as a source 
of supply for items with the above source codes, except for those items source 
coded “XA” or those aircraft support items restricted by requirements of AR 750-1. 

 
Maintenance Code.  Maintenance codes tell you the level(s) of maintenance authorized to use and 
repair support items.  The maintenance codes are entered in the third and fourth positions of the SMR 
code as follows: 
 
Third Position.  The maintenance code entered in the third position tells you the lowest maintenance 
level authorized to remove, replace, and use an item.  The maintenance code entered in the third position 
will indicate authorization to one of the following levels of maintenance. 
 
Maintenance 
Code 

Application/Explanation 

  
C - Crew or operator maintenance done within organizational or aviation unit 

maintenance. 
  

O* - Organizational or aviation unit category can remove, replace, and use the item. 
  

F - Direct support or aviation intermediate level can remove, replace, and use the item. 
  

H - General support level can remove, replace, and use the item. 
  

L - Specialized repair activity can remove, replace, and use the item. 
  

G - Afloat and ashore intermediate maintenance can remove, replace, and use the item 
(Navy only. 

  
K - Contractor facility can remove, replace, and use the item. 

  
Z - Item is not authorized to be removed, replaced, or used at any maintenance level. 

  
D - Depot can remove, replace, and use the item. 

 
NOTE 

 
Army may use C in the third position.  However, for joint service publications, 
Army will use O. 

 
Fourth Position.  The maintenance code entered in the fourth position tells you whether or not the item is 
to be repaired and identifies the lowest maintenance level with the capability to do complete repair; (i.e., 
perform all authorized repair functions). 
 

NOTE 
 

Some limited repair may be done on the item at a lower category of maintenance if 
authorized by the Maintenance Allocation Chart (MAC) and SMR codes. 

 
Maintenance 
Code 

Applicability/ Explanation 

  
O - Field (service)/AMC is the lowest level that can do complete repair of the item. 
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Maintenance 
Code 

Applicability/ Explanation 

F - Field ASB is the lowest level that can do complete repair of the item. 
  

H - Below depot sustainment is the lowest level that can do complete repair of the item.  
  

L - Specialized repair activity/TASMG (enter specialized repair activity designator) is 
the lowest level that can do complete repair of the item. 

  
D - Depot is the lowest level that can do complete repair of the item. 

  
G - Both afloat and ashore intermediate levels are capable of complete repair of item.  

(Navy only) 
  

K - Complete repair is done at contractor facility 
  

Z - Nonrepairable.  No repair is authorized. 
  

B - No repair is authorized.  No parts or special tools are authorized for the 
maintenance of a “B” coded item.  However, the item may be reconditioned by 
adjusting, lubricating, etc., at the user level. 

 
Recoverability Code.  Recoverability codes are assigned to items to indicate the disposition action on 
unserviceable items.  The recoverability code is shown in the fifth position of the SMR code as follows: 
 
Recoverability 
Code 

Application/Explanation 

  
Z - Nonrepairable item.  When unserviceable, condemn and dispose of the item at the 

level of maintenance shown in 3rd position of SMR Code. 
  

O - Repairable item.  When uneconomically repairable, condemn and dispose of the 
item at organizational or aviation unit level. 

  
F - Repairable item.  When uneconomically repairable, condemn and dispose of the 

item at field level. 
  

H - Repairable item.  When uneconomically repairable, condemn and dispose of the 
item at field level. 

  
D - Repairable item.  When beyond lower level repair capability, return to depot.  

Condemnation and disposal of item not authorized below depot level. 
  

L - Repairable item.  Condemnation and disposal not authorized below Specialized 
Repair Activity (SRA)/TASMG. 

  
A - Item requires special handling or condemnation procedures because of specific 

reasons (e.g., precious metal content, high dollar value, critical material, or 
hazardous material).  Refer to appropriate manuals/directives for specific 
instructions. 

  
G - Filed level reparable item.  Condemn and dispose at either afloat or ashore 

intermediate levels.  (Navy only) 
  

K - Reparable item.  Condemnation and disposal to be performed at contractor facility. 
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NSN (Column (3).  The National Stock Number (NSN) for the item is listed in this column. 
 
CAGEC (Column (4).  The Commercial and Government Entity Code (CAGEC) is a 5-digit code which is 
used to identify the manufacturer, distributor, or Government agency etc. that supplies the item. 
   
Part Number (Column (5).  Indicates the primary number used by the manufacturer (individual, 
company, firm, corporation, or Government activity), which controls the design and characteristics of the 
item by means of its engineering drawings, specifications, standards, and inspection requirements to 
identify an item or range of items. 
 

NOTE 
 

When you use an NSN to requisition an item, the item you receive may have a 
different part number from the number listed. 

 
Description and Usable On Code (UOC) (Column (6).  This column includes the following information. 
 
1. The Federal item name and, when required, a minimum description to identify the item. 
 
2. Part Numbers of bulk materials are referenced in this column in the line entry to be manufactured or 

fabricated. 
 
3. Hardness Critical Item (HCI).  A support item that provides the equipment with special protection from 

electromagnetic pulse (EMP) damage during a nuclear attack. 
 
4. The statement "END OF FIGURE" appears just below the last item description in Column (6) for a 

given figure in both the repair parts list and special tools list work packages.. 
 
Qty (Column (7).  Indicates the quantity of the item used in the breakdown shown on the illustration 
figure, which is prepared for a functional group, sub functional group, or an assembly.  A "V" appearing in 
this column in lieu of a quantity indicates that the quantity is variable and that the quantity may vary from 
application to application. 
 
EXPLANATION OF CROSS-REFERENCE INDEXES WORK PACKAGES FORMAT AND COLUMNS  
 
1. National Stock Number (NSN) Index Work Package.  NSNs in this index are listed National Item 

Identification Number (NIIN) sequence.. 
 
STOCK NUMBER Column.  This column lists the NSN in NIIN sequence.  The NIIN consists of the last 
nine digits of the NSN.  When using this column to locate an item, ignore the first four digits of the NSN.  
However, the complete NSN should be used when ordering items by stock number.  For example, if the 
NSN is 5385-01-574-1476, the NIIN is 01-574-1476. 
 
FIGURE Column.  This column lists the number of the figure where the item is identified/located.  The 
figures are in numerical order in the repair parts list and special tools list work packages. 
 
ITEM Column.  The item number identifies the item associated with the figure listed in the adjacent Fig. 
column.  This item is also identified by the NSN listed on the same line. 
 
2. Part Number (P/N) Index Work Package.  Part numbers in this index are listed in ascending 

alphanumeric sequence (vertical arrangement of letter and number combinations which places the 
first letter or digit of each group in order A through Z, followed in the numbers 0 through 9 and each 
following letter or digit in like order ).. 

 
PART NUMBER Column.  This column indicates the part number assigned to the item.   
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FIGURE Column.  This column lists the number of the figure where the item is identified/located in the 
repair parts list and special tools list work packages. 
 
ITEM Column.  This column lists the number assigned to the item as it appears in the figure referenced in 
the adjacent figure number column. 
 
SPECIAL INFORMATION 
 
Usable On Code (UOC).  The usable on code appears in the lower left corner of the description column 
heading.  Usable on codes are shown as "UOC:" in the Description Column (justified left) on the first line 
applicable item nomenclature.  Uncoded items are applicable to all models.  Identification of the usable on 
codes used in this RPSTL are:   
 

Code Used On 
  
TBD AN/PYQ-10(C) 

 
HOW TO LOCATE REPAIR PARTS 
 
1. When NSNs or Part Numbers Are Not Known. 
 
First.  Using the table of contents, determine the assembly group to which the item belongs.  This is 
necessary since figures are prepared for assembly groups and subassembly groups, and lists are divided 
into the same groups. 
 
Second.  Find the figure covering the functional group or the sub-functional group to which the item 
belongs. 
 
Third.  Identify the item on the figure and note the number(s). 
 
Fourth.  Look in the repair parts list work packages for the figure and item numbers.  The NSNs and part 
numbers are on the same line as the associated item numbers. 
 
2. When the NSN is known: 
 
First.  If you have the NSN, look in the STOCK NUMBER column of the NSN index work package. The 
NSN is arranged in NIIN sequence.  Note the figure and item number next to the NSN. 
 
Second.  Turn to the figure and locate the item number.  Verify that the item is the one you are looking 
for. 
 
3. When Part Number Is Known. 
 
First.  If you have the part number and not the NSN, look in the PART NUMBER column of the part 
number index work package.  Identify the figure and item number. 
 
Second.  Look up the item on the figure in the applicable repair parts list work package. 
 
ABBREVIATIONS 
 
(Not applicable.) 
 
 
END OF WORK PACKAGE 
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REPAIR PARTS LIST 
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Figure 1.  Transfer Unit, Cryptographic Key, AN/PYQ-10 (C), Simple Key Loader (SKL). 
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Figure 2.  Transfer Unit, Cryptographic Key, AN/PYQ-10(C), Simple Key Loader (SKL). 
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Table 1.  Transfer Unit, Cryptographic Key, AN/PYQ-10 (C), Simple Key Loader (SKL) Parts List. 
 
Item 

# 
SMR 
Code 

NSN CAGEC Part Number Description and Usable 
on Code (UOC) 

Qty 

01 PAODD 5810-01-517-3587 3CN36 200-00001-001 Transfer Unit, 
Cryptographic Key, 
AN/PYQ-10 (C), also 
referred to as the Simple 
Key Loader (SKL) 

1ea 

       
02 PAOZZ 5340-01-524-9480 3CN36 230-00038-01 Fill Port Dust Cover 1ea 
       
03 PAOZZ 5365-01-524-9820 3CN36 270-00042-01 Zeroize Button Cover 

retaining E-Ring 
1ea 

       
04 PAOZZ 5310-01-524-9457 3CN36 270-00041-01 Zeroize Button Cover 

Washer 
1ea 

       
05 PAOZZ 5340-01-524-9816 3CN36 230-00040-01 Zeroize Button Cover 1ea 
       
06 PAOZZ 5895-01-525-0352 3CN36 220-00073 Stylus Lanyard 2ea 
       
07 PAOZZ 7520-01-524-9762 3CN36 200-00054 Stylus, Inductive 2ea 
       
08 PAOZZ 5331-01-525-2035 3CN36 250-00005-01 Battery Receptacle O-Ring 1ea 
       
09 PAOZZ 5331-01-545-0210 3CN36 250-00008-01 Side Door O-Ring (radial) 1ea 
       
10 PAOZZ 5331-01-525-2064 3CN36 250-00009-01 Side Door O-Ring (face 

seal) 
1ea 

       
11 PAOZZ 5330-01-525-2011 3CN36 250-00020-01 AA Battery Pack O-Ring 1ea 
       
12 PAOZZ 6130-01-525-2788 3CN36 200-00006-01 Battery Pack (Li-Ion)  

High Capacity 
1ea 

       
13 PAOZZ 6130-01-525-1635 3CN36 200-00005-01 Battery Pack (Li-Ion) 

Standard Capacity 
1ea 

       
14 PAOZZ 6130-01-548-1505 3CN36 200-00056 Battery Charger Assembly 1ea 
       
15 PAOZZ 5810-01-529-8767 3CN36 450-00012-01 CIK 1ea 
       
16 PAOZZ 5995-01-545-0167 3CN36 290-00008-01 USB Adapter 1ea 
 
 
END OF WORK PACKAGE 
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FIELD MAINTENANCE 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
 

 
REPAIR PARTS NSN INDEX 
 
 

Table 1.  National Stock Number Index. 
 

Stock Number Figure Item 
5810-01-517-3587 1 1 

   
5310-01-524-9457 1 4 

   
5340-01-524-9480 1 2 

   
7520-01-524-9762 1 7 

   
5340-01-524-9816 1 5 

   
5365-01-524-9820 1 3 

   
5895-01-525-0352 1 6 

   
6130-01-525-1635 2 13 

   
5330-01-525-2011 1 11 

   
5331-01-525-2035 1 8 

   
5331-01-525-2064 1 10 

   
6130-01-525-2788 2 12 

   
5810-01-529-8767 2 15 

   
5995-01-545-0167 2 16 

   
5331-01-545-0210 1 9 

   
6130-01-548-1505 2 14 

 
 
 
END OF WORK PACKAGE 
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FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
 

 
REPAIR PARTS, PART NUMBER INDEX 
 
 

Table 1.  Part Number Index. 
 

Part Number Figure Item 
200-00001-001 1 1 

   
200-00005-01 2 13 

   
200-00006-01 2 12 

   
200-00054 1 7 

   
200-00056 2 14 

   
220-00073 1 6 

   
230-00038-01 1 2 

   
230-00040-01 1 5 

   
250-00005-01 1 8 

   
250-00008-01 1 9 

   
250-00009-01 1 10 

   
250-00020-01 1 11 

   
270-00042-01 1 3 

   
270-00080 1 4 

   
290-00008-01 2 16 

   
450-00012-01 2 15 

 
 
END OF WORK PACKAGE 
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SUPPORTING INFORMATION 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
 

 
REFERENCES 
 
 
ARMY REGULATIONS 
 
 Information Assurance ............................................................................................................  AR 25-2
Reporting of Item and Packaging Discrepancies........................................................................AR 735-11-2 
 
COMMON TABLES OF ALLOWANCE 
 
Expendable Items (Except Medical, Class V, Repair Parts, and Heraldic Items)........................CTA 50-970 
 
FIELD MANUALS 
 
First Aid for Soldiers......................................................................................................................FM 4-25.11 
 
FORMS 
 
Boxes, Shipping, Reusable w/Cushioning ..............................................................................PPP-B-1672D 
Recommended Changes to Publications and Blank Forms ....................................................DA Form 2028 
Equipment Inspection and Maintenance Worksheet ...............................................................DA Form 2404 
Equipment Maintenance and Inspection Worksheet ............................................................ DA Form 5988-E 
Packaging Army General Supplies .................................................................................................. SB 746-1 
Reporting of Item and Packaging Discrepancies................................................................................ SF 364 
Transportation Discrepancy Report .................................................................................................... SF 361 
Product Quality Deficiency Report ...................................................................................................... SF 368 
Federal Property Management Regulation (FPMR), Code of Federal Regulations, Title 41, Chapter 101, 
Public Contracts  and Property Management.  
 
MILITARY STANDARDS  
 
Marking for Shipment and Storage ........................................................................................... MIL-STD-129 
 
PAMPHLETS 
 
Consolidation Index of Army Publications and Blank Forms .................................................. DA Pam 25-30
Security Procedures for Controlled Cryptographic Items ...................................................DA Pam 25-380-2 
The Army Maintenance Management System (TAMMS) User Manual.................................. DA Pam 750-8 
 
TECHNICAL BULLETINS 
 
Warranty Bulletin for the Transfer Unit, Cryptographic Key, AN/PYQ-10 (C)..................TB 11-5810-410-24 
Safety Requirements for Maintenance of Electrical and Electronic Equipment............................... TB 385-4 
Security Procedures for Safeguarding, Accounting, and Supply Control of COMSEC Material ... TB 380-41 
 
TECHNICAL MANUALS 
 
Procedures for Destruction of Electronics Material to Prevent Enemy Use .............................. TM 750-244-2 
 
 END OF WORK PACKAGE 
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SUPPORTING INFORMATION 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
 

 
MAINTENANCE ALLOCATION CHART (MAC) INTRODUCTION 
 
 
GENERAL 
 
This Work Package provides a summary of the maintenance operations for Transfer Unit, Cryptographic 
Key, AN/PYQ-10 (C).  It authorizes categories of maintenance for specific maintenance functions on 
repairable items and components and lists the tools and equipment required to perform each function.  
This Work Package may be used as an aid in planning maintenance operations. 
 
This introduction provides a general explanation of all maintenance and repair functions authorized at the 
two maintenance levels under the Two-Level Maintenance System concept. 
 
The Maintenance Allocation Chart (MAC) designates overall authority and responsibility for the 
performance of maintenance functions on the identified end item or component.  The application of the 
maintenance functions to the end item or component shall be consistent with the capacities of the 
designated maintenance levels, which are shown on the MAC in column (4) as: 
 

Field ⎯ includes two subcolumns, Unit (C (operator/crew) and O (unit) 
maintenance) and Direct Support (F) maintenance 

   
Sustainment ⎯ includes two subcolumns, general support (H) and depot (D). 

 
The tools and test equipment requirements list the tools and test equipment (both special tools and 
common tool sets) required for each maintenance function as referenced from the MAC.  The remarks 
contain supplemental instructions and explanatory notes for a particular maintenance function.  
 
MAINTENANCE FUNCTION 
 
Maintenance functions will be limited to and defined as follows: 
 
1. Inspect.  To determine the serviceability of an item by comparing its physical, mechanical, and/or 

electrical characteristics with established standards through examination. 
 
2. Test.  To verify serviceability and to detect incipient failure by measuring the mechanical or electrical 

characteristics of an item and comparing those characteristics with prescribed standards. 
 
3. Service.  To perform operations required periodically to keep an item in proper operating condition; 

i.e., to clean or paint to replenish fuel, lubricants, hydraulic fluids, or compressed air supplies. 
 
4. Adjust.  To maintain, within prescribed limits, by bringing into proper or exact position, or by setting 

the operating characteristics to the specified parameters. 
 
5. Align.  To adjust specified variable elements of an item to bring about optimum or desired 

performance. 
 
6. Calibrate.  To determine and cause corrections to be made or to be adjusted on instruments of test, 

measuring, and diagnostic equipment used in precision measurement.  Consists of comparisons of 
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two instruments, one of which is a certified standard of known accuracy, to detect and adjust any 
discrepancy in the accuracy of the instrument being compared.   

 
7. Remove/Install.  To remove and install the same item when required to perform service or other 

maintenance functions.  To emplace, seat, or fix into position an item, part, module (component or 
assembly) in a manner to allow the proper functioning of the equipment or system. 

 
8. Replace.  To remove an unserviceable item and install a serviceable counterpart in its place.  

"Replace" is authorized by the MAC and assigned maintenance level is shown as the third position 
code of the Source, Maintenance and Recoverability (SMR) code. 

 
9. Repair.  To perform maintenance services (inspection, testing, servicing, adjustment, alignment, 

replacement) or other maintenance actions (welding, grinding, riveting, straightening, facing, re-
machining, or resurfacing) to restore serviceability to an item by correcting specific damage, faults, 
malfunctions, or failures in a part, subassembly, module (component or assembly), end item, or 
system. 

 
10. Overhaul.  To perform the maintenance efforts (service/action) necessary to restore an item to a 

completely serviceable/operational condition as prescribed by maintenance standards (i.e., Depot 
Maintenance Work Request (DMWR)) in appropriate technical publications.  Overhaul is normally the 
highest degree of maintenance performed by the Army.  Overhaul does not normally return an item to 
like-new condition. 

 
11. Rebuild.  Consists of those services/actions necessary for the restoration of unserviceable 

equipment to a like new condition in accordance with (IAW) original manufacturing standards.  
Rebuild is the highest degree of materiel maintenance applied to Army equipment.  The rebuild 
operation includes the act of returning to zero those age measurements (e.g., hours/miles) 
considered in classifying Army equipment/components. 

 
COLUMN ENTRIES 
 
1. Column 1, Group Number.  Column 1 lists FGC numbers, the purpose of which is to identify 

maintenance significant components, assemblies, subassemblies, and modules with the next higher 
assembly (NHA). 

 
2. Column 2, Component/Assembly.  Column 2 contains the item names of components, assemblies, 

subassemblies, and modules for which maintenance is authorized. 
 
3. Column 3, Maintenance Function.  Column 3 lists the functions to be performed on the item listed in 

column 2.  When items are listed without maintenance functions, it is solely for the purpose of having 
the group numbers in the MAC and RPSTL coincide. 

 
4. Column 4, Maintenance Level.  Column 4 specifies, by the listing of a "worktime" figure in the 

appropriate sub-column(s), the lowest level of maintenance authorized to perform the function listed 
in column 3.  This figure represents the active time required to perform that maintenance function at 
the indicated category of maintenance.  If the number of complexity of the tasks within the listed 
maintenance function vary at different maintenance categories, appropriate "worktime" figures are 
shown for each category.  The number of task-hours specified by the "worktime" figure represents the 
average time required to restore an item (assembly, component, module, end item, or system) to a 
serviceable condition under typical field operating conditions.  This time includes preparation time, 
troubleshooting time, and quality assurance/quality control time in addition to the time required to 
perform the specific tasks identified for the maintenance functions authorized in the maintenance 
allocation chart.  Sub-columns of column 4 are as follows: 
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Field:
C - Crew 
O - Service 
F - Field 
 
Sustainment:
H - Below Depot 
D - Depot 

 
NOTE 

 
The "L" maintenance level is not included in column (4) of the MAC.  Functions to 
this level of maintenance are identified by a work time figure in the "H" column of 
column (4), and an associated reference code is used in the REMARKS column (6).  
This code is keyed to the remarks and the SRA complete repair application is 
explained there. 

 
5. Column 5, Tools and Test Equipment.  Column 5 specifies, by code, the common tool sets (not 

individual tools), common Test Measurement and Diagnostic Equipment (TMDE), and special tools, 
special TMDE, special support equipment required to perform the designated function.  Codes are 
keyed to the entries in the tools and test equipment table. 

 
6. Column 6, Remarks.  Column 6 contains a letter code in alphabetic order, which is keyed to the 

remarks table entries. 
 
TOOLS AND TEST EQUIPMENT REQUIREMENTS (SECTION III) 
 
1. Tool or Test Equipment Reference Code.  This column lists the numbers that coincide with the 

numbers used in the tools and equipment column of the MAC.  The numbers indicate the applicable 
tool or test equipment for the maintenance functions. 

 
2. Maintenance Category.  This column lists the codes that indicate the maintenance category 

allocated the tool or test equipment. 
 
3. Nomenclature.  This column lists the noun name and nomenclature of the tools and test equipment 

required to perform the maintenance functions. 
 
4. National/NATO Stock Number.  This column lists the National/ North Atlantic Treaty Organization 

(NATO) stock number of the specific tool or test equipment. 
 
5. Tool Number.  This column lists the manufacturer's part number of the tool. 
 
REMARKS (SECTION IV) 
 
1. Reference Code.  This column lists the codes that refer to the appropriate items in section II, 

column 6. 
 
2. Remarks.  This column provides the required explanatory information necessary to clarify items 

appearing in section II. 
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NOTE 
 

A # in the maintenance category, Section II, column (4), indicates that there is a 
technical manual in the Remarks section that is referenced. 
 
A * indicates maintenance time has not been computed.  Refer to the ARIL for 
distribution. 

 
 
END OF WORK PACKAGE 
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MAINTENANCE ALLOCATION CHART (MAC)  
 
 

Table 1.  MAC FOR THE SIMPLE KEY LOADER, AN/PYQ-10 (C). 
 

(1) 
GROUP 

NUMBER 

(2) 
COMPONENT/ 

ASSEMBLY 
 

(3) 
MAINT 

FUNCTION 

(4) 
MAINTENANCE LEVEL 

(5) 
TOOLS 

AND TEST 
EQUIPMENT 

(6) 
REMARKS 

CODE 

   FIELD SUSTAINMENT   
   CREW SERVICE FIELD DELOW 

DEPOT 
DEPOT   

   C O F H  D   
00 Transfer Unit, 

Cryptographic 
Key, 
AN/PYQ-10 (C) 

INSPECT 
SERVICE 
TEST 
REPLACE 
REPAIR 
REPAIR 
OVERHAUL 

  0.1 
0.2 
0.5 
0.5 

 

  
 
 
 
 
* 

50.0 

 A 
 
B 
C, D 
 
 

 
Table 2.  Remarks. 

 
REFERENCE 

CODE REMARKS 

A Visual/Mechanical 
 

B Test is performed using Built In Test/Built In Test Equipment (BIT/BITE) 
and/or functional checks. 
 

C Repair limited to the replacement of all external components. 
 

D (*)  Return failed items to the manufacturer in accordance with the 
Warranty Bulletin. 
 

 
 
END OF WORK PACKAGE 
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COMPONENTS OF END ITEM AND BASIC ISSUE ITEMS 
 
 
SCOPE 
 
This Work Package lists integral components of and basic issue items for the Simple Key Loader (SKL). 
 
GENERAL 
 
This Components of End Item List is divided into the following sections: 
 
1. Section II.  Integral Components of the End Item.  These items, when assembled, comprise the SKL 

and must accompany it whenever it is transferred or turned in.  The illustrations will aid in the identity 
of these items. 

 
2. Section III.  Basic Issue Items (BII).  These are the minimum essential items required to place the 

SKL in operation, to operate it, and to perform emergency repairs.  Although shipped separately 
packed, they must accompany the SKL during operation and whenever it is transferred between 
accountable officers.  The illustrations will assist with identity of the hard-to-identify items.  This 
manual is the authority to requisition replacement BII, based on Table of Organization and Equipment 
(TOE)/Modified Table of Organization and Equipment (MTOE) authorization of the end item. 

 
EXPLANATION OF COLUMNS 
 
1. Illustration.  This column is divided as follows: 
 

a. Figure number.  Indicates the figure number of the illustration on which the item is shown.  Note 
that figures are after the end of the table. 

 
b. Item number.  The number used to identify the item called out in the illustration. 

 
2. National Stock Number (NSN).  Indicates the National Stock Number assigned to the item that is 

used for requisitioning. 
 
3. Description.  Indicates the Federal item name and, if required, a minimum description to identify the 

item.  The part number (when applicable) indicates the primary number used by the manufacturer, 
which controls the design and characteristics of the item by means of its engineering drawings, 
specifications, standards, and inspection requirements to identify an item or range of items.  
Following the part number, the Commercial and Government Entity Code (CAGEC) (as applicable) is 
shown in parentheses. 

 
4. Units of Measure (U/M).  Indicates the measure used in performing the actual operator or 

maintenance function.  This measure is expressed by a 2 character alphabetical abbreviation (e.g., 
ea, in, pr). 

 
5. Quantity Required (Qty Reqd).  This column lists the quantity of each item required for a complete 

major item. 
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Figure 1.  Components of End Item. 
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Table 1.  Components of End Item List. 
 

 
Illus 
No 

(2) 
National 

Stock Number 

(3) 
Description 

(CAGEC) and Part Number 

 
Usable 

On 
Code 

(4) 
 

U/M 

(5) 
Qty 

Reqd 

1 5810-01-517-3587 Transfer Unit, Cryptographic Key, AN/PYQ-10 
(C), Simple Key Loader (SKL), Completed 
Assembly (no battery) 
Cage: 3CN36, P/N 200-00001-001 

 EA 1 

      
2 7520-01-524-9762 Inductive Stylus 

Cage: 3CN36, P/N 450-000009-01 
 EA 2 

      
3 5810-01-529-8767 CIK 

Cage: 3CN36, P/N 450-00012-01  
 EA 1 

      
4 6130-01-525-2788 Battery Pack (High Capacity) 

Cage: 3CN36, P/N 200-00006-01 
 EA 1 

      
5 6130-01-525-1635 Battery Pack (Standard Capacity) 

Cage: 3CN36, P/N 200-00005-01 
 EA 1 

      
6 6130-01-548-1505 Battery Charger Assy 

Cage: 3CN36, P/N 200-00056 
 EA 1 

      
7 5995-01-545-0167 USB Adapter (Female to Male) 

Cage: 3CN36, P/N 290-00008-01 
 EA 1 

 
 

Table 2.  Basic Issue Items List. 
 

 
Illus 
No 

(2) 
National 

Stock Number 

(3) 
Description 

(CAGEC) and Part Number 

 
Usable On 

Code 

(4) 
 

U/M 

(5) 
Qty 

Reqd 

  Technical Manual, Operator’s and 
Field Maintenance Manual, Including 
Repair Parts and Special Tools List 
for the Transfer Unit, Cryptographic 
Key, AN/PYQ-10 (C), Simple Key 
Loader (SKL) SKL UAS Version 4.0 
TM 11-5810-410-13&P 
Cage: TBD, P/N N/A 

 EA 1 

 
 
END OF WORK PACKAGE 
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SUPPORTING INFORMATION 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
 

 
ADDITIONAL AUTHORIZATION LIST 
 
 
SCOPE 
 
This Work Package lists additional items authorized for the support of the Simple Key Loader. 
 
GENERAL 
 
This list identifies items that do not accompany the Simple Key Loader configuration, but are available 
through standard logistics channels.  These items can be authorized by Common Table of Allowances 
(CTA), MTOE, Table of Allowances (TDA), or Joint Table of Allowances (JTA.) 
 
EXPLANATION OF LISTING 
 
National Stock Numbers, descriptions, and quantities recommended are provided to help identify and 
request the additional items required to support this equipment. 
 

Table 1.  Additional Authorized Items List. 
 

(1) 
Item 
No. 

(2) 
National Stock Number 

(3) 
Description 

(CAGEC) and Part Number 

(4) 
U/M 

(5) 
Qty 

Recm 
1 5810-01-348-4675 Cable, RS-232, ON433836-1 EA N/A 

2 6130-01-525-1617 AA Battery Pack, 3CN36, 200-00012-01 EA N/A 

3 6130-01-525-2021 Assembly, Battery Eliminator, 3CN36, 200-
00010-01 EA N/A 

4 7045-01-525-2029 Carrying Case for PDA, Nylon, 3CN36, 650-
00003 EA N/A 

5 5180-00-610-8177 Alignment Tool, Elec (Screwdriver Type; 7” Long) EA 1 

6 5120-00-293-3486 Pliers, Short Nose, Without Cutter EA 1 

7 5120-00-236-2140 Screwdriver, Flat Tip EA 1 
 
 
END OF WORK PACKAGE 
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SUPPORTING INFORMATION 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
 

 
EXPENDABLE SUPPLIES AND MATERIALS LIST 
 
 
SCOPE 
 
This appendix lists expendable supplies and materials needed to operate and maintain the SKL.  These 
items are authorized by CTA 50-970, Expendable Items (Except Medical, Class V, Repair Parts, and 
Heraldic Items). 
 
EXPLANATION OF COLUMNS 
 
1. Column 1 - Item Number.  This number is assigned to the entry in the listing and is referenced in the 

narrative instructions. 
 
2. Column 2 - Level.  This column identifies the lowest level of maintenance that requires the listed item. 
 

O - Operator/Crew 
C - Organizational Maintenance 
F - Direct Support Maintenance 
H - General Support Maintenance 

 
3. Column 3 - National Stock Number (NSN).  This is the National Stock Number assigned to the item; 

use it to request or requisition the item. 
 
4. Column 4 - Description.  Indicates the Federal Item Name and, if required, a description to identify the 

item.  The last line for each item indicates the part number followed by the Commercial and 
Government Entity Code (CAGEC) in parentheses, if applicable. 

 
5. Column 5 - Unit of Measure (U/M).  Indicates the measure used in performing the actual maintenance 

function.  This measure is expressed by a two-character alphabetical abbreviation (e.g., ea, in, pr).  If 
the unit of measure differs from the unit of issue, requisition the lowest unit of issue that will satisfy 
unit requirements. 

 
Table 1.  Expendable Supplies and Materials List. 

 
(1) 

ITEM 
No 

(2) 
Level 

(3) 
National 

Stock Number 

(4) 
Description 

(CAGEC) and Part Number 

(5) 
 

U/M 

1 C 8305-00-267-3015 Cloth, Cotton TD 
     
2 C 6135-00-985-7845 Battery, AA EA 

 
 
END OF WORK PACKAGE 
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REAR MATTER 
FOR 

TRANSFER UNIT, CRYPTOGRAPHIC KEY, AN/PYQ-10(C) 
SIMPLE KEY LOADER (SKL) 

SKL UAS VERSION 4.0 
 

 
GLOSSARY 
 
 
87-27 The 87-27 file is used by the ACES Workstation to export a database in a .DAT 

format.  The file then can be brought into the SKL for use. 
  
AC Alternating Current 
  
ACES Automated Communication Engineering Software 
  
AES Advanced Encryption Standard 
  
AK Automatic Rekey 
  
AMDF Army Master Data File 
  
Active Window The window currently accepting input. 
  
Application A computer program that performs a particular task, such as the SKL UAS. 
  
AR Army Regulation 
  
ARNG Army National Guard 
  
BDE Brigade 
  
BII Basic Issue Items 
  
BIT Built In Test 
  
BITE Built In Test Equipment 
  
Boot The process by which the computer is powered on and goes through the necessary 

steps to load and start the operating system.  This also refers to the program in the 
root directory that loads and starts the operating system. 

  
CAGEC Commercial and Government Entity Code 
  
CBT Computer Based Training 
  
CCI Controlled Cryptographic Items 
  
CD Compact Disk 
  
CDR Commander 
  
CIK Cryptographic Ignition Key 
  
COMSEC Communications Security 

Glossary-2 
UNCLASSIFIED//FOR OFFICIAL USE ONLY 



 UNCLASSIFIED/FOR OFFICIAL USE ONLY 
 TM 11-5810-410-13&P  
 
CPC Corrosion Prevention Control 
  
CPU Computer Processing Unit 
  
Crypto Period The time span during which each key segment remains in effect. 
  
CTA Common Tables of Allowances 
  
CT3 Common Tier 3 
  
DA Department of the Army 
  
DC Direct Current 
  
DIVID Division Identification 
  
DMD Data Management Device 
  
DMWR Depot Maintenance Work Request 
  
DOD Department of Defense 
  
DS-101 A type of communications protocol. 
  
DS-102 A type of communications protocol. 
  
DTD Data Transfer Device 
  
ECU End Cryptographic Unit 
  
EIR Equipment Improvement Recommendation 
  
EKMS Electronic Key Management System 
  
EP Electronic Protection 
  
EPLRS Enhanced Position Location Reporting System 
  
EQS Equipment 
  
Equipment Defines the actual hardware that is resident on the Platform. 
  
Equipment 
Profile 

Defines the steps that must be taken to load the designated ECU with key. 

  
FAT File Allocation Table 
  
FM Field Maintenance 
  
GPS Global Positioning System 
  
HMMV High Mobility Multipurpose Vehicle 
  
IAW In Accordance With 
  
ICOM Integrated COMSEC 
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ID Identification 
  
IKEK Initial Key Encryption Key 
  
Inductive Stylus A stylus that uses inductive technology to activate an object on the screen of the 

SKL. 
  
INFOSEC Information Security 
  
JTA Joint Tables of Authorization 
  
JTIDS Joint Tactical Information Distribution System 
  
KP Key Processor 
  
KEK Key Encryption Key 
  
Key Information (usually a sequence of random or pseudorandom binary digits) used 

initially to set up and periodically change the operations performed in crypto-
equipment for the purpose of encrypting and decrypting electronic signals. 

  
Key Tag Key “tags” are records containing Short Title, Edition, Text ID, Segment Number 

and other information related to the key. 
  
KLS Key Load Status 
  
KMID Key Material Identification 
  
LCD Light Conducting Diode 
  
LCMS Local COMSEC Management Software 
  
LED Light Emitting Diode 
  
LKEK Local Key Encryption Key 
  
Load The sequence of events that moves the key from a fill device to the intended End 

Cryptographic Equipment (ECU). 
  
Logon The process of gaining access to the system or a particular software application. 
  
Logout The process of disconnecting from the system or software application. 
  
MAC Maintenance Allocation Chart 
  
MK Manual Rekey 
  
MTOE Modified Table of Organizational Equipment 
  
NATO North Atlantic Treaty Organization 
  
NCS Net Control Station 
  
NIIN National Item Identification Number 
  
NSA National Security Agency 
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NSN National Stock Number 
  
NVG Night Vision Goggles 
  
Operating 
System 

A group of programs and functions that provide basic functionality on a computer.  
The software that manages access to the system’s hardware and other resources. 

  
OS Operating System 
  
OTAD Over the Air Distribution 
  
PAM Pamphlet 
  
PCMCIA Personal Computer Memory Card International Association 
  
PDA Personal Digital Assistant 
  
PIN Personal Identification Number 
  
PLATS Platforms 
  
Platform An individual communications system or assemblage with a unique name in a net.  

Depending on the network definition and mission needs, the platform may be a 
logical grouping of equipment such as:  a vehicle with multiple COMSEC equipment 
items, a piece of COMSEC equipment, or a command center (TOC). 

  
PLGR Precision Lightweight GPS Receiver 
  
PMCS Preventive Maintenance Checks and Services 
  
Profile See Equipment Profile 
  
RAM Random Access Memory 
  
Receive The process by which information in the form of database(s) and/or key is 

transferred from a workstation or other repository to the SKL. 
  
RS-232 Interface between Data Terminal Equipment (DTE) and Data Communications 

Equipment (DCE) employing serial binary data interchange. 
  
RPSTL Repair Parts and Special Tools List 
  
RV Receive Variable 
  
SB Service Bulletin 
  
SDRAM Synchronous Dynamic Random Access Memory 
  
Segment Traditional key that is valid for one cryptoperiod. 
  
Short Title An identifying combination of letters and numbers assigned to certain COMSEC 

items to facilitate handling, accounting, and control. 
SINCGARS Single Channel Ground and Airborne Radio System 
  
SKL Simple Key Loader 
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SMR Source Maintenance & Recoverability 
  
STU III Secure Telephone Unit – Third Generation 
  
SOI Signal Operating Instructions 
  
SOP Standing Operating Procedures 
  
SSO Site Security Officer 
  
TAMMS The Army Maintenance Management System 
  
TB Technical Bulletin 
  
TDA Table of Distribution and Allowances 
  
TEK Transmission Encryption Key 
  
Text ID Free form text field in a key tag which associates key to a specific use or 

destination. 
  
TM Technical Manual 
  
TMDE Test Measurement and Diagnostic Equipment 
  
TOE Tables of  Organizational Equipment 
  
Transmit The process which information in the form of database(s) or key is transferred from 

the SKL to an ECU or another SKL. 
  
TrKEK Transmission Key Encryption Key 
  
User Account This consists of the logon name and password which when combined allows access 

to the SKL’s software packages. 
  
UAS User Application Software 
  
USB Universal Serial Bus 
  
VGA Video Graphics Array 
  
VG Variable Generate 
  
VU Variable Update 
  
XML Extensible Markup Language 
  
Wake Up The process of sending a known data stream to a Communications Bus to open it 

for use.  Primarily used with the DS-101 protocol. 
  
Zeroize To remove or eliminate the key permanently from cryptographic equipment or fill 

device. 
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Abbreviations/Acronyms And Definitions. .....................................................................................WP 0001-4 
ARC-210......................................................................................................................................WP 0029-12 
Accessing the Core Library Features............................................................................................WP 0007-4 
Accessing the Core Library Program. ...........................................................................................WP 0007-2 
Add Equipment..............................................................................................................................WP 0011-6 
Add Platform. ................................................................................................................................WP 0011-2 
Add and Edit Functions .................................................................................................................WP 0011-2 
Adding Nets to the Quick Reference...........................................................................................WP 0028-11 
Additional Authorization List (AAL) ...............................................................................................WP 0045-2 
All Net Names. ..............................................................................................................................WP 0028-4 
Alphabetical Index............................................................................................................................... Index-1 
AN/PYQ-10 (C) Simple Key Loader Operator Interfaces..............................................................WP 0004-4 
AN/PYQ-10 (C) Troubleshooting Procedures ...............................................................................WP 0031-2 
Assembling the AN/PYQ-10 Simple Key Loader ..........................................................................WP 0035-2 
Assembling the Battery Charger ...................................................................................................WP 0035-2 
Assembling the Optional Battery Eliminator..................................................................................WP 0035-5 
Assembling the Optional AA Battery Pack....................................................................................WP 0035-6 
Assign EP Data to an Equipment Fill Location. ............................................................................WP 0022-4 
Assign Equipment to a Platform....................................................................................................WP 0022-9 
Assign Key to an Equipment Fill Location.....................................................................................WP 0022-2 
Assign Message Data. ..................................................................................................................WP 0022-7 
Assign............................................................................................................................................WP 0022-2 
Assigned Versus Unassigned Key................................................................................................WP 0003-9 
Audit ............................................................................................................................................WP 0029-16 
Audit Functions. ..........................................................................................................................WP 0007-19 
Automatic Rekey (AK)...................................................................................................................WP 0020-2 
 

B 
 
Battery Charger has a Flashing Amber LED when a Battery is Inserted......................................WP 0031-4 
Battery Charger LED is not Lit ......................................................................................................WP 0031-4 
Battery Fuel Gauge, Warnings, And Events. ..............................................................................WP 0004-12 
Battery Removal..........................................................................................................................WP 0004-13 
Benign Fill......................................................................................................................................WP 0027-8 
 

C 
 
Calibrating the Inductive Stylus.....................................................................................................WP 0004-8 
Cannot Logon to the Core Library with a Valid Account and Password .....................................WP 0031-20 
Change a User’s Password.........................................................................................................WP 0007-18 
Change User Password. ...............................................................................................................WP 0007-7 
Changing the Core Library Protocol..............................................................................................WP 0007-5 
Checking Unpacked Equipment....................................................................................................WP 0034-2 
Clear Audit...................................................................................................................................WP 0007-20 
Cloning the Core Library Firmware. ............................................................................................WP 0007-25 
Components of End Item and Basic Issue Items..........................................................................WP 0044-2 
Transfer Unit, Cryptographic Key AN/PYQ-10 (C) Parts List........................................................WP 0038-4 
Core Library and SKL UAS Error/Information Messages ..........................................................WP 0031.1-2 
Core Library Help Menu. .............................................................................................................WP 0007-27 
Core Library Program....................................................................................................................WP 0007-2 
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Create Key Tags. ..........................................................................................................................WP 0021-2 
Create or Re-Create a User Account..........................................................................................WP 0007-15 
Crypto Ignition Key (CIK) Interface. ..............................................................................................WP 0004-9 
Crypto Ignition Key (CIK). .............................................................................................................WP 0003-5 
Current Selection. .........................................................................................................................WP 0026-4 
 

D 
 
Database Management...........................................................................................WP 0003-10, WP 0024-2 
Date Load......................................................................................................................................WP 0029-3 
Delete a Database. .......................................................................................................................WP 0013-2 
Delete Function .............................................................................................................................WP 0009-2 
Delete a Platform. .........................................................................................................................WP 0009-2 
Delete Edition..............................................................................................................................WP 0009-10 
Delete Equipment..........................................................................................................................WP 0009-4 
Delete Key Tag. ............................................................................................................................WP 0009-7 
Delete Modern Key .....................................................................................................................WP 0009-15 
Delete Segment. .........................................................................................................................WP 0009-12 
Delete User Account. ..................................................................................................................WP 0007-16 
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Description of the SKL. .................................................................................................................WP 0002-2 
Destruction of Army Materiel to Prevent Enemy Use. ..................................................................WP 0001-3 
Disable the Date Load Filter..........................................................................................................WP 0029-8 
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E 
 
ECU Equipment is Loaded with Incorrect Time. .........................................................................WP 0031-13 
Edit Equipment..............................................................................................................................WP 0011-8 
Edit Platform..................................................................................................................................WP 0011-4 
EKMS Information Flow. ...............................................................................................................WP 0003-2 
EKMS Overview. ...........................................................................................................................WP 0003-2 
Empty all Quick Reference Entries. ..............................................................................................WP 0012-2 
Empty or Remove a Quick Reference. .........................................................................................WP 0012-2 
Equipment (Eqs) Tab. ...................................................................................................................WP 0008-2 
Equipment Characteristics, Capabilities, and Features ................................................................WP 0002-2 
Equipment Components................................................................................................................WP 0001-2 
Equipment Data ............................................................................................................................WP 0002-4 
Equipment Description And Data..................................................................................................WP 0002-2 
Equipment Mission Data. ..............................................................................................................WP 0003-9 
Error/Information Messages.......................................................................................................WP 0031.1-2 
Exit. ...............................................................................................................................................WP 0023-3 
Expand Tree................................................................................................................................WP 0028-20 
Expendable Supplies and Materials List .......................................................................................WP 0046-2 
Expired Keys. ................................................................................................................................WP 0027-2 
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Installing and Removing the Crypto Ignition Key (CIK).................................................................WP 0035-3 
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Key Load .....................................................................................................................................WP 0029-15 
Key Load Status (KLS)................................................................................................................WP 0028-20 
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Move Down. ................................................................................................................................WP 0028-20 
Move Up. .....................................................................................................................................WP 0028-20 
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Navigating the SKL UAS Desktop.................................................................................................WP 0008-4 
Navigation/Control Buttons Interface. ...........................................................................................WP 0004-4 
Normal Powering Up and Logging onto the SKL. .........................................................................WP 0006-6 
Nomenclature Cross-Reference List.............................................................................................WP 0001-4 
 

O 
 
Operation Under Usual Conditions .................................................................................................. WP 0005 
Operation Under Unusual Conditions .............................................................................................. WP 0030 
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